/[packages]/cauldron/tk/current/SPECS/tk.spec
ViewVC logotype

Contents of /cauldron/tk/current/SPECS/tk.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2047894 - (show annotations) (download)
Wed Mar 6 16:35:52 2024 UTC (6 weeks, 1 day ago) by daviddavid
File size: 2993 byte(s)
- new version: 8.6.14

1 %define majorver 8.6
2 %define minorver %{majorver}.14
3 #define patchver 1
4 %define libname %mklibname %{name} %{majorver}
5 %define develname %mklibname %{name} -d
6
7 Name: tk
8 Epoch: 1
9 Version: %{minorver}%{?patchver:.%{patchver}}
10 Release: %mkrel 1
11 Summary: The graphical toolkit for the Tcl scripting language
12 License: TCL
13 Group: Development/Other
14 URL: https://tcl.sourceforge.net/
15 Source0: https://downloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
16 Patch1: tk-8.6.1-make.patch
17 Patch2: tk-8.6.12-conf.patch
18 BuildRequires: autoconf
19 BuildRequires: pkgconfig(tcl) = %{minorver}
20 BuildRequires: pkgconfig(x11)
21 BuildRequires: pkgconfig(xft)
22 BuildRequires: pkgconfig(xscrnsaver)
23
24 Requires: tcl = %{epoch}:%{minorver}
25
26 %description
27 When paired with the Tcl scripting language, Tk provides a fast and powerful
28 way to create cross-platform GUI applications.
29
30 %package -n %{libname}
31 Summary: Shared libraries for %{name}
32 Group: System/Libraries
33
34 %description -n %{libname}
35 When paired with the Tcl scripting language, Tk provides a fast and powerful
36 way to create cross-platform GUI applications.
37
38 %package -n %{develname}
39 Summary: Tk graphical toolkit development files
40 Group: Development/Other
41 Requires: %{name} = %{epoch}:%{version}-%{release}
42 Requires: %{libname} = %{epoch}:%{version}-%{release}
43 Provides: %{name}-devel = %{epoch}:%{version}-%{release}
44
45 %description -n %{develname}
46 When paired with the Tcl scripting language, Tk provides a fast and powerful
47 way to create cross-platform GUI applications.
48
49 The package contains the development files and man pages for tk.
50
51 %prep
52 %setup -q -n %{name}%{minorver}
53
54 %autopatch -p1
55
56 %build
57 cd unix
58 autoconf
59 %configure --enable-threads
60 %make_build \
61 CFLAGS="%{optflags}" TK_LIBRARY=%{_datadir}/%{name}%{majorver}
62
63 %install
64 %make_install -C unix \
65 TK_LIBRARY=%{_datadir}/%{name}%{majorver}
66
67 ln -s wish%{majorver} %{buildroot}%{_bindir}/wish
68
69 # for linking with -l%%{name}
70 ln -s lib%{name}%{majorver}.so %{buildroot}%{_libdir}/lib%{name}.so
71
72 mkdir -p %{buildroot}%{_includedir}/%{name}-private/{generic/ttk,unix}
73 find generic unix -name "*.h" -exec cp -p '{}' %{buildroot}%{_includedir}/%{name}-private/'{}' ';'
74 ( cd %{buildroot}%{_includedir}
75 for i in *.h ; do
76 [ -f %{buildroot}%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i %{buildroot}%{_includedir}/%{name}-private/generic ;
77 done
78 )
79
80 # remove buildroot traces
81 sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" %{buildroot}%{_libdir}/%{name}Config.sh
82
83 %files
84 %doc README.md changes license.terms
85 %{_bindir}/wish*
86 %{_datadir}/%{name}%{majorver}
87 %exclude %{_datadir}/%{name}%{majorver}/tkAppInit.c
88 %{_libdir}/%{name}%{majorver}
89 %{_mandir}/man1/*
90 %{_mandir}/mann/*
91
92 %files -n %{libname}
93 %{_libdir}/lib%{name}%{majorver}.so
94
95 %files -n %{develname}
96 %{_includedir}/*
97 %{_libdir}/lib%{name}.so
98 %{_libdir}/lib%{name}stub%{majorver}.a
99 %{_libdir}/%{name}Config.sh
100 %{_libdir}/pkgconfig/%{name}.pc
101 %{_mandir}/man3/*
102 %{_datadir}/%{name}%{majorver}/tkAppInit.c

  ViewVC Help
Powered by ViewVC 1.1.30