1 |
%define _version2 %(echo %version | tr . _) |
2 |
|
3 |
Name: triplea |
4 |
Version: 1.8.0.9 |
5 |
Release: %mkrel 1 |
6 |
Summary: A networked open source strategy game |
7 |
Group: Games/Strategy |
8 |
License: GPLv2+ |
9 |
URL: http://triplea.sourceforge.net/ |
10 |
Source0: http://prdownloads.sourceforge.net/triplea/%{name}_%{_version2}_source_code_only.zip |
11 |
Source1: %{name}.png |
12 |
Patch0: %{name}-mga-build.xml.patch |
13 |
|
14 |
BuildRequires: ant |
15 |
BuildRequires: dos2unix |
16 |
BuildRequires: jakarta-commons-codec |
17 |
BuildRequires: jakarta-commons-logging |
18 |
BuildRequires: java-devel |
19 |
BuildRequires: jpackage-utils |
20 |
BuildRequires: junit |
21 |
BuildRequires: ant-junit |
22 |
BuildRequires: xerces-j2 |
23 |
BuildRequires: xmlbeans |
24 |
Requires: jakarta-commons-codec |
25 |
Requires: jakarta-commons-logging |
26 |
Requires: java >= 1.6 |
27 |
BuildArch: noarch |
28 |
|
29 |
%description |
30 |
TripleA is a networked open source strategy game, based on the |
31 |
Axis & Allies board game. It allows people to implement and play various |
32 |
strategy board games (i.e. Axis & Allies). The TripleA engine has full |
33 |
networking support for online play, support for sounds, XML support for |
34 |
game files, and has its own imaging subsystem that allows for customized |
35 |
user editable maps to be used. TripleA is versatile, scalable and robust. |
36 |
|
37 |
|
38 |
%prep |
39 |
%setup -q -n %{name}_%{_version2} |
40 |
%patch0 -p1 -b .orig~ |
41 |
%__rm triplea_mac_os_x.sh |
42 |
%__rm triplea_windows.bat |
43 |
dos2unix readme.html changelog.txt doc/*.html |
44 |
|
45 |
%build |
46 |
%ant zip |
47 |
|
48 |
%install |
49 |
# ant makes a zip file, so unzip that into the final dir. |
50 |
# Don't know another way to do it, yet. |
51 |
%__install -dm 755 %{buildroot}%{_gamesdatadir} |
52 |
%__unzip -q -d %{buildroot}%{_gamesdatadir} release/%{name}_all_platforms.zip |
53 |
|
54 |
# startscript |
55 |
%__install -dm 755 %{buildroot}%{_gamesbindir} |
56 |
|
57 |
%__cat > %{buildroot}%{_gamesbindir}/%{name} << EOF |
58 |
#!/bin/sh |
59 |
%{_gamesdatadir}/%{name}/%{name}_unix.sh |
60 |
EOF |
61 |
chmod 755 %{buildroot}%{_gamesbindir}/%{name} |
62 |
|
63 |
# icon and menu-entry |
64 |
%__install -dm 755 %{buildroot}%{_datadir}/pixmaps |
65 |
%__install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/pixmaps |
66 |
|
67 |
%__install -dm 755 %{buildroot}%{_datadir}/applications |
68 |
%__cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF |
69 |
[Desktop Entry] |
70 |
Encoding=UTF-8 |
71 |
Comment=Axis and Allies clone |
72 |
Name=TripleA |
73 |
GenericName=TripleA |
74 |
Type=Application |
75 |
Exec=%{_gamesbindir}/%{name} |
76 |
Icon=%{name} |
77 |
Categories=Game;StrategyGame; |
78 |
Terminal=false |
79 |
EOF |
80 |
|
81 |
%files |
82 |
%doc changelog.txt readme.html doc/* |
83 |
%{_gamesbindir}/%{name} |
84 |
%{_datadir}/applications/%{name}.desktop |
85 |
%{_datadir}/pixmaps/%{name}.png |
86 |
%dir %{_gamesdatadir}/%{name} |
87 |
%{_gamesdatadir}/%{name}/* |