/[packages]/cauldron/uhd/current/SPECS/uhd.spec
ViewVC logotype

Annotation of /cauldron/uhd/current/SPECS/uhd.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 196168 - (hide annotations) (download)
Sat Jan 14 22:13:44 2012 UTC (12 years, 7 months ago) by barjac
File size: 2603 byte(s)
Corrected Group in sub packages
1 barjac 196101 # Pull from git
2     %global git_tag release_003_003_001
3    
4     # git clone git://code.ettus.com/ettus/uhd.git
5     # cd uhd
6     # git archive --format=tar --prefix=%%{name}-%%{version}/ %%{git_tag} | \
7     # gzip > ../%%{name}-%%{version}.tar.gz
8    
9     Name: uhd
10     URL: http://code.ettus.com/redmine/ettus/projects/uhd/wiki
11     Version: 3.3.1
12 barjac 196157 Release: %mkrel 1
13     Group: Communications
14     Summary: Universal Hardware Driver for Ettus Research products
15 barjac 196101 License: GPLv3+
16 barjac 196157 Source0: %{name}-%{version}.tar.gz
17 barjac 196101 BuildRequires: cmake
18 barjac 196157 BuildRequires: boost-devel
19     BuildRequires: libusb1-devel
20     BuildRequires: liborc-devel
21     BuildRequires: python-cheetah
22     BuildRequires: python-docutils
23     BuildRequires: doxygen
24     BuildRequires: pkgconfig
25 barjac 196101
26     %description
27     The UHD is the universal hardware driver for Ettus Research products.
28     The goal of the UHD is to provide a host driver and API for current and
29     future Ettus Research products. It can be used standalone without GNU Radio.
30    
31     %prep
32     %setup -q
33    
34     %build
35 barjac 196157 mkdir -p host/build
36 barjac 196101 cd host/build
37 barjac 196157 cmake ../ -DCMAKE_INSTALL_PREFIX=/usr
38     %make
39 barjac 196101
40     %check
41     cd host/build
42     make test
43    
44     %install
45     pushd host/build
46     make install DESTDIR=%{buildroot}
47    
48     # Allow access only to users in usrp group
49     sed -i 's/MODE:="0666"/MODE:="0660"/' %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules
50     mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d
51     mv %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules %{buildroot}%{_sysconfdir}/udev/rules.d/10-usrp-uhd.rules
52    
53     # Remove binaries for tests, examples
54     rm -rf %{buildroot}%{_datadir}/uhd/{tests,examples}
55    
56     # Move the utils stuff to libexec dir
57     mkdir -p %{buildroot}%{_libexecdir}/uhd
58     mv %{buildroot}%{_datadir}/uhd/utils/* %{buildroot}%{_libexecdir}/uhd
59    
60     popd
61     # Package base docs to base package
62     mkdir _tmpdoc
63     mv %{buildroot}%{_docdir}/%{name}/{AUTHORS.txt,LICENSE.txt,README.txt} _tmpdoc
64    
65     %package devel
66     Summary: Development files for UHD
67 barjac 196168 Group: Communications
68 barjac 196101 Requires: %{name} = %{version}-%{release}
69    
70     %description devel
71     Development files for the Universal Hardware Driver (UHD).
72    
73     %package doc
74     Summary: Documentation files for UHD
75 barjac 196168 Group: Communications
76 barjac 196101 BuildArch: noarch
77    
78     %description doc
79     Documentation for the Universal Hardware Driver (UHD).
80    
81     %pre -n uhd
82     getent group usrp >/dev/null || groupadd -r usrp
83    
84     %files
85     %doc _tmpdoc/*
86     %{_bindir}/uhd_find_devices
87     %{_bindir}/uhd_usrp_probe
88     %config(noreplace) %{_sysconfdir}/udev/rules.d/10-usrp-uhd.rules
89     %{_libdir}/lib*.so.*
90     %{_libexecdir}/uhd
91    
92     %files devel
93     %{_includedir}/*
94     %{_libdir}/lib*.so
95     %{_libdir}/pkgconfig/*.pc
96    
97     %files doc
98     %doc %{_docdir}/%{name}/*

  ViewVC Help
Powered by ViewVC 1.1.30