/[packages]/cauldron/uhd/current/SPECS/uhd.spec
ViewVC logotype

Annotation of /cauldron/uhd/current/SPECS/uhd.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 217237 - (hide annotations) (download)
Sat Mar 3 13:19:56 2012 UTC (12 years, 6 months ago) by barjac
File size: 2524 byte(s)
- new version 3.3.2
- added make-tarball script for simpler updates
1 barjac 196101 Name: uhd
2     URL: http://code.ettus.com/redmine/ettus/projects/uhd/wiki
3 barjac 217237 Version: 3.3.2
4 barjac 196157 Release: %mkrel 1
5     Group: Communications
6     Summary: Universal Hardware Driver for Ettus Research products
7 barjac 196101 License: GPLv3+
8 barjac 196157 Source0: %{name}-%{version}.tar.gz
9 barjac 217237 # Create tarball from git with:
10     # $ make-tarball uhd git://code.ettus.com/ettus/uhd.git
11     # See note in make-tarball script
12     Source1: make-tarball
13    
14 barjac 196101 BuildRequires: cmake
15 barjac 196157 BuildRequires: boost-devel
16     BuildRequires: libusb1-devel
17     BuildRequires: liborc-devel
18     BuildRequires: python-cheetah
19     BuildRequires: python-docutils
20     BuildRequires: doxygen
21     BuildRequires: pkgconfig
22 barjac 196101
23     %description
24     The UHD is the universal hardware driver for Ettus Research products.
25     The goal of the UHD is to provide a host driver and API for current and
26     future Ettus Research products. It can be used standalone without GNU Radio.
27    
28     %prep
29     %setup -q
30    
31     %build
32 barjac 196157 mkdir -p host/build
33 barjac 196101 cd host/build
34 barjac 196157 cmake ../ -DCMAKE_INSTALL_PREFIX=/usr
35     %make
36 barjac 196101
37     %check
38     cd host/build
39     make test
40    
41     %install
42     pushd host/build
43     make install DESTDIR=%{buildroot}
44    
45     # Allow access only to users in usrp group
46     sed -i 's/MODE:="0666"/MODE:="0660"/' %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules
47     mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d
48     mv %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules %{buildroot}%{_sysconfdir}/udev/rules.d/10-usrp-uhd.rules
49    
50     # Remove binaries for tests, examples
51     rm -rf %{buildroot}%{_datadir}/uhd/{tests,examples}
52    
53     # Move the utils stuff to libexec dir
54     mkdir -p %{buildroot}%{_libexecdir}/uhd
55     mv %{buildroot}%{_datadir}/uhd/utils/* %{buildroot}%{_libexecdir}/uhd
56    
57     popd
58     # Package base docs to base package
59     mkdir _tmpdoc
60     mv %{buildroot}%{_docdir}/%{name}/{AUTHORS.txt,LICENSE.txt,README.txt} _tmpdoc
61    
62     %package devel
63     Summary: Development files for UHD
64 barjac 196168 Group: Communications
65 barjac 196101 Requires: %{name} = %{version}-%{release}
66    
67     %description devel
68     Development files for the Universal Hardware Driver (UHD).
69    
70     %package doc
71     Summary: Documentation files for UHD
72 barjac 196168 Group: Communications
73 barjac 196101 BuildArch: noarch
74    
75     %description doc
76     Documentation for the Universal Hardware Driver (UHD).
77    
78     %pre -n uhd
79     getent group usrp >/dev/null || groupadd -r usrp
80    
81     %files
82     %doc _tmpdoc/*
83     %{_bindir}/uhd_find_devices
84     %{_bindir}/uhd_usrp_probe
85     %config(noreplace) %{_sysconfdir}/udev/rules.d/10-usrp-uhd.rules
86     %{_libdir}/lib*.so.*
87     %{_libexecdir}/uhd
88    
89     %files devel
90     %{_includedir}/*
91     %{_libdir}/lib*.so
92     %{_libdir}/pkgconfig/*.pc
93    
94     %files doc
95     %doc %{_docdir}/%{name}/*

  ViewVC Help
Powered by ViewVC 1.1.30