/[packages]/cauldron/uhd/current/SPECS/uhd.spec
ViewVC logotype

Annotation of /cauldron/uhd/current/SPECS/uhd.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 249840 - (hide annotations) (download)
Wed May 30 06:09:54 2012 UTC (12 years, 3 months ago) by fwang
File size: 2548 byte(s)
drop unused command
1 barjac 196101 Name: uhd
2     URL: http://code.ettus.com/redmine/ettus/projects/uhd/wiki
3 barjac 232342 Version: 3.4.1
4 fwang 249727 Release: %mkrel 2
5 barjac 196157 Group: Communications
6     Summary: Universal Hardware Driver for Ettus Research products
7 barjac 196101 License: GPLv3+
8 barjac 196157 Source0: %{name}-%{version}.tar.gz
9 barjac 217237 # Create tarball from git with:
10     # $ make-tarball uhd git://code.ettus.com/ettus/uhd.git
11     # See note in make-tarball script
12     Source1: make-tarball
13    
14 barjac 196101 BuildRequires: cmake
15 barjac 196157 BuildRequires: boost-devel
16     BuildRequires: libusb1-devel
17     BuildRequires: liborc-devel
18     BuildRequires: python-cheetah
19     BuildRequires: python-docutils
20     BuildRequires: doxygen
21     BuildRequires: pkgconfig
22 barjac 196101
23     %description
24     The UHD is the universal hardware driver for Ettus Research products.
25     The goal of the UHD is to provide a host driver and API for current and
26     future Ettus Research products. It can be used standalone without GNU Radio.
27    
28     %prep
29     %setup -q
30    
31     %build
32 fwang 249727 pushd host
33     %cmake
34 barjac 196157 %make
35 fwang 249727 popd
36 barjac 196101
37     %check
38     cd host/build
39     make test
40    
41     %install
42 fwang 249727 %makeinstall_std -C host/build
43 barjac 196101
44     # Allow access only to users in usrp group
45     sed -i 's/MODE:="0666"/MODE:="0660"/' %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules
46     mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d
47     mv %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules %{buildroot}%{_sysconfdir}/udev/rules.d/10-usrp-uhd.rules
48    
49     # Remove binaries for tests, examples
50     rm -rf %{buildroot}%{_datadir}/uhd/{tests,examples}
51    
52     # Move the utils stuff to libexec dir
53     mkdir -p %{buildroot}%{_libexecdir}/uhd
54     mv %{buildroot}%{_datadir}/uhd/utils/* %{buildroot}%{_libexecdir}/uhd
55    
56     # Package base docs to base package
57     mkdir _tmpdoc
58     mv %{buildroot}%{_docdir}/%{name}/{AUTHORS.txt,LICENSE.txt,README.txt} _tmpdoc
59    
60     %package devel
61     Summary: Development files for UHD
62 barjac 196168 Group: Communications
63 barjac 196101 Requires: %{name} = %{version}-%{release}
64    
65     %description devel
66     Development files for the Universal Hardware Driver (UHD).
67    
68     %package doc
69     Summary: Documentation files for UHD
70 barjac 196168 Group: Communications
71 barjac 196101 BuildArch: noarch
72    
73     %description doc
74     Documentation for the Universal Hardware Driver (UHD).
75    
76     %pre -n uhd
77     getent group usrp >/dev/null || groupadd -r usrp
78    
79     %files
80     %doc _tmpdoc/*
81     %{_bindir}/uhd_find_devices
82     %{_bindir}/uhd_usrp_probe
83 barjac 232342 %{_bindir}/uhd_cal_rx_iq_balance
84     %{_bindir}/uhd_cal_tx_dc_offset
85     %{_bindir}/uhd_cal_tx_iq_balance
86 barjac 196101 %config(noreplace) %{_sysconfdir}/udev/rules.d/10-usrp-uhd.rules
87     %{_libdir}/lib*.so.*
88     %{_libexecdir}/uhd
89    
90     %files devel
91     %{_includedir}/*
92     %{_libdir}/lib*.so
93     %{_libdir}/pkgconfig/*.pc
94    
95     %files doc
96     %doc %{_docdir}/%{name}/*
97 barjac 232342

  ViewVC Help
Powered by ViewVC 1.1.30