/[packages]/cauldron/uhd/current/SPECS/uhd.spec
ViewVC logotype

Annotation of /cauldron/uhd/current/SPECS/uhd.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2087746 - (hide annotations) (download)
Thu Aug 22 13:23:42 2024 UTC (2 weeks, 3 days ago) by barjac
File size: 3745 byte(s)
- new version 4.7.0
- remove obsolete patches
- remove python temporary fixes related to python 2 to 3 updgrade
1 barjac 1631907 %define major 4
2 barjac 1085065 %define libname %mklibname %{name} %{major}
3 daviddavid 1439873 %define devname %mklibname %{name} -d
4 barjac 1085065
5 wally 1441618 # comment out if not prerel
6 barjac 1476039 #define prel rc1
7 wally 1441618
8 barjac 1476039 # Release
9 barjac 2087746 %define rel 1
10 wally 1441618
11 barjac 196101 Name: uhd
12 barjac 1050270 Summary: Universal Hardware Driver for Ettus Research products
13 barjac 2087746 Version: 4.7.0.0
14 wally 1441618 Release: %mkrel %{?prel:0.%prel.}%{rel}
15 barjac 299080 Group: Communications/Radio
16 barjac 196101 License: GPLv3+
17 wally 2075535 Url: http://uhd.ettus.com/
18     Source0: https://github.com/EttusResearch/uhd/archive/v%{version}%{?prel:-%prel}/%{name}-%{version}%{?prel:-%prel}.tar.gz
19 barjac 1393227 # Bug tracker https://github.com/EttusResearch/uhd/issues
20 barjac 1852641
21 barjac 196101 BuildRequires: cmake
22 barjac 914236 BuildRequires: boost-devel
23 barjac 1631907 BuildRequires: git
24 barjac 1239719 BuildRequires: pkgconfig(ncurses)
25 barjac 1171607 BuildRequires: pkgconfig(libgps)
26 barjac 341382 BuildRequires: pkgconfig(libusb-1.0)
27 barjac 1631907 BuildRequires: pkgconfig(python3)
28 barjac 1439521 BuildRequires: python3-docutils
29     BuildRequires: python3-mako
30     BuildRequires: python3-numpy-devel
31     BuildRequires: python3-requests
32 barjac 1852641 BuildRequires: python3-ruamel-yaml
33 barjac 1439521 BuildRequires: python3-setuptools
34 barjac 196157 BuildRequires: doxygen
35     BuildRequires: pkgconfig
36 barjac 196101
37     %description
38     The UHD is the universal hardware driver for Ettus Research products.
39     The goal of the UHD is to provide a host driver and API for current and
40     future Ettus Research products. It can be used standalone without GNU Radio.
41    
42     %prep
43 wally 1441618 %autosetup -p1 -n %{name}-%{version}%{?prel:-%prel}
44 barjac 196101
45     %build
46 wally 1474211 %global _vpath_srcdir host
47 barjac 1357881 %cmake \
48 wally 1744694 -DCMAKE_SKIP_RPATH=ON \
49 barjac 1393227 -DENABLE_UTILS=ON \
50     -DENABLE_E100=ON \
51     -DENABLE_E300=ON \
52 wally 1441618 -DENABLE_PYTHON_API=ON \
53 barjac 1439521 -DENABLE_PYTHON3=ON \
54 barjac 1393227 -DENABLE_TESTS=OFF \
55     -DENABLE_EXAMPLES=OFF \
56 barjac 1357881 %ifarch %arm
57 barjac 1393227 -DNEON_SIMD_ENABLE=OFF
58 barjac 1357881 %endif
59 wally 1474211 %cmake_build
60 barjac 909266
61 barjac 196101 %install
62 wally 1474211 %cmake_install
63 wally 1441618
64 barjac 196101 # Allow access only to users in usrp group
65 barjac 909266 mkdir -p %{buildroot}%{_udevrulesdir}
66 barjac 1086302 mv %{buildroot}%{_libdir}/uhd/utils/uhd-usrp.rules %{buildroot}%{_udevrulesdir}/10-usrp-uhd.rules
67 barjac 1085065 sed -i 's/MODE:="0666"/MODE:="0660"/' %{buildroot}%{_udevrulesdir}/10-usrp-uhd.rules
68 barjac 196101
69     # Remove binaries for tests, examples
70 barjac 1085065 rm -rf %{buildroot}%{_libdir}/uhd/{tests,examples}
71 barjac 196101
72     # Move the utils stuff to libexec dir
73     mkdir -p %{buildroot}%{_libexecdir}/uhd
74 barjac 1085065 mv %{buildroot}%{_libdir}/uhd/utils %{buildroot}%{_libexecdir}/uhd/utils
75     mv %{buildroot}%{_datadir}/uhd/rfnoc %{buildroot}%{_libexecdir}/uhd/
76 barjac 196101
77     # Package base docs to base package
78     mkdir _tmpdoc
79 barjac 588134 mv %{buildroot}%{_docdir}/%{name}/{LICENSE,README.md} _tmpdoc
80 barjac 196101
81 barjac 1171607 # Make version sane in uhd.pc
82     sed -i '/Version/c Version: %{version}' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
83    
84 barjac 1085065 %package -n %{libname}
85 barjac 1239719 Summary: Library files
86 barjac 299080 Group: Communications/Radio
87 barjac 196101 Requires: %{name} = %{version}-%{release}
88    
89 barjac 1085065 %description -n %{libname}
90     Library files for the Universal Hardware Driver (UHD).
91    
92     %package -n %{devname}
93     Summary: Development files for UHD
94     Group: Communications/Radio
95     Requires: %{libname} = %{version}-%{release}
96     Provides: %{name}-devel = %{version}-%{release}
97    
98     %description -n %{devname}
99 barjac 196101 Development files for the Universal Hardware Driver (UHD).
100    
101     %package doc
102     Summary: Documentation files for UHD
103 barjac 299080 Group: Communications/Radio
104 barjac 196101 BuildArch: noarch
105    
106     %description doc
107     Documentation for the Universal Hardware Driver (UHD).
108    
109     %pre -n uhd
110     getent group usrp >/dev/null || groupadd -r usrp
111    
112     %files
113     %doc _tmpdoc/*
114 barjac 1476039 %{_bindir}/*
115 barjac 1631907 %{_datadir}/%{name}/cal/*.fbs
116 barjac 909266 %{_udevrulesdir}/10-usrp-uhd.rules
117 barjac 1745895 %{_libexecdir}/%{name}
118 daviddavid 1439873 %{python3_sitearch}/%{name}/
119 barjac 1745895 %{python3_sitearch}/usrp_mpm/
120 barjac 196101
121 barjac 1085065 %files -n %{libname}
122     %{_libdir}/lib%{name}.so.%{major}{,.*}
123    
124     %files -n %{devname}
125 barjac 196101 %{_includedir}/*
126 barjac 1085065 %{_libdir}/lib%{name}.so
127 barjac 196101 %{_libdir}/pkgconfig/*.pc
128 barjac 1745895 %{_libdir}/cmake/%{name}/
129 barjac 196101
130     %files doc
131 daviddavid 1439873 %doc %{_docdir}/%{name}/
132 barjac 433512 %{_mandir}/man1/*

  ViewVC Help
Powered by ViewVC 1.1.30