1 |
Name: uhd |
2 |
URL: http://code.ettus.com/redmine/ettus/projects/uhd/wiki |
3 |
Version: 3.5.0 |
4 |
Release: %mkrel 2 |
5 |
Group: Communications/Radio |
6 |
Summary: Universal Hardware Driver for Ettus Research products |
7 |
License: GPLv3+ |
8 |
Source0: %{name}-%{version}.tar.gz |
9 |
# Create tarball from git with: |
10 |
# $ ./make-tarball uhd git://code.ettus.com/ettus/uhd.git |
11 |
# See note in make-tarball script |
12 |
Source1: make-tarball |
13 |
|
14 |
BuildRequires: cmake |
15 |
BuildRequires: boost-devel |
16 |
BuildRequires: pkgconfig(libusb-1.0) |
17 |
BuildRequires: pkgconfig(orc-0.4) |
18 |
BuildRequires: python-cheetah |
19 |
BuildRequires: python-docutils |
20 |
BuildRequires: doxygen |
21 |
BuildRequires: pkgconfig |
22 |
|
23 |
%description |
24 |
The UHD is the universal hardware driver for Ettus Research products. |
25 |
The goal of the UHD is to provide a host driver and API for current and |
26 |
future Ettus Research products. It can be used standalone without GNU Radio. |
27 |
|
28 |
%prep |
29 |
%setup -q |
30 |
|
31 |
%build |
32 |
pushd host |
33 |
%cmake |
34 |
%make |
35 |
popd |
36 |
|
37 |
%install |
38 |
%makeinstall_std -C host/build |
39 |
|
40 |
# Allow access only to users in usrp group |
41 |
sed -i 's/MODE:="0666"/MODE:="0660"/' %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules |
42 |
mkdir -p %{buildroot}%{_prefix}/lib/udev/rules.d |
43 |
mv %{buildroot}%{_datadir}/uhd/utils/uhd-usrp.rules %{buildroot}%{_prefix}/lib/udev/rules.d/10-usrp-uhd.rules |
44 |
|
45 |
# Remove binaries for tests, examples |
46 |
rm -rf %{buildroot}%{_datadir}/uhd/{tests,examples} |
47 |
|
48 |
# Move the utils stuff to libexec dir |
49 |
mkdir -p %{buildroot}%{_libexecdir}/uhd |
50 |
mv %{buildroot}%{_datadir}/uhd/utils/* %{buildroot}%{_libexecdir}/uhd |
51 |
|
52 |
# Package base docs to base package |
53 |
mkdir _tmpdoc |
54 |
mv %{buildroot}%{_docdir}/%{name}/{AUTHORS.txt,LICENSE.txt,README.txt} _tmpdoc |
55 |
|
56 |
%package devel |
57 |
Summary: Development files for UHD |
58 |
Group: Communications/Radio |
59 |
Requires: %{name} = %{version}-%{release} |
60 |
|
61 |
%description devel |
62 |
Development files for the Universal Hardware Driver (UHD). |
63 |
|
64 |
%package doc |
65 |
Summary: Documentation files for UHD |
66 |
Group: Communications/Radio |
67 |
BuildArch: noarch |
68 |
|
69 |
%description doc |
70 |
Documentation for the Universal Hardware Driver (UHD). |
71 |
|
72 |
%pre -n uhd |
73 |
getent group usrp >/dev/null || groupadd -r usrp |
74 |
|
75 |
%files |
76 |
%doc _tmpdoc/* |
77 |
%{_bindir}/uhd_find_devices |
78 |
%{_bindir}/uhd_usrp_probe |
79 |
%{_bindir}/uhd_cal_rx_iq_balance |
80 |
%{_bindir}/uhd_cal_tx_dc_offset |
81 |
%{_bindir}/uhd_cal_tx_iq_balance |
82 |
%{_prefix}/lib/udev/rules.d/10-usrp-uhd.rules |
83 |
%{_libdir}/lib*.so.* |
84 |
%{_libexecdir}/uhd |
85 |
|
86 |
%files devel |
87 |
%{_includedir}/* |
88 |
%{_libdir}/lib*.so |
89 |
%{_libdir}/pkgconfig/*.pc |
90 |
|
91 |
%files doc |
92 |
%doc %{_docdir}/%{name}/* |