1 |
neoclust |
1100701 |
%global namedreltag .Final |
2 |
|
|
%global namedversion %{version}%{?namedreltag} |
3 |
|
|
Name: wildfly-build-tools |
4 |
|
|
Version: 1.1.6 |
5 |
umeabot |
1501248 |
Release: %mkrel 3 |
6 |
neoclust |
1100701 |
Group: Development/Java |
7 |
|
|
Summary: Wildfly build and provisioning tools |
8 |
|
|
License: ASL 2.0 |
9 |
|
|
URL: https://github.com/wildfly/wildfly-build-tools |
10 |
|
|
Source0: https://github.com/wildfly/wildfly-build-tools/archive/%{namedversion}.tar.gz |
11 |
|
|
|
12 |
|
|
BuildRequires: maven-local |
13 |
|
|
BuildRequires: mvn(junit:junit) |
14 |
|
|
BuildRequires: mvn(org.apache.maven:maven-aether-provider) |
15 |
|
|
BuildRequires: mvn(org.apache.maven:maven-compat) |
16 |
|
|
BuildRequires: mvn(org.apache.maven:maven-core) |
17 |
|
|
BuildRequires: mvn(org.apache.maven:maven-model) |
18 |
|
|
BuildRequires: mvn(org.apache.maven:maven-plugin-api) |
19 |
|
|
BuildRequires: mvn(org.apache.maven:maven-settings-builder) |
20 |
|
|
BuildRequires: mvn(org.apache.maven.plugin-testing:maven-plugin-testing-harness) |
21 |
|
|
BuildRequires: mvn(org.apache.maven.plugin-tools:maven-plugin-annotations) |
22 |
|
|
BuildRequires: mvn(org.apache.maven.plugins:maven-enforcer-plugin) |
23 |
|
|
BuildRequires: mvn(org.apache.maven.plugins:maven-plugin-plugin) |
24 |
|
|
BuildRequires: mvn(org.eclipse.aether:aether-api) |
25 |
|
|
BuildRequires: mvn(org.eclipse.aether:aether-connector-basic) |
26 |
|
|
BuildRequires: mvn(org.eclipse.aether:aether-impl) |
27 |
|
|
BuildRequires: mvn(org.eclipse.aether:aether-spi) |
28 |
|
|
BuildRequires: mvn(org.eclipse.aether:aether-transport-file) |
29 |
|
|
BuildRequires: mvn(org.eclipse.aether:aether-transport-http) |
30 |
|
|
BuildRequires: mvn(org.eclipse.aether:aether-util) |
31 |
|
|
BuildRequires: mvn(org.jboss:jandex) |
32 |
|
|
BuildRequires: mvn(org.jboss:jboss-parent:pom:) |
33 |
|
|
BuildRequires: mvn(org.jboss:staxmapper) |
34 |
|
|
BuildRequires: mvn(org.jboss.logging:jboss-logging) |
35 |
|
|
BuildRequires: mvn(org.jboss.logging:jboss-logging-annotations) |
36 |
|
|
|
37 |
|
|
BuildArch: noarch |
38 |
|
|
|
39 |
|
|
%description |
40 |
|
|
Tools used for building and provisioning the Wildfly server. |
41 |
|
|
|
42 |
|
|
%package -n wildfly-feature-pack-build-maven-plugin |
43 |
|
|
Summary: WildFly Build Tools: Feature Pack Build Maven Plugin |
44 |
|
|
|
45 |
|
|
%description -n wildfly-feature-pack-build-maven-plugin |
46 |
|
|
This package contains WildFly Build Tools Feature Pack Build Maven Plugin. |
47 |
|
|
|
48 |
|
|
%package -n wildfly-server-provisioning |
49 |
|
|
Summary: WildFly Build Tools: Server Provisioning |
50 |
|
|
|
51 |
|
|
%description -n wildfly-server-provisioning |
52 |
|
|
This package contains WildFly Build Tools Server Provisioning. |
53 |
|
|
|
54 |
|
|
%package -n wildfly-server-provisioning-maven-plugin |
55 |
|
|
Summary: WildFly Build Tools: Server Provisioning Maven Plugin |
56 |
|
|
|
57 |
|
|
%description -n wildfly-server-provisioning-maven-plugin |
58 |
|
|
This package contains WildFly Build Tools Server Provisioning Maven Plugin. |
59 |
|
|
|
60 |
|
|
%package -n wildfly-server-provisioning-standalone |
61 |
|
|
Summary: WildFly Build Tools: Server Provisioning Standalone |
62 |
|
|
|
63 |
|
|
%description -n wildfly-server-provisioning-standalone |
64 |
|
|
This package contains WildFly Build Tools Server Provisioning Standalone. |
65 |
|
|
|
66 |
|
|
%package javadoc |
67 |
|
|
Summary: Javadoc for %{name} |
68 |
|
|
|
69 |
|
|
%description javadoc |
70 |
|
|
This package contains javadoc for %{name}. |
71 |
|
|
|
72 |
|
|
%prep |
73 |
|
|
%setup -q -n %{name}-%{namedversion} |
74 |
|
|
|
75 |
|
|
# Use not available org.wildfly.checkstyle:wildfly-checkstyle-config:jar:1.0.0.Final |
76 |
|
|
%pom_remove_plugin -r :maven-checkstyle-plugin |
77 |
|
|
|
78 |
|
|
%pom_remove_plugin -r :maven-shade-plugin |
79 |
|
|
%pom_remove_dep -r :wildfly-checkstyle-config |
80 |
|
|
|
81 |
|
|
%pom_remove_dep -r org.sonatype.aether: |
82 |
|
|
|
83 |
|
|
# disable maven-invoker-plugin |
84 |
|
|
%pom_xpath_remove pom:profiles provisioning-maven-plugin |
85 |
|
|
|
86 |
|
|
%build |
87 |
|
|
|
88 |
|
|
%mvn_build -s |
89 |
|
|
|
90 |
|
|
%install |
91 |
|
|
%mvn_install |
92 |
|
|
|
93 |
|
|
%files -f .mfiles-wildfly-build-tools-parent |
94 |
|
|
%license LICENSE.txt |
95 |
|
|
|
96 |
|
|
%files -n wildfly-feature-pack-build-maven-plugin -f .mfiles-wildfly-feature-pack-build-maven-plugin |
97 |
|
|
|
98 |
|
|
%files -n wildfly-server-provisioning -f .mfiles-wildfly-server-provisioning |
99 |
|
|
%license LICENSE.txt |
100 |
|
|
|
101 |
|
|
%files -n wildfly-server-provisioning-maven-plugin -f .mfiles-wildfly-server-provisioning-maven-plugin |
102 |
|
|
%files -n wildfly-server-provisioning-standalone -f .mfiles-wildfly-server-provisioning-standalone |
103 |
|
|
|
104 |
|
|
%files javadoc -f .mfiles-javadoc |
105 |
|
|
%license LICENSE.txt |
106 |
|
|
|