/[packages]/cauldron/wine-gecko/current/SPECS/wine-gecko.spec
ViewVC logotype

Annotation of /cauldron/wine-gecko/current/SPECS/wine-gecko.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 67277 - (hide annotations) (download)
Thu Mar 10 01:40:22 2011 UTC (13 years, 1 month ago) by ahmad
File size: 3189 byte(s)
imported package wine-gecko
1 ahmad 67277
2     %define name wine-gecko
3     %define oname wine-mozilla
4     %define version 1.1.0
5     %define rel 1
6    
7     # random working revision from mingw-w64 trunk:
8     %define mingw64_snap 2847
9     # not working due to various errors:
10     # - 3272 (crt build failure)
11     # - 3500 (redefinition of UINT8 while building mozilla)
12     # - 3713 (crt build failure)
13    
14     # See:
15     # http://wiki.winehq.org/Gecko
16     # http://wiki.winehq.org/BuildingWineGecko
17    
18     # We bundle custom versions of mingw64 headers and crt here because
19     # wine-gecko does not currently build with those from our system mingw32.
20    
21     Summary: HTML engine for Wine based on Gecko
22     Name: %{name}
23     Version: %{version}
24     Release: %mkrel %{rel}
25     Group: Emulators
26     License: MPLv1.1
27     URL: http://wiki.winehq.org/Gecko
28     Source: http://downloads.sourceforge.net/wine/%{oname}-%{version}-src.tar.bz2
29     # https://mingw-w64.svn.sourceforge.net/svnroot/mingw-w64/trunk
30     Source1: mingw-w64-headers-svn%mingw64_snap.tar.bz2
31     Source2: mingw-w64-crt-svn%mingw64_snap.tar.bz2
32     BuildRoot: %{_tmppath}/%{name}-root
33     # We would need a mingw64 crosscompiler for a 64-bit binary.
34     # NOTE: building this package as-is on x86_64 will build a 32-bit binary instead.
35     ExclusiveArch: %ix86
36     Requires: wine32
37     BuildRequires: mingw32-gcc
38     BuildRequires: mingw32-gcc-c++
39     BuildRequires: autoconf2.1
40     BuildRequires: zip
41     BuildRequires: glib2-devel
42     BuildRequires: libIDL-devel
43     BuildRequires: x11-proto-devel
44     # lcab creates cabs without compression, but it is better than nothing
45     BuildRequires: lcab
46    
47     %description
48     A custom version of Mozilla's Gecko Layout Engine for Wine. This package
49     is needed when running such Windows applications in Wine that display web
50     pages using embedded IE.
51    
52     %prep
53     %setup -q -c -a1 -a2
54    
55     %build
56     # disabled as build fails due to various issues if set:
57     # %%_mingw32_env
58    
59     builddir=$PWD
60     mkdir -p mingw-headers-build mingw-crt-build
61     cd mingw-headers-build
62     ../mingw-w64-headers/configure --host=%_mingw32_host --prefix=$builddir/mingw-sysroot --enable-sdk=all
63     %make install
64     ln -s %_mingw32_host $builddir/mingw-sysroot/mingw
65     cd ..
66    
67     OVERRIDE_FLAGS="--sysroot=$builddir/mingw-sysroot"
68     export CC="%_mingw32_cc $OVERRIDE_FLAGS"
69     export CXX="%_mingw32_cxx $OVERRIDE_FLAGS"
70    
71     cd mingw-crt-build
72     ../mingw-w64-crt/configure --host=%_mingw32_host --prefix=$builddir/mingw-sysroot
73     %make
74     %make install
75     cd ..
76    
77     # Something strange happens here. Mozilla configure will detect this as true,
78     # but the relevant code using __stdcall will fail to compile anyway (even if
79     # the test in configure compiled fine). - Anssi 10/2010
80     export ac_cv___stdcall=false
81    
82     cd wine-mozilla
83     cp -af wine/mozconfig wine/mozconfig-mdv
84     echo "ac_add_options --target=%_mingw32_host" >> wine/mozconfig-mdv
85     export MOZCONFIG=$PWD/wine/mozconfig-mdv
86    
87     %make -f client.mk build
88     wine/make_package ../wine_gecko
89     cd ../wine_gecko/dist
90    
91     lcab -r wine_gecko ../../wine_gecko-%{version}-x86.cab
92    
93     %install
94     rm -rf %{buildroot}
95     install -d -m755 %{buildroot}%{_datadir}/wine/gecko
96     install -m644 wine_gecko-%{version}-x86.cab %{buildroot}%{_datadir}/wine/gecko
97    
98     %clean
99     rm -rf %{buildroot}
100    
101     %files
102     %defattr(-,root,root)
103     %doc wine-mozilla/LEGAL
104     %doc wine-mozilla/LICENSE
105     %doc wine-mozilla/toolkit/content/license.html
106     %dir %{_datadir}/wine/gecko
107     %{_datadir}/wine/gecko/*.cab
108    
109    

  ViewVC Help
Powered by ViewVC 1.1.30