/[packages]/cauldron/wine/current/SPECS/wine.spec
ViewVC logotype

Annotation of /cauldron/wine/current/SPECS/wine.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 120933 - (hide annotations) (download)
Sat Jul 9 07:52:22 2011 UTC (12 years, 9 months ago) by ahmad
File size: 15254 byte(s)
- Update to 1.3.24
1 ahmad 36061 %ifarch x86_64
2     %define wine wine64
3     %define mark64 ()(64bit)
4     %else
5     %define wine wine
6     %define mark64 %{nil}
7     %endif
8     %define lib_name_orig lib%{name}
9     %define lib_major 1
10     %define lib_name %mklibname %{name} %{lib_major}
11     %define lib_name_devel %{mklibname -d wine}
12    
13     # On 32-bit we have
14     # wine32 - those 32-bit binaries that are also used on 64-bit for 32-bit support
15     # wine - all other files (requires 'wine32')
16     # On 64-bit we have
17     # wine64 - all 64-bit files (suggests 'wine32')
18     # - Anssi 07/2010
19    
20     Name: wine
21 ahmad 120933 Version: 1.3.24
22 ahmad 36061 %define pre 0
23 ahmad 101529 %define rel 1
24 ahmad 36061 %if %pre
25     Release: %mkrel 0.%pre.%rel
26     %define o_ver %version-%pre
27     %else
28     Release: %mkrel %rel
29     %define o_ver %version
30     %endif
31     Epoch: 1
32     Summary: WINE Is Not An Emulator - runs MS Windows programs
33     License: LGPLv2+
34     Group: Emulators
35     URL: http://www.winehq.com/
36 ahmad 103264 Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2
37     Source1: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2.sign
38 ahmad 36061
39     # RH stuff
40     Source2: wine.init
41     Patch0: wine-1.0-rc3-fix-conflicts-with-openssl.patch
42     Patch1: wine-1.1.7-chinese-font-substitutes.patch
43     # (Anssi 05/2008) Adds:
44     # a: => /media/floppy (/mnt/floppy on 2007.1 and older)
45     # d: => $HOME (at config_dir creation time, not refreshed if $HOME changes;
46     # note that Wine also provides $HOME in My Documents)
47     # com4 => /dev/ttyUSB0 (replaces /dev/ttyS3)
48 ahmad 37896 Patch108: wine-mgaconf.patch
49 ahmad 36061
50     #(eandry) add a pulseaudio sound driver (from http://art.ified.ca/downloads/ )
51 ahmad 113795 Patch400: http://art.ified.ca/downloads/winepulse/winepulse-configure.ac-1.3.22.patch
52     Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.40.patch
53 ahmad 37896 Patch402: http://art.ified.ca/downloads/winepulse/winepulse-winecfg-1.3.11.patch
54 ahmad 36061
55     # (anssi) Wine needs GCC 4.4+ on x86_64 for MS ABI support. Note also that
56 anssi 96590 # 64-bit wine cannot run 32-bit programs without wine32.
57 ahmad 36061 %ifarch x86_64
58     BuildRequires: gcc >= 4.4
59     %endif
60 ahmad 101529 BuildRequires: bison flex
61 ahmad 71420 BuildRequires: gpm-devel
62     BuildRequires: perl-devel
63     BuildRequires: ncurses-devel
64     BuildRequires: cups-devel
65     BuildRequires: sane-devel
66     BuildRequires: lcms-devel
67     BuildRequires: autoconf
68     BuildRequires: docbook-utils docbook-dtd-sgml
69     BuildRequires: docbook-utils docbook-dtd-sgml sgml-tools
70     BuildRequires: jackit-devel
71     BuildRequires: pulseaudio-devel
72 ahmad 36061 BuildRequires: libmpg123-devel
73     BuildRequires: openal-devel
74 ahmad 71420 BuildRequires: libalsa-devel
75 ahmad 36061 BuildRequires: gstreamer0.10-devel libgstreamer0.10-plugins-base-devel
76 ahmad 71420 BuildRequires: isdn4k-utils-devel
77     BuildRequires: glibc-static-devel
78     BuildRequires: chrpath
79     BuildRequires: ungif-devel xpm-devel
80     BuildRequires: tiff-devel
81     BuildRequires: librsvg
82     BuildRequires: imagemagick
83     BuildRequires: gphoto2-devel
84     BuildRequires: desktop-file-utils
85     BuildRequires: openldap-devel
86     BuildRequires: libxslt-devel
87     BuildRequires: dbus-devel
88     BuildRequires: hal-devel
89 ahmad 110810 BuildRequires: valgrind-devel
90 ahmad 71420 BuildRequires: gsm-devel
91     BuildRequires: unixODBC-devel
92 ahmad 110810 BuildRequires: gnutls-devel
93 ahmad 36061 BuildRequires: prelink
94 ahmad 70893 BuildRequires: gettext-devel
95 ahmad 71420 BuildRequires: mesaglu-devel
96     BuildRequires: libv4l-devel
97     BuildRequires: libxcursor-devel libxcomposite-devel
98     BuildRequires: libxinerama-devel libxrandr-devel
99     BuildRequires: libx11-devel libxrender-devel
100     BuildRequires: libxext-devel libsm-devel
101     BuildRequires: fontforge fontconfig-devel freetype2-devel
102 ahmad 36061
103     %define desc Wine is a program which allows running Microsoft Windows programs \
104     (including DOS, Windows 3.x and Win32 executables) on Unix. It \
105     consists of a program loader which loads and executes a Microsoft \
106     Windows binary, and a library (called Winelib) that implements Windows \
107     API calls using their Unix or X11 equivalents. The library may also \
108     be used for porting Win32 code into native Unix executables.
109    
110     %ifarch x86_64
111     %package -n %{wine}
112     Summary: WINE Is Not An Emulator - runs MS Windows programs
113     Group: Emulators
114     Suggests: wine32 = %{epoch}:%{version}-%{release}
115 anssi 96590 Suggests: wine64-gecko
116 ahmad 36061 %else
117     # on 32-bit we always want wine32 package
118     Requires: wine32 = %{epoch}:%{version}-%{release}
119     %endif
120    
121     Provides: %{wine}-utils = %{epoch}:%{version}-%{release} %{wine}-full = %{epoch}:%{version}-%{release}
122     Provides: %{lib_name}-capi = %{epoch}:%{version}-%{release} %{lib_name}-twain = %{epoch}:%{version}-%{release}
123     Provides: %{lib_name} = %{epoch}:%{version}-%{release}
124     Provides: wine-bin = %{epoch}:%{version}-%{release}
125     Obsoletes: %{wine}-utils %{wine}-full %{lib_name}-capi %{lib_name}-twain
126     Obsoletes: %{lib_name} <= %{epoch}:%{version}-%{release}
127     Requires: xmessage
128     Suggests: sane-frontends
129     # wine dlopen's these, so let's add the dependencies ourself
130     Requires: libfreetype.so.6%{mark64} libasound.so.2%{mark64}
131 ahmad 72084 # wine needs to dlopen libfontconfig to make CJK fonts show correctly in winecfg
132     Requires: libfontconfig.so.1%{mark64}
133 ahmad 72093 Requires: libncurses.so.5%{mark64}
134 ahmad 36061 Requires: libXrender.so.1%{mark64} libpng.so.3%{mark64}
135     Requires(post): desktop-file-utils
136     Requires(postun): desktop-file-utils
137     Requires(post): desktop-common-data
138     Requires(postun): desktop-common-data
139     Requires(preun): rpm-helper
140     Requires(post): rpm-helper
141     %ifarch %{ix86}
142     Conflicts: wine64
143     %else
144     Conflicts: wine
145     %endif
146    
147     %description
148     %desc
149    
150     %ifarch x86_64
151     %description -n %{wine}
152     %desc
153    
154     This package contains the Win64 version of Wine. You need the wine32
155     package from the 32-bit repository to be able to run 32-bit applications.
156     %endif
157    
158     %ifarch %ix86
159     %package -n wine32
160     Summary: 32-bit support for Wine
161     Group: Emulators
162     # This is not an EVR-specific requirement, as otherwise on x86_64 urpmi could
163     # resolve the dependency to wine64 even on upgrades, and therefore replace
164     # wine+wine32 installation with a wine32+wine64 installation. - Anssi
165     Requires: wine-bin
166     Conflicts: wine < 1:1.2-0.rc7.1
167     Conflicts: wine64 < 1:1.2-0.rc7.1
168     # (Anssi) If wine-gecko is not installed, wine pops up a dialog on first
169     # start proposing to download wine-gecko from sourceforge, while recommending
170     # to use distribution packages instead. Therefore suggest wine-gecko here:
171     Suggests: wine-gecko
172    
173     %description -n wine32
174     Wine is a program which allows running Microsoft Windows programs
175     (including DOS, Windows 3.x and Win32 executables) on Unix.
176    
177     This package contains the files needed to support 32-bit Windows
178     programs.
179     %endif
180    
181     %package -n %{wine}-devel
182     Summary: Static libraries and headers for %{name}
183     Group: Development/C
184     Requires: %{wine} = %{epoch}:%{version}
185     Provides: %{lib_name_devel} = %{epoch}:%{version}-%{release}
186     Provides: %{lib_name_orig}-devel = %{epoch}:%{version}-%{release}
187     Obsoletes: %{lib_name_devel} <= %{epoch}:%{version}-%{release}
188     Obsoletes: %{mklibname -d wine 1} < %{epoch}:%{version}
189     %ifarch %{ix86}
190     Conflicts: wine64-devel
191     %else
192     Conflicts: wine-devel
193     %endif
194    
195     %description -n %{wine}-devel
196     Wine is a program which allows running Microsoft Windows programs
197     (including DOS, Windows 3.x and Win32 executables) on Unix.
198    
199     %{wine}-devel contains the libraries and header files needed to
200     develop programs which make use of wine.
201    
202     Wine is often updated.
203    
204     %prep
205     %setup -q -n %name-%o_ver
206     %patch1 -p0 -b .chinese
207     %patch108 -p1 -b .conf
208     %patch400 -p1
209     %patch401 -p1
210     %patch402 -p1
211    
212     %build
213     %ifarch %ix86
214     # (Anssi 04/2008) bug #39604
215     # Some protection systems complain "debugger detected" with our
216     # -fomit-frame-pointer flag, so disable it.
217     export CFLAGS="%{optflags} -fno-omit-frame-pointer"
218     %endif
219    
220     # (Anssi 04/2008)
221     # If icotool is present, it is used to rebuild icon files. It is in contrib
222     # so we do not do that; this is here to ensure that installed icoutils does
223     # not change build behaviour.
224     export ICOTOOL=false
225    
226     autoreconf
227     %configure2_5x --with-x \
228     --with-pulse \
229     --without-nas \
230     --without-esd \
231     %ifarch x86_64
232     --enable-win64
233     %endif
234    
235     %make depend
236     %make
237    
238     %install
239     rm -rf %{buildroot}
240     %makeinstall_std LDCONFIG=/bin/true
241    
242     # Danny: dirty:
243     install -m755 tools/fnt2bdf -D %{buildroot}%{_bindir}/fnt2bdf
244    
245     # Allow users to launch Windows programs by just clicking on the .exe file...
246     install -m755 %{SOURCE2} -D %{buildroot}%{_initrddir}/%{name}
247    
248     mkdir -p %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged
249     cat > %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged/mageia-%{name}.menu <<EOF
250     <!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
251     "http://www.freedesktop.org/standards/menu-spec/menu-1.0.dtd">
252     <Menu>
253     <Name>Applications</Name>
254     <Menu>
255     <Name>Tools</Name>
256     <Menu>
257     <Name>Emulators</Name>
258     <Menu>
259     <Name>Wine</Name>
260     <Directory>mageia-%{name}.directory</Directory>
261     <Include>
262     <Category>X-MandrivaLinux-MoreApplications-Emulators-Wine</Category>
263     </Include>
264     </Menu>
265     </Menu>
266     </Menu>
267     </Menu>
268     EOF
269    
270     mkdir -p %{buildroot}%{_datadir}/desktop-directories
271     cat > %{buildroot}%{_datadir}/desktop-directories/mageia-%{name}.directory <<EOF
272     [Desktop Entry]
273     Name=Wine
274     Icon=%{name}
275     Type=Directory
276     EOF
277    
278     mkdir -p %{buildroot}%{_datadir}/applications/
279     for i in winecfg:Configurator \
280     notepad:Notepad \
281     winefile:File\ Manager \
282     regedit:Registry\ Editor \
283     winemine:Minesweeper \
284     wineboot:Reboot \
285     "wineconsole cmd":Command\ Line \
286     "wine uninstaller:Wine Software Uninstaller";
287     do cat > %{buildroot}%{_datadir}/applications/mageia-%{name}-`echo $i|cut -d: -f1`.desktop << EOF
288     [Desktop Entry]
289     Name=`echo $i|cut -d: -f2`
290     Comment=`echo $i|cut -d: -f2`
291     Exec=`echo $i|cut -d: -f1`
292     Icon=%{name}
293     Terminal=false
294     Type=Application
295     Categories=X-MandrivaLinux-MoreApplications-Emulators-Wine;
296     EOF
297     done
298    
299     # Categories=Emulator does nothing and is added as a workaround to kde #27700
300     desktop-file-install --vendor="" \
301     --add-mime-type=application/x-zip-compressed \
302     --remove-mime-type=application/x-zip-compressed \
303     --add-category=Emulator \
304     --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/wine.desktop
305    
306     %ifarch x86_64
307     # fix the binary name
308     sed -i 's,Exec=wine ,Exec=wine64 ,' %{buildroot}%{_datadir}/applications/wine.desktop
309     %endif
310    
311     install -d %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
312    
313     # winecfg icon
314     convert dlls/user32/resources/oic_winlogo.ico[8] %{buildroot}%{_miconsdir}/%{name}.png
315     convert dlls/user32/resources/oic_winlogo.ico[7] %{buildroot}%{_iconsdir}/%{name}.png
316     convert dlls/user32/resources/oic_winlogo.ico[6] %{buildroot}%{_liconsdir}/%{name}.png
317    
318     # notepad icon
319     convert programs/notepad/notepad.ico[2] %{buildroot}%{_miconsdir}/notepad.png
320     convert programs/notepad/notepad.ico[7] %{buildroot}%{_iconsdir}/notepad.png
321     convert programs/notepad/notepad.ico[8] %{buildroot}%{_liconsdir}/notepad.png
322     # winefile icon
323     convert programs/winefile/winefile.ico[2] %{buildroot}%{_miconsdir}/winefile.png
324     convert programs/winefile/winefile.ico[8] %{buildroot}%{_iconsdir}/winefile.png
325     convert programs/winefile/winefile.ico[7] %{buildroot}%{_liconsdir}/winefile.png
326     # regedit icon
327     convert programs/regedit/regedit.ico[2] %{buildroot}%{_miconsdir}/regedit.png
328     convert programs/regedit/regedit.ico[8] %{buildroot}%{_iconsdir}/regedit.png
329     convert programs/regedit/regedit.ico[7] %{buildroot}%{_liconsdir}/regedit.png
330     # winemine icon
331     convert programs/winemine/winemine.ico[2] %{buildroot}%{_miconsdir}/winemine.png
332     convert programs/winemine/winemine.ico[8] %{buildroot}%{_iconsdir}/winemine.png
333     convert programs/winemine/winemine.ico[7] %{buildroot}%{_liconsdir}/winemine.png
334    
335     # wine uninstaller icon:
336     convert programs/msiexec/msiexec.ico[2] %{buildroot}%{_miconsdir}/msiexec.png
337     convert programs/msiexec/msiexec.ico[8] %{buildroot}%{_iconsdir}/msiexec.png
338     convert programs/msiexec/msiexec.ico[7] %{buildroot}%{_liconsdir}/msiexec.png
339    
340     # change the icons in the respective .desktop files, in order:
341     sed -i 's,Icon=%{name},Icon=notepad,' %{buildroot}%{_datadir}/applications/mageia-wine-notepad.desktop
342     sed -i 's,Icon=%{name},Icon=winefile,' %{buildroot}%{_datadir}/applications/mageia-wine-winefile.desktop
343     sed -i 's,Icon=%{name},Icon=regedit,' %{buildroot}%{_datadir}/applications/mageia-wine-regedit.desktop
344     sed -i 's,Icon=%{name},Icon=winemine,' %{buildroot}%{_datadir}/applications/mageia-wine-winemine.desktop
345     sed -i 's,Icon=%{name},Icon=msiexec,' "%{buildroot}%{_datadir}/applications/mageia-wine-wine uninstaller.desktop"
346    
347     %ifarch x86_64
348     chrpath -d %{buildroot}%{_bindir}/{wine64,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
349     %else
350     chrpath -d %{buildroot}%{_bindir}/{wine,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
351     %endif
352    
353     %ifarch x86_64
354     cat > README.install.urpmi <<EOF
355     This is the Win64 version of Wine. This version can only be used to run
356     64-bit Windows applications as is. For running 32-bit Windows applications,
357     you need to also install the 'wine32' package from the 32-bit repository.
358     EOF
359     %endif
360    
361     %clean
362     rm -fr %{buildroot}
363    
364     %preun -n %{wine}
365     %_preun_service %{name}
366    
367     %post -n %{wine}
368     %_post_service %{name}
369    
370     %files -n %{wine}
371     %defattr(-,root,root)
372     %doc ANNOUNCE AUTHORS README
373     %ifarch x86_64
374     %doc README.install.urpmi
375     %{_bindir}/wine64
376     %{_bindir}/wine64-preloader
377     %endif
378     %{_initrddir}/%{name}
379     %{_bindir}/winecfg
380     %{_bindir}/wineconsole*
381     %{_bindir}/wineserver
382     %{_bindir}/wineboot
383     %{_bindir}/function_grep.pl
384     #%{_bindir}/wineprefixcreate
385     %{_bindir}/msiexec
386     %{_bindir}/notepad
387     %{_bindir}/regedit
388     %{_bindir}/winemine
389     %{_bindir}/winepath
390     %{_bindir}/regsvr32
391     %{_bindir}/winefile
392     %{_mandir}/man1/wine.1*
393     %lang(de) %{_mandir}/de.UTF-8/man1/wine.1*
394     %lang(de) %{_mandir}/de.UTF-8/man1/winemaker.1*
395     %lang(de) %{_mandir}/de.UTF-8/man1/wineserver.1*
396     %lang(fr) %{_mandir}/fr.UTF-8/man1/*
397 ahmad 103264 %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
398 ahmad 36061 %{_mandir}/man1/wineserver.1*
399     %{_mandir}/man1/msiexec.1*
400     %{_mandir}/man1/notepad.1*
401     %{_mandir}/man1/regedit.1*
402     %{_mandir}/man1/regsvr32.1*
403     %{_mandir}/man1/wineboot.1*
404     %{_mandir}/man1/winecfg.1*
405     %{_mandir}/man1/wineconsole.1*
406     %{_mandir}/man1/winecpp.1*
407     %{_mandir}/man1/winefile.1*
408     %{_mandir}/man1/winemine.1*
409     %{_mandir}/man1/winepath.1*
410     %dir %{_datadir}/%{name}
411     %{_datadir}/%{name}/generic.ppd
412     %{_datadir}/%{name}/%{name}.inf
413     %{_datadir}/%{name}/l_intl.nls
414     %{_datadir}/applications/*.desktop
415     %{_sysconfdir}/xdg/menus/applications-merged/mageia-%{name}.menu
416     %{_datadir}/desktop-directories/mageia-%{name}.directory
417     %dir %{_datadir}/wine/fonts
418     %{_datadir}/wine/fonts/*
419     %{_miconsdir}/*.png
420     %{_iconsdir}/*.png
421     %{_liconsdir}/*.png
422    
423     %ifarch %{ix86}
424     %files -n wine32
425     %defattr(-,root,root)
426     %{_bindir}/wine
427     %{_bindir}/wine-preloader
428     %endif
429    
430     %{_libdir}/libwine*.so.%{lib_major}*
431     %dir %{_libdir}/%{name}
432     %{_libdir}/%{name}/*.cpl.so
433     %{_libdir}/%{name}/*.drv.so
434     %{_libdir}/%{name}/*.dll.so
435     %{_libdir}/%{name}/*.exe.so
436     %{_libdir}/%{name}/*.acm.so
437     %{_libdir}/%{name}/*.ocx.so
438     %ifarch %{ix86}
439     %{_libdir}/%{name}/*.vxd.so
440     %{_libdir}/%{name}/*16.so
441     %endif
442     %{_libdir}/%{name}/*.tlb.so
443     %{_libdir}/%{name}/*.ds.so
444     %{_libdir}/%{name}/*.sys.so
445     %{_libdir}/%{name}/fakedlls
446    
447     %files -n %{wine}-devel
448     %defattr(-,root,root)
449     %{_libdir}/%{name}/*.a
450     %{_libdir}/libwine*.so
451     %{_libdir}/%{name}/*.def
452     %{_includedir}/*
453     %{_bindir}/fnt2bdf
454     %{_bindir}/wmc
455     %{_bindir}/wrc
456     %{_bindir}/winebuild
457     %{_bindir}/winegcc
458     %{_bindir}/wineg++
459     %{_bindir}/winecpp
460     %{_bindir}/widl
461     %{_bindir}/winedbg
462     %{_bindir}/winemaker
463     %{_bindir}/winedump
464     %{_mandir}/man1/wmc.1*
465     %{_mandir}/man1/wrc.1*
466     %{_mandir}/man1/winebuild.1*
467     %{_mandir}/man1/winemaker.1*
468     %{_mandir}/man1/winedump.1*
469     %{_mandir}/man1/widl.1*
470     %{_mandir}/man1/winedbg.1*
471     %{_mandir}/man1/wineg++.1*
472     %{_mandir}/man1/winegcc.1*

  ViewVC Help
Powered by ViewVC 1.1.30