/[packages]/cauldron/wine/current/SPECS/wine.spec
ViewVC logotype

Annotation of /cauldron/wine/current/SPECS/wine.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 128071 - (hide annotations) (download)
Sat Jul 23 14:28:27 2011 UTC (12 years, 9 months ago) by ahmad
File size: 15289 byte(s)
- Drop the, now, redundant BR jackit-devel, upstream dropped support for Jack
1 ahmad 36061 %ifarch x86_64
2     %define wine wine64
3     %define mark64 ()(64bit)
4     %else
5     %define wine wine
6     %define mark64 %{nil}
7     %endif
8     %define lib_name_orig lib%{name}
9     %define lib_major 1
10     %define lib_name %mklibname %{name} %{lib_major}
11     %define lib_name_devel %{mklibname -d wine}
12    
13     # On 32-bit we have
14     # wine32 - those 32-bit binaries that are also used on 64-bit for 32-bit support
15     # wine - all other files (requires 'wine32')
16     # On 64-bit we have
17     # wine64 - all 64-bit files (suggests 'wine32')
18     # - Anssi 07/2010
19    
20     Name: wine
21 ahmad 128038 Version: 1.3.25
22 ahmad 36061 %define pre 0
23 ahmad 128071 %define rel 2
24 ahmad 36061 %if %pre
25     Release: %mkrel 0.%pre.%rel
26     %define o_ver %version-%pre
27     %else
28     Release: %mkrel %rel
29     %define o_ver %version
30     %endif
31     Epoch: 1
32     Summary: WINE Is Not An Emulator - runs MS Windows programs
33     License: LGPLv2+
34     Group: Emulators
35     URL: http://www.winehq.com/
36 ahmad 103264 Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2
37     Source1: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2.sign
38 ahmad 36061
39     # RH stuff
40     Source2: wine.init
41     Patch0: wine-1.0-rc3-fix-conflicts-with-openssl.patch
42     Patch1: wine-1.1.7-chinese-font-substitutes.patch
43     # (Anssi 05/2008) Adds:
44     # a: => /media/floppy (/mnt/floppy on 2007.1 and older)
45     # d: => $HOME (at config_dir creation time, not refreshed if $HOME changes;
46     # note that Wine also provides $HOME in My Documents)
47     # com4 => /dev/ttyUSB0 (replaces /dev/ttyS3)
48 ahmad 37896 Patch108: wine-mgaconf.patch
49 ahmad 36061
50     #(eandry) add a pulseaudio sound driver (from http://art.ified.ca/downloads/ )
51 ahmad 128038 #Patch400: http://art.ified.ca/downloads/winepulse/winepulse-configure.ac-1.3.22.patch
52     Patch400: wine-1.3.25-winepulse-configure.ac.patch
53 ahmad 113795 Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.40.patch
54 ahmad 128038 #Patch402: http://art.ified.ca/downloads/winepulse/winepulse-winecfg-1.3.11.patch
55     Patch402: wine-1.3.25-winepulse-winecfg.patch
56 ahmad 36061
57     # (anssi) Wine needs GCC 4.4+ on x86_64 for MS ABI support. Note also that
58 anssi 96590 # 64-bit wine cannot run 32-bit programs without wine32.
59 ahmad 36061 %ifarch x86_64
60     BuildRequires: gcc >= 4.4
61     %endif
62 ahmad 101529 BuildRequires: bison flex
63 ahmad 71420 BuildRequires: gpm-devel
64     BuildRequires: perl-devel
65     BuildRequires: ncurses-devel
66     BuildRequires: cups-devel
67     BuildRequires: sane-devel
68     BuildRequires: lcms-devel
69     BuildRequires: autoconf
70     BuildRequires: docbook-utils docbook-dtd-sgml
71     BuildRequires: docbook-utils docbook-dtd-sgml sgml-tools
72     BuildRequires: pulseaudio-devel
73 ahmad 36061 BuildRequires: libmpg123-devel
74     BuildRequires: openal-devel
75 ahmad 71420 BuildRequires: libalsa-devel
76 ahmad 36061 BuildRequires: gstreamer0.10-devel libgstreamer0.10-plugins-base-devel
77 ahmad 71420 BuildRequires: isdn4k-utils-devel
78     BuildRequires: glibc-static-devel
79     BuildRequires: chrpath
80     BuildRequires: ungif-devel xpm-devel
81     BuildRequires: tiff-devel
82     BuildRequires: librsvg
83     BuildRequires: imagemagick
84     BuildRequires: gphoto2-devel
85     BuildRequires: desktop-file-utils
86     BuildRequires: openldap-devel
87     BuildRequires: libxslt-devel
88     BuildRequires: dbus-devel
89     BuildRequires: hal-devel
90 ahmad 110810 BuildRequires: valgrind-devel
91 ahmad 71420 BuildRequires: gsm-devel
92     BuildRequires: unixODBC-devel
93 ahmad 110810 BuildRequires: gnutls-devel
94 ahmad 36061 BuildRequires: prelink
95 ahmad 70893 BuildRequires: gettext-devel
96 ahmad 71420 BuildRequires: mesaglu-devel
97     BuildRequires: libv4l-devel
98     BuildRequires: libxcursor-devel libxcomposite-devel
99     BuildRequires: libxinerama-devel libxrandr-devel
100     BuildRequires: libx11-devel libxrender-devel
101     BuildRequires: libxext-devel libsm-devel
102     BuildRequires: fontforge fontconfig-devel freetype2-devel
103 ahmad 36061
104     %define desc Wine is a program which allows running Microsoft Windows programs \
105     (including DOS, Windows 3.x and Win32 executables) on Unix. It \
106     consists of a program loader which loads and executes a Microsoft \
107     Windows binary, and a library (called Winelib) that implements Windows \
108     API calls using their Unix or X11 equivalents. The library may also \
109     be used for porting Win32 code into native Unix executables.
110    
111     %ifarch x86_64
112     %package -n %{wine}
113     Summary: WINE Is Not An Emulator - runs MS Windows programs
114     Group: Emulators
115     Suggests: wine32 = %{epoch}:%{version}-%{release}
116 anssi 96590 Suggests: wine64-gecko
117 ahmad 36061 %else
118     # on 32-bit we always want wine32 package
119     Requires: wine32 = %{epoch}:%{version}-%{release}
120     %endif
121    
122     Provides: %{wine}-utils = %{epoch}:%{version}-%{release} %{wine}-full = %{epoch}:%{version}-%{release}
123     Provides: %{lib_name}-capi = %{epoch}:%{version}-%{release} %{lib_name}-twain = %{epoch}:%{version}-%{release}
124     Provides: %{lib_name} = %{epoch}:%{version}-%{release}
125     Provides: wine-bin = %{epoch}:%{version}-%{release}
126     Obsoletes: %{wine}-utils %{wine}-full %{lib_name}-capi %{lib_name}-twain
127     Obsoletes: %{lib_name} <= %{epoch}:%{version}-%{release}
128     Requires: xmessage
129     Suggests: sane-frontends
130     # wine dlopen's these, so let's add the dependencies ourself
131     Requires: libfreetype.so.6%{mark64} libasound.so.2%{mark64}
132 ahmad 72084 # wine needs to dlopen libfontconfig to make CJK fonts show correctly in winecfg
133     Requires: libfontconfig.so.1%{mark64}
134 ahmad 72093 Requires: libncurses.so.5%{mark64}
135 ahmad 36061 Requires: libXrender.so.1%{mark64} libpng.so.3%{mark64}
136     Requires(post): desktop-file-utils
137     Requires(postun): desktop-file-utils
138     Requires(post): desktop-common-data
139     Requires(postun): desktop-common-data
140     Requires(preun): rpm-helper
141     Requires(post): rpm-helper
142     %ifarch %{ix86}
143     Conflicts: wine64
144     %else
145     Conflicts: wine
146     %endif
147    
148     %description
149     %desc
150    
151     %ifarch x86_64
152     %description -n %{wine}
153     %desc
154    
155     This package contains the Win64 version of Wine. You need the wine32
156     package from the 32-bit repository to be able to run 32-bit applications.
157     %endif
158    
159     %ifarch %ix86
160     %package -n wine32
161     Summary: 32-bit support for Wine
162     Group: Emulators
163     # This is not an EVR-specific requirement, as otherwise on x86_64 urpmi could
164     # resolve the dependency to wine64 even on upgrades, and therefore replace
165     # wine+wine32 installation with a wine32+wine64 installation. - Anssi
166     Requires: wine-bin
167     Conflicts: wine < 1:1.2-0.rc7.1
168     Conflicts: wine64 < 1:1.2-0.rc7.1
169     # (Anssi) If wine-gecko is not installed, wine pops up a dialog on first
170     # start proposing to download wine-gecko from sourceforge, while recommending
171     # to use distribution packages instead. Therefore suggest wine-gecko here:
172     Suggests: wine-gecko
173    
174     %description -n wine32
175     Wine is a program which allows running Microsoft Windows programs
176     (including DOS, Windows 3.x and Win32 executables) on Unix.
177    
178     This package contains the files needed to support 32-bit Windows
179     programs.
180     %endif
181    
182     %package -n %{wine}-devel
183     Summary: Static libraries and headers for %{name}
184     Group: Development/C
185     Requires: %{wine} = %{epoch}:%{version}
186     Provides: %{lib_name_devel} = %{epoch}:%{version}-%{release}
187     Provides: %{lib_name_orig}-devel = %{epoch}:%{version}-%{release}
188     Obsoletes: %{lib_name_devel} <= %{epoch}:%{version}-%{release}
189     Obsoletes: %{mklibname -d wine 1} < %{epoch}:%{version}
190     %ifarch %{ix86}
191     Conflicts: wine64-devel
192     %else
193     Conflicts: wine-devel
194     %endif
195    
196     %description -n %{wine}-devel
197     Wine is a program which allows running Microsoft Windows programs
198     (including DOS, Windows 3.x and Win32 executables) on Unix.
199    
200     %{wine}-devel contains the libraries and header files needed to
201     develop programs which make use of wine.
202    
203     Wine is often updated.
204    
205     %prep
206     %setup -q -n %name-%o_ver
207     %patch1 -p0 -b .chinese
208     %patch108 -p1 -b .conf
209     %patch400 -p1
210     %patch401 -p1
211     %patch402 -p1
212    
213     %build
214     %ifarch %ix86
215     # (Anssi 04/2008) bug #39604
216     # Some protection systems complain "debugger detected" with our
217     # -fomit-frame-pointer flag, so disable it.
218     export CFLAGS="%{optflags} -fno-omit-frame-pointer"
219     %endif
220    
221     # (Anssi 04/2008)
222     # If icotool is present, it is used to rebuild icon files. It is in contrib
223     # so we do not do that; this is here to ensure that installed icoutils does
224     # not change build behaviour.
225     export ICOTOOL=false
226    
227     autoreconf
228     %configure2_5x --with-x \
229     --with-pulse \
230     %ifarch x86_64
231     --enable-win64
232     %endif
233    
234     %make depend
235     %make
236    
237     %install
238     rm -rf %{buildroot}
239     %makeinstall_std LDCONFIG=/bin/true
240    
241     # Danny: dirty:
242     install -m755 tools/fnt2bdf -D %{buildroot}%{_bindir}/fnt2bdf
243    
244     # Allow users to launch Windows programs by just clicking on the .exe file...
245     install -m755 %{SOURCE2} -D %{buildroot}%{_initrddir}/%{name}
246    
247     mkdir -p %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged
248     cat > %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged/mageia-%{name}.menu <<EOF
249     <!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
250     "http://www.freedesktop.org/standards/menu-spec/menu-1.0.dtd">
251     <Menu>
252     <Name>Applications</Name>
253     <Menu>
254     <Name>Tools</Name>
255     <Menu>
256     <Name>Emulators</Name>
257     <Menu>
258     <Name>Wine</Name>
259     <Directory>mageia-%{name}.directory</Directory>
260     <Include>
261     <Category>X-MandrivaLinux-MoreApplications-Emulators-Wine</Category>
262     </Include>
263     </Menu>
264     </Menu>
265     </Menu>
266     </Menu>
267     EOF
268    
269     mkdir -p %{buildroot}%{_datadir}/desktop-directories
270     cat > %{buildroot}%{_datadir}/desktop-directories/mageia-%{name}.directory <<EOF
271     [Desktop Entry]
272     Name=Wine
273     Icon=%{name}
274     Type=Directory
275     EOF
276    
277     mkdir -p %{buildroot}%{_datadir}/applications/
278     for i in winecfg:Configurator \
279     notepad:Notepad \
280     winefile:File\ Manager \
281     regedit:Registry\ Editor \
282     winemine:Minesweeper \
283     wineboot:Reboot \
284     "wineconsole cmd":Command\ Line \
285     "wine uninstaller:Wine Software Uninstaller";
286     do cat > %{buildroot}%{_datadir}/applications/mageia-%{name}-`echo $i|cut -d: -f1`.desktop << EOF
287     [Desktop Entry]
288     Name=`echo $i|cut -d: -f2`
289     Comment=`echo $i|cut -d: -f2`
290     Exec=`echo $i|cut -d: -f1`
291     Icon=%{name}
292     Terminal=false
293     Type=Application
294     Categories=X-MandrivaLinux-MoreApplications-Emulators-Wine;
295     EOF
296     done
297    
298     # Categories=Emulator does nothing and is added as a workaround to kde #27700
299     desktop-file-install --vendor="" \
300     --add-mime-type=application/x-zip-compressed \
301     --remove-mime-type=application/x-zip-compressed \
302     --add-category=Emulator \
303     --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/wine.desktop
304    
305     %ifarch x86_64
306     # fix the binary name
307     sed -i 's,Exec=wine ,Exec=wine64 ,' %{buildroot}%{_datadir}/applications/wine.desktop
308     %endif
309    
310     install -d %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
311    
312     # winecfg icon
313     convert dlls/user32/resources/oic_winlogo.ico[8] %{buildroot}%{_miconsdir}/%{name}.png
314     convert dlls/user32/resources/oic_winlogo.ico[7] %{buildroot}%{_iconsdir}/%{name}.png
315     convert dlls/user32/resources/oic_winlogo.ico[6] %{buildroot}%{_liconsdir}/%{name}.png
316    
317     # notepad icon
318     convert programs/notepad/notepad.ico[2] %{buildroot}%{_miconsdir}/notepad.png
319     convert programs/notepad/notepad.ico[7] %{buildroot}%{_iconsdir}/notepad.png
320     convert programs/notepad/notepad.ico[8] %{buildroot}%{_liconsdir}/notepad.png
321     # winefile icon
322     convert programs/winefile/winefile.ico[2] %{buildroot}%{_miconsdir}/winefile.png
323     convert programs/winefile/winefile.ico[8] %{buildroot}%{_iconsdir}/winefile.png
324     convert programs/winefile/winefile.ico[7] %{buildroot}%{_liconsdir}/winefile.png
325     # regedit icon
326     convert programs/regedit/regedit.ico[2] %{buildroot}%{_miconsdir}/regedit.png
327     convert programs/regedit/regedit.ico[8] %{buildroot}%{_iconsdir}/regedit.png
328     convert programs/regedit/regedit.ico[7] %{buildroot}%{_liconsdir}/regedit.png
329     # winemine icon
330     convert programs/winemine/winemine.ico[2] %{buildroot}%{_miconsdir}/winemine.png
331     convert programs/winemine/winemine.ico[8] %{buildroot}%{_iconsdir}/winemine.png
332     convert programs/winemine/winemine.ico[7] %{buildroot}%{_liconsdir}/winemine.png
333    
334     # wine uninstaller icon:
335     convert programs/msiexec/msiexec.ico[2] %{buildroot}%{_miconsdir}/msiexec.png
336     convert programs/msiexec/msiexec.ico[8] %{buildroot}%{_iconsdir}/msiexec.png
337     convert programs/msiexec/msiexec.ico[7] %{buildroot}%{_liconsdir}/msiexec.png
338    
339     # change the icons in the respective .desktop files, in order:
340     sed -i 's,Icon=%{name},Icon=notepad,' %{buildroot}%{_datadir}/applications/mageia-wine-notepad.desktop
341     sed -i 's,Icon=%{name},Icon=winefile,' %{buildroot}%{_datadir}/applications/mageia-wine-winefile.desktop
342     sed -i 's,Icon=%{name},Icon=regedit,' %{buildroot}%{_datadir}/applications/mageia-wine-regedit.desktop
343     sed -i 's,Icon=%{name},Icon=winemine,' %{buildroot}%{_datadir}/applications/mageia-wine-winemine.desktop
344     sed -i 's,Icon=%{name},Icon=msiexec,' "%{buildroot}%{_datadir}/applications/mageia-wine-wine uninstaller.desktop"
345    
346     %ifarch x86_64
347     chrpath -d %{buildroot}%{_bindir}/{wine64,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
348     %else
349     chrpath -d %{buildroot}%{_bindir}/{wine,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
350     %endif
351    
352     %ifarch x86_64
353     cat > README.install.urpmi <<EOF
354     This is the Win64 version of Wine. This version can only be used to run
355     64-bit Windows applications as is. For running 32-bit Windows applications,
356     you need to also install the 'wine32' package from the 32-bit repository.
357     EOF
358     %endif
359    
360     %clean
361     rm -fr %{buildroot}
362    
363     %preun -n %{wine}
364     %_preun_service %{name}
365    
366     %post -n %{wine}
367     %_post_service %{name}
368    
369     %files -n %{wine}
370     %defattr(-,root,root)
371     %doc ANNOUNCE AUTHORS README
372     %ifarch x86_64
373     %doc README.install.urpmi
374     %{_bindir}/wine64
375     %{_bindir}/wine64-preloader
376     %endif
377     %{_initrddir}/%{name}
378     %{_bindir}/winecfg
379     %{_bindir}/wineconsole*
380     %{_bindir}/wineserver
381     %{_bindir}/wineboot
382     %{_bindir}/function_grep.pl
383     #%{_bindir}/wineprefixcreate
384     %{_bindir}/msiexec
385     %{_bindir}/notepad
386     %{_bindir}/regedit
387     %{_bindir}/winemine
388     %{_bindir}/winepath
389     %{_bindir}/regsvr32
390     %{_bindir}/winefile
391     %{_mandir}/man1/wine.1*
392     %lang(de) %{_mandir}/de.UTF-8/man1/wine.1*
393     %lang(de) %{_mandir}/de.UTF-8/man1/winemaker.1*
394     %lang(de) %{_mandir}/de.UTF-8/man1/wineserver.1*
395     %lang(fr) %{_mandir}/fr.UTF-8/man1/*
396 ahmad 103264 %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
397 ahmad 36061 %{_mandir}/man1/wineserver.1*
398     %{_mandir}/man1/msiexec.1*
399     %{_mandir}/man1/notepad.1*
400     %{_mandir}/man1/regedit.1*
401     %{_mandir}/man1/regsvr32.1*
402     %{_mandir}/man1/wineboot.1*
403     %{_mandir}/man1/winecfg.1*
404     %{_mandir}/man1/wineconsole.1*
405     %{_mandir}/man1/winecpp.1*
406     %{_mandir}/man1/winefile.1*
407     %{_mandir}/man1/winemine.1*
408     %{_mandir}/man1/winepath.1*
409     %dir %{_datadir}/%{name}
410     %{_datadir}/%{name}/generic.ppd
411     %{_datadir}/%{name}/%{name}.inf
412     %{_datadir}/%{name}/l_intl.nls
413     %{_datadir}/applications/*.desktop
414     %{_sysconfdir}/xdg/menus/applications-merged/mageia-%{name}.menu
415     %{_datadir}/desktop-directories/mageia-%{name}.directory
416     %dir %{_datadir}/wine/fonts
417     %{_datadir}/wine/fonts/*
418     %{_miconsdir}/*.png
419     %{_iconsdir}/*.png
420     %{_liconsdir}/*.png
421    
422     %ifarch %{ix86}
423     %files -n wine32
424     %defattr(-,root,root)
425     %{_bindir}/wine
426     %{_bindir}/wine-preloader
427     %endif
428    
429     %{_libdir}/libwine*.so.%{lib_major}*
430     %dir %{_libdir}/%{name}
431     %{_libdir}/%{name}/*.cpl.so
432     %{_libdir}/%{name}/*.drv.so
433     %{_libdir}/%{name}/*.dll.so
434     %{_libdir}/%{name}/*.exe.so
435     %{_libdir}/%{name}/*.acm.so
436     %{_libdir}/%{name}/*.ocx.so
437     %ifarch %{ix86}
438     %{_libdir}/%{name}/*.vxd.so
439     %{_libdir}/%{name}/*16.so
440     %endif
441     %{_libdir}/%{name}/*.tlb.so
442     %{_libdir}/%{name}/*.ds.so
443     %{_libdir}/%{name}/*.sys.so
444     %{_libdir}/%{name}/fakedlls
445    
446     %files -n %{wine}-devel
447     %defattr(-,root,root)
448     %{_libdir}/%{name}/*.a
449     %{_libdir}/libwine*.so
450     %{_libdir}/%{name}/*.def
451     %{_includedir}/*
452     %{_bindir}/fnt2bdf
453     %{_bindir}/wmc
454     %{_bindir}/wrc
455     %{_bindir}/winebuild
456     %{_bindir}/winegcc
457     %{_bindir}/wineg++
458     %{_bindir}/winecpp
459     %{_bindir}/widl
460     %{_bindir}/winedbg
461     %{_bindir}/winemaker
462     %{_bindir}/winedump
463     %{_mandir}/man1/wmc.1*
464     %{_mandir}/man1/wrc.1*
465     %{_mandir}/man1/winebuild.1*
466     %{_mandir}/man1/winemaker.1*
467     %{_mandir}/man1/winedump.1*
468     %{_mandir}/man1/widl.1*
469     %{_mandir}/man1/winedbg.1*
470     %{_mandir}/man1/wineg++.1*
471     %{_mandir}/man1/winegcc.1*

  ViewVC Help
Powered by ViewVC 1.1.30