/[packages]/cauldron/wine/current/SPECS/wine.spec
ViewVC logotype

Annotation of /cauldron/wine/current/SPECS/wine.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 263611 - (hide annotations) (download)
Mon Jun 25 17:48:03 2012 UTC (11 years, 9 months ago) by dams
File size: 15166 byte(s)
new version 1.5.7
1 ahmad 36061 %ifarch x86_64
2     %define wine wine64
3     %define mark64 ()(64bit)
4     %else
5     %define wine wine
6     %define mark64 %{nil}
7     %endif
8     %define lib_name_orig lib%{name}
9     %define lib_major 1
10     %define lib_name %mklibname %{name} %{lib_major}
11     %define lib_name_devel %{mklibname -d wine}
12    
13     # On 32-bit we have
14     # wine32 - those 32-bit binaries that are also used on 64-bit for 32-bit support
15     # wine - all other files (requires 'wine32')
16     # On 64-bit we have
17     # wine64 - all 64-bit files (suggests 'wine32')
18     # - Anssi 07/2010
19    
20 anssi 188253 # When altering this, make sure the new wine-gecko is submitted or at least
21     # notify its maintainer of the needed update.
22 dams 263611 %define gecko_version 1.6
23 anssi 188253
24 ahmad 36061 Name: wine
25 dams 263611 Version: 1.5.7
26 fwang 221865 %define pre 0
27 zezinho 177101 %define rel 1
28 ahmad 36061 %if %pre
29     Release: %mkrel 0.%pre.%rel
30     %define o_ver %version-%pre
31     %else
32     Release: %mkrel %rel
33     %define o_ver %version
34     %endif
35     Epoch: 1
36     Summary: WINE Is Not An Emulator - runs MS Windows programs
37     License: LGPLv2+
38     Group: Emulators
39     URL: http://www.winehq.com/
40 ahmad 103264 Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2
41     Source1: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2.sign
42 ahmad 36061
43     # RH stuff
44     Source2: wine.init
45     Patch0: wine-1.0-rc3-fix-conflicts-with-openssl.patch
46     Patch1: wine-1.1.7-chinese-font-substitutes.patch
47     # (Anssi 05/2008) Adds:
48     # a: => /media/floppy (/mnt/floppy on 2007.1 and older)
49     # d: => $HOME (at config_dir creation time, not refreshed if $HOME changes;
50     # note that Wine also provides $HOME in My Documents)
51     # com4 => /dev/ttyUSB0 (replaces /dev/ttyS3)
52 ahmad 37896 Patch108: wine-mgaconf.patch
53 ahmad 36061
54     # (anssi) Wine needs GCC 4.4+ on x86_64 for MS ABI support. Note also that
55 anssi 96590 # 64-bit wine cannot run 32-bit programs without wine32.
56 ahmad 36061 %ifarch x86_64
57     BuildRequires: gcc >= 4.4
58     %endif
59 ahmad 101529 BuildRequires: bison flex
60 ahmad 71420 BuildRequires: gpm-devel
61     BuildRequires: perl-devel
62     BuildRequires: ncurses-devel
63     BuildRequires: cups-devel
64     BuildRequires: sane-devel
65     BuildRequires: lcms-devel
66     BuildRequires: autoconf
67     BuildRequires: docbook-utils docbook-dtd-sgml
68     BuildRequires: docbook-utils docbook-dtd-sgml sgml-tools
69     BuildRequires: pulseaudio-devel
70 ahmad 36061 BuildRequires: libmpg123-devel
71     BuildRequires: openal-devel
72 ahmad 71420 BuildRequires: libalsa-devel
73 ahmad 36061 BuildRequires: gstreamer0.10-devel libgstreamer0.10-plugins-base-devel
74 ahmad 71420 BuildRequires: isdn4k-utils-devel
75     BuildRequires: glibc-static-devel
76     BuildRequires: chrpath
77     BuildRequires: ungif-devel xpm-devel
78     BuildRequires: tiff-devel
79     BuildRequires: librsvg
80     BuildRequires: imagemagick
81     BuildRequires: gphoto2-devel
82     BuildRequires: desktop-file-utils
83     BuildRequires: openldap-devel
84     BuildRequires: libxslt-devel
85     BuildRequires: dbus-devel
86 ahmad 110810 BuildRequires: valgrind-devel
87 ahmad 71420 BuildRequires: gsm-devel
88     BuildRequires: unixODBC-devel
89 ahmad 110810 BuildRequires: gnutls-devel
90 ahmad 36061 BuildRequires: prelink
91 ahmad 70893 BuildRequires: gettext-devel
92 ahmad 71420 BuildRequires: mesaglu-devel
93     BuildRequires: libv4l-devel
94     BuildRequires: libxcursor-devel libxcomposite-devel
95     BuildRequires: libxinerama-devel libxrandr-devel
96     BuildRequires: libx11-devel libxrender-devel
97     BuildRequires: libxext-devel libsm-devel
98     BuildRequires: fontforge fontconfig-devel freetype2-devel
99 ahmad 36061
100     %define desc Wine is a program which allows running Microsoft Windows programs \
101     (including DOS, Windows 3.x and Win32 executables) on Unix. It \
102     consists of a program loader which loads and executes a Microsoft \
103     Windows binary, and a library (called Winelib) that implements Windows \
104     API calls using their Unix or X11 equivalents. The library may also \
105     be used for porting Win32 code into native Unix executables.
106    
107     %ifarch x86_64
108     %package -n %{wine}
109     Summary: WINE Is Not An Emulator - runs MS Windows programs
110     Group: Emulators
111     Suggests: wine32 = %{epoch}:%{version}-%{release}
112 anssi 188253 Suggests: wine64-gecko = %gecko_version
113 ahmad 36061 %else
114     # on 32-bit we always want wine32 package
115     Requires: wine32 = %{epoch}:%{version}-%{release}
116     %endif
117    
118     Provides: %{wine}-utils = %{epoch}:%{version}-%{release} %{wine}-full = %{epoch}:%{version}-%{release}
119     Provides: %{lib_name}-capi = %{epoch}:%{version}-%{release} %{lib_name}-twain = %{epoch}:%{version}-%{release}
120     Provides: %{lib_name} = %{epoch}:%{version}-%{release}
121     Provides: wine-bin = %{epoch}:%{version}-%{release}
122     Obsoletes: %{wine}-utils %{wine}-full %{lib_name}-capi %{lib_name}-twain
123     Obsoletes: %{lib_name} <= %{epoch}:%{version}-%{release}
124     Requires: xmessage
125     Suggests: sane-frontends
126     # wine dlopen's these, so let's add the dependencies ourself
127     Requires: libfreetype.so.6%{mark64} libasound.so.2%{mark64}
128 ahmad 72084 # wine needs to dlopen libfontconfig to make CJK fonts show correctly in winecfg
129     Requires: libfontconfig.so.1%{mark64}
130 ahmad 72093 Requires: libncurses.so.5%{mark64}
131 fwang 142563 Requires: libXrender.so.1%{mark64} libpng15.so.15%{mark64}
132 ahmad 36061 Requires(post): desktop-file-utils
133     Requires(postun): desktop-file-utils
134     Requires(post): desktop-common-data
135     Requires(postun): desktop-common-data
136     Requires(preun): rpm-helper
137     Requires(post): rpm-helper
138     %ifarch %{ix86}
139     Conflicts: wine64
140     %else
141     Conflicts: wine
142     %endif
143    
144     %description
145     %desc
146    
147     %ifarch x86_64
148     %description -n %{wine}
149     %desc
150    
151     This package contains the Win64 version of Wine. You need the wine32
152     package from the 32-bit repository to be able to run 32-bit applications.
153     %endif
154    
155     %ifarch %ix86
156     %package -n wine32
157     Summary: 32-bit support for Wine
158     Group: Emulators
159     # This is not an EVR-specific requirement, as otherwise on x86_64 urpmi could
160     # resolve the dependency to wine64 even on upgrades, and therefore replace
161     # wine+wine32 installation with a wine32+wine64 installation. - Anssi
162     Requires: wine-bin
163     Conflicts: wine < 1:1.2-0.rc7.1
164     Conflicts: wine64 < 1:1.2-0.rc7.1
165     # (Anssi) If wine-gecko is not installed, wine pops up a dialog on first
166     # start proposing to download wine-gecko from sourceforge, while recommending
167     # to use distribution packages instead. Therefore suggest wine-gecko here:
168 anssi 188253 Suggests: wine-gecko = %gecko_version
169 ahmad 36061
170     %description -n wine32
171     Wine is a program which allows running Microsoft Windows programs
172     (including DOS, Windows 3.x and Win32 executables) on Unix.
173    
174     This package contains the files needed to support 32-bit Windows
175     programs.
176     %endif
177    
178     %package -n %{wine}-devel
179     Summary: Static libraries and headers for %{name}
180     Group: Development/C
181     Requires: %{wine} = %{epoch}:%{version}
182     Provides: %{lib_name_devel} = %{epoch}:%{version}-%{release}
183     Provides: %{lib_name_orig}-devel = %{epoch}:%{version}-%{release}
184     Obsoletes: %{lib_name_devel} <= %{epoch}:%{version}-%{release}
185     Obsoletes: %{mklibname -d wine 1} < %{epoch}:%{version}
186     %ifarch %{ix86}
187     Conflicts: wine64-devel
188     %else
189     Conflicts: wine-devel
190     %endif
191    
192     %description -n %{wine}-devel
193     Wine is a program which allows running Microsoft Windows programs
194     (including DOS, Windows 3.x and Win32 executables) on Unix.
195    
196     %{wine}-devel contains the libraries and header files needed to
197     develop programs which make use of wine.
198    
199     Wine is often updated.
200    
201     %prep
202     %setup -q -n %name-%o_ver
203     %patch1 -p0 -b .chinese
204     %patch108 -p1 -b .conf
205    
206 anssi 188253 GECKO_VERSION=$(sed -rn 's,^#define\s+GECKO_VERSION\s+"([^"]*)".*$,\1,p' dlls/appwiz.cpl/addons.c)
207     [ "$GECKO_VERSION" = "%gecko_version" ] || { echo wine-gecko version mismatch; exit 1; }
208    
209 ahmad 36061 %build
210     %ifarch %ix86
211     # (Anssi 04/2008) bug #39604
212     # Some protection systems complain "debugger detected" with our
213     # -fomit-frame-pointer flag, so disable it.
214     export CFLAGS="%{optflags} -fno-omit-frame-pointer"
215     %endif
216    
217     # (Anssi 04/2008)
218     # If icotool is present, it is used to rebuild icon files. It is in contrib
219     # so we do not do that; this is here to ensure that installed icoutils does
220     # not change build behaviour.
221     export ICOTOOL=false
222    
223     autoreconf
224     %configure2_5x --with-x \
225     --with-pulse \
226     %ifarch x86_64
227     --enable-win64
228     %endif
229    
230     %make depend
231     %make
232    
233     %install
234     %makeinstall_std LDCONFIG=/bin/true
235    
236     # Danny: dirty:
237 dams 259841 #install -m755 tools/fnt2bdf -D %{buildroot}%{_bindir}/fnt2bdf
238 ahmad 36061
239     # Allow users to launch Windows programs by just clicking on the .exe file...
240     install -m755 %{SOURCE2} -D %{buildroot}%{_initrddir}/%{name}
241    
242     mkdir -p %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged
243 zezinho 156874 cat > %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged/%{_real_vendor}-%{name}.menu <<EOF
244 ahmad 36061 <!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
245     "http://www.freedesktop.org/standards/menu-spec/menu-1.0.dtd">
246     <Menu>
247     <Name>Applications</Name>
248     <Menu>
249     <Name>Tools</Name>
250     <Menu>
251     <Name>Emulators</Name>
252     <Menu>
253     <Name>Wine</Name>
254 zezinho 156874 <Directory>%{_real_vendor}-%{name}.directory</Directory>
255 ahmad 36061 <Include>
256     <Category>X-MandrivaLinux-MoreApplications-Emulators-Wine</Category>
257     </Include>
258     </Menu>
259     </Menu>
260     </Menu>
261     </Menu>
262     EOF
263    
264     mkdir -p %{buildroot}%{_datadir}/desktop-directories
265 zezinho 156874 cat > %{buildroot}%{_datadir}/desktop-directories/%{_real_vendor}-%{name}.directory <<EOF
266 ahmad 36061 [Desktop Entry]
267     Name=Wine
268     Icon=%{name}
269     Type=Directory
270     EOF
271    
272     mkdir -p %{buildroot}%{_datadir}/applications/
273     for i in winecfg:Configurator \
274     notepad:Notepad \
275     winefile:File\ Manager \
276     regedit:Registry\ Editor \
277     winemine:Minesweeper \
278     wineboot:Reboot \
279     "wineconsole cmd":Command\ Line \
280     "wine uninstaller:Wine Software Uninstaller";
281 zezinho 156874 do cat > %{buildroot}%{_datadir}/applications/%{_real_vendor}-%{name}-`echo $i|cut -d: -f1`.desktop << EOF
282 ahmad 36061 [Desktop Entry]
283     Name=`echo $i|cut -d: -f2`
284     Comment=`echo $i|cut -d: -f2`
285     Exec=`echo $i|cut -d: -f1`
286     Icon=%{name}
287     Terminal=false
288     Type=Application
289     Categories=X-MandrivaLinux-MoreApplications-Emulators-Wine;
290     EOF
291     done
292    
293     # Categories=Emulator does nothing and is added as a workaround to kde #27700
294     desktop-file-install --vendor="" \
295     --add-mime-type=application/x-zip-compressed \
296     --remove-mime-type=application/x-zip-compressed \
297     --add-category=Emulator \
298     --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/wine.desktop
299    
300     %ifarch x86_64
301     # fix the binary name
302     sed -i 's,Exec=wine ,Exec=wine64 ,' %{buildroot}%{_datadir}/applications/wine.desktop
303     %endif
304    
305     install -d %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
306    
307     # winecfg icon
308     convert dlls/user32/resources/oic_winlogo.ico[8] %{buildroot}%{_miconsdir}/%{name}.png
309     convert dlls/user32/resources/oic_winlogo.ico[7] %{buildroot}%{_iconsdir}/%{name}.png
310     convert dlls/user32/resources/oic_winlogo.ico[6] %{buildroot}%{_liconsdir}/%{name}.png
311    
312     # notepad icon
313     convert programs/notepad/notepad.ico[2] %{buildroot}%{_miconsdir}/notepad.png
314     convert programs/notepad/notepad.ico[7] %{buildroot}%{_iconsdir}/notepad.png
315     convert programs/notepad/notepad.ico[8] %{buildroot}%{_liconsdir}/notepad.png
316     # winefile icon
317     convert programs/winefile/winefile.ico[2] %{buildroot}%{_miconsdir}/winefile.png
318     convert programs/winefile/winefile.ico[8] %{buildroot}%{_iconsdir}/winefile.png
319     convert programs/winefile/winefile.ico[7] %{buildroot}%{_liconsdir}/winefile.png
320     # regedit icon
321     convert programs/regedit/regedit.ico[2] %{buildroot}%{_miconsdir}/regedit.png
322     convert programs/regedit/regedit.ico[8] %{buildroot}%{_iconsdir}/regedit.png
323     convert programs/regedit/regedit.ico[7] %{buildroot}%{_liconsdir}/regedit.png
324     # winemine icon
325     convert programs/winemine/winemine.ico[2] %{buildroot}%{_miconsdir}/winemine.png
326     convert programs/winemine/winemine.ico[8] %{buildroot}%{_iconsdir}/winemine.png
327     convert programs/winemine/winemine.ico[7] %{buildroot}%{_liconsdir}/winemine.png
328    
329     # wine uninstaller icon:
330     convert programs/msiexec/msiexec.ico[2] %{buildroot}%{_miconsdir}/msiexec.png
331     convert programs/msiexec/msiexec.ico[8] %{buildroot}%{_iconsdir}/msiexec.png
332     convert programs/msiexec/msiexec.ico[7] %{buildroot}%{_liconsdir}/msiexec.png
333    
334     # change the icons in the respective .desktop files, in order:
335 zezinho 156874 sed -i 's,Icon=%{name},Icon=notepad,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-notepad.desktop
336     sed -i 's,Icon=%{name},Icon=winefile,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-winefile.desktop
337     sed -i 's,Icon=%{name},Icon=regedit,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-regedit.desktop
338     sed -i 's,Icon=%{name},Icon=winemine,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-winemine.desktop
339     sed -i 's,Icon=%{name},Icon=msiexec,' "%{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-wine uninstaller.desktop"
340 ahmad 36061
341     %ifarch x86_64
342     chrpath -d %{buildroot}%{_bindir}/{wine64,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
343     %else
344     chrpath -d %{buildroot}%{_bindir}/{wine,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
345     %endif
346    
347     %ifarch x86_64
348     cat > README.install.urpmi <<EOF
349     This is the Win64 version of Wine. This version can only be used to run
350     64-bit Windows applications as is. For running 32-bit Windows applications,
351     you need to also install the 'wine32' package from the 32-bit repository.
352     EOF
353     %endif
354    
355     %preun -n %{wine}
356     %_preun_service %{name}
357    
358     %post -n %{wine}
359     %_post_service %{name}
360    
361     %files -n %{wine}
362     %doc ANNOUNCE AUTHORS README
363     %ifarch x86_64
364     %doc README.install.urpmi
365     %{_bindir}/wine64
366     %{_bindir}/wine64-preloader
367     %endif
368     %{_initrddir}/%{name}
369     %{_bindir}/winecfg
370     %{_bindir}/wineconsole*
371     %{_bindir}/wineserver
372     %{_bindir}/wineboot
373     %{_bindir}/function_grep.pl
374     #%{_bindir}/wineprefixcreate
375     %{_bindir}/msiexec
376     %{_bindir}/notepad
377     %{_bindir}/regedit
378     %{_bindir}/winemine
379     %{_bindir}/winepath
380     %{_bindir}/regsvr32
381     %{_bindir}/winefile
382     %{_mandir}/man1/wine.1*
383     %lang(de) %{_mandir}/de.UTF-8/man1/wine.1*
384     %lang(de) %{_mandir}/de.UTF-8/man1/winemaker.1*
385     %lang(de) %{_mandir}/de.UTF-8/man1/wineserver.1*
386     %lang(fr) %{_mandir}/fr.UTF-8/man1/*
387 ahmad 103264 %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
388 ahmad 36061 %{_mandir}/man1/wineserver.1*
389     %{_mandir}/man1/msiexec.1*
390     %{_mandir}/man1/notepad.1*
391     %{_mandir}/man1/regedit.1*
392     %{_mandir}/man1/regsvr32.1*
393     %{_mandir}/man1/wineboot.1*
394     %{_mandir}/man1/winecfg.1*
395     %{_mandir}/man1/wineconsole.1*
396     %{_mandir}/man1/winecpp.1*
397     %{_mandir}/man1/winefile.1*
398     %{_mandir}/man1/winemine.1*
399     %{_mandir}/man1/winepath.1*
400     %dir %{_datadir}/%{name}
401     %{_datadir}/%{name}/generic.ppd
402     %{_datadir}/%{name}/%{name}.inf
403     %{_datadir}/%{name}/l_intl.nls
404     %{_datadir}/applications/*.desktop
405 zezinho 156874 %{_sysconfdir}/xdg/menus/applications-merged/%{_real_vendor}-%{name}.menu
406     %{_datadir}/desktop-directories/%{_real_vendor}-%{name}.directory
407 ahmad 36061 %dir %{_datadir}/wine/fonts
408     %{_datadir}/wine/fonts/*
409     %{_miconsdir}/*.png
410     %{_iconsdir}/*.png
411     %{_liconsdir}/*.png
412    
413     %ifarch %{ix86}
414     %files -n wine32
415     %{_bindir}/wine
416     %{_bindir}/wine-preloader
417     %endif
418    
419     %{_libdir}/libwine*.so.%{lib_major}*
420     %dir %{_libdir}/%{name}
421     %{_libdir}/%{name}/*.cpl.so
422     %{_libdir}/%{name}/*.drv.so
423     %{_libdir}/%{name}/*.dll.so
424     %{_libdir}/%{name}/*.exe.so
425     %{_libdir}/%{name}/*.acm.so
426     %{_libdir}/%{name}/*.ocx.so
427     %ifarch %{ix86}
428     %{_libdir}/%{name}/*.vxd.so
429     %{_libdir}/%{name}/*16.so
430     %endif
431     %{_libdir}/%{name}/*.tlb.so
432     %{_libdir}/%{name}/*.ds.so
433     %{_libdir}/%{name}/*.sys.so
434     %{_libdir}/%{name}/fakedlls
435    
436     %files -n %{wine}-devel
437     %{_libdir}/%{name}/*.a
438     %{_libdir}/libwine*.so
439     %{_libdir}/%{name}/*.def
440     %{_includedir}/*
441 dams 259841 #%{_bindir}/fnt2bdf
442 ahmad 36061 %{_bindir}/wmc
443     %{_bindir}/wrc
444     %{_bindir}/winebuild
445     %{_bindir}/winegcc
446     %{_bindir}/wineg++
447     %{_bindir}/winecpp
448     %{_bindir}/widl
449     %{_bindir}/winedbg
450     %{_bindir}/winemaker
451     %{_bindir}/winedump
452     %{_mandir}/man1/wmc.1*
453     %{_mandir}/man1/wrc.1*
454     %{_mandir}/man1/winebuild.1*
455     %{_mandir}/man1/winemaker.1*
456     %{_mandir}/man1/winedump.1*
457     %{_mandir}/man1/widl.1*
458     %{_mandir}/man1/winedbg.1*
459     %{_mandir}/man1/wineg++.1*
460     %{_mandir}/man1/winegcc.1*

  ViewVC Help
Powered by ViewVC 1.1.30