/[packages]/cauldron/wine/pristine/SPECS/wine.spec
ViewVC logotype

Annotation of /cauldron/wine/pristine/SPECS/wine.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 72093 - (hide annotations) (download)
Tue Mar 15 18:40:56 2011 UTC (13 years, 1 month ago) by ahmad
Original Path: cauldron/wine/current/SPECS/wine.spec
File size: 15424 byte(s)
- add a requires on libncurses.so.*, winecfg (i586) complains about it in
  x86_64 installs

1 ahmad 36061 %ifarch x86_64
2     %define wine wine64
3     %define mark64 ()(64bit)
4     %else
5     %define wine wine
6     %define mark64 %{nil}
7     %endif
8     %define lib_name_orig lib%{name}
9     %define lib_major 1
10     %define lib_name %mklibname %{name} %{lib_major}
11     %define lib_name_devel %{mklibname -d wine}
12    
13     # On 32-bit we have
14     # wine32 - those 32-bit binaries that are also used on 64-bit for 32-bit support
15     # wine - all other files (requires 'wine32')
16     # On 64-bit we have
17     # wine64 - all 64-bit files (suggests 'wine32')
18     # - Anssi 07/2010
19    
20     Name: wine
21 ahmad 64272 Version: 1.3.15
22 ahmad 36061 %define pre 0
23 ahmad 72093 %define rel 5
24 ahmad 36061 %if %pre
25     Release: %mkrel 0.%pre.%rel
26     %define o_ver %version-%pre
27     %else
28     Release: %mkrel %rel
29     %define o_ver %version
30     %endif
31     Epoch: 1
32     Summary: WINE Is Not An Emulator - runs MS Windows programs
33     License: LGPLv2+
34     Group: Emulators
35     URL: http://www.winehq.com/
36     BuildRoot: %_tmppath/%{name}-%{version}-%{release}-buildroot
37     Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{o_ver}.tar.bz2
38     Source1: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{o_ver}.tar.bz2.sign
39    
40     # RH stuff
41     Source2: wine.init
42     Patch0: wine-1.0-rc3-fix-conflicts-with-openssl.patch
43     Patch1: wine-1.1.7-chinese-font-substitutes.patch
44     # (Anssi 05/2008) Adds:
45     # a: => /media/floppy (/mnt/floppy on 2007.1 and older)
46     # d: => $HOME (at config_dir creation time, not refreshed if $HOME changes;
47     # note that Wine also provides $HOME in My Documents)
48     # com4 => /dev/ttyUSB0 (replaces /dev/ttyS3)
49 ahmad 37896 Patch108: wine-mgaconf.patch
50 ahmad 36061
51     #(eandry) add a pulseaudio sound driver (from http://art.ified.ca/downloads/ )
52 ahmad 37896 Patch400: http://art.ified.ca/downloads/winepulse/winepulse-configure.ac-1.3.10.patch
53 ahmad 36061 Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.39.patch
54 ahmad 37896 Patch402: http://art.ified.ca/downloads/winepulse/winepulse-winecfg-1.3.11.patch
55 ahmad 36061
56     # (anssi) Wine needs GCC 4.4+ on x86_64 for MS ABI support. Note also that
57     # 64-bit wine cannot run 32-bit programs, so it should be named differently
58     # to allow co-installation. Upstream has not yet implemented this
59     # co-habitation, so one would need to resolve conflicts manually.
60     %ifarch x86_64
61     BuildRequires: gcc >= 4.4
62     %endif
63 ahmad 71420 BuildRequires: bison flex
64     BuildRequires: gpm-devel
65     BuildRequires: perl-devel
66     BuildRequires: ncurses-devel
67     BuildRequires: cups-devel
68     BuildRequires: sane-devel
69     BuildRequires: lcms-devel
70     BuildRequires: autoconf
71     BuildRequires: docbook-utils docbook-dtd-sgml
72     BuildRequires: docbook-utils docbook-dtd-sgml sgml-tools
73     BuildRequires: jackit-devel
74     BuildRequires: pulseaudio-devel
75 ahmad 36061 BuildRequires: libmpg123-devel
76     BuildRequires: openal-devel
77 ahmad 71420 BuildRequires: libalsa-devel
78 ahmad 36061 BuildRequires: gstreamer0.10-devel libgstreamer0.10-plugins-base-devel
79 ahmad 71420 BuildRequires: isdn4k-utils-devel
80     BuildRequires: glibc-static-devel
81     BuildRequires: chrpath
82     BuildRequires: ungif-devel xpm-devel
83     BuildRequires: tiff-devel
84     BuildRequires: librsvg
85     BuildRequires: imagemagick
86     BuildRequires: gphoto2-devel
87     BuildRequires: desktop-file-utils
88     BuildRequires: openldap-devel
89     BuildRequires: libxslt-devel
90     BuildRequires: dbus-devel
91     BuildRequires: hal-devel
92     BuildRequires: valgrind
93     BuildRequires: gsm-devel
94     BuildRequires: unixODBC-devel
95     BuildRequires: gnutls-devel
96 ahmad 36061 BuildRequires: prelink
97 ahmad 70893 BuildRequires: gettext-devel
98 ahmad 71420 BuildRequires: mesaglu-devel
99     BuildRequires: libv4l-devel
100     BuildRequires: libxcursor-devel libxcomposite-devel
101     BuildRequires: libxinerama-devel libxrandr-devel
102     BuildRequires: libx11-devel libxrender-devel
103     BuildRequires: libxext-devel libsm-devel
104     BuildRequires: fontforge fontconfig-devel freetype2-devel
105 ahmad 36061
106     %define desc Wine is a program which allows running Microsoft Windows programs \
107     (including DOS, Windows 3.x and Win32 executables) on Unix. It \
108     consists of a program loader which loads and executes a Microsoft \
109     Windows binary, and a library (called Winelib) that implements Windows \
110     API calls using their Unix or X11 equivalents. The library may also \
111     be used for porting Win32 code into native Unix executables.
112    
113     %ifarch x86_64
114     %package -n %{wine}
115     Summary: WINE Is Not An Emulator - runs MS Windows programs
116     Group: Emulators
117     Suggests: wine32 = %{epoch}:%{version}-%{release}
118     %else
119     # on 32-bit we always want wine32 package
120     Requires: wine32 = %{epoch}:%{version}-%{release}
121     %endif
122    
123     Provides: %{wine}-utils = %{epoch}:%{version}-%{release} %{wine}-full = %{epoch}:%{version}-%{release}
124     Provides: %{lib_name}-capi = %{epoch}:%{version}-%{release} %{lib_name}-twain = %{epoch}:%{version}-%{release}
125     Provides: %{lib_name} = %{epoch}:%{version}-%{release}
126     Provides: wine-bin = %{epoch}:%{version}-%{release}
127     Obsoletes: %{wine}-utils %{wine}-full %{lib_name}-capi %{lib_name}-twain
128     Obsoletes: %{lib_name} <= %{epoch}:%{version}-%{release}
129     Requires: xmessage
130     Suggests: sane-frontends
131     # wine dlopen's these, so let's add the dependencies ourself
132     Requires: libfreetype.so.6%{mark64} libasound.so.2%{mark64}
133 ahmad 72084 # wine needs to dlopen libfontconfig to make CJK fonts show correctly in winecfg
134     Requires: libfontconfig.so.1%{mark64}
135 ahmad 72093 Requires: libncurses.so.5%{mark64}
136 ahmad 36061 Requires: libXrender.so.1%{mark64} libpng.so.3%{mark64}
137     Requires(post): desktop-file-utils
138     Requires(postun): desktop-file-utils
139     Requires(post): desktop-common-data
140     Requires(postun): desktop-common-data
141     Requires(preun): rpm-helper
142     Requires(post): rpm-helper
143     %ifarch %{ix86}
144     Conflicts: wine64
145     %else
146     Conflicts: wine
147     %endif
148    
149     %description
150     %desc
151    
152     %ifarch x86_64
153     %description -n %{wine}
154     %desc
155    
156     This package contains the Win64 version of Wine. You need the wine32
157     package from the 32-bit repository to be able to run 32-bit applications.
158     %endif
159    
160     %ifarch %ix86
161     %package -n wine32
162     Summary: 32-bit support for Wine
163     Group: Emulators
164     # This is not an EVR-specific requirement, as otherwise on x86_64 urpmi could
165     # resolve the dependency to wine64 even on upgrades, and therefore replace
166     # wine+wine32 installation with a wine32+wine64 installation. - Anssi
167     Requires: wine-bin
168     Conflicts: wine < 1:1.2-0.rc7.1
169     Conflicts: wine64 < 1:1.2-0.rc7.1
170     # (Anssi) If wine-gecko is not installed, wine pops up a dialog on first
171     # start proposing to download wine-gecko from sourceforge, while recommending
172     # to use distribution packages instead. Therefore suggest wine-gecko here:
173     Suggests: wine-gecko
174    
175     %description -n wine32
176     Wine is a program which allows running Microsoft Windows programs
177     (including DOS, Windows 3.x and Win32 executables) on Unix.
178    
179     This package contains the files needed to support 32-bit Windows
180     programs.
181     %endif
182    
183     %package -n %{wine}-devel
184     Summary: Static libraries and headers for %{name}
185     Group: Development/C
186     Requires: %{wine} = %{epoch}:%{version}
187     Provides: %{lib_name_devel} = %{epoch}:%{version}-%{release}
188     Provides: %{lib_name_orig}-devel = %{epoch}:%{version}-%{release}
189     Obsoletes: %{lib_name_devel} <= %{epoch}:%{version}-%{release}
190     Obsoletes: %{mklibname -d wine 1} < %{epoch}:%{version}
191     %ifarch %{ix86}
192     Conflicts: wine64-devel
193     %else
194     Conflicts: wine-devel
195     %endif
196    
197     %description -n %{wine}-devel
198     Wine is a program which allows running Microsoft Windows programs
199     (including DOS, Windows 3.x and Win32 executables) on Unix.
200    
201     %{wine}-devel contains the libraries and header files needed to
202     develop programs which make use of wine.
203    
204     Wine is often updated.
205    
206     %prep
207     %setup -q -n %name-%o_ver
208     %patch1 -p0 -b .chinese
209     %patch108 -p1 -b .conf
210     %patch400 -p1
211     %patch401 -p1
212     %patch402 -p1
213    
214     %build
215     %ifarch %ix86
216     # (Anssi 04/2008) bug #39604
217     # Some protection systems complain "debugger detected" with our
218     # -fomit-frame-pointer flag, so disable it.
219     export CFLAGS="%{optflags} -fno-omit-frame-pointer"
220     %endif
221    
222     # (Anssi 04/2008)
223     # If icotool is present, it is used to rebuild icon files. It is in contrib
224     # so we do not do that; this is here to ensure that installed icoutils does
225     # not change build behaviour.
226     export ICOTOOL=false
227    
228     autoreconf
229     %configure2_5x --with-x \
230     --with-pulse \
231     --without-nas \
232     --without-esd \
233     %ifarch x86_64
234     --enable-win64
235     %endif
236    
237     %make depend
238     %make
239    
240     %install
241     rm -rf %{buildroot}
242     %makeinstall_std LDCONFIG=/bin/true
243    
244     # Danny: dirty:
245     install -m755 tools/fnt2bdf -D %{buildroot}%{_bindir}/fnt2bdf
246    
247     # Allow users to launch Windows programs by just clicking on the .exe file...
248     install -m755 %{SOURCE2} -D %{buildroot}%{_initrddir}/%{name}
249    
250     mkdir -p %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged
251     cat > %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged/mageia-%{name}.menu <<EOF
252     <!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
253     "http://www.freedesktop.org/standards/menu-spec/menu-1.0.dtd">
254     <Menu>
255     <Name>Applications</Name>
256     <Menu>
257     <Name>Tools</Name>
258     <Menu>
259     <Name>Emulators</Name>
260     <Menu>
261     <Name>Wine</Name>
262     <Directory>mageia-%{name}.directory</Directory>
263     <Include>
264     <Category>X-MandrivaLinux-MoreApplications-Emulators-Wine</Category>
265     </Include>
266     </Menu>
267     </Menu>
268     </Menu>
269     </Menu>
270     EOF
271    
272     mkdir -p %{buildroot}%{_datadir}/desktop-directories
273     cat > %{buildroot}%{_datadir}/desktop-directories/mageia-%{name}.directory <<EOF
274     [Desktop Entry]
275     Name=Wine
276     Icon=%{name}
277     Type=Directory
278     EOF
279    
280     mkdir -p %{buildroot}%{_datadir}/applications/
281     for i in winecfg:Configurator \
282     notepad:Notepad \
283     winefile:File\ Manager \
284     regedit:Registry\ Editor \
285     winemine:Minesweeper \
286     wineboot:Reboot \
287     "wineconsole cmd":Command\ Line \
288     "wine uninstaller:Wine Software Uninstaller";
289     do cat > %{buildroot}%{_datadir}/applications/mageia-%{name}-`echo $i|cut -d: -f1`.desktop << EOF
290     [Desktop Entry]
291     Name=`echo $i|cut -d: -f2`
292     Comment=`echo $i|cut -d: -f2`
293     Exec=`echo $i|cut -d: -f1`
294     Icon=%{name}
295     Terminal=false
296     Type=Application
297     Categories=X-MandrivaLinux-MoreApplications-Emulators-Wine;
298     EOF
299     done
300    
301     # Categories=Emulator does nothing and is added as a workaround to kde #27700
302     desktop-file-install --vendor="" \
303     --add-mime-type=application/x-zip-compressed \
304     --remove-mime-type=application/x-zip-compressed \
305     --add-category=Emulator \
306     --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/wine.desktop
307    
308     %ifarch x86_64
309     # fix the binary name
310     sed -i 's,Exec=wine ,Exec=wine64 ,' %{buildroot}%{_datadir}/applications/wine.desktop
311     %endif
312    
313     install -d %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
314    
315     # winecfg icon
316     convert dlls/user32/resources/oic_winlogo.ico[8] %{buildroot}%{_miconsdir}/%{name}.png
317     convert dlls/user32/resources/oic_winlogo.ico[7] %{buildroot}%{_iconsdir}/%{name}.png
318     convert dlls/user32/resources/oic_winlogo.ico[6] %{buildroot}%{_liconsdir}/%{name}.png
319    
320     # notepad icon
321     convert programs/notepad/notepad.ico[2] %{buildroot}%{_miconsdir}/notepad.png
322     convert programs/notepad/notepad.ico[7] %{buildroot}%{_iconsdir}/notepad.png
323     convert programs/notepad/notepad.ico[8] %{buildroot}%{_liconsdir}/notepad.png
324     # winefile icon
325     convert programs/winefile/winefile.ico[2] %{buildroot}%{_miconsdir}/winefile.png
326     convert programs/winefile/winefile.ico[8] %{buildroot}%{_iconsdir}/winefile.png
327     convert programs/winefile/winefile.ico[7] %{buildroot}%{_liconsdir}/winefile.png
328     # regedit icon
329     convert programs/regedit/regedit.ico[2] %{buildroot}%{_miconsdir}/regedit.png
330     convert programs/regedit/regedit.ico[8] %{buildroot}%{_iconsdir}/regedit.png
331     convert programs/regedit/regedit.ico[7] %{buildroot}%{_liconsdir}/regedit.png
332     # winemine icon
333     convert programs/winemine/winemine.ico[2] %{buildroot}%{_miconsdir}/winemine.png
334     convert programs/winemine/winemine.ico[8] %{buildroot}%{_iconsdir}/winemine.png
335     convert programs/winemine/winemine.ico[7] %{buildroot}%{_liconsdir}/winemine.png
336    
337     # wine uninstaller icon:
338     convert programs/msiexec/msiexec.ico[2] %{buildroot}%{_miconsdir}/msiexec.png
339     convert programs/msiexec/msiexec.ico[8] %{buildroot}%{_iconsdir}/msiexec.png
340     convert programs/msiexec/msiexec.ico[7] %{buildroot}%{_liconsdir}/msiexec.png
341    
342     # change the icons in the respective .desktop files, in order:
343     sed -i 's,Icon=%{name},Icon=notepad,' %{buildroot}%{_datadir}/applications/mageia-wine-notepad.desktop
344     sed -i 's,Icon=%{name},Icon=winefile,' %{buildroot}%{_datadir}/applications/mageia-wine-winefile.desktop
345     sed -i 's,Icon=%{name},Icon=regedit,' %{buildroot}%{_datadir}/applications/mageia-wine-regedit.desktop
346     sed -i 's,Icon=%{name},Icon=winemine,' %{buildroot}%{_datadir}/applications/mageia-wine-winemine.desktop
347     sed -i 's,Icon=%{name},Icon=msiexec,' "%{buildroot}%{_datadir}/applications/mageia-wine-wine uninstaller.desktop"
348    
349     %ifarch x86_64
350     chrpath -d %{buildroot}%{_bindir}/{wine64,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
351     %else
352     chrpath -d %{buildroot}%{_bindir}/{wine,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
353     %endif
354    
355     %ifarch x86_64
356     cat > README.install.urpmi <<EOF
357     This is the Win64 version of Wine. This version can only be used to run
358     64-bit Windows applications as is. For running 32-bit Windows applications,
359     you need to also install the 'wine32' package from the 32-bit repository.
360     EOF
361     %endif
362    
363     %clean
364     rm -fr %{buildroot}
365    
366     %preun -n %{wine}
367     %_preun_service %{name}
368    
369     %post -n %{wine}
370     %_post_service %{name}
371    
372     %files -n %{wine}
373     %defattr(-,root,root)
374     %doc ANNOUNCE AUTHORS README
375     %ifarch x86_64
376     %doc README.install.urpmi
377     %{_bindir}/wine64
378     %{_bindir}/wine64-preloader
379     %endif
380     %{_initrddir}/%{name}
381     %{_bindir}/winecfg
382     %{_bindir}/wineconsole*
383     %{_bindir}/wineserver
384     %{_bindir}/wineboot
385     %{_bindir}/function_grep.pl
386     #%{_bindir}/wineprefixcreate
387     %{_bindir}/msiexec
388     %{_bindir}/notepad
389     %{_bindir}/regedit
390     %{_bindir}/winemine
391     %{_bindir}/winepath
392     %{_bindir}/regsvr32
393     %{_bindir}/winefile
394     %{_mandir}/man1/wine.1*
395     %lang(de) %{_mandir}/de.UTF-8/man1/wine.1*
396     %lang(de) %{_mandir}/de.UTF-8/man1/winemaker.1*
397     %lang(de) %{_mandir}/de.UTF-8/man1/wineserver.1*
398     %lang(fr) %{_mandir}/fr.UTF-8/man1/*
399     %{_mandir}/man1/wineserver.1*
400     %{_mandir}/man1/msiexec.1*
401     %{_mandir}/man1/notepad.1*
402     %{_mandir}/man1/regedit.1*
403     %{_mandir}/man1/regsvr32.1*
404     %{_mandir}/man1/wineboot.1*
405     %{_mandir}/man1/winecfg.1*
406     %{_mandir}/man1/wineconsole.1*
407     %{_mandir}/man1/winecpp.1*
408     %{_mandir}/man1/winefile.1*
409     %{_mandir}/man1/winemine.1*
410     %{_mandir}/man1/winepath.1*
411     %dir %{_datadir}/%{name}
412     %{_datadir}/%{name}/generic.ppd
413     %{_datadir}/%{name}/%{name}.inf
414     %{_datadir}/%{name}/l_intl.nls
415     %{_datadir}/applications/*.desktop
416     %{_sysconfdir}/xdg/menus/applications-merged/mageia-%{name}.menu
417     %{_datadir}/desktop-directories/mageia-%{name}.directory
418     %dir %{_datadir}/wine/fonts
419     %{_datadir}/wine/fonts/*
420     %{_miconsdir}/*.png
421     %{_iconsdir}/*.png
422     %{_liconsdir}/*.png
423    
424     %ifarch %{ix86}
425     %files -n wine32
426     %defattr(-,root,root)
427     %{_bindir}/wine
428     %{_bindir}/wine-preloader
429     %endif
430    
431     %{_libdir}/libwine*.so.%{lib_major}*
432     %dir %{_libdir}/%{name}
433     %{_libdir}/%{name}/*.cpl.so
434     %{_libdir}/%{name}/*.drv.so
435     %{_libdir}/%{name}/*.dll.so
436     %{_libdir}/%{name}/*.exe.so
437     %{_libdir}/%{name}/*.acm.so
438     %{_libdir}/%{name}/*.ocx.so
439     %ifarch %{ix86}
440     %{_libdir}/%{name}/*.vxd.so
441     %{_libdir}/%{name}/*16.so
442     %endif
443     %{_libdir}/%{name}/*.tlb.so
444     %{_libdir}/%{name}/*.ds.so
445     %{_libdir}/%{name}/*.sys.so
446     %{_libdir}/%{name}/fakedlls
447    
448     %files -n %{wine}-devel
449     %defattr(-,root,root)
450     %{_libdir}/%{name}/*.a
451     %{_libdir}/libwine*.so
452     %{_libdir}/%{name}/*.def
453     %{_includedir}/*
454     %{_bindir}/fnt2bdf
455     %{_bindir}/wmc
456     %{_bindir}/wrc
457     %{_bindir}/winebuild
458     %{_bindir}/winegcc
459     %{_bindir}/wineg++
460     %{_bindir}/winecpp
461     %{_bindir}/widl
462     %{_bindir}/winedbg
463     %{_bindir}/winemaker
464     %{_bindir}/winedump
465     %{_mandir}/man1/wmc.1*
466     %{_mandir}/man1/wrc.1*
467     %{_mandir}/man1/winebuild.1*
468     %{_mandir}/man1/winemaker.1*
469     %{_mandir}/man1/winedump.1*
470     %{_mandir}/man1/widl.1*
471     %{_mandir}/man1/winedbg.1*
472     %{_mandir}/man1/wineg++.1*
473     %{_mandir}/man1/winegcc.1*

  ViewVC Help
Powered by ViewVC 1.1.30