/[packages]/cauldron/wine/releases/1:1.5.13/1.mga3/SPECS/wine.spec
ViewVC logotype

Annotation of /cauldron/wine/releases/1:1.5.13/1.mga3/SPECS/wine.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 259841 - (hide annotations) (download)
Mon Jun 11 19:04:25 2012 UTC (11 years, 9 months ago) by dams
Original Path: cauldron/wine/current/SPECS/wine.spec
File size: 15280 byte(s)
new version 1.5.6
1 ahmad 36061 %ifarch x86_64
2     %define wine wine64
3     %define mark64 ()(64bit)
4     %else
5     %define wine wine
6     %define mark64 %{nil}
7     %endif
8     %define lib_name_orig lib%{name}
9     %define lib_major 1
10     %define lib_name %mklibname %{name} %{lib_major}
11     %define lib_name_devel %{mklibname -d wine}
12    
13     # On 32-bit we have
14     # wine32 - those 32-bit binaries that are also used on 64-bit for 32-bit support
15     # wine - all other files (requires 'wine32')
16     # On 64-bit we have
17     # wine64 - all 64-bit files (suggests 'wine32')
18     # - Anssi 07/2010
19    
20 anssi 188253 # When altering this, make sure the new wine-gecko is submitted or at least
21     # notify its maintainer of the needed update.
22 dams 259841 %define gecko_version 1.5
23 anssi 188253
24 ahmad 36061 Name: wine
25 dams 259841 Version: 1.5.6
26 fwang 221865 %define pre 0
27 zezinho 177101 %define rel 1
28 ahmad 36061 %if %pre
29     Release: %mkrel 0.%pre.%rel
30     %define o_ver %version-%pre
31     %else
32     Release: %mkrel %rel
33     %define o_ver %version
34     %endif
35     Epoch: 1
36     Summary: WINE Is Not An Emulator - runs MS Windows programs
37     License: LGPLv2+
38     Group: Emulators
39     URL: http://www.winehq.com/
40 ahmad 103264 Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2
41     Source1: http://prdownloads.sourceforge.net/wine/%{name}-%{o_ver}.tar.bz2.sign
42 ahmad 36061
43     # RH stuff
44     Source2: wine.init
45     Patch0: wine-1.0-rc3-fix-conflicts-with-openssl.patch
46     Patch1: wine-1.1.7-chinese-font-substitutes.patch
47     # (Anssi 05/2008) Adds:
48     # a: => /media/floppy (/mnt/floppy on 2007.1 and older)
49     # d: => $HOME (at config_dir creation time, not refreshed if $HOME changes;
50     # note that Wine also provides $HOME in My Documents)
51     # com4 => /dev/ttyUSB0 (replaces /dev/ttyS3)
52 ahmad 37896 Patch108: wine-mgaconf.patch
53 ahmad 36061
54     # (anssi) Wine needs GCC 4.4+ on x86_64 for MS ABI support. Note also that
55 anssi 96590 # 64-bit wine cannot run 32-bit programs without wine32.
56 ahmad 36061 %ifarch x86_64
57     BuildRequires: gcc >= 4.4
58     %endif
59 ahmad 101529 BuildRequires: bison flex
60 ahmad 71420 BuildRequires: gpm-devel
61     BuildRequires: perl-devel
62     BuildRequires: ncurses-devel
63     BuildRequires: cups-devel
64     BuildRequires: sane-devel
65     BuildRequires: lcms-devel
66     BuildRequires: autoconf
67     BuildRequires: docbook-utils docbook-dtd-sgml
68     BuildRequires: docbook-utils docbook-dtd-sgml sgml-tools
69     BuildRequires: pulseaudio-devel
70 ahmad 36061 BuildRequires: libmpg123-devel
71     BuildRequires: openal-devel
72 ahmad 71420 BuildRequires: libalsa-devel
73 ahmad 36061 BuildRequires: gstreamer0.10-devel libgstreamer0.10-plugins-base-devel
74 ahmad 71420 BuildRequires: isdn4k-utils-devel
75     BuildRequires: glibc-static-devel
76     BuildRequires: chrpath
77     BuildRequires: ungif-devel xpm-devel
78     BuildRequires: tiff-devel
79     BuildRequires: librsvg
80     BuildRequires: imagemagick
81     BuildRequires: gphoto2-devel
82     BuildRequires: desktop-file-utils
83     BuildRequires: openldap-devel
84     BuildRequires: libxslt-devel
85     BuildRequires: dbus-devel
86 ahmad 110810 BuildRequires: valgrind-devel
87 ahmad 71420 BuildRequires: gsm-devel
88     BuildRequires: unixODBC-devel
89 ahmad 110810 BuildRequires: gnutls-devel
90 ahmad 36061 BuildRequires: prelink
91 ahmad 70893 BuildRequires: gettext-devel
92 ahmad 71420 BuildRequires: mesaglu-devel
93     BuildRequires: libv4l-devel
94     BuildRequires: libxcursor-devel libxcomposite-devel
95     BuildRequires: libxinerama-devel libxrandr-devel
96     BuildRequires: libx11-devel libxrender-devel
97     BuildRequires: libxext-devel libsm-devel
98     BuildRequires: fontforge fontconfig-devel freetype2-devel
99 ahmad 36061
100     %define desc Wine is a program which allows running Microsoft Windows programs \
101     (including DOS, Windows 3.x and Win32 executables) on Unix. It \
102     consists of a program loader which loads and executes a Microsoft \
103     Windows binary, and a library (called Winelib) that implements Windows \
104     API calls using their Unix or X11 equivalents. The library may also \
105     be used for porting Win32 code into native Unix executables.
106    
107     %ifarch x86_64
108     %package -n %{wine}
109     Summary: WINE Is Not An Emulator - runs MS Windows programs
110     Group: Emulators
111     Suggests: wine32 = %{epoch}:%{version}-%{release}
112 anssi 188253 Suggests: wine64-gecko = %gecko_version
113 ahmad 36061 %else
114     # on 32-bit we always want wine32 package
115     Requires: wine32 = %{epoch}:%{version}-%{release}
116     %endif
117    
118     Provides: %{wine}-utils = %{epoch}:%{version}-%{release} %{wine}-full = %{epoch}:%{version}-%{release}
119     Provides: %{lib_name}-capi = %{epoch}:%{version}-%{release} %{lib_name}-twain = %{epoch}:%{version}-%{release}
120     Provides: %{lib_name} = %{epoch}:%{version}-%{release}
121     Provides: wine-bin = %{epoch}:%{version}-%{release}
122     Obsoletes: %{wine}-utils %{wine}-full %{lib_name}-capi %{lib_name}-twain
123     Obsoletes: %{lib_name} <= %{epoch}:%{version}-%{release}
124     Requires: xmessage
125     Suggests: sane-frontends
126     # wine dlopen's these, so let's add the dependencies ourself
127     Requires: libfreetype.so.6%{mark64} libasound.so.2%{mark64}
128 ahmad 72084 # wine needs to dlopen libfontconfig to make CJK fonts show correctly in winecfg
129     Requires: libfontconfig.so.1%{mark64}
130 ahmad 72093 Requires: libncurses.so.5%{mark64}
131 fwang 142563 Requires: libXrender.so.1%{mark64} libpng15.so.15%{mark64}
132 ahmad 36061 Requires(post): desktop-file-utils
133     Requires(postun): desktop-file-utils
134     Requires(post): desktop-common-data
135     Requires(postun): desktop-common-data
136     Requires(preun): rpm-helper
137     Requires(post): rpm-helper
138     %ifarch %{ix86}
139     Conflicts: wine64
140     %else
141     Conflicts: wine
142     %endif
143    
144     %description
145     %desc
146    
147     %ifarch x86_64
148     %description -n %{wine}
149     %desc
150    
151     This package contains the Win64 version of Wine. You need the wine32
152     package from the 32-bit repository to be able to run 32-bit applications.
153     %endif
154    
155     %ifarch %ix86
156     %package -n wine32
157     Summary: 32-bit support for Wine
158     Group: Emulators
159     # This is not an EVR-specific requirement, as otherwise on x86_64 urpmi could
160     # resolve the dependency to wine64 even on upgrades, and therefore replace
161     # wine+wine32 installation with a wine32+wine64 installation. - Anssi
162     Requires: wine-bin
163     Conflicts: wine < 1:1.2-0.rc7.1
164     Conflicts: wine64 < 1:1.2-0.rc7.1
165     # (Anssi) If wine-gecko is not installed, wine pops up a dialog on first
166     # start proposing to download wine-gecko from sourceforge, while recommending
167     # to use distribution packages instead. Therefore suggest wine-gecko here:
168 anssi 188253 Suggests: wine-gecko = %gecko_version
169 ahmad 36061
170     %description -n wine32
171     Wine is a program which allows running Microsoft Windows programs
172     (including DOS, Windows 3.x and Win32 executables) on Unix.
173    
174     This package contains the files needed to support 32-bit Windows
175     programs.
176     %endif
177    
178     %package -n %{wine}-devel
179     Summary: Static libraries and headers for %{name}
180     Group: Development/C
181     Requires: %{wine} = %{epoch}:%{version}
182     Provides: %{lib_name_devel} = %{epoch}:%{version}-%{release}
183     Provides: %{lib_name_orig}-devel = %{epoch}:%{version}-%{release}
184     Obsoletes: %{lib_name_devel} <= %{epoch}:%{version}-%{release}
185     Obsoletes: %{mklibname -d wine 1} < %{epoch}:%{version}
186     %ifarch %{ix86}
187     Conflicts: wine64-devel
188     %else
189     Conflicts: wine-devel
190     %endif
191    
192     %description -n %{wine}-devel
193     Wine is a program which allows running Microsoft Windows programs
194     (including DOS, Windows 3.x and Win32 executables) on Unix.
195    
196     %{wine}-devel contains the libraries and header files needed to
197     develop programs which make use of wine.
198    
199     Wine is often updated.
200    
201     %prep
202     %setup -q -n %name-%o_ver
203     %patch1 -p0 -b .chinese
204     %patch108 -p1 -b .conf
205    
206 anssi 188253 GECKO_VERSION=$(sed -rn 's,^#define\s+GECKO_VERSION\s+"([^"]*)".*$,\1,p' dlls/appwiz.cpl/addons.c)
207     [ "$GECKO_VERSION" = "%gecko_version" ] || { echo wine-gecko version mismatch; exit 1; }
208    
209 ahmad 36061 %build
210     %ifarch %ix86
211     # (Anssi 04/2008) bug #39604
212     # Some protection systems complain "debugger detected" with our
213     # -fomit-frame-pointer flag, so disable it.
214     export CFLAGS="%{optflags} -fno-omit-frame-pointer"
215     %endif
216    
217     # (Anssi 04/2008)
218     # If icotool is present, it is used to rebuild icon files. It is in contrib
219     # so we do not do that; this is here to ensure that installed icoutils does
220     # not change build behaviour.
221     export ICOTOOL=false
222    
223     autoreconf
224     %configure2_5x --with-x \
225     --with-pulse \
226     %ifarch x86_64
227     --enable-win64
228     %endif
229    
230     %make depend
231     %make
232    
233     %install
234     rm -rf %{buildroot}
235     %makeinstall_std LDCONFIG=/bin/true
236    
237     # Danny: dirty:
238 dams 259841 #install -m755 tools/fnt2bdf -D %{buildroot}%{_bindir}/fnt2bdf
239 ahmad 36061
240     # Allow users to launch Windows programs by just clicking on the .exe file...
241     install -m755 %{SOURCE2} -D %{buildroot}%{_initrddir}/%{name}
242    
243     mkdir -p %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged
244 zezinho 156874 cat > %{buildroot}%{_sysconfdir}/xdg/menus/applications-merged/%{_real_vendor}-%{name}.menu <<EOF
245 ahmad 36061 <!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
246     "http://www.freedesktop.org/standards/menu-spec/menu-1.0.dtd">
247     <Menu>
248     <Name>Applications</Name>
249     <Menu>
250     <Name>Tools</Name>
251     <Menu>
252     <Name>Emulators</Name>
253     <Menu>
254     <Name>Wine</Name>
255 zezinho 156874 <Directory>%{_real_vendor}-%{name}.directory</Directory>
256 ahmad 36061 <Include>
257     <Category>X-MandrivaLinux-MoreApplications-Emulators-Wine</Category>
258     </Include>
259     </Menu>
260     </Menu>
261     </Menu>
262     </Menu>
263     EOF
264    
265     mkdir -p %{buildroot}%{_datadir}/desktop-directories
266 zezinho 156874 cat > %{buildroot}%{_datadir}/desktop-directories/%{_real_vendor}-%{name}.directory <<EOF
267 ahmad 36061 [Desktop Entry]
268     Name=Wine
269     Icon=%{name}
270     Type=Directory
271     EOF
272    
273     mkdir -p %{buildroot}%{_datadir}/applications/
274     for i in winecfg:Configurator \
275     notepad:Notepad \
276     winefile:File\ Manager \
277     regedit:Registry\ Editor \
278     winemine:Minesweeper \
279     wineboot:Reboot \
280     "wineconsole cmd":Command\ Line \
281     "wine uninstaller:Wine Software Uninstaller";
282 zezinho 156874 do cat > %{buildroot}%{_datadir}/applications/%{_real_vendor}-%{name}-`echo $i|cut -d: -f1`.desktop << EOF
283 ahmad 36061 [Desktop Entry]
284     Name=`echo $i|cut -d: -f2`
285     Comment=`echo $i|cut -d: -f2`
286     Exec=`echo $i|cut -d: -f1`
287     Icon=%{name}
288     Terminal=false
289     Type=Application
290     Categories=X-MandrivaLinux-MoreApplications-Emulators-Wine;
291     EOF
292     done
293    
294     # Categories=Emulator does nothing and is added as a workaround to kde #27700
295     desktop-file-install --vendor="" \
296     --add-mime-type=application/x-zip-compressed \
297     --remove-mime-type=application/x-zip-compressed \
298     --add-category=Emulator \
299     --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/wine.desktop
300    
301     %ifarch x86_64
302     # fix the binary name
303     sed -i 's,Exec=wine ,Exec=wine64 ,' %{buildroot}%{_datadir}/applications/wine.desktop
304     %endif
305    
306     install -d %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
307    
308     # winecfg icon
309     convert dlls/user32/resources/oic_winlogo.ico[8] %{buildroot}%{_miconsdir}/%{name}.png
310     convert dlls/user32/resources/oic_winlogo.ico[7] %{buildroot}%{_iconsdir}/%{name}.png
311     convert dlls/user32/resources/oic_winlogo.ico[6] %{buildroot}%{_liconsdir}/%{name}.png
312    
313     # notepad icon
314     convert programs/notepad/notepad.ico[2] %{buildroot}%{_miconsdir}/notepad.png
315     convert programs/notepad/notepad.ico[7] %{buildroot}%{_iconsdir}/notepad.png
316     convert programs/notepad/notepad.ico[8] %{buildroot}%{_liconsdir}/notepad.png
317     # winefile icon
318     convert programs/winefile/winefile.ico[2] %{buildroot}%{_miconsdir}/winefile.png
319     convert programs/winefile/winefile.ico[8] %{buildroot}%{_iconsdir}/winefile.png
320     convert programs/winefile/winefile.ico[7] %{buildroot}%{_liconsdir}/winefile.png
321     # regedit icon
322     convert programs/regedit/regedit.ico[2] %{buildroot}%{_miconsdir}/regedit.png
323     convert programs/regedit/regedit.ico[8] %{buildroot}%{_iconsdir}/regedit.png
324     convert programs/regedit/regedit.ico[7] %{buildroot}%{_liconsdir}/regedit.png
325     # winemine icon
326     convert programs/winemine/winemine.ico[2] %{buildroot}%{_miconsdir}/winemine.png
327     convert programs/winemine/winemine.ico[8] %{buildroot}%{_iconsdir}/winemine.png
328     convert programs/winemine/winemine.ico[7] %{buildroot}%{_liconsdir}/winemine.png
329    
330     # wine uninstaller icon:
331     convert programs/msiexec/msiexec.ico[2] %{buildroot}%{_miconsdir}/msiexec.png
332     convert programs/msiexec/msiexec.ico[8] %{buildroot}%{_iconsdir}/msiexec.png
333     convert programs/msiexec/msiexec.ico[7] %{buildroot}%{_liconsdir}/msiexec.png
334    
335     # change the icons in the respective .desktop files, in order:
336 zezinho 156874 sed -i 's,Icon=%{name},Icon=notepad,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-notepad.desktop
337     sed -i 's,Icon=%{name},Icon=winefile,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-winefile.desktop
338     sed -i 's,Icon=%{name},Icon=regedit,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-regedit.desktop
339     sed -i 's,Icon=%{name},Icon=winemine,' %{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-winemine.desktop
340     sed -i 's,Icon=%{name},Icon=msiexec,' "%{buildroot}%{_datadir}/applications/%{_real_vendor}-wine-wine uninstaller.desktop"
341 ahmad 36061
342     %ifarch x86_64
343     chrpath -d %{buildroot}%{_bindir}/{wine64,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
344     %else
345     chrpath -d %{buildroot}%{_bindir}/{wine,wineserver,wmc,wrc} %{buildroot}%{_libdir}/%{name}/*.so
346     %endif
347    
348     %ifarch x86_64
349     cat > README.install.urpmi <<EOF
350     This is the Win64 version of Wine. This version can only be used to run
351     64-bit Windows applications as is. For running 32-bit Windows applications,
352     you need to also install the 'wine32' package from the 32-bit repository.
353     EOF
354     %endif
355    
356     %clean
357     rm -fr %{buildroot}
358    
359     %preun -n %{wine}
360     %_preun_service %{name}
361    
362     %post -n %{wine}
363     %_post_service %{name}
364    
365     %files -n %{wine}
366     %defattr(-,root,root)
367     %doc ANNOUNCE AUTHORS README
368     %ifarch x86_64
369     %doc README.install.urpmi
370     %{_bindir}/wine64
371     %{_bindir}/wine64-preloader
372     %endif
373     %{_initrddir}/%{name}
374     %{_bindir}/winecfg
375     %{_bindir}/wineconsole*
376     %{_bindir}/wineserver
377     %{_bindir}/wineboot
378     %{_bindir}/function_grep.pl
379     #%{_bindir}/wineprefixcreate
380     %{_bindir}/msiexec
381     %{_bindir}/notepad
382     %{_bindir}/regedit
383     %{_bindir}/winemine
384     %{_bindir}/winepath
385     %{_bindir}/regsvr32
386     %{_bindir}/winefile
387     %{_mandir}/man1/wine.1*
388     %lang(de) %{_mandir}/de.UTF-8/man1/wine.1*
389     %lang(de) %{_mandir}/de.UTF-8/man1/winemaker.1*
390     %lang(de) %{_mandir}/de.UTF-8/man1/wineserver.1*
391     %lang(fr) %{_mandir}/fr.UTF-8/man1/*
392 ahmad 103264 %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
393 ahmad 36061 %{_mandir}/man1/wineserver.1*
394     %{_mandir}/man1/msiexec.1*
395     %{_mandir}/man1/notepad.1*
396     %{_mandir}/man1/regedit.1*
397     %{_mandir}/man1/regsvr32.1*
398     %{_mandir}/man1/wineboot.1*
399     %{_mandir}/man1/winecfg.1*
400     %{_mandir}/man1/wineconsole.1*
401     %{_mandir}/man1/winecpp.1*
402     %{_mandir}/man1/winefile.1*
403     %{_mandir}/man1/winemine.1*
404     %{_mandir}/man1/winepath.1*
405     %dir %{_datadir}/%{name}
406     %{_datadir}/%{name}/generic.ppd
407     %{_datadir}/%{name}/%{name}.inf
408     %{_datadir}/%{name}/l_intl.nls
409     %{_datadir}/applications/*.desktop
410 zezinho 156874 %{_sysconfdir}/xdg/menus/applications-merged/%{_real_vendor}-%{name}.menu
411     %{_datadir}/desktop-directories/%{_real_vendor}-%{name}.directory
412 ahmad 36061 %dir %{_datadir}/wine/fonts
413     %{_datadir}/wine/fonts/*
414     %{_miconsdir}/*.png
415     %{_iconsdir}/*.png
416     %{_liconsdir}/*.png
417    
418     %ifarch %{ix86}
419     %files -n wine32
420     %defattr(-,root,root)
421     %{_bindir}/wine
422     %{_bindir}/wine-preloader
423     %endif
424    
425     %{_libdir}/libwine*.so.%{lib_major}*
426     %dir %{_libdir}/%{name}
427     %{_libdir}/%{name}/*.cpl.so
428     %{_libdir}/%{name}/*.drv.so
429     %{_libdir}/%{name}/*.dll.so
430     %{_libdir}/%{name}/*.exe.so
431     %{_libdir}/%{name}/*.acm.so
432     %{_libdir}/%{name}/*.ocx.so
433     %ifarch %{ix86}
434     %{_libdir}/%{name}/*.vxd.so
435     %{_libdir}/%{name}/*16.so
436     %endif
437     %{_libdir}/%{name}/*.tlb.so
438     %{_libdir}/%{name}/*.ds.so
439     %{_libdir}/%{name}/*.sys.so
440     %{_libdir}/%{name}/fakedlls
441    
442     %files -n %{wine}-devel
443     %defattr(-,root,root)
444     %{_libdir}/%{name}/*.a
445     %{_libdir}/libwine*.so
446     %{_libdir}/%{name}/*.def
447     %{_includedir}/*
448 dams 259841 #%{_bindir}/fnt2bdf
449 ahmad 36061 %{_bindir}/wmc
450     %{_bindir}/wrc
451     %{_bindir}/winebuild
452     %{_bindir}/winegcc
453     %{_bindir}/wineg++
454     %{_bindir}/winecpp
455     %{_bindir}/widl
456     %{_bindir}/winedbg
457     %{_bindir}/winemaker
458     %{_bindir}/winedump
459     %{_mandir}/man1/wmc.1*
460     %{_mandir}/man1/wrc.1*
461     %{_mandir}/man1/winebuild.1*
462     %{_mandir}/man1/winemaker.1*
463     %{_mandir}/man1/winedump.1*
464     %{_mandir}/man1/widl.1*
465     %{_mandir}/man1/winedbg.1*
466     %{_mandir}/man1/wineg++.1*
467     %{_mandir}/man1/winegcc.1*

  ViewVC Help
Powered by ViewVC 1.1.30