1 |
%define oname wxGTK |
2 |
%define fname wxGTK |
3 |
%define majorminor 2.8 |
4 |
%define name wxgtk%majorminor |
5 |
%define version 2.8.11 |
6 |
%define major %majorminor |
7 |
%define release %mkrel 5 |
8 |
|
9 |
%define libname %mklibname wxgtk %{major} |
10 |
%define libnamedev %mklibname -d wxgtk %{major} |
11 |
%define libgl %mklibname wxgtkgl %{major} |
12 |
|
13 |
%define libnameu %mklibname wxgtku %{major} |
14 |
%define libnameudev %mklibname -d wxgtku %{major} |
15 |
%define libglu %mklibname wxgtkglu %{major} |
16 |
|
17 |
Summary: GTK+ port of the wxWidgets library |
18 |
Name: %{name} |
19 |
Version: %{version} |
20 |
Release: %{release} |
21 |
License: wxWidgets Library Licence |
22 |
Group: System/Libraries |
23 |
URL: http://www.wxwidgets.org/ |
24 |
Source0: http://prdownloads.sourceforge.net/wxwindows/%fname-%version.tar.bz2 |
25 |
#gw security patch for bundled expat which we don't use: |
26 |
Patch2: wxGTK-2.8.10-CVE-2009-XXXX.diff |
27 |
Patch3: wxgtk2.8-2.8.11-fix-linking.patch |
28 |
Patch8: wxWidgets-2.7.0-multiarch-includes.patch |
29 |
#gw security patch for bundled expat which we don't use: |
30 |
Patch9: wxGTK-2.8.8-CVE-2009-3560.diff |
31 |
BuildRequires: libSDL-devel |
32 |
BuildRequires: libsm-devel |
33 |
BuildRequires: libx11-devel |
34 |
BuildRequires: libxinerama-devel |
35 |
BuildRequires: libxxf86vm-devel |
36 |
BuildRequires: libexpat-devel |
37 |
BuildRequires: gtk+2-devel |
38 |
BuildRequires: jpeg-devel |
39 |
BuildRequires: png-devel |
40 |
BuildRequires: tiff-devel |
41 |
BuildRequires: bison, flex |
42 |
BuildRequires: mesaglu-devel |
43 |
BuildRequires: libgnomeprintui-devel |
44 |
BuildRequires: gstreamer0.10-devel libgstreamer0.10-plugins-base-devel |
45 |
BuildRequires: libGConf2-devel |
46 |
BuildRequires: cppunit-devel |
47 |
#Conflicts: wxGTK2.6 wxGTK2.5 wxGTK |
48 |
Conflicts: %mklibname wx_base2.4_ 0 |
49 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot |
50 |
|
51 |
%description |
52 |
wxWidgets is a free C++ library for cross-platform GUI development. |
53 |
With wxWidgets, you can create applications for different GUIs (GTK+, |
54 |
Motif/LessTif, MS Windows, Mac) from the same source code. |
55 |
|
56 |
%package -n %libname |
57 |
Group: System/Libraries |
58 |
Summary: Base shared library part of wxGTK |
59 |
Requires: %name >= %version |
60 |
|
61 |
%description -n %libname |
62 |
wxWidgets is a free C++ library for cross-platform GUI development. |
63 |
With wxWidgets, you can create applications for different GUIs (GTK+, |
64 |
Motif/LessTif, MS Windows, Mac) from the same source code. |
65 |
|
66 |
This package contains the library needed to run programs dynamically |
67 |
linked with %{name}. |
68 |
|
69 |
%package -n %{libnamedev} |
70 |
Summary: Header files and development documentation for wxGTK |
71 |
Group: Development/C++ |
72 |
Requires: %{libname} = %version |
73 |
Requires: %{libgl} = %version |
74 |
Provides: wxGTK-devel = %version-%release |
75 |
Provides: wxGTK%{majorminor}-devel = %version-%release |
76 |
Provides: libwxgtk%majorminor-devel = %version-%release |
77 |
Provides: libwxgtk-devel = %version-%release |
78 |
Conflicts: wxGTK6-devel wxGTK2.2-devel wxGTK2.3_1-devel |
79 |
Conflicts: libwxBase0-devel |
80 |
Conflicts: %mklibname wxgtk 2.4 -d |
81 |
Conflicts: %mklibname wxgtk 2.5_3 -d |
82 |
Conflicts: %mklibname wxgtk 2.6 -d |
83 |
Conflicts: %mklibname wxgtku 2.6 -d |
84 |
Conflicts: %mklibname wx_base2.4_ 0 -d |
85 |
|
86 |
%description -n %{libnamedev} |
87 |
Header files for wxGTK, the GTK+ port of the wxWidgets library. |
88 |
|
89 |
%package -n %{libgl} |
90 |
Summary: GTK+ port of the wxWidgets library, OpenGl add-on |
91 |
Group: System/Libraries |
92 |
Provides: wxGTK-gl = %version-%release |
93 |
Provides: wxGTK%{majorminor}-gl = %version-%release |
94 |
|
95 |
%description -n %{libgl} |
96 |
OpenGl add-on library for wxGTK, the GTK+ port of the wxWidgets library. |
97 |
|
98 |
%package -n %libnameu |
99 |
Group: System/Libraries |
100 |
Summary: Base shared library part of wxGTK - Unicode enabled |
101 |
Requires: %name >= %version |
102 |
|
103 |
%description -n %libnameu |
104 |
wxWidgets is a free C++ library for cross-platform GUI development. |
105 |
With wxWidgets, you can create applications for different GUIs (GTK+, |
106 |
Motif/LessTif, MS Windows, Mac) from the same source code. |
107 |
|
108 |
This package contains the library needed to run programs dynamically |
109 |
linked with the unicode enabled version of %{name}. |
110 |
|
111 |
%package -n %{libnameudev} |
112 |
Summary: Header files and development documentation for wxGTK - unicode |
113 |
Group: Development/C++ |
114 |
Requires: %{libnameu} = %version |
115 |
Requires: %{libglu} = %version |
116 |
Provides: libwxgtku-devel = %version-%release |
117 |
Provides: wxgtku-devel = %version-%release |
118 |
Provides: wxgtku%majorminor-devel = %version-%release |
119 |
Provides: libwxgtku%majorminor-devel = %version-%release |
120 |
Conflicts: %libname-devel < %version-%release |
121 |
Conflicts: %libname-devel > %version-%release |
122 |
Conflicts: %mklibname wxgtk 2.4 -d |
123 |
Conflicts: %mklibname wxgtk 2.5_3 -d |
124 |
Conflicts: %mklibname wxgtk 2.6 -d |
125 |
Conflicts: %mklibname wxgtku 2.6 -d |
126 |
Conflicts: %mklibname wx_base2.4_ 0 -d |
127 |
|
128 |
%description -n %{libnameudev} |
129 |
Header files for the unicode enabled version of wxGTK, the GTK+ port of |
130 |
the wxWidgets library. |
131 |
|
132 |
%package -n %{libglu} |
133 |
Summary: GTK+ port of the wxWidgets library, OpenGl add-on - unicode |
134 |
Group: System/Libraries |
135 |
|
136 |
%description -n %{libglu} |
137 |
OpenGl add-on library for the unicode enabled version of wxGTK, the |
138 |
GTK+ port of the wxWidgets library. |
139 |
|
140 |
%prep |
141 |
%setup -q -n %oname-%version -a 0 |
142 |
%patch2 -p0 -b .CVE-2009-XXXX |
143 |
%patch3 -p1 -b .linking |
144 |
%patch8 -p1 -b .multiarch |
145 |
%patch9 -p0 -b .CVE-2009-3560 |
146 |
cd %oname-%version |
147 |
%patch2 -p0 -b .CVE-2009-XXXX |
148 |
%patch3 -p1 -b .linking |
149 |
%patch8 -p1 |
150 |
%patch9 -p0 -b .CVE-2009-3560 |
151 |
|
152 |
cd .. |
153 |
# fix plugin dir for 64-bit |
154 |
sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp %oname-%version/src/unix/stdpaths.cpp |
155 |
|
156 |
find samples demos -name .cvsignore -exec rm {} \; |
157 |
|
158 |
%build |
159 |
#gw 2.8.11 doesn't build otherwise: |
160 |
%define Werror_cflags %nil |
161 |
# --disable-optimise prevents our $RPM_OPT_FLAGS being overridden |
162 |
# (see OPTIMISE in configure). |
163 |
# this code dereferences type-punned pointers like there's no tomorrow. |
164 |
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" |
165 |
CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" |
166 |
|
167 |
%configure2_5x \ |
168 |
--without-odbc \ |
169 |
--with-opengl \ |
170 |
--enable-gtk2 --with-gtk \ |
171 |
--without-debug_flag \ |
172 |
--without-debug_info \ |
173 |
--with-sdl \ |
174 |
--with-libpng=sys \ |
175 |
--with-libjpeg=sys \ |
176 |
--with-libtiff=sys \ |
177 |
--with-zlib=sys \ |
178 |
--with-expat=sys \ |
179 |
--disable-optimise \ |
180 |
--enable-calendar \ |
181 |
--enable-wave \ |
182 |
--enable-fraction \ |
183 |
--enable-wxprintfv \ |
184 |
--enable-xresources \ |
185 |
--enable-controls \ |
186 |
--enable-tabdialog \ |
187 |
--enable-msgdlg \ |
188 |
--enable-dirdlg \ |
189 |
--enable-numberdlg \ |
190 |
--enable-splash \ |
191 |
--enable-textdlg \ |
192 |
--enable-graphics_ctx \ |
193 |
--enable-grid \ |
194 |
--disable-catch_segvs \ |
195 |
--disable-rpath |
196 |
|
197 |
%make |
198 |
# Why isn't this this part of the main build? Need to investigate. |
199 |
%make -C locale allmo |
200 |
cd contrib |
201 |
%make |
202 |
cd .. |
203 |
#gw prepare samples |
204 |
cd demos |
205 |
make clean |
206 |
rm -f makefile* demos.bkl |
207 |
cd ../samples |
208 |
make clean |
209 |
rm -f makefile* samples.bkl |
210 |
cd .. |
211 |
find demos samples -name Makefile|xargs perl -pi -e 's^CXXC =.*^CXXC=\$(CXX) `wx-config --cflags`^' |
212 |
find demos samples -name Makefile|xargs perl -pi -e 's^EXTRALIBS =.*^EXTRALIBS=^' |
213 |
find demos samples -name Makefile|xargs perl -pi -e 's^SAMPLES_RPATH_FLAG =.*^SAMPLES_RPATH_FLAG=^' |
214 |
|
215 |
cd %oname-%version |
216 |
%configure2_5x --enable-unicode \ |
217 |
--without-odbc \ |
218 |
--with-opengl \ |
219 |
--enable-gtk2 --with-gtk \ |
220 |
--without-debug_flag \ |
221 |
--without-debug_info \ |
222 |
--with-sdl \ |
223 |
--with-libpng=sys \ |
224 |
--with-libjpeg=sys \ |
225 |
--with-libtiff=sys \ |
226 |
--with-zlib=sys \ |
227 |
--disable-optimise \ |
228 |
--enable-calendar \ |
229 |
--enable-wave \ |
230 |
--enable-fraction \ |
231 |
--enable-wxprintfv \ |
232 |
--enable-xresources \ |
233 |
--enable-controls \ |
234 |
--enable-tabdialog \ |
235 |
--enable-msgdlg \ |
236 |
--enable-dirdlg \ |
237 |
--enable-numberdlg \ |
238 |
--enable-splash \ |
239 |
--enable-textdlg \ |
240 |
--enable-graphics_ctx \ |
241 |
--enable-grid \ |
242 |
--disable-catch_segvs \ |
243 |
--disable-rpath |
244 |
%make |
245 |
cd contrib |
246 |
%make |
247 |
|
248 |
%install |
249 |
rm -rf %buildroot wxstd.lang wxmsw.lang |
250 |
%makeinstall |
251 |
%find_lang wxstd |
252 |
%find_lang wxmsw |
253 |
cat wxmsw.lang >> wxstd.lang |
254 |
cd contrib |
255 |
%makeinstall |
256 |
cd .. |
257 |
mv %buildroot%_bindir/wxrc-%{majorminor} %buildroot%_bindir/wxrc-%{majorminor}-ansi |
258 |
#gw fix broken symlink |
259 |
rm -f %buildroot%_bindir/{wx-config,wxrc} |
260 |
### |
261 |
cd %oname-%version |
262 |
%makeinstall |
263 |
cd contrib |
264 |
%makeinstall |
265 |
mv %buildroot%_bindir/wxrc-%{majorminor} %buildroot%_bindir/wxrc-%{majorminor}-unicode |
266 |
### |
267 |
#gw fix broken symlink |
268 |
rm -f %buildroot%_bindir/{wx-config,wxrc} |
269 |
ln -sf %_libdir/wx/config/gtk2-ansi-release-%{majorminor} %buildroot%_bindir/wx-config-ansi |
270 |
ln -sf %_libdir/wx/config/gtk2-unicode-release-%{majorminor} %buildroot%_bindir/wx-config-unicode |
271 |
|
272 |
%multiarch_binaries $RPM_BUILD_ROOT%{_libdir}/wx/config/gtk2-{ansi,unicode}-release-%{majorminor} |
273 |
#gw this breaks /usr/bin/wx-config |
274 |
mkdir %buildroot%multiarch_bindir |
275 |
ln -s %{_libdir}/wx/config/%multiarch_platform/gtk2-ansi-release-%{majorminor} %buildroot%multiarch_bindir/wx-config-ansi |
276 |
ln -s %{_libdir}/wx/config/%multiarch_platform/gtk2-unicode-release-%{majorminor} %buildroot%multiarch_bindir/wx-config-unicode |
277 |
%multiarch_includes $RPM_BUILD_ROOT%{_libdir}/wx/include/gtk2-{ansi,unicode}-release-%{majorminor}/wx/setup.h |
278 |
%multiarch_includes $RPM_BUILD_ROOT%{_includedir}/wx-%{majorminor}/wx/defs.h |
279 |
|
280 |
#gw remove Mandriva linker flags |
281 |
sed -i -e "s^-Wl,--as-needed^^g" %buildroot%_libdir/wx/config/%multiarch_platform/* |
282 |
|
283 |
|
284 |
%clean |
285 |
rm -rf %buildroot |
286 |
|
287 |
|
288 |
%post -n %libnamedev |
289 |
update-alternatives --install %{_bindir}/wx-config wx-config %{_libdir}/wx/config/gtk2-ansi-release-%{majorminor} 20 --slave %_bindir/wxrc wxrc %_bindir/wxrc-%{majorminor}-ansi |
290 |
%postun -n %libnamedev |
291 |
if [ "$1" = "0" ]; then |
292 |
update-alternatives --remove wx-config %{_libdir}/wx/config/gtk2-ansi-release-%{majorminor} |
293 |
fi |
294 |
|
295 |
%post -n %libnameudev |
296 |
update-alternatives --install %{_bindir}/wx-config wx-config %{_libdir}/wx/config/gtk2-unicode-release-%{majorminor} 15 --slave %_bindir/wxrc wxrc %_bindir/wxrc-%{majorminor}-unicode |
297 |
%postun -n %libnameudev |
298 |
if [ "$1" = "0" ]; then |
299 |
update-alternatives --remove wx-config %{_libdir}/wx/config/gtk2-unicode-release-%{majorminor} |
300 |
fi |
301 |
|
302 |
%files -f wxstd.lang |
303 |
%defattr(-,root,root,-) |
304 |
%doc *.txt |
305 |
|
306 |
%files -n %libname |
307 |
%defattr(-,root,root,-) |
308 |
%_libdir/libwx_gtk2_adv-%{majorminor}.so.* |
309 |
%_libdir/libwx_gtk2_aui-%{majorminor}.so.* |
310 |
%_libdir/libwx_gtk2_core-%{majorminor}.so.* |
311 |
%_libdir/libwx_gtk2_html-%{majorminor}.so.* |
312 |
%_libdir/libwx_gtk2_richtext-%{majorminor}.so.* |
313 |
%_libdir/libwx_base-%majorminor.so.* |
314 |
%_libdir/libwx_base_net-%majorminor.so.* |
315 |
%_libdir/libwx_base_xml-%majorminor.so.* |
316 |
# contribs |
317 |
%_libdir/libwx_gtk2_fl-%{majorminor}.so.* |
318 |
%_libdir/libwx_gtk2_gizmos-%{majorminor}.so.* |
319 |
%_libdir/libwx_gtk2_gizmos_xrc-%{majorminor}.so.* |
320 |
%_libdir/libwx_gtk2_ogl-%{majorminor}.so.* |
321 |
%_libdir/libwx_gtk2_plot-%{majorminor}.so.* |
322 |
%_libdir/libwx_gtk2_qa-%{majorminor}.so.* |
323 |
%_libdir/libwx_gtk2_stc-%{majorminor}.so.* |
324 |
%_libdir/libwx_gtk2_svg-%{majorminor}.so.* |
325 |
%_libdir/libwx_gtk2_xrc-%{majorminor}.so.* |
326 |
|
327 |
%files -n %libnameu |
328 |
%defattr(-,root,root,-) |
329 |
%_libdir/libwx_gtk2u_adv-%{majorminor}.so.* |
330 |
%_libdir/libwx_gtk2u_aui-%{majorminor}.so.* |
331 |
%_libdir/libwx_gtk2u_core-%{majorminor}.so.* |
332 |
%_libdir/libwx_gtk2u_html-%{majorminor}.so.* |
333 |
%_libdir/libwx_gtk2u_richtext-%{majorminor}.so.* |
334 |
%_libdir/libwx_baseu-%majorminor.so.* |
335 |
%_libdir/libwx_baseu_net-%majorminor.so.* |
336 |
%_libdir/libwx_baseu_xml-%majorminor.so.* |
337 |
# contribs |
338 |
%_libdir/libwx_gtk2u_fl-%{majorminor}.so.* |
339 |
%_libdir/libwx_gtk2u_gizmos-%{majorminor}.so.* |
340 |
%_libdir/libwx_gtk2u_gizmos_xrc-%{majorminor}.so.* |
341 |
%_libdir/libwx_gtk2u_ogl-%{majorminor}.so.* |
342 |
%_libdir/libwx_gtk2u_plot-%{majorminor}.so.* |
343 |
%_libdir/libwx_gtk2u_qa-%{majorminor}.so.* |
344 |
%_libdir/libwx_gtk2u_stc-%{majorminor}.so.* |
345 |
%_libdir/libwx_gtk2u_svg-%{majorminor}.so.* |
346 |
%_libdir/libwx_gtk2u_xrc-%{majorminor}.so.* |
347 |
|
348 |
%files -n %{libnamedev} |
349 |
%defattr(-,root,root,-) |
350 |
%doc samples/ |
351 |
%doc docs/ |
352 |
%doc demos/ |
353 |
%{_bindir}/wx-config-ansi |
354 |
%{_bindir}/wxrc-*ansi |
355 |
%{multiarch_bindir}/wx-config-ansi |
356 |
%{_includedir}/wx-%{majorminor}/ |
357 |
%dir %{_libdir}/wx/ |
358 |
%dir %{_libdir}/wx/include/ |
359 |
%dir %{_libdir}/wx/include/gtk2-ansi-release-%{majorminor}/ |
360 |
%dir %{_libdir}/wx/include/gtk2-ansi-release-%{majorminor}/wx/ |
361 |
%dir %{_libdir}/wx/config |
362 |
%{_libdir}/wx/config/gtk2-ansi-release-%{majorminor} |
363 |
%{_libdir}/wx/include/gtk2-ansi-release-%{majorminor}/wx/setup.h |
364 |
%_libdir/libwx_gtk2_adv-%{majorminor}.so |
365 |
%_libdir/libwx_gtk2_aui-%{majorminor}.so |
366 |
%_libdir/libwx_gtk2_core-%{majorminor}.so |
367 |
%_libdir/libwx_gtk2_html-%{majorminor}.so |
368 |
%_libdir/libwx_gtk2_richtext-%{majorminor}.so |
369 |
%_libdir/libwx_base-%majorminor.so |
370 |
%_libdir/libwx_base_net-%majorminor.so |
371 |
%_libdir/libwx_base_xml-%majorminor.so |
372 |
# contribs |
373 |
%_libdir/libwx_gtk2_fl-%{majorminor}.so |
374 |
%_libdir/libwx_gtk2_gizmos-%{majorminor}.so |
375 |
%_libdir/libwx_gtk2_gizmos_xrc-%{majorminor}.so |
376 |
%_libdir/libwx_gtk2_ogl-%{majorminor}.so |
377 |
%_libdir/libwx_gtk2_plot-%{majorminor}.so |
378 |
%_libdir/libwx_gtk2_qa-%{majorminor}.so |
379 |
%_libdir/libwx_gtk2_stc-%{majorminor}.so |
380 |
%_libdir/libwx_gtk2_svg-%{majorminor}.so |
381 |
%_libdir/libwx_gtk2_xrc-%{majorminor}.so |
382 |
#gl |
383 |
%_libdir/libwx_gtk2_gl-%{majorminor}.so |
384 |
%_datadir/aclocal/* |
385 |
%_datadir/bakefile/ |
386 |
%multiarch %{_libdir}/wx/config/multiarch-*/gtk2-ansi-release-%{majorminor} |
387 |
%multiarch %{_libdir}/wx/include/multiarch-*/gtk2-ansi-release-%{majorminor} |
388 |
%multiarch %{_includedir}/multiarch-*/wx-%{majorminor}/wx/defs.h |
389 |
|
390 |
%files -n %{libnameudev} |
391 |
%defattr(-,root,root,-) |
392 |
%doc samples/ |
393 |
%doc docs/ |
394 |
%doc demos/ |
395 |
%{_bindir}/wx-config-unicode |
396 |
%{_bindir}/wxrc-*unicode |
397 |
%{multiarch_bindir}/wx-config-unicode |
398 |
%{_includedir}/wx-%{majorminor}/ |
399 |
%dir %{_libdir}/wx/ |
400 |
%dir %{_libdir}/wx/include/ |
401 |
%dir %{_libdir}/wx/include/gtk2-unicode-release-%{majorminor}/ |
402 |
%dir %{_libdir}/wx/include/gtk2-unicode-release-%{majorminor}/wx/ |
403 |
%dir %{_libdir}/wx/config |
404 |
%{_libdir}/wx/config/gtk2-unicode-release-%{majorminor} |
405 |
%{_libdir}/wx/include/gtk2-unicode-release-%{majorminor}/wx/setup.h |
406 |
%_libdir/libwx_gtk2u_adv-%{majorminor}.so |
407 |
%_libdir/libwx_gtk2u_aui-%{majorminor}.so |
408 |
%_libdir/libwx_gtk2u_core-%{majorminor}.so |
409 |
%_libdir/libwx_gtk2u_html-%{majorminor}.so |
410 |
%_libdir/libwx_gtk2u_richtext-%{majorminor}.so |
411 |
%_libdir/libwx_baseu-%majorminor.so |
412 |
%_libdir/libwx_baseu_net-%majorminor.so |
413 |
%_libdir/libwx_baseu_xml-%majorminor.so |
414 |
# contribs |
415 |
%_libdir/libwx_gtk2u_fl-%{majorminor}.so |
416 |
%_libdir/libwx_gtk2u_gizmos-%{majorminor}.so |
417 |
%_libdir/libwx_gtk2u_gizmos_xrc-%{majorminor}.so |
418 |
%_libdir/libwx_gtk2u_ogl-%{majorminor}.so |
419 |
%_libdir/libwx_gtk2u_plot-%{majorminor}.so |
420 |
%_libdir/libwx_gtk2u_qa-%{majorminor}.so |
421 |
%_libdir/libwx_gtk2u_stc-%{majorminor}.so |
422 |
%_libdir/libwx_gtk2u_svg-%{majorminor}.so |
423 |
%_libdir/libwx_gtk2u_xrc-%{majorminor}.so |
424 |
#gl |
425 |
%_libdir/libwx_gtk2u_gl-%{majorminor}.so |
426 |
%_datadir/aclocal/* |
427 |
%_datadir/bakefile/ |
428 |
%multiarch %{_libdir}/wx/config/multiarch-*/gtk2-unicode-release-%{majorminor} |
429 |
%multiarch %{_libdir}/wx/include/multiarch-*/gtk2-unicode-release-%{majorminor} |
430 |
%multiarch %{_includedir}/multiarch-*/wx-%{majorminor}/wx/defs.h |
431 |
|
432 |
%files -n %{libgl} |
433 |
%defattr(-,root,root,-) |
434 |
%{_libdir}/libwx_gtk2_gl-%majorminor.so.* |
435 |
|
436 |
%files -n %{libglu} |
437 |
%defattr(-,root,root,-) |
438 |
%{_libdir}/libwx_gtk2u_gl-%majorminor.so.* |