1 |
obgr_seneca |
104962 |
%define oname vdr-plugin-xineliboutput |
2 |
|
|
%define plugin xineliboutput |
3 |
obgr_seneca |
103162 |
# manually created tarball from CVS tag |
4 |
|
|
%define snapshot 0 |
5 |
obgr_seneca |
104962 |
%define prever 0 |
6 |
umeabot |
963623 |
%define rel 7 |
7 |
obgr_seneca |
103162 |
|
8 |
|
|
%if %snapshot |
9 |
|
|
%if %prever |
10 |
obgr_seneca |
104962 |
%define release %mkrel 0.%prever.%snapshot.%rel |
11 |
obgr_seneca |
103162 |
%else |
12 |
|
|
%define release %mkrel 0.%snapshot.%rel |
13 |
|
|
%endif |
14 |
|
|
%else |
15 |
|
|
%if %prever |
16 |
|
|
%define release %mkrel 0.%prever.%rel |
17 |
|
|
%else |
18 |
|
|
%define release %mkrel %rel |
19 |
|
|
%endif |
20 |
|
|
%endif |
21 |
|
|
|
22 |
obgr_seneca |
104962 |
%define xineplugindir %(xine-config --plugindir 2>/dev/null || echo 0) |
23 |
obgr_seneca |
103162 |
# Does not always match rpm version, reports 1.1.9 on 1.1.9.1, so use rpmver directly instead. |
24 |
obgr_seneca |
104962 |
#define xineversion %(xine-config --version 2>/dev/null || echo 0) |
25 |
|
|
%define xineversion %(rpm -qf --qf '%%{version}' %{_bindir}/xine-config 2>/dev/null || echo 0) |
26 |
|
|
%define xineapi %(A=%xineplugindir; echo ${A##*/}) |
27 |
obgr_seneca |
103162 |
|
28 |
obgr_seneca |
104962 |
Summary: Xine frontend for the xineliboutput VDR plugin |
29 |
|
|
Name: xine-xvdr |
30 |
|
|
Version: 1.0.6 |
31 |
|
|
Release: %release |
32 |
fwang |
391100 |
Group: Video/Players |
33 |
obgr_seneca |
104962 |
License: GPLv2+ |
34 |
danf |
1563264 |
URL: https://sourceforge.net/projects/xineliboutput/ |
35 |
obgr_seneca |
103162 |
%if %snapshot |
36 |
obgr_seneca |
104962 |
Source0: vdr-%plugin-%snapshot.tar.bz2 |
37 |
obgr_seneca |
103162 |
%else |
38 |
|
|
%if %prever |
39 |
danf |
1563264 |
Source0: https://prdownloads.sourceforge.net/xineliboutput/vdr-%plugin-%{version}%{prever}.tar.bz2 |
40 |
obgr_seneca |
103162 |
%else |
41 |
danf |
1563264 |
Source0: https://prdownloads.sourceforge.net/xineliboutput/vdr-%plugin-%version.tar.lzma |
42 |
obgr_seneca |
104941 |
Patch0: xineliboutput-link.patch |
43 |
obgr_seneca |
103162 |
%endif |
44 |
|
|
%endif |
45 |
obgr_seneca |
104941 |
|
46 |
obgr_seneca |
104962 |
BuildRequires: vdr-devel >= 1.6.0 |
47 |
|
|
BuildRequires: libx11-devel |
48 |
|
|
BuildRequires: libxv-devel |
49 |
|
|
BuildRequires: libxine-devel |
50 |
|
|
BuildRequires: jpeg-devel |
51 |
|
|
BuildRequires: libextractor-devel |
52 |
|
|
BuildRequires: libxrender-devel |
53 |
|
|
BuildRequires: libxinerama-devel |
54 |
|
|
BuildRequires: dbus-glib-devel |
55 |
obgr_seneca |
103162 |
|
56 |
obgr_seneca |
104962 |
Requires: xine-plugin-api >= %xineapi |
57 |
|
|
Obsoletes: vdr-plugin-xineliboutput-frontend-xine <= %{version}-%{release} |
58 |
|
|
Obsoletes: xineliboutput-fe-xine <= %{version}-%{release} |
59 |
|
|
|
60 |
obgr_seneca |
103162 |
%description |
61 |
|
|
With this package you can connect to your VDR with xine with an MRL |
62 |
|
|
like below: |
63 |
|
|
xvdr://127.0.0.1#nocache;demux:mpeg_block |
64 |
|
|
|
65 |
|
|
Frontend packages: |
66 |
|
|
- xine-xvdr: Xine frontend |
67 |
|
|
- xine1.2-xvdr: Xine1.2 frontend |
68 |
|
|
- xineliboutput-sxfe: Standalone X11 frontend |
69 |
|
|
- xineliboutput-fbfe: Standalone FB frontend |
70 |
|
|
- xineliboutput-local-sxfe: Local X11 frontend |
71 |
|
|
- xineliboutput-local-fbfe: Local FB frontend |
72 |
|
|
|
73 |
|
|
%prep |
74 |
|
|
%if %snapshot |
75 |
|
|
%setup -q -n vdr-%plugin |
76 |
|
|
%else |
77 |
|
|
%if %prever |
78 |
|
|
%setup -q -n %plugin-%version%prever |
79 |
|
|
%else |
80 |
|
|
%setup -q -n %plugin-%version |
81 |
wally |
2093934 |
%patch -P 0 -p0 |
82 |
obgr_seneca |
103162 |
%endif |
83 |
|
|
%endif |
84 |
|
|
|
85 |
|
|
find -name CVS -type d | while read i; do rm -r "$i" || exit 1; done |
86 |
|
|
|
87 |
|
|
%build |
88 |
wally |
1474454 |
%set_build_flags |
89 |
obgr_seneca |
103162 |
CFLAGS="$CFLAGS -fPIC" |
90 |
obgr_seneca |
104941 |
LC_ALL=C %make XINELIBOUTPUT_VDRPLUGIN=0 XINELIBOUTPUT_X11=0 XINELIBOUTPUT_FB=0 VDRDIR=%{_includedir}/vdr LIBDIR=%{_libdir} VDRINCDIR=%{_includedir}/vdr BINDIR=%{_bindir} LOCALEDIR=. |
91 |
obgr_seneca |
103162 |
|
92 |
|
|
%install |
93 |
|
|
install -d -m755 %buildroot%xineplugindir/post %buildroot%_bindir |
94 |
|
|
%makeinstall XINELIBOUTPUT_VDRPLUGIN=0 XINELIBOUTPUT_X11=0 XINELIBOUTPUT_FB=0 LOCALEDIR=. \ |
95 |
obgr_seneca |
104962 |
XINEPLUGINDIR=%buildroot%xineplugindir |
96 |
tv |
895105 |
# (tv) fix debuginfo: |
97 |
|
|
chmod +x %{buildroot}%{_libdir}/xine/plugins/*/{,*/}*.so |
98 |
obgr_seneca |
103162 |
|
99 |
|
|
%files |
100 |
|
|
%doc README |
101 |
|
|
# xine-plugins maybe upgraded without new xine-xvdr (while everything still |
102 |
|
|
# works). Therefore we have to include the plugindir as well. |
103 |
|
|
%dir %{xineplugindir} |
104 |
|
|
%{xineplugindir}/*.so |
105 |
|
|
%{xineplugindir}/post/*.so |