1 |
%define oname vdr-plugin-xineliboutput |
2 |
%define plugin xineliboutput |
3 |
# manually created tarball from CVS tag |
4 |
%define snapshot 0 |
5 |
%define prever 0 |
6 |
%define rel 7 |
7 |
|
8 |
%if %snapshot |
9 |
%if %prever |
10 |
%define release %mkrel 0.%prever.%snapshot.%rel |
11 |
%else |
12 |
%define release %mkrel 0.%snapshot.%rel |
13 |
%endif |
14 |
%else |
15 |
%if %prever |
16 |
%define release %mkrel 0.%prever.%rel |
17 |
%else |
18 |
%define release %mkrel %rel |
19 |
%endif |
20 |
%endif |
21 |
|
22 |
%define xineplugindir %(xine-config --plugindir 2>/dev/null || echo 0) |
23 |
# Does not always match rpm version, reports 1.1.9 on 1.1.9.1, so use rpmver directly instead. |
24 |
#define xineversion %(xine-config --version 2>/dev/null || echo 0) |
25 |
%define xineversion %(rpm -qf --qf '%%{version}' %{_bindir}/xine-config 2>/dev/null || echo 0) |
26 |
%define xineapi %(A=%xineplugindir; echo ${A##*/}) |
27 |
|
28 |
Summary: Xine frontend for the xineliboutput VDR plugin |
29 |
Name: xine-xvdr |
30 |
Version: 1.0.6 |
31 |
Release: %release |
32 |
Group: Video/Players |
33 |
License: GPLv2+ |
34 |
URL: https://sourceforge.net/projects/xineliboutput/ |
35 |
%if %snapshot |
36 |
Source0: vdr-%plugin-%snapshot.tar.bz2 |
37 |
%else |
38 |
%if %prever |
39 |
Source0: https://prdownloads.sourceforge.net/xineliboutput/vdr-%plugin-%{version}%{prever}.tar.bz2 |
40 |
%else |
41 |
Source0: https://prdownloads.sourceforge.net/xineliboutput/vdr-%plugin-%version.tar.lzma |
42 |
Patch0: xineliboutput-link.patch |
43 |
%endif |
44 |
%endif |
45 |
|
46 |
BuildRequires: vdr-devel >= 1.6.0 |
47 |
BuildRequires: libx11-devel |
48 |
BuildRequires: libxv-devel |
49 |
BuildRequires: libxine-devel |
50 |
BuildRequires: jpeg-devel |
51 |
BuildRequires: libextractor-devel |
52 |
BuildRequires: libxrender-devel |
53 |
BuildRequires: libxinerama-devel |
54 |
BuildRequires: dbus-glib-devel |
55 |
|
56 |
Requires: xine-plugin-api >= %xineapi |
57 |
Obsoletes: vdr-plugin-xineliboutput-frontend-xine <= %{version}-%{release} |
58 |
Obsoletes: xineliboutput-fe-xine <= %{version}-%{release} |
59 |
|
60 |
%description |
61 |
With this package you can connect to your VDR with xine with an MRL |
62 |
like below: |
63 |
xvdr://127.0.0.1#nocache;demux:mpeg_block |
64 |
|
65 |
Frontend packages: |
66 |
- xine-xvdr: Xine frontend |
67 |
- xine1.2-xvdr: Xine1.2 frontend |
68 |
- xineliboutput-sxfe: Standalone X11 frontend |
69 |
- xineliboutput-fbfe: Standalone FB frontend |
70 |
- xineliboutput-local-sxfe: Local X11 frontend |
71 |
- xineliboutput-local-fbfe: Local FB frontend |
72 |
|
73 |
%prep |
74 |
%if %snapshot |
75 |
%setup -q -n vdr-%plugin |
76 |
%else |
77 |
%if %prever |
78 |
%setup -q -n %plugin-%version%prever |
79 |
%else |
80 |
%setup -q -n %plugin-%version |
81 |
%patch -P 0 -p0 |
82 |
%endif |
83 |
%endif |
84 |
|
85 |
find -name CVS -type d | while read i; do rm -r "$i" || exit 1; done |
86 |
|
87 |
%build |
88 |
%set_build_flags |
89 |
CFLAGS="$CFLAGS -fPIC" |
90 |
LC_ALL=C %make XINELIBOUTPUT_VDRPLUGIN=0 XINELIBOUTPUT_X11=0 XINELIBOUTPUT_FB=0 VDRDIR=%{_includedir}/vdr LIBDIR=%{_libdir} VDRINCDIR=%{_includedir}/vdr BINDIR=%{_bindir} LOCALEDIR=. |
91 |
|
92 |
%install |
93 |
install -d -m755 %buildroot%xineplugindir/post %buildroot%_bindir |
94 |
%makeinstall XINELIBOUTPUT_VDRPLUGIN=0 XINELIBOUTPUT_X11=0 XINELIBOUTPUT_FB=0 LOCALEDIR=. \ |
95 |
XINEPLUGINDIR=%buildroot%xineplugindir |
96 |
# (tv) fix debuginfo: |
97 |
chmod +x %{buildroot}%{_libdir}/xine/plugins/*/{,*/}*.so |
98 |
|
99 |
%files |
100 |
%doc README |
101 |
# xine-plugins maybe upgraded without new xine-xvdr (while everything still |
102 |
# works). Therefore we have to include the plugindir as well. |
103 |
%dir %{xineplugindir} |
104 |
%{xineplugindir}/*.so |
105 |
%{xineplugindir}/post/*.so |