1 |
|
2 |
%define oname vdr-plugin-xineliboutput |
3 |
%define plugin xineliboutput |
4 |
# manually created tarball from CVS tag |
5 |
%define snapshot 0 |
6 |
%define prever 0 |
7 |
%define rel 1 |
8 |
|
9 |
%if %snapshot |
10 |
%if %prever |
11 |
%define release %mkrel 0.%prever.%snapshot.%rel |
12 |
%else |
13 |
%define release %mkrel 0.%snapshot.%rel |
14 |
%endif |
15 |
%else |
16 |
%if %prever |
17 |
%define release %mkrel 0.%prever.%rel |
18 |
%else |
19 |
%define release %mkrel %rel |
20 |
%endif |
21 |
%endif |
22 |
|
23 |
%define xineplugindir %(xine-config --plugindir 2>/dev/null || echo 0) |
24 |
# Does not always match rpm version, reports 1.1.9 on 1.1.9.1, so use rpmver directly instead. |
25 |
#define xineversion %(xine-config --version 2>/dev/null || echo 0) |
26 |
%define xineversion %(rpm -qf --qf '%%{version}' %{_bindir}/xine-config 2>/dev/null || echo 0) |
27 |
%define xineapi %(A=%xineplugindir; echo ${A##*/}) |
28 |
|
29 |
Summary: Xine frontend for the xineliboutput VDR plugin |
30 |
Name: xine-xvdr |
31 |
Version: 1.0.6 |
32 |
Release: %release |
33 |
Group: Video |
34 |
License: GPLv2+ |
35 |
URL: http://sourceforge.net/projects/xineliboutput/ |
36 |
%if %snapshot |
37 |
Source0: vdr-%plugin-%snapshot.tar.bz2 |
38 |
%else |
39 |
%if %prever |
40 |
Source0: http://prdownloads.sourceforge.net/xineliboutput/vdr-%plugin-%{version}%{prever}.tar.bz2 |
41 |
%else |
42 |
Source0: http://prdownloads.sourceforge.net/xineliboutput/vdr-%plugin-%version.tar.lzma |
43 |
Patch0: xineliboutput-link.patch |
44 |
%endif |
45 |
%endif |
46 |
|
47 |
BuildRequires: vdr-devel >= 1.6.0 |
48 |
BuildRequires: libx11-devel |
49 |
BuildRequires: libxv-devel |
50 |
BuildRequires: libxine-devel |
51 |
BuildRequires: jpeg-devel |
52 |
BuildRequires: libextractor-devel |
53 |
BuildRequires: libxrender-devel |
54 |
BuildRequires: libxinerama-devel |
55 |
BuildRequires: dbus-glib-devel |
56 |
Requires: xine-plugin-api >= %xineapi |
57 |
Obsoletes: vdr-plugin-xineliboutput-frontend-xine xineliboutput-fe-xine |
58 |
|
59 |
%description |
60 |
With this package you can connect to your VDR with xine with an MRL |
61 |
like below: |
62 |
xvdr://127.0.0.1#nocache;demux:mpeg_block |
63 |
|
64 |
Frontend packages: |
65 |
- xine-xvdr: Xine frontend |
66 |
- xine1.2-xvdr: Xine1.2 frontend |
67 |
- xineliboutput-sxfe: Standalone X11 frontend |
68 |
- xineliboutput-fbfe: Standalone FB frontend |
69 |
- xineliboutput-local-sxfe: Local X11 frontend |
70 |
- xineliboutput-local-fbfe: Local FB frontend |
71 |
|
72 |
%prep |
73 |
%if %snapshot |
74 |
%setup -q -n vdr-%plugin |
75 |
%else |
76 |
%if %prever |
77 |
%setup -q -n %plugin-%version%prever |
78 |
%else |
79 |
%setup -q -n %plugin-%version |
80 |
%patch0 -p0 |
81 |
%endif |
82 |
%endif |
83 |
|
84 |
find -name CVS -type d | while read i; do rm -r "$i" || exit 1; done |
85 |
|
86 |
%build |
87 |
%setup_compile_flags |
88 |
CFLAGS="$CFLAGS -fPIC" |
89 |
LC_ALL=C %make XINELIBOUTPUT_VDRPLUGIN=0 XINELIBOUTPUT_X11=0 XINELIBOUTPUT_FB=0 VDRDIR=%{_includedir}/vdr LIBDIR=%{_libdir} VDRINCDIR=%{_includedir}/vdr BINDIR=%{_bindir} LOCALEDIR=. |
90 |
|
91 |
%install |
92 |
rm -rf %{buildroot} |
93 |
install -d -m755 %buildroot%xineplugindir/post %buildroot%_bindir |
94 |
%makeinstall XINELIBOUTPUT_VDRPLUGIN=0 XINELIBOUTPUT_X11=0 XINELIBOUTPUT_FB=0 LOCALEDIR=. \ |
95 |
XINEPLUGINDIR=%buildroot%xineplugindir |
96 |
|
97 |
%clean |
98 |
rm -rf %{buildroot} |
99 |
|
100 |
%files |
101 |
%defattr(-,root,root) |
102 |
%doc README |
103 |
# xine-plugins maybe upgraded without new xine-xvdr (while everything still |
104 |
# works). Therefore we have to include the plugindir as well. |
105 |
%dir %{xineplugindir} |
106 |
%{xineplugindir}/*.so |
107 |
%{xineplugindir}/post/*.so |
108 |
|
109 |
|