1 |
dams |
314476 |
Summary: Standard terminal emulator for the X window system |
2 |
pterjan |
26629 |
Name: xterm |
3 |
dams |
314476 |
Version: 286 |
4 |
tv |
128584 |
Release: %mkrel 1 |
5 |
pterjan |
26629 |
Source0: ftp://invisible-island.net/xterm/%{name}-%{version}.tgz |
6 |
|
|
Source1: ftp://invisible-island.net/xterm/%{name}-%{version}.tgz.asc |
7 |
|
|
|
8 |
|
|
# from http://www.vim.org/scripts/script.php?script_id=1349, public domain |
9 |
dams |
314476 |
Source20: colortest.pl |
10 |
pterjan |
26629 |
|
11 |
|
|
Url: http://invisible-island.net/xterm/ |
12 |
|
|
License: MIT |
13 |
|
|
Group: Terminals |
14 |
|
|
BuildRequires: libx11-devel |
15 |
|
|
BuildRequires: libxaw-devel |
16 |
|
|
BuildRequires: libxft-devel |
17 |
|
|
BuildRequires: libxmu-devel |
18 |
|
|
BuildRequires: libxt-devel |
19 |
|
|
BuildRequires: fontconfig-devel |
20 |
wally |
92057 |
BuildRequires: libncurses-devel |
21 |
|
|
BuildRequires: luit |
22 |
pterjan |
26629 |
Requires: luit |
23 |
|
|
Requires(post,postun): update-alternatives |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
The XTerm program is the standard terminal emulator for the X Window System. It |
27 |
|
|
provides DEC VT102/VT220 and Tektronix 4014 compatible terminals for programs |
28 |
|
|
that can't use the window system directly. If the underlying operating system |
29 |
|
|
supports terminal resizing capabilities (for example, the SIGWINCH signal in |
30 |
|
|
systems derived from 4.3bsd), xterm will use the facilities to notify programs |
31 |
|
|
running in the window whenever it is resized. |
32 |
|
|
|
33 |
|
|
The xterm included in this package has support for 256 colors enabled. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup -q |
37 |
|
|
cp %{SOURCE20} . |
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
%configure2_5x \ |
41 |
|
|
--disable-full-tgetent \ |
42 |
|
|
--enable-wide-chars \ |
43 |
|
|
--x-includes=%{_includedir}/freetype2 \ |
44 |
|
|
--enable-luit \ |
45 |
|
|
--enable-256-color \ |
46 |
dams |
314476 |
--with-app-defaults=%{_libdir}/X11/app-defaults \ |
47 |
|
|
--with-icon-theme=hicolor \ |
48 |
|
|
--with-icondir=%{_datadir}/icons |
49 |
pterjan |
26629 |
|
50 |
|
|
%make |
51 |
|
|
|
52 |
|
|
%install |
53 |
dams |
217080 |
make DESTDIR=%{buildroot} install |
54 |
pterjan |
26629 |
|
55 |
|
|
# NOTE: encodingMode: locale means to follow the charset encoding of the |
56 |
|
|
# locale. A quite complete unicode font is set as the default (instead of the |
57 |
|
|
# very poor "fixed" one). a quick cat is used instead of patching the sources; |
58 |
|
|
# it shoulmd be made the default imho |
59 |
|
|
# locale: true means to use luit to convert locale encoding to unicode |
60 |
|
|
# for display. |
61 |
|
|
# luit support is needed for it to work -- pablo |
62 |
dams |
217080 |
cat << EOF >> %{buildroot}%{_libdir}/X11/app-defaults/XTerm |
63 |
pterjan |
26629 |
|
64 |
|
|
*.vt100.font: -misc-fixed-medium-r-normal--15-140-75-75-c-90-iso10646-1 |
65 |
|
|
*.vt100.encodingMode: locale |
66 |
|
|
*.locale: true |
67 |
|
|
*.PtyInitialErase: on |
68 |
|
|
*.backarrowKeyIsErase: on |
69 |
|
|
EOF |
70 |
|
|
|
71 |
dams |
217080 |
mkdir -p %{buildroot}%{_datadir}/applications |
72 |
dams |
314476 |
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF |
73 |
pterjan |
26629 |
[Desktop Entry] |
74 |
|
|
Name=XTerm |
75 |
dams |
314476 |
GenericName=Terminal |
76 |
dams |
217080 |
Comment=%{Summary} |
77 |
pterjan |
26629 |
Exec=%{name} -name Terminal |
78 |
dams |
314476 |
Icon=xterm-color |
79 |
pterjan |
26629 |
Terminal=false |
80 |
|
|
Type=Application |
81 |
|
|
StartupNotify=true |
82 |
|
|
Categories=TerminalEmulator;System;Utility; |
83 |
|
|
EOF |
84 |
|
|
|
85 |
dams |
314476 |
for xpm in *xterm{-color_32x32,-color_48x48,_32x32,_48x48}.xpm; do |
86 |
dams |
217080 |
rm -f %{buildroot}%{_datadir}/pixmaps/$xpm |
87 |
pterjan |
26629 |
done |
88 |
|
|
|
89 |
|
|
%post |
90 |
|
|
update-alternatives --install %{_bindir}/xvt xvt %{_bindir}/xterm 18 || : |
91 |
|
|
|
92 |
|
|
%postun |
93 |
|
|
[[ "$1" = "0" ]] && update-alternatives --remove xvt %{_bindir}/xterm || : |
94 |
|
|
|
95 |
|
|
%files |
96 |
|
|
%doc ctlseqs.txt colortest.pl |
97 |
|
|
%{_bindir}/* |
98 |
|
|
%{_mandir}/*/* |
99 |
|
|
%{_libdir}/X11/app-defaults/* |
100 |
dams |
314476 |
%{_datadir}/applications/%{name}.desktop |
101 |
|
|
%{_iconsdir}/hicolor/*/apps/xterm-*.* |
102 |
|
|
#%{_datadir}/pixmaps/*xterm.xpm |