/[packages]/cauldron/ykclient/current/SPECS/ykclient.spec
ViewVC logotype

Contents of /cauldron/ykclient/current/SPECS/ykclient.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 296688 - (show annotations) (download)
Sat Sep 22 16:43:24 2012 UTC (11 years, 7 months ago) by dlucio
File size: 2078 byte(s)
imported package ykclient
1 %define major 3
2 %define libname %mklibname ykclient %{major}
3 %define develname %mklibname -d ykclient
4
5 Summary: Implements online validation of Yubikey OTPs
6 Name: ykclient
7 Version: 2.6
8 Release: %mkrel 1
9 Group: System/Libraries
10 License: BSD
11 URL: http://code.google.com/p/yubico-c-client/
12 Source0: http://yubico-c-client.googlecode.com/files/%{name}-%{version}.tar.gz
13 Source1: http://yubico-c-client.googlecode.com/files/%{name}-%{version}.tar.gz.sig
14 BuildRequires: autoconf
15 BuildRequires: chrpath
16 BuildRequires: curl-devel
17 BuildRequires: libtool
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
19
20 %description
21 This is a library written in C to validate a Yubikey OTP against the Yubico
22 online server.
23
24 %package -n %{libname}
25 Summary: Implements online validation of Yubikey OTPs
26 Group: System/Libraries
27 Obsoletes: %{mklibname libyubikey-client 0}
28
29 %description -n %{libname}
30 This is a library written in C to validate a Yubikey OTP against the Yubico
31 online server.
32
33 %package -n %{develname}
34 Summary: Static library and header files for the libykclientt library
35 Group: Development/C
36 Provides: %{name}-devel = %{version}
37 Requires: %{libname} = %{version}
38 Obsoletes: %{mklibname libyubikey-client -d}
39
40 %description -n %{develname}
41 This is a library written in C to validate a Yubikey OTP against the Yubico
42 online server.
43
44 This package contains the static libyubikey-client library and its header files.
45
46 %prep
47
48 %setup -q -n %{name}-%{version}
49
50 %build
51
52 %configure2_5x \
53 --with-libcurl=%{_prefix}
54
55 %make
56
57 %check
58 make check
59
60 %install
61 rm -rf %{buildroot}
62
63 %makeinstall_std
64
65 # nuke rpath
66 chrpath -d %{buildroot}%{_bindir}/ykclient
67
68 %if %mdkversion < 200900
69 %post -n %{libname} -p /sbin/ldconfig
70 %endif
71
72 %if %mdkversion < 200900
73 %postun -n %{libname} -p /sbin/ldconfig
74 %endif
75
76 %clean
77 rm -rf %{buildroot}
78
79 %files
80 %defattr(-,root,root)
81 %{_bindir}/ykclient
82
83 %files -n %{libname}
84 %defattr(-,root,root)
85 %doc AUTHORS ChangeLog NEWS README
86 %{_libdir}/*.so.%{major}*
87
88 %files -n %{develname}
89 %defattr(-,root,root)
90 %{_includedir}/*
91 %{_libdir}/*.so
92 %{_libdir}/*.*a
93
94

  ViewVC Help
Powered by ViewVC 1.1.30