/[packages]/cauldron/zint/current/SPECS/zint.spec
ViewVC logotype

Contents of /cauldron/zint/current/SPECS/zint.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 101518 - (show annotations) (download)
Tue Jun 7 13:47:35 2011 UTC (12 years, 10 months ago) by wally
File size: 4433 byte(s)
- new version 2.4.3
1 %define name zint
2 %define version 2.4.3
3 %define rel 1
4
5 %define major 2.4
6 %define libname %mklibname %{name} %{major}
7 %define devname %mklibname -d %{name}
8 %define qlibname %mklibname q%{name} %{major}
9 %define qdevname %mklibname -d q%{name}
10
11 Name: %{name}
12 Version: %{version}
13 Release: %mkrel %{rel}
14 Summary: Barcode generator
15 License: GPLv3+
16 URL: http://www.zint.org.uk
17 Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
18 Group: Graphics
19
20 # patch to disable creation of rpaths
21 Patch0: %{name}-rpath.patch
22
23 BuildRequires: cmake
24 BuildRequires: libpng-devel
25 BuildRequires: zlib-devel
26 BuildRequires: qt4-devel
27 BuildRequires: desktop-file-utils
28
29 %description
30 Zint is a C library for encoding data in several barcode variants. The
31 bundled command-line utility provides a simple interface to the library.
32 Features of the library:
33 - Over 50 symbologies including all ISO/IEC standards, like QR codes.
34 - Unicode translation for symbologies which support Latin-1 and
35 Kanji character sets.
36 - Full GS1 support including data verification and automated insertion of
37 FNC1 characters.
38 - Support for encoding binary data including NULL (ASCII 0) characters.
39 - Health Industry Barcode (HIBC) encoding capabilities.
40 - Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
41 - Verification stage for SBN, ISBN and ISBN-13 data.
42
43 %package -n %{libname}
44 Summary: C library for encoding data in several barcode variants
45 Group: System/Libraries
46
47 %description -n %{libname}
48 Zint is a C library for encoding data in several barcode variants.
49
50 Features of the library:
51 - Over 50 symbologies including all ISO/IEC standards, like QR codes.
52 - Unicode translation for symbologies which support Latin-1 and
53 Kanji character sets.
54 - Full GS1 support including data verification and automated insertion of
55 FNC1 characters.
56 - Support for encoding binary data including NULL (ASCII 0) characters.
57 - Health Industry Barcode (HIBC) encoding capabilities.
58 - Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
59 - Verification stage for SBN, ISBN and ISBN-13 data.
60
61 %package -n %{devname}
62 Summary: Library and header files for %{name}
63 Group: Development/C
64 Requires: %{libname} = %{version}-%{release}
65 Provides: %{name}-devel = %{version}-%{release}
66 Provides: lib%{name}-devel = %{version}-%{release}
67
68 %description -n %{devname}
69 C library and header files needed to develop applications that use
70 the Zint library. The API documentation can be found on the project website:
71 http://www.zint.org.uk/zintSite/Manual.aspx
72
73 %package qt
74 Summary: Zint Barcode Studio
75 Group: Graphics
76
77 %description qt
78 Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
79 barcodes which can then be embedded in documents or HTML pages.
80
81 %package -n %{qlibname}
82 Summary: libQZint shared libraries
83 Group: System/Libraries
84
85 %description -n %{qlibname}
86 libQZint shared libraries.
87
88 %package -n %{qdevname}
89 Summary: Library and header files for %{name}-qt
90 Group: Development/C
91 Requires: %{qlibname} = %{version}-%{release}
92 Provides: q%{name}-devel = %{version}-%{release}
93 Provides: libq%{name}-devel = %{version}-%{release}
94
95 %description -n %{qdevname}
96 C library and header files needed to develop applications that use libQZint.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 # remove BSD-licensed file required for Windows only (just to ensure that this package is plain GPLv3+)
103 rm -f backend/ms_stdint.h
104
105 # remove bundled getopt sources (we use the corresponding Fedora package instead)
106 rm -f frontend/getopt*.*
107
108 %build
109 %cmake
110 %make VERBOSE=1
111
112 %install
113 rm -rf %{buildroot}
114 %makeinstall_std -C build
115
116 #we don't need this(?)
117 rm -rf %{buildroot}%{_datadir}/cmake
118
119 #icon
120 install -D -p -m 644 %{name}.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
121
122 #.desktop file
123 install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
124
125 %clean
126 rm -rf %{buildroot}
127
128 %files
129 %defattr(-,root,root)
130 %doc README
131 %{_bindir}/%{name}
132
133 %files -n %{libname}
134 %defattr(-,root,root)
135 %{_libdir}/libzint.so.%{major}*
136
137 %files -n %{devname}
138 %defattr(-,root,root)
139 %{_includedir}/%{name}.h
140 %{_libdir}/libzint.so
141
142 %files qt
143 %defattr(-,root,root)
144 %{_bindir}/%{name}-qt
145 %{_datadir}/applications/%{name}-qt.desktop
146 %{_datadir}/pixmaps/%{name}.png
147
148 %files -n %{qlibname}
149 %defattr(-,root,root)
150 %{_libdir}/libQZint.so.%{major}*
151
152 %files -n %{qdevname}
153 %defattr(-,root,root)
154 %{_includedir}/qzint.h
155 %{_libdir}/libQZint.so

  ViewVC Help
Powered by ViewVC 1.1.30