/[packages]/obsolete/ant4eclipse0/pristine/SPECS/ant4eclipse0.spec
ViewVC logotype

Annotation of /obsolete/ant4eclipse0/pristine/SPECS/ant4eclipse0.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 647089 - (hide annotations) (download)
Sun Jul 6 14:07:42 2014 UTC (9 years, 9 months ago) by ovitters
Original Path: cauldron/ant4eclipse0/current/SPECS/ant4eclipse0.spec
File size: 2347 byte(s)
SILENT remove cleaning buildroot in install
1 gil 102788 Name: ant4eclipse0
2     Version: 0.4.0
3 umeabot 502510 Release: %mkrel 4
4 gil 102788 Summary: A collection of tasks for Apache Ant that parse eclipse metadata
5     Group: Development/Java
6     License: Eclipse Public License
7     Url: http://www.ant4eclipse.org/
8     Source0: http://sourceforge.net/projects/ant4eclipse/files/ant4eclipse/0.4.0/ant4eclipse-0.4.0.tar.gz
9     BuildRequires: ant
10     BuildRequires: ant-junit
11     BuildRequires: java-devel
12     BuildRequires: junit
13     BuildRequires: jpackage-utils
14     Requires: jpackage-utils
15     BuildArch: noarch
16    
17     %description
18     The aim of ant4eclipse is to avoid redundancy between Eclipse and Ant configurations.
19     Its tasks can read Eclipse' configuration files, such as .classpath or .psf.
20     Changes of Eclipse configurations are immediately visible to buildfiles without changes.
21    
22     %package javadoc
23     Group: Development/Java
24     Summary: Javadoc for %{name}
25    
26     %description javadoc
27     Ant4Eclipse - A collection of tasks for Apache Ant that parse eclipse metadata.
28    
29     This package contains javadoc for %{name}.
30    
31     %prep
32     %setup -q -n ant4eclipse-%{version}
33    
34     for j in $(find . -name "*.jar"); do
35     mv $j $j.no
36     done
37    
38     unzip -qq ant4eclipse-%{version}-src.zip
39     mkdir -p classes
40     %build
41    
42     javac \
43     -d classes \
44     -classpath $(build-classpath ant ant/ant-junit junit) \
45     -target 1.5 -source 1.5 \
46     $(find source -type f -name "*.java")
47    
48     pushd classes
49     mkdir -p META-INF
50     cat > META-INF/MANIFEST.MF << EOF
51     Manifest-Version: 1.0
52     Created-By: 1.6.0_22 (Sun Microsystems Inc.)
53     Implementation-Title: ant4eclipse
54     Implementation-Version: %{version}
55     EOF
56     jar cMf ../ant4eclipse-%{version}.jar *
57     popd
58    
59     javadoc -d apidocs \
60     -source 1.5 \
61     -encoding iso-8859-1 \
62     $(find source -type f -name "*.java")
63    
64     %install
65     mkdir -p %{buildroot}%{_javadir}
66     install -m 644 ant4eclipse-%{version}.jar %{buildroot}%{_javadir}/ant4eclipse0-%{version}.jar
67    
68     (
69     cd %{buildroot}%{_javadir}/
70     for jar in *-%{version}*; do
71     ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
72     done
73     )
74    
75     mkdir -p %{buildroot}%{_javadocdir}/ant4eclipse0-%{version}
76     cp -pr apidocs/* %{buildroot}%{_javadocdir}/ant4eclipse0-%{version}
77     ln -s ant4eclipse0-%{version} %{buildroot}%{_javadocdir}/ant4eclipse0
78    
79     %files
80     %{_javadir}/ant4eclipse0-%{version}.jar
81     %{_javadir}/ant4eclipse0.jar
82    
83     %files javadoc
84     %{_javadocdir}/ant4eclipse0-%{version}
85     %{_javadocdir}/ant4eclipse0
86    

  ViewVC Help
Powered by ViewVC 1.1.30