/[packages]/updates/1/cultivation/current/SPECS/cultivation.spec
ViewVC logotype

Annotation of /updates/1/cultivation/current/SPECS/cultivation.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 82158 - (hide annotations) (download)
Fri Apr 8 11:54:18 2011 UTC (13 years ago) by ennael
Original Path: cauldron/cultivation/current/SPECS/cultivation.spec
File size: 3800 byte(s)
imported package cultivation
1 ennael 82158 %define name cultivation
2     %define Name Cultivation
3     %define version 9
4     %define snapshot 20071217
5     %define release %mkrel 0.%{snapshot}.5
6    
7     Name: %{name}
8     Version: %{version}
9     Release: %{release}
10     Summary: A game about the interactions within a gardening community
11     License: Public Domain
12     Group: Games/Strategy
13     URL: http://cultivation.sourceforge.net/
14     Source0: %Name-%{version}cvs%{snapshot}.tar.bz2
15     BuildRequires: mesaglut-devel
16     BuildRoot: %{_tmppath}/%{name}-%{version}
17    
18     %description
19     Cultivation is a game about a community of gardeners growing food
20     for themselves in a shared space.
21    
22     Cultivation is quite different from most other games. It is a
23     social simulation, and the primary form of conflict is over land
24     and plant resources --- there is no shooting, but there are plenty
25     of angry looks. It is also an evolution simulation. Within the
26     world of Cultivation, you can explore a virtually infinite
27     spectrum of different plant and gardener varieties.
28    
29     All of the graphics, sounds, melodies,and other content in
30     Cultivation are 100% procedurally generated at playtime. In other
31     words, there are no hand-painted texture maps --- instead, each
32     object has a uniquely 'grown' appearance. Every time you play,
33     Cultivation generates fresh visuals, music, and behaviors.
34    
35    
36     %prep
37     %setup -q -n %{Name}-%{version}cvs%{snapshot}
38    
39     %build
40     export CFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
41     pushd minorGems/sound/portaudio
42     chmod u+x ./configure
43     %configure2_5x
44     %__make
45     popd
46    
47     pushd game2
48     %__rm -f gameSource/Makefile
49     %__cat \
50     Makefile.GnuLinux \
51     Makefile.common \
52     ../minorGems/build/Makefile.minorGems \
53     gameSource/Makefile.all \
54     ../minorGems/build/Makefile.minorGems_targets > gameSource/Makefile
55    
56     pushd gameSource
57     %__make %{?_smp_mflags}
58     popd
59    
60     popd
61    
62     %install
63     install -d -m 755 %{buildroot}%{_gamesbindir}
64     install -m 755 game2/gameSource/%{Name} \
65     %{buildroot}%{_gamesbindir}/%{name}.real
66    
67     install -d -m 755 %{buildroot}%{_gamesdatadir}/%{name}
68     install -m 644 game2/gameSource/font.tga \
69     %{buildroot}%{_gamesdatadir}/%{name}
70     install -m 644 game2/gameSource/features.txt \
71     %{buildroot}%{_gamesdatadir}/%{name}
72     install -m 644 game2/gameSource/language.txt \
73     %{buildroot}%{_gamesdatadir}/%{name}
74     install -d -m 755 %{buildroot}%{_gamesdatadir}/%{name}/languages
75     install -m 644 game2/gameSource/languages/*.txt \
76     %{buildroot}%{_gamesdatadir}/%{name}/languages
77    
78     # startscript
79     cat > %{buildroot}%{_gamesbindir}/%{name} <<'EOF'
80     #!/bin/bash
81     if [ ! -d $HOME/.%{name} ]; then
82     mkdir -p $HOME/.%{name}
83     cd $HOME/.%{name}
84     cp %{_gamesdatadir}/%{name}/*.txt .
85     ln -s %{_gamesdatadir}/%{name}/*.tga .
86     ln -s %{_gamesdatadir}/%{name}/languages .
87     ln -s %{_gamesbindir}/%{name}.real .
88     fi
89    
90     cd $HOME/.%{name}
91    
92     # Basic switch of language according to locale defined in Unix systems
93     case "$LC_MESSAGES" in
94     fr* )
95     language="French"
96     ;;
97     pt* )
98     language="Portuguese"
99     ;;
100     * )
101     language="English"
102     ;;
103     esac
104     echo $language > ./language.txt
105    
106     ./%{name}.real
107     EOF
108     chmod 755 %{buildroot}%{_gamesbindir}/%{name}
109    
110     # icon
111     install -d -m 755 %{buildroot}%{_datadir}/pixmaps
112     install -m 644 game2/build/win32/iconSource.png \
113     %{buildroot}%{_datadir}/pixmaps/%{name}.png
114    
115     mkdir -p %{buildroot}%{_datadir}/applications
116     cat > %{buildroot}%{_datadir}/applications/mandriva-%{name}.desktop << EOF
117     [Desktop Entry]
118     Name=%{name}
119     Comment=%summary
120     Exec=%{name}
121     Icon=%{name}
122     Terminal=false
123     Type=Application
124     StartupNotify=true
125     Categories=Game;Simulation;
126     EOF
127    
128     %if %mdkversion < 200900
129     %post
130     %update_menus
131     %endif
132    
133     %if %mdkversion < 200900
134     %postun
135     %clean_menus
136     %endif
137    
138     %clean
139     rm -rf %{buildroot}
140    
141     %files
142     %defattr(-, root, games)
143     %doc game2/documentation/*
144     %{_gamesbindir}/%{name}
145     %{_gamesbindir}/%{name}.real
146     %{_gamesdatadir}/%{name}
147     %{_datadir}/applications/*.desktop
148     %{_datadir}/pixmaps/*.png
149    
150    
151    

  ViewVC Help
Powered by ViewVC 1.1.30