/[packages]/updates/1/cultivation/current/SPECS/cultivation.spec
ViewVC logotype

Annotation of /updates/1/cultivation/current/SPECS/cultivation.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 82160 - (hide annotations) (download)
Fri Apr 8 11:55:21 2011 UTC (13 years ago) by ennael
Original Path: cauldron/cultivation/current/SPECS/cultivation.spec
File size: 3646 byte(s)
clean spec file

1 ennael 82158 %define name cultivation
2     %define Name Cultivation
3     %define version 9
4     %define snapshot 20071217
5     %define release %mkrel 0.%{snapshot}.5
6    
7     Name: %{name}
8     Version: %{version}
9     Release: %{release}
10     Summary: A game about the interactions within a gardening community
11     License: Public Domain
12     Group: Games/Strategy
13     URL: http://cultivation.sourceforge.net/
14     Source0: %Name-%{version}cvs%{snapshot}.tar.bz2
15     BuildRequires: mesaglut-devel
16    
17     %description
18     Cultivation is a game about a community of gardeners growing food
19     for themselves in a shared space.
20    
21     Cultivation is quite different from most other games. It is a
22     social simulation, and the primary form of conflict is over land
23     and plant resources --- there is no shooting, but there are plenty
24     of angry looks. It is also an evolution simulation. Within the
25     world of Cultivation, you can explore a virtually infinite
26     spectrum of different plant and gardener varieties.
27    
28     All of the graphics, sounds, melodies,and other content in
29     Cultivation are 100% procedurally generated at playtime. In other
30     words, there are no hand-painted texture maps --- instead, each
31     object has a uniquely 'grown' appearance. Every time you play,
32     Cultivation generates fresh visuals, music, and behaviors.
33    
34    
35     %prep
36     %setup -q -n %{Name}-%{version}cvs%{snapshot}
37    
38     %build
39     export CFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
40     pushd minorGems/sound/portaudio
41     chmod u+x ./configure
42     %configure2_5x
43     %__make
44     popd
45    
46     pushd game2
47     %__rm -f gameSource/Makefile
48     %__cat \
49     Makefile.GnuLinux \
50     Makefile.common \
51     ../minorGems/build/Makefile.minorGems \
52     gameSource/Makefile.all \
53     ../minorGems/build/Makefile.minorGems_targets > gameSource/Makefile
54    
55     pushd gameSource
56     %__make %{?_smp_mflags}
57     popd
58    
59     popd
60    
61     %install
62     install -d -m 755 %{buildroot}%{_gamesbindir}
63     install -m 755 game2/gameSource/%{Name} \
64     %{buildroot}%{_gamesbindir}/%{name}.real
65    
66     install -d -m 755 %{buildroot}%{_gamesdatadir}/%{name}
67     install -m 644 game2/gameSource/font.tga \
68     %{buildroot}%{_gamesdatadir}/%{name}
69     install -m 644 game2/gameSource/features.txt \
70     %{buildroot}%{_gamesdatadir}/%{name}
71     install -m 644 game2/gameSource/language.txt \
72     %{buildroot}%{_gamesdatadir}/%{name}
73     install -d -m 755 %{buildroot}%{_gamesdatadir}/%{name}/languages
74     install -m 644 game2/gameSource/languages/*.txt \
75     %{buildroot}%{_gamesdatadir}/%{name}/languages
76    
77     # startscript
78     cat > %{buildroot}%{_gamesbindir}/%{name} <<'EOF'
79     #!/bin/bash
80     if [ ! -d $HOME/.%{name} ]; then
81     mkdir -p $HOME/.%{name}
82     cd $HOME/.%{name}
83     cp %{_gamesdatadir}/%{name}/*.txt .
84     ln -s %{_gamesdatadir}/%{name}/*.tga .
85     ln -s %{_gamesdatadir}/%{name}/languages .
86     ln -s %{_gamesbindir}/%{name}.real .
87     fi
88    
89     cd $HOME/.%{name}
90    
91     # Basic switch of language according to locale defined in Unix systems
92     case "$LC_MESSAGES" in
93     fr* )
94     language="French"
95     ;;
96     pt* )
97     language="Portuguese"
98     ;;
99     * )
100     language="English"
101     ;;
102     esac
103     echo $language > ./language.txt
104    
105     ./%{name}.real
106     EOF
107     chmod 755 %{buildroot}%{_gamesbindir}/%{name}
108    
109     # icon
110     install -d -m 755 %{buildroot}%{_datadir}/pixmaps
111     install -m 644 game2/build/win32/iconSource.png \
112     %{buildroot}%{_datadir}/pixmaps/%{name}.png
113    
114     mkdir -p %{buildroot}%{_datadir}/applications
115     cat > %{buildroot}%{_datadir}/applications/mandriva-%{name}.desktop << EOF
116     [Desktop Entry]
117     Name=%{name}
118     Comment=%summary
119     Exec=%{name}
120     Icon=%{name}
121     Terminal=false
122     Type=Application
123     StartupNotify=true
124     Categories=Game;Simulation;
125     EOF
126    
127     %clean
128     rm -rf %{buildroot}
129    
130     %files
131     %defattr(-, root, games)
132     %doc game2/documentation/*
133     %{_gamesbindir}/%{name}
134     %{_gamesbindir}/%{name}.real
135     %{_gamesdatadir}/%{name}
136     %{_datadir}/applications/*.desktop
137     %{_datadir}/pixmaps/*.png
138    
139    
140    

  ViewVC Help
Powered by ViewVC 1.1.30