/[packages]/updates/1/gnupg2/current/SPECS/gnupg2.spec
ViewVC logotype

Annotation of /updates/1/gnupg2/current/SPECS/gnupg2.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 338302 - (hide annotations) (download)
Thu Jan 3 19:01:25 2013 UTC (11 years, 3 months ago) by luigiwalser
File size: 4414 byte(s)
add upstream patch to fix CVE-2012-6085 (mga#8572)
1 mikala 18603 %define pkgname gnupg
2    
3     Summary: GNU privacy guard - a free PGP replacement
4     Name: gnupg2
5     Version: 2.0.16
6 luigiwalser 338302 %define subrel 1
7 mikala 18603 Release: %mkrel 6
8     License: GPLv3
9     Group: File tools
10     URL: http://www.gnupg.org
11     Source0: ftp://ftp.gnupg.org/gcrypt/gnupg/%{pkgname}-%{version}.tar.bz2
12     Source1: %{SOURCE0}.sig
13     Source2: gpg-agent.sh
14     Source3: gpg-agent-xinit.sh
15     Source4: sysconfig-gnupg2
16     Patch0: gnupg-1.9.3-use-ImageMagick-for-photo.patch
17     Patch1: gnupg-2.0.14-tests-s2kcount.patch
18     Patch2: gnupg-gpgsm-sec-fix
19 luigiwalser 338302 Patch3: gnupg-2.0.18-CVE-2012-6085.diff
20 mikala 18603 BuildRequires: openldap-devel
21     BuildRequires: sendmail-command
22     BuildRequires: libgpg-error-devel >= 1.4
23     BuildRequires: libgcrypt-devel >= 1.2.0
24     BuildRequires: libassuan-devel >= 1.0.2
25     BuildRequires: libksba-devel >= 1.0.2
26     BuildRequires: zlib-devel
27     BuildRequires: pth-devel >= 2.0.0
28     BuildRequires: docbook-utils
29     BuildRequires: libreadline-devel
30     BuildRequires: libtermcap-devel
31     BuildRequires: libcurl-devel
32     BuildRequires: libusb-devel
33     BuildRequires: bzip2-devel
34     BuildRequires: libassuan-devel
35     Requires(post): info-install
36     Requires(preun): info-install
37     Requires: info-install
38     Obsoletes: newpg
39     Provides: newpg = %{version}-%{release}
40     Requires: dirmngr
41     Requires: pinentry
42     Requires: gnupg
43    
44     %description
45     GnuPG is GNU's tool for secure communication and data storage.
46     It can be used to encrypt data and to create digital signatures.
47     It includes an advanced key management facility and is compliant
48     with the proposed OpenPGP Internet standard as described in RFC2440.
49    
50     %prep
51     %setup -q -n %{pkgname}-%{version}
52     %patch0 -p1 -b .ImageMagick
53     %patch1 -p1
54     %patch2 -p0
55 luigiwalser 338302 %patch3 -p0 -b .CVE-2012-6085
56 mikala 18603
57     %build
58     %serverbuild
59    
60     ./autogen.sh
61    
62     %configure2_5x \
63     --libexecdir=%{_libdir}/gnupg2 \
64     --enable-symcryptrun \
65     --disable-rpath \
66     --without-capabilities \
67     --with-adns=no \
68     --with-pkits-tests
69    
70     # no parallel make (v2.0.5 at least)
71     %make
72    
73     # all tests must pass on i586 and x86_64
74     %check
75     [[ -n "$GPG_AGENT_INFO" ]] || eval `./agent/gpg-agent --use-standard-socket --daemon --write-env-file gpg-agent-info`
76     make check
77     [[ -a gpg-agent-info ]] && kill -0 `cut -d: -f 2 gpg-agent-info`
78     rm -f gpg-agent-info
79    
80     %install
81     rm -rf %{buildroot}
82    
83     %makeinstall_std
84     #Remove: #60298
85     install -d %{buildroot}/%{_sysconfdir}/profile.d
86     install %{SOURCE2} %{buildroot}/%{_sysconfdir}/profile.d/gpg-agent.sh
87     install -d %{buildroot}/%{_sysconfdir}/X11/xinit.d
88     install %{SOURCE3} %{buildroot}/%{_sysconfdir}/X11/xinit.d/gpg-agent
89     install -d %{buildroot}/%{_sysconfdir}/sysconfig
90     install %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
91    
92     # remove this from package because the content of options.skel is the
93     # identical for both gnupg 1/2, except for comment
94     rm -rf %{buildroot}%{_datadir}/gnupg
95    
96     rm -rf %{buildroot}%{_docdir}/gnupg
97    
98     # fix file conflict with 'gnupg' package
99     rm %{buildroot}%{_mandir}/man1/gpg-zip.1
100    
101     %find_lang %{name}
102    
103     %post
104     %_install_info gnupg.info
105    
106     %preun
107     %_remove_install_info gnupg.info
108    
109     %clean
110     rm -rf %{buildroot}
111    
112     %files -f %{name}.lang
113     %doc README NEWS THANKS TODO ChangeLog
114     %doc doc/FAQ doc/HACKING doc/KEYSERVER doc/OpenPGP doc/TRANSLATE doc/DETAILS doc/faq.html
115     %doc doc/examples
116     %attr(0755,root,root) %{_sysconfdir}/profile.d/gpg-agent.sh
117     %attr(0755,root,root) %{_sysconfdir}/X11/xinit.d/gpg-agent
118     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
119     %attr(4755,root,root) %{_bindir}/gpgsm
120     %{_bindir}/gpg-agent
121     %{_bindir}/gpgconf
122     %{_bindir}/kbxutil
123     %{_bindir}/sc*
124     %{_bindir}/watchgnupg
125     %{_bindir}/gpgsm-gencert.sh
126     %{_bindir}/gpgkey2ssh
127     %{_bindir}/gpg-connect-agent
128     %{_bindir}/gpgparsemail
129     %{_bindir}/gpg2
130     %{_bindir}/gpgv2
131     %{_bindir}/symcryptrun
132     %{_sbindir}/addgnupghome
133     %{_sbindir}/applygnupgdefaults
134     %dir %{_libdir}/gnupg2
135     %{_libdir}/gnupg2/gpg-check-pattern
136     %{_libdir}/gnupg2/gpg-preset-passphrase
137     %{_libdir}/gnupg2/gpg-protect-tool
138     %{_libdir}/gnupg2/gnupg-pcsc-wrapper
139     %{_libdir}/gnupg2/gpg2keys_curl
140     %{_libdir}/gnupg2/gpg2keys_finger
141     %{_libdir}/gnupg2/gpg2keys_hkp
142     %{_libdir}/gnupg2/gpg2keys_ldap
143     %{_infodir}/gnupg.info*
144     %{_mandir}/man1/gpg-agent.1*
145     %{_mandir}/man1/gpg-connect-agent.1*
146     %{_mandir}/man1/gpg-preset-passphrase.1*
147     %{_mandir}/man1/gpg2.1*
148     %{_mandir}/man1/gpgconf.1*
149     %{_mandir}/man1/gpgparsemail.1*
150     %{_mandir}/man1/gpgsm-gencert.sh.1*
151     %{_mandir}/man1/gpgsm.1*
152     %{_mandir}/man1/gpgv2.1*
153     %{_mandir}/man1/scdaemon.1*
154     %{_mandir}/man1/symcryptrun.1*
155     %{_mandir}/man1/watchgnupg.1*
156     %{_mandir}/man8/addgnupghome.8*
157     %{_mandir}/man8/applygnupgdefaults.8*

  ViewVC Help
Powered by ViewVC 1.1.30