/[packages]/updates/1/msec/current/SPECS/msec.spec
ViewVC logotype

Annotation of /updates/1/msec/current/SPECS/msec.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 36042 - (hide annotations) (download)
Mon Jan 24 03:50:23 2011 UTC (13 years, 3 months ago) by spuhler
Original Path: cauldron/msec/current/SPECS/msec.spec
File size: 4660 byte(s)
imported package msec
1 spuhler 36042 Name: msec
2     Version: 0.80.10
3     Release: %mkrel 1
4     Summary: Security Level management for the Mandriva Linux distribution
5     License: GPLv2+
6     Group: System/Base
7     Url: http://www.mandrivalinux.com/
8     Source0: %{name}-%{version}.tar.bz2
9     Requires: perl-base
10     Requires: diffutils
11     Requires: gawk
12     Requires: coreutils
13     Requires: iproute2
14     Requires: setup >= 2.2.0-21mdk
15     Requires: chkconfig >= 1.2.24-3mdk
16     Requires: python-base >= 2.3.3-2mdk
17     Requires: mailx
18     Requires: python
19     # at least xargs is used
20     Requires: findutils
21     # ensure sysctl.conf and inittab are present before installing msec
22     Requires(post): initscripts
23    
24     Requires(pre): rpm-helper >= 0.4
25     Requires(postun): rpm-helper >= 0.4
26    
27     Suggests: msec-gui
28     # using s2u for desktop notifications
29     # it should be pulled by xinit to reduce basesystem size
30     # Suggests: s2u >= 0.9
31    
32     Conflicts: passwd < 0.67
33     BuildRequires: python
34     BuildRoot: %{_tmppath}/%{name}-%{version}
35    
36     %description
37     The Mandriva Linux Security package is designed to provide security features to
38     the Mandriva Linux users. It allows to select from a set of preconfigured
39     security levels, and supports custom permission settings, user-specified
40     levels, and several security utilities. This packages includes main msec
41     application and several programs that will be run periodically in order to test
42     the security of your system and alert you if needed.
43    
44     %package gui
45     Summary: Graphical msec interface
46     Group: System/Configuration/Other
47     Requires: pygtk2.0
48     Requires: msec
49    
50     %description gui
51     The Mandriva Linux Security package is designed to provide security
52     features to the Mandriva Linux users. It allows to select from a set
53     of preconfigured security levels, and also supports custom permission
54     settings, user-specified levels, and several security utilities.
55     This packages includes graphical interface to control and tune msec
56     permissions.
57    
58    
59     %prep
60     %setup -q
61    
62     %build
63     make CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
64    
65     %install
66     rm -rf %{buildroot}
67    
68     make install
69    
70     mkdir -p %{buildroot}/%{_sysconfdir}/{logrotate.d,profile.d}
71     touch %{buildroot}/var/log/security.log
72     touch %{buildroot}/etc/security/msec/security.conf
73     touch %{buildroot}/etc/security/msec/perms.conf
74     # init script
75     install -d %{buildroot}/%{_initrddir}
76     install -m755 %{_builddir}/%{name}-%{version}/msec.init %{buildroot}/%{_initrddir}/%{name}
77     mkdir -p %{buildroot}/etc/X11/xinit.d
78     touch %{buildroot}/etc/X11/xinit.d/msec
79    
80     %find_lang %name
81    
82     %pre
83     %_pre_groupadd xgrp
84     %_pre_groupadd ntools
85     %_pre_groupadd ctools
86    
87     %preun
88     %_preun_service msec
89    
90     %post
91     %_post_service msec
92    
93     touch /var/log/security.log
94    
95     if [ $1 != 1 ]; then
96     # since 0.80.3, msec has its own upgrade script, which handles upgrades from previous versions
97     /usr/share/msec/upgrade.sh
98     fi
99    
100     # creating default configuration if not installed by installer
101     if [ "$DURING_INSTALL" != "1" ]; then
102     if [ ! -s /etc/security/msec/security.conf ]; then
103     # creating default level configuration
104     cp -f /etc/security/msec/level.standard /etc/security/msec/security.conf
105     fi
106    
107     if [ ! -s /etc/security/msec/perms.conf ]; then
108     # creating default level configuration
109     cp -f /etc/security/msec/perm.standard /etc/security/msec/perms.conf
110     fi
111     fi
112    
113     %postun
114    
115     if [ $1 = 0 ]; then
116     # cleanup crontabs on package removal
117     rm -f /etc/cron.*/msec
118     fi
119    
120     %_postun_groupdel xgrp
121     %_postun_groupdel ntools
122     %_postun_groupdel ctools
123    
124     %clean
125     rm -rf %{buildroot}
126    
127     %files -f %{name}.lang
128     %defattr(-,root,root)
129     %doc AUTHORS COPYING README*
130     %doc ChangeLog doc/*.txt
131     %_bindir/promisc_check
132     %_bindir/msec_find
133     %{_initrddir}/%{name}
134     %_sbindir/msec
135     %_sbindir/msecperms
136     %_datadir/msec/msec.py*
137     %_datadir/msec/config.py*
138     %_datadir/msec/libmsec.py*
139     %_datadir/msec/msecperms.py*
140     %_datadir/msec/tools.py*
141     %_datadir/msec/version.py*
142     %_datadir/msec/*.sh
143     %_datadir/msec/plugins/*
144     %_datadir/msec/scripts/*
145     %_mandir/*/*.*
146     %lang(cs) %_mandir/cs/man?/*
147     %lang(et) %_mandir/et/man?/*
148     %lang(eu) %_mandir/eu/man?/*
149     %lang(fi) %_mandir/fi/man?/*
150     %lang(fr) %_mandir/fr/man?/*
151     %lang(it) %_mandir/it/man?/*
152     %lang(nl) %_mandir/nl/man?/*
153     %lang(pl) %_mandir/pl/man?/*
154     %lang(ru) %_mandir/ru/man?/*
155     %lang(uk) %_mandir/uk/man?/*
156     %dir /var/log/security
157     %dir /etc/security/msec
158     %config /etc/security/msec/level.*
159     %config /etc/security/msec/perm.*
160     %config /etc/security/msec/server.*
161     %config(noreplace) /etc/security/msec/security.conf
162     %config(noreplace) /etc/security/msec/perms.conf
163     %config(noreplace) /etc/logrotate.d/msec
164     /etc/profile.d/*msec*
165    
166     %config %attr(0755,root,root) /etc/X11/xinit.d/msec
167    
168     %ghost /var/log/security.log
169     %ghost /var/log/msec.log
170    
171     %files gui
172     %defattr(-,root,root)
173     %_sbindir/msecgui
174     %_datadir/msec/msecgui.py*
175     %_datadir/msec/help.py*
176     %_datadir/msec/msec.png
177    
178    
179    
180    
181    

  ViewVC Help
Powered by ViewVC 1.1.30