/[packages]/updates/1/msec/current/SPECS/msec.spec
ViewVC logotype

Annotation of /updates/1/msec/current/SPECS/msec.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 36052 - (hide annotations) (download)
Mon Jan 24 03:57:13 2011 UTC (13 years, 3 months ago) by spuhler
Original Path: cauldron/msec/current/SPECS/msec.spec
File size: 4618 byte(s)
removed buildroot definition from .spec

1 spuhler 36042 Name: msec
2     Version: 0.80.10
3     Release: %mkrel 1
4     Summary: Security Level management for the Mandriva Linux distribution
5     License: GPLv2+
6     Group: System/Base
7     Url: http://www.mandrivalinux.com/
8     Source0: %{name}-%{version}.tar.bz2
9     Requires: perl-base
10     Requires: diffutils
11     Requires: gawk
12     Requires: coreutils
13     Requires: iproute2
14     Requires: setup >= 2.2.0-21mdk
15     Requires: chkconfig >= 1.2.24-3mdk
16     Requires: python-base >= 2.3.3-2mdk
17     Requires: mailx
18     Requires: python
19     # at least xargs is used
20     Requires: findutils
21     # ensure sysctl.conf and inittab are present before installing msec
22     Requires(post): initscripts
23    
24     Requires(pre): rpm-helper >= 0.4
25     Requires(postun): rpm-helper >= 0.4
26    
27     Suggests: msec-gui
28     # using s2u for desktop notifications
29     # it should be pulled by xinit to reduce basesystem size
30     # Suggests: s2u >= 0.9
31    
32     Conflicts: passwd < 0.67
33     BuildRequires: python
34    
35     %description
36     The Mandriva Linux Security package is designed to provide security features to
37     the Mandriva Linux users. It allows to select from a set of preconfigured
38     security levels, and supports custom permission settings, user-specified
39     levels, and several security utilities. This packages includes main msec
40     application and several programs that will be run periodically in order to test
41     the security of your system and alert you if needed.
42    
43     %package gui
44     Summary: Graphical msec interface
45     Group: System/Configuration/Other
46     Requires: pygtk2.0
47     Requires: msec
48    
49     %description gui
50     The Mandriva Linux Security package is designed to provide security
51     features to the Mandriva Linux users. It allows to select from a set
52     of preconfigured security levels, and also supports custom permission
53     settings, user-specified levels, and several security utilities.
54     This packages includes graphical interface to control and tune msec
55     permissions.
56    
57    
58     %prep
59     %setup -q
60    
61     %build
62     make CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
63    
64     %install
65     rm -rf %{buildroot}
66    
67     make install
68    
69     mkdir -p %{buildroot}/%{_sysconfdir}/{logrotate.d,profile.d}
70     touch %{buildroot}/var/log/security.log
71     touch %{buildroot}/etc/security/msec/security.conf
72     touch %{buildroot}/etc/security/msec/perms.conf
73     # init script
74     install -d %{buildroot}/%{_initrddir}
75     install -m755 %{_builddir}/%{name}-%{version}/msec.init %{buildroot}/%{_initrddir}/%{name}
76     mkdir -p %{buildroot}/etc/X11/xinit.d
77     touch %{buildroot}/etc/X11/xinit.d/msec
78    
79     %find_lang %name
80    
81     %pre
82     %_pre_groupadd xgrp
83     %_pre_groupadd ntools
84     %_pre_groupadd ctools
85    
86     %preun
87     %_preun_service msec
88    
89     %post
90     %_post_service msec
91    
92     touch /var/log/security.log
93    
94     if [ $1 != 1 ]; then
95     # since 0.80.3, msec has its own upgrade script, which handles upgrades from previous versions
96     /usr/share/msec/upgrade.sh
97     fi
98    
99     # creating default configuration if not installed by installer
100     if [ "$DURING_INSTALL" != "1" ]; then
101     if [ ! -s /etc/security/msec/security.conf ]; then
102     # creating default level configuration
103     cp -f /etc/security/msec/level.standard /etc/security/msec/security.conf
104     fi
105    
106     if [ ! -s /etc/security/msec/perms.conf ]; then
107     # creating default level configuration
108     cp -f /etc/security/msec/perm.standard /etc/security/msec/perms.conf
109     fi
110     fi
111    
112     %postun
113    
114     if [ $1 = 0 ]; then
115     # cleanup crontabs on package removal
116     rm -f /etc/cron.*/msec
117     fi
118    
119     %_postun_groupdel xgrp
120     %_postun_groupdel ntools
121     %_postun_groupdel ctools
122    
123     %clean
124     rm -rf %{buildroot}
125    
126     %files -f %{name}.lang
127     %defattr(-,root,root)
128     %doc AUTHORS COPYING README*
129     %doc ChangeLog doc/*.txt
130     %_bindir/promisc_check
131     %_bindir/msec_find
132     %{_initrddir}/%{name}
133     %_sbindir/msec
134     %_sbindir/msecperms
135     %_datadir/msec/msec.py*
136     %_datadir/msec/config.py*
137     %_datadir/msec/libmsec.py*
138     %_datadir/msec/msecperms.py*
139     %_datadir/msec/tools.py*
140     %_datadir/msec/version.py*
141     %_datadir/msec/*.sh
142     %_datadir/msec/plugins/*
143     %_datadir/msec/scripts/*
144     %_mandir/*/*.*
145     %lang(cs) %_mandir/cs/man?/*
146     %lang(et) %_mandir/et/man?/*
147     %lang(eu) %_mandir/eu/man?/*
148     %lang(fi) %_mandir/fi/man?/*
149     %lang(fr) %_mandir/fr/man?/*
150     %lang(it) %_mandir/it/man?/*
151     %lang(nl) %_mandir/nl/man?/*
152     %lang(pl) %_mandir/pl/man?/*
153     %lang(ru) %_mandir/ru/man?/*
154     %lang(uk) %_mandir/uk/man?/*
155     %dir /var/log/security
156     %dir /etc/security/msec
157     %config /etc/security/msec/level.*
158     %config /etc/security/msec/perm.*
159     %config /etc/security/msec/server.*
160     %config(noreplace) /etc/security/msec/security.conf
161     %config(noreplace) /etc/security/msec/perms.conf
162     %config(noreplace) /etc/logrotate.d/msec
163     /etc/profile.d/*msec*
164    
165     %config %attr(0755,root,root) /etc/X11/xinit.d/msec
166    
167     %ghost /var/log/security.log
168     %ghost /var/log/msec.log
169    
170     %files gui
171     %defattr(-,root,root)
172     %_sbindir/msecgui
173     %_datadir/msec/msecgui.py*
174     %_datadir/msec/help.py*
175     %_datadir/msec/msec.png
176    
177    
178    
179    
180    

  ViewVC Help
Powered by ViewVC 1.1.30