/[packages]/updates/1/msec/current/SPECS/msec.spec
ViewVC logotype

Annotation of /updates/1/msec/current/SPECS/msec.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 52710 - (hide annotations) (download)
Wed Feb 16 19:47:33 2011 UTC (13 years, 2 months ago) by ahmad
Original Path: cauldron/msec/current/SPECS/msec.spec
File size: 4478 byte(s)
- use a generic description/summary
- use non-versioned Requires, we have recent enough versions anyway

1 spuhler 36042 Name: msec
2     Version: 0.80.10
3 ahmad 52710 Release: %mkrel 2
4     Summary: Security Level management Linux distributions
5 spuhler 36042 License: GPLv2+
6     Group: System/Base
7     Url: http://www.mandrivalinux.com/
8     Source0: %{name}-%{version}.tar.bz2
9     Requires: perl-base
10     Requires: diffutils
11     Requires: gawk
12     Requires: coreutils
13     Requires: iproute2
14 ahmad 52710 Requires: setup
15     Requires: chkconfig
16 spuhler 36042 Requires: mailx
17     Requires: python
18     # at least xargs is used
19     Requires: findutils
20     # ensure sysctl.conf and inittab are present before installing msec
21     Requires(post): initscripts
22    
23     Requires(pre): rpm-helper >= 0.4
24     Requires(postun): rpm-helper >= 0.4
25    
26     Suggests: msec-gui
27     # using s2u for desktop notifications
28     # it should be pulled by xinit to reduce basesystem size
29     # Suggests: s2u >= 0.9
30    
31     Conflicts: passwd < 0.67
32     BuildRequires: python
33    
34     %description
35 ahmad 52710 The Security package is designed to provide security features to Linux users.
36     It allows to select from a set of preconfigured security levels, and supports
37     custom permission settings, user-specified levels, and several security
38     utilities. This packages includes main msec application and several programs
39     that will be run periodically in order to test the security of your system and
40     alert you if needed.
41 spuhler 36042
42     %package gui
43     Summary: Graphical msec interface
44     Group: System/Configuration/Other
45     Requires: pygtk2.0
46     Requires: msec
47    
48     %description gui
49 ahmad 52710 The Security package is designed to provide security features to the Linux
50     users. It allows to select from a set of preconfigured security levels, and also
51     supports custom permission settings, user-specified levels, and several security
52     utilities. This packages includes graphical interface to control and tune msec
53 spuhler 36042 permissions.
54    
55    
56     %prep
57     %setup -q
58    
59     %build
60     make CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
61    
62     %install
63     rm -rf %{buildroot}
64    
65     make install
66    
67     mkdir -p %{buildroot}/%{_sysconfdir}/{logrotate.d,profile.d}
68     touch %{buildroot}/var/log/security.log
69     touch %{buildroot}/etc/security/msec/security.conf
70     touch %{buildroot}/etc/security/msec/perms.conf
71     # init script
72     install -d %{buildroot}/%{_initrddir}
73     install -m755 %{_builddir}/%{name}-%{version}/msec.init %{buildroot}/%{_initrddir}/%{name}
74     mkdir -p %{buildroot}/etc/X11/xinit.d
75     touch %{buildroot}/etc/X11/xinit.d/msec
76    
77     %find_lang %name
78    
79     %pre
80     %_pre_groupadd xgrp
81     %_pre_groupadd ntools
82     %_pre_groupadd ctools
83    
84     %preun
85     %_preun_service msec
86    
87     %post
88     %_post_service msec
89    
90     touch /var/log/security.log
91    
92     if [ $1 != 1 ]; then
93     # since 0.80.3, msec has its own upgrade script, which handles upgrades from previous versions
94     /usr/share/msec/upgrade.sh
95     fi
96    
97     # creating default configuration if not installed by installer
98     if [ "$DURING_INSTALL" != "1" ]; then
99     if [ ! -s /etc/security/msec/security.conf ]; then
100     # creating default level configuration
101     cp -f /etc/security/msec/level.standard /etc/security/msec/security.conf
102     fi
103    
104     if [ ! -s /etc/security/msec/perms.conf ]; then
105     # creating default level configuration
106     cp -f /etc/security/msec/perm.standard /etc/security/msec/perms.conf
107     fi
108     fi
109    
110     %postun
111    
112     if [ $1 = 0 ]; then
113     # cleanup crontabs on package removal
114     rm -f /etc/cron.*/msec
115     fi
116    
117     %_postun_groupdel xgrp
118     %_postun_groupdel ntools
119     %_postun_groupdel ctools
120    
121     %clean
122     rm -rf %{buildroot}
123    
124     %files -f %{name}.lang
125     %defattr(-,root,root)
126     %doc AUTHORS COPYING README*
127     %doc ChangeLog doc/*.txt
128     %_bindir/promisc_check
129     %_bindir/msec_find
130     %{_initrddir}/%{name}
131     %_sbindir/msec
132     %_sbindir/msecperms
133     %_datadir/msec/msec.py*
134     %_datadir/msec/config.py*
135     %_datadir/msec/libmsec.py*
136     %_datadir/msec/msecperms.py*
137     %_datadir/msec/tools.py*
138     %_datadir/msec/version.py*
139     %_datadir/msec/*.sh
140     %_datadir/msec/plugins/*
141     %_datadir/msec/scripts/*
142     %_mandir/*/*.*
143     %lang(cs) %_mandir/cs/man?/*
144     %lang(et) %_mandir/et/man?/*
145     %lang(eu) %_mandir/eu/man?/*
146     %lang(fi) %_mandir/fi/man?/*
147     %lang(fr) %_mandir/fr/man?/*
148     %lang(it) %_mandir/it/man?/*
149     %lang(nl) %_mandir/nl/man?/*
150     %lang(pl) %_mandir/pl/man?/*
151     %lang(ru) %_mandir/ru/man?/*
152     %lang(uk) %_mandir/uk/man?/*
153     %dir /var/log/security
154     %dir /etc/security/msec
155     %config /etc/security/msec/level.*
156     %config /etc/security/msec/perm.*
157     %config /etc/security/msec/server.*
158     %config(noreplace) /etc/security/msec/security.conf
159     %config(noreplace) /etc/security/msec/perms.conf
160     %config(noreplace) /etc/logrotate.d/msec
161     /etc/profile.d/*msec*
162    
163     %config %attr(0755,root,root) /etc/X11/xinit.d/msec
164    
165     %ghost /var/log/security.log
166     %ghost /var/log/msec.log
167    
168     %files gui
169     %defattr(-,root,root)
170     %_sbindir/msecgui
171     %_datadir/msec/msecgui.py*
172     %_datadir/msec/help.py*
173     %_datadir/msec/msec.png

  ViewVC Help
Powered by ViewVC 1.1.30