/[packages]/updates/1/postgresql9.0/current/SPECS/postgresql9.0.spec
ViewVC logotype

Contents of /updates/1/postgresql9.0/current/SPECS/postgresql9.0.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 410078 - (show annotations) (download)
Sun Apr 14 09:06:30 2013 UTC (11 years ago) by boklm
File size: 23198 byte(s)
Update to version 9.0.13, fixing a few security bugs
1 %if %_lib == lib64
2 %define _requires_exceptions devel(libtcl8.4(64bit))
3 %else
4 %define _requires_exceptions devel(libtcl8.4)
5 %endif
6
7 %define Werror_cflags %nil
8 %define _disable_ld_no_undefined 1
9
10 %define perl_version %(rpm -q --qf "%{VERSION}" perl)
11 %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
12
13 %define pgdata /var/lib/pgsql
14 %define logrotatedir %{_sysconfdir}/logrotate.d
15
16 %define major 5
17 %define major_ecpg 6
18
19 %define bname postgresql
20 %define current_major_version 9.0
21 %define current_minor_version 13
22
23 # Define if it's a beta
24 # %%define beta rc2
25
26 %define rel 1
27
28 %define release %mkrel %{?beta:0.rc.%{beta}.}%{rel}
29
30 %define libname %mklibname pq%{current_major_version} _%{major}
31 %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
32
33 # (blino) FIXME: enable back when ossp_uuid (and php) are available
34 %define withuuid 0
35 #define withuuid 1
36
37 Summary: PostgreSQL client programs and libraries
38 Name: %{bname}%{current_major_version}
39 Version: %{current_major_version}%{?!beta:.%{current_minor_version}}
40 Release: %release
41 License: BSD
42 Group: Databases
43 URL: http://www.postgresql.org/
44 Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2
45 Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2.md5
46 Source10: postgres.profile
47 Source11: postgresql.init
48 Source13: postgresql.distro.releasenote
49 Requires: perl
50 Provides: postgresql-clients = %{version}-%{release}
51 Conflicts: postgresql-clients < %{version}-%{release}
52 BuildRequires: X11-devel bison flex gettext termcap-devel ncurses-devel openssl-devel
53 BuildRequires: pam-devel perl-devel python-devel readline-devel >= 4.3 tk zlib-devel tcl
54 BuildRequires: tcl tcl-devel
55 BuildRequires: libxml2-devel
56 BuildRequires: libxslt-devel
57 BuildRequires: edit-devel
58 %if %withuuid
59 BuildRequires: ossp_uuid-devel
60 %endif
61 # Need to build doc
62 BuildRequires: docbook-dtd42-sgml openjade docbook-utils xsltproc
63 Provides: %{bname}-virtual = %{current_major_version}
64 Conflicts: %{bname}-virtual < %{current_major_version}
65 Provides: %{bname} = %{version}-%{release}
66 Conflicts: %{bname} < %{version}-%{release}
67 Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
68
69 %description
70 PostgreSQL is an advanced Object-Relational database management system (DBMS)
71 that supports almost all SQL constructs (including transactions, subselects and
72 user-defined types and functions). The postgresql package includes the client
73 programs and libraries that you'll need to access a PostgreSQL DBMS server.
74 These PostgreSQL client programs are programs that directly manipulate the
75 internal structure of PostgreSQL databases on a PostgreSQL server. These client
76 programs can be located on the same machine with the PostgreSQL server, or may
77 be on a remote machine which accesses a PostgreSQL server over a network
78 connection. This package contains the client libraries for C and C++, as well
79 as command-line utilities for managing PostgreSQL databases on a PostgreSQL
80 server.
81
82 If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
83 you need this package. You also need to install this package if you're
84 installing the postgresql-server package.
85
86 %package -n %{libname}
87 Summary: The shared libraries required for any PostgreSQL clients
88 Group: System/Libraries
89 Conflicts: postgresql-libs < %{version}-%{release}
90 Provides: postgresql-libs = %{version}-%{release}
91 Provides: libpq = %{version}-%{release}
92 Provides: %{libname}-virtual = %{current_major_version}
93 Conflicts: %{libname}-virtual < %{current_major_version}
94 # Avoid conflicts with lib having bad major
95 Conflicts: libpq3 = 8.0.2
96
97 %description -n %{libname}
98 C and C++ libraries to enable user programs to communicate with the PostgreSQL
99 database backend. The backend can be on another machine and accessed through
100 TCP/IP.
101
102 %package -n %{libecpg}
103 Summary: Shared library libecpg for PostgreSQL
104 Group: System/Libraries
105 Requires: postgresql%{current_major_version} = %{version}-%{release}
106 Provides: libecpg = %{version}-%{release}
107 Provides: %{libecpg}-virtual = %{current_major_version}
108 Conflicts: %{libecpg}-virtual < %{current_major_version}
109
110 %description -n %{libecpg}
111 Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
112 postgresql-dev to develop such programs.
113
114 %package server
115 Summary: The programs needed to create and run a PostgreSQL server
116 Group: Databases
117 Provides: sqlserver
118 Requires(post): %{libname} >= %{version}-%{release}
119 Requires(preun): %{libname} >= %{version}-%{release}
120 # add/remove services
121 Requires(post): rpm-helper
122 Requires(preun): rpm-helper
123 # add/del user
124 Requires(pre): rpm-helper
125 Requires(postun): rpm-helper
126 Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
127 Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
128 Conflicts: postgresql < 7.3
129 Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
130 Provides: %{bname}-server-virtual = %{current_major_version}
131 Conflicts: %{bname}-server-virtual < %{current_major_version}
132 Provides: %{bname}-server = %{version}-%{release}
133 Conflicts: %{bname}8.3-test < %{version}-%{release}
134 Requires: postgresql-plpgsql = %{version}-%{release}
135
136 %description server
137 The postgresql-server package includes the programs needed to create and run a
138 PostgreSQL server, which will in turn allow you to create and maintain
139 PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
140 management system (DBMS) that supports almost all SQL constructs (including
141 transactions, subselects and user-defined types and functions). You should
142 install postgresql-server if you want to create and maintain your own
143 PostgreSQL databases and/or your own PostgreSQL server. You also need to
144 install the postgresql and postgresql-devel packages.
145
146 After installing this package, please read postgresql.%{_vendor}.releasenote.
147
148 %package docs
149 Summary: Extra documentation for PostgreSQL
150 Group: Databases
151 Provides: %{bname}-docs-virtual = %{current_major_version}
152 Conflicts: %{bname}-docs-virtual < %{current_major_version}
153
154 %description docs
155 The postgresql-docs package includes the SGML source for the documentation as
156 well as the documentation in other formats, and some extra documentation.
157 Install this package if you want to help with the PostgreSQL documentation
158 project, or if you want to generate printed documentation.
159
160 %package contrib
161 Summary: Contributed binaries distributed with PostgreSQL
162 Group: Databases
163 Requires: postgresql%{current_major_version}-server = %{version}-%{release}
164 Provides: %{bname}-contrib-virtual = %{current_major_version}
165 Conflicts: %{bname}-contrib-virtual < %{current_major_version}
166
167 %description contrib
168 The postgresql-contrib package includes the contrib tree distributed with the
169 PostgreSQL tarball. Selected contrib modules are prebuilt.
170
171 %package devel
172 Summary: PostgreSQL development header files and libraries
173 Group: Development/Databases
174 Requires: postgresql%{current_major_version} = %{version}-%{release}
175 Provides: %{bname}-devel-virtual = %{current_major_version}
176 Conflicts: %{bname}-devel-virtual < %{current_major_version}
177 Requires: %{libname} = %{version}-%{release}
178 Provides: postgresql-libs-devel = %{version}-%{release}
179 Provides: pq-devel = %{version}-%{release}
180 # Avoid conflicts with lib having bad major
181 Conflicts: libpq3-devel = 8.0.2
182 %if %_lib != lib
183 Provides: libpq-devel = %{version}-%{release}
184 %endif
185 Provides: %{_lib}pq-devel = %{version}
186 Conflicts: %{_lib}pq-devel < %{version}
187 Requires: %{libecpg} = %{version}-%{release}
188 Provides: libecpg-devel = %{version}-%{release}
189 Provides: %{_lib}ecpg-devel = %{version}-%{release}
190 Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
191 Conflicts: %mklibname -d ecpg 5
192 Conflicts: %mklibname -d pq 5
193 Conflicts: %mklibname -d pq8.3
194 Conflicts: %mklibname -d ecpg8.3
195 Conflicts: %mklibname -d pq8.4
196 Conflicts: %mklibname -d ecpg8.4
197 Provides: %{bname}-devel = %{version}-%{release}
198 Conflicts: %{bname}-devel < %{version}-%{release}
199
200 %description devel
201 The postgresql-devel package contains the header files and libraries needed to
202 compile C or C++ applications which will directly interact with a PostgreSQL
203 database management server and the ecpg Embedded C Postgres preprocessor. You
204 need to install this package if you want to develop applications which will
205 interact with a PostgreSQL server. If you're installing postgresql-server, you
206 need to install this package.
207
208 %package pl
209 Summary: Procedurals languages for PostgreSQL
210 Group: Databases
211 Conflicts: libpgsql2
212 Requires: %{name}-plpython = %{version}-%{release}
213 Requires: %{name}-plperl = %{version}-%{release}
214 Requires: %{name}-pltcl = %{version}-%{release}
215 Requires: %{name}-plpgsql = %{version}-%{release}
216 Provides: %{bname}-pl-virtual = %{current_major_version}
217 Conflicts: %{bname}-pl-virtual < %{current_major_version}
218 Conflicts: %{bname}-pl < %{version}-%{release}
219 Provides: %{bname}-pl = %{version}-%{release}
220
221 %description pl
222 PostgreSQL is an advanced Object-Relational database management system. The
223 postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
224 languages for the backend. PL/Pgsql is part of the core server package.
225
226 %package plpython
227 Summary: The PL/Python procedural language for PostgreSQL
228 Group: Databases
229 Requires: postgresql%{current_major_version}-server = %{version}
230 Conflicts: postgresql-pl < %version-%release
231 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
232 Provides: %{bname}-plpython-virtual = %{current_major_version}
233 Conflicts: %{bname}-plpython-virtual < %{current_major_version}
234 Conflicts: %{bname}-plpython < %{version}-%{release}
235 Provides: %{bname}-plpython = %{version}-%{release}
236
237 %description plpython
238 PostgreSQL is an advanced Object-Relational database management system. The
239 postgresql-plpython package contains the the PL/Python procedural languages for
240 the backend. PL/Python is part of the core server package.
241
242 %package plperl
243 Summary: The PL/Perl procedural language for PostgreSQL
244 Group: Databases
245 Requires: postgresql%{current_major_version}-server = %{version}
246 Requires: perl-base = %{perl_epoch}:%{perl_version}
247 Conflicts: postgresql-pl < %version-%release
248 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
249 Provides: %{bname}-plperl-virtual = %{current_major_version}
250 Conflicts: %{bname}-plperl-virtual < %{current_major_version}
251 Conflicts: %{bname}-plperl < %{version}-%{release}
252 Provides: %{bname}-plperl = %{version}-%{release}
253
254 %description plperl
255 PostgreSQL is an advanced Object-Relational database management system. The
256 postgresql-plperl package contains the the PL/Perl procedural languages for the
257 backend. PL/Perl is part of the core server package.
258
259 %package pltcl
260 Summary: The PL/Tcl procedural language for PostgreSQL
261 Group: Databases
262 Requires: postgresql%{current_major_version}-server = %{version}
263 Conflicts: postgresql-pl < %version-%release
264 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
265 Provides: %{bname}-pltcl-virtual = %{current_major_version}
266 Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
267 Conflicts: %{bname}-pltcl < %{version}-%{release}
268 Provides: %{bname}-pltcl = %{version}-%{release}
269
270 %description pltcl
271 PostgreSQL is an advanced Object-Relational database management system. The
272 postgresql-pltcl package contains the the PL/Tcl procedural languages for the
273 backend. PL/Tcl is part of the core server package.
274
275 %package plpgsql
276 Summary: The PL/PgSQL procedural language for PostgreSQL
277 Group: Databases
278 Requires: postgresql%{current_major_version}-server = %{version}
279 Conflicts: postgresql-pl < %version-%release
280 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
281 Provides: %{bname}-plpgsql-virtual = %{current_major_version}
282 Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
283 Conflicts: %{bname}-plpgsql < %{version}-%{release}
284 Provides: %{bname}-plpgsql = %{version}-%{release}
285
286 %description plpgsql
287 PostgreSQL is an advanced Object-Relational database management system. The
288 postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
289 the backend. PL/PgSQL is part of the core server package.
290
291 %prep
292
293 %setup -q -n %{bname}-%{version}%{?beta}
294
295 %build
296
297 %serverbuild
298
299 %configure \
300 --disable-rpath \
301 --enable-hba \
302 --enable-locale \
303 --enable-multibyte \
304 --enable-syslog\
305 --with-CXX \
306 --enable-odbc \
307 --with-perl \
308 --with-python \
309 --with-tcl --with-tclconfig=%{_libdir} \
310 --without-tk \
311 --with-openssl \
312 --with-pam \
313 --with-libxml \
314 --with-libxslt \
315 --libdir=%{_libdir} \
316 --with-docdir=%{_docdir} \
317 --mandir=%{_mandir} \
318 --prefix=%_prefix \
319 --sysconfdir=%{_sysconfdir}/pgsql \
320 --enable-nls \
321 %if %withuuid
322 --with-ossp-uuid
323 %endif
324
325 # $(rpathdir) come from Makefile
326 perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
327
328 %make world
329
330 pushd src/test
331 make all
332 popd
333
334 %check
335 make check
336
337 %install
338 rm -rf %{buildroot}
339
340 make DESTDIR=%{buildroot} install-world install-docs
341
342 # install odbcinst.ini
343 mkdir -p %{buildroot}%{_sysconfdir}/pgsql
344
345 # copy over Makefile.global to the include dir....
346 #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
347
348 # PGDATA needs removal of group and world permissions due to pg_pwd hole.
349 install -d -m 700 %{buildroot}/var/lib/pgsql/data
350
351 # backups of data go here...
352 install -d -m 700 %{buildroot}/var/lib/pgsql/backups
353
354 # Create the multiple postmaster startup directory
355 install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
356
357 %if 0
358 # tests. There are many files included here that are unnecessary, but include
359 # them anyway for completeness.
360 mkdir -p %{buildroot}%{_libdir}/pgsql/test
361 cp -a src/test/regress %{buildroot}%{_libdir}/pgsql/test
362 install -m 0755 contrib/spi/refint.so %{buildroot}%{_libdir}/pgsql/test/regress
363 install -m 0755 contrib/spi/autoinc.so %{buildroot}%{_libdir}/pgsql/test/regress
364 pushd %{buildroot}%{_libdir}/pgsql/test/regress/
365 strip *.so
366 popd
367 %endif
368
369 mkdir -p %buildroot/var/log/postgres
370
371 mkdir -p %buildroot%logrotatedir
372 cat > %buildroot%logrotatedir/%{bname} <<EOF
373 /var/log/postgres/postgresql {
374 notifempty
375 missingok
376 copytruncate
377 }
378 EOF
379
380 install -D -m755 %{SOURCE11} %{buildroot}%{_initrddir}/postgresql
381
382 mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
383
384 echo -n '' > main.lst
385 for i in \
386 pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
387 ecpg libpq%{major} ecpglib%{major_ecpg}; do
388 %find_lang $i-%{current_major_version}
389 cat $i-%{current_major_version}.lang >> main.lst
390 %find_lang $i
391 cat $i.lang >> main.lst
392 done
393 echo -n '' > server.lst
394 for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl; do
395 %find_lang $i
396 cat $i.lang >> server.lst
397 %find_lang $i-%{current_major_version}
398 cat $i-%{current_major_version}.lang >> server.lst
399 done
400
401 # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
402 # postgres.lang pg_resetxlog.lang pg_controldata.lang \
403 # libpq.lang libecpg.lang \
404
405 # taken directly in build dir.
406 rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
407
408 mkdir -p %buildroot/%_sys_macros_dir
409 cat > %buildroot/%_sys_macros_dir/%{name}.macros <<EOF
410 %%postgresql_version %{version}
411 %%postgresql_major %{current_major_version}
412 %%postgresql_minor %{current_minor_version}
413 %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
414 EOF
415
416 cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
417 cat > README.urpmi <<EOF
418 You just installed or updated %{bname} server.
419 You can find important information about %{distribution} %{bname} rpms and database
420 management in:
421
422 %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
423
424 Please read it.
425 EOF
426
427 # postgres' .profile and .bashrc
428 install -D -m 700 %SOURCE10 %{buildroot}/var/lib/pgsql/.profile
429 (
430 cd %{buildroot}/var/lib/pgsql/
431 ln -s .profile .bashrc
432 )
433
434 cat > %buildroot%_sysconfdir/sysconfig/postgresql <<EOF
435 # Olivier Thauvin <nanardon@mandriva.org>
436
437 # The database location:
438 # You probably won't change this
439 # PGDATA=/var/lib/pgsql/data
440
441 # What is the based locales for postgresql
442 # Setting locales to C allow to use any encoding
443 # ISO or UTF, any other choice will restrict you
444 # either ISO or UTF.
445 LC_ALL=C
446
447 # These are additional to pass to pg_ctl when starting/restarting postgresql.
448 # PGOPTIONS=
449 EOF
450
451 %pre server
452 %_pre_useradd postgres /var/lib/pgsql /bin/bash
453
454 [ ! -f %pgdata/data/PG_VERSION ] && exit 0
455 mypgversion=`cat %pgdata/data/PG_VERSION`
456 [ $mypgversion = %{current_major_version} ] && exit 0
457
458 echo ""
459 echo "You currently have database tree for Postgresql $mypgversion"
460 echo "You must use postgresql${mypgversion}-server"
461 echo "To update you Postgresql server, dump your databases"
462 echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
463 echo "restore your databases from your backup"
464 echo ""
465
466 exit 1
467
468 %posttrans server
469
470 %_post_service %{bname}
471
472 %preun server
473 %_preun_service %{bname}
474
475 %postun server
476 %_postun_userdel postgres
477
478 %clean
479 rm -rf %{buildroot}
480
481 %files -f main.lst
482 %defattr(-,root,root)
483 %doc doc/KNOWN_BUGS doc/MISSING_FEATURES doc/README*
484 %doc COPYRIGHT README HISTORY doc/bug.template
485 %{_bindir}/clusterdb
486 %{_bindir}/createdb
487 %{_bindir}/createlang
488 %{_bindir}/createuser
489 %{_bindir}/dropdb
490 %{_bindir}/droplang
491 %{_bindir}/dropuser
492 %{_bindir}/pg_dump
493 %{_bindir}/pg_dumpall
494 %{_bindir}/pg_restore
495 %{_bindir}/psql
496 %{_bindir}/reindexdb
497 %{_bindir}/vacuumdb
498 %{_mandir}/man1/clusterdb.*
499 %{_mandir}/man1/createdb.*
500 %{_mandir}/man1/createlang.*
501 %{_mandir}/man1/createuser.*
502 %{_mandir}/man1/dropdb.*
503 %{_mandir}/man1/droplang.*
504 %{_mandir}/man1/dropuser.*
505 %{_mandir}/man1/pg_dump.*
506 %{_mandir}/man1/pg_dumpall.*
507 %{_mandir}/man1/pg_restore.*
508 %{_mandir}/man1/psql.*
509 %{_mandir}/man1/vacuumdb.*
510 %{_mandir}/man1/reindexdb.*
511 %{_mandir}/man7/*
512 %_sys_macros_dir/%{name}.macros
513
514 %files -n %{libname}
515 %defattr(-,root,root)
516 %{_libdir}/libpq.so.%{major}*
517
518 %files -n %{libecpg}
519 %defattr(-,root,root)
520 %{_libdir}/libecpg.so.%{major_ecpg}*
521 %{_libdir}/libecpg_compat.so.*
522 %{_libdir}/libpgtypes.so.*
523
524 %files docs
525 %defattr(-,root,root)
526 %doc %{_docdir}/%{name}-docs-%{version}
527
528 %files contrib
529 %defattr(-,root,root)
530 # %doc contrib/*/README.* contrib/spi/*.example
531 %{_libdir}/postgresql/_int.so
532 %{_libdir}/postgresql/btree_gist.so
533 %{_libdir}/postgresql/chkpass.so
534 %{_libdir}/postgresql/cube.so
535 %{_libdir}/postgresql/dblink.so
536 %{_libdir}/postgresql/earthdistance.so
537 %{_libdir}/postgresql/fuzzystrmatch.so
538 %{_libdir}/postgresql/insert_username.so
539 %{_libdir}/postgresql/lo.so
540 %{_libdir}/postgresql/ltree.so
541 %{_libdir}/postgresql/moddatetime.so
542 %{_libdir}/postgresql/pgcrypto.so
543 %{_libdir}/postgresql/pgstattuple.so
544 %{_libdir}/postgresql/refint.so
545 %{_libdir}/postgresql/seg.so
546 %{_libdir}/postgresql/tablefunc.so
547 %{_libdir}/postgresql/timetravel.so
548 %{_libdir}/postgresql/pg_trgm.so
549 %{_libdir}/postgresql/autoinc.so
550 %{_libdir}/postgresql/pg_buffercache.so
551 %{_libdir}/postgresql/adminpack.so
552 %{_libdir}/postgresql/hstore.so
553 %{_libdir}/postgresql/isn.so
554 %{_libdir}/postgresql/pg_freespacemap.so
555 %{_libdir}/postgresql/pgrowlocks.so
556 %{_libdir}/postgresql/sslinfo.so
557 %{_libdir}/postgresql/pageinspect.so
558
559 %{_datadir}/postgresql/contrib/
560 %{_bindir}/oid2name
561 %{_bindir}/pgbench
562 %{_bindir}/vacuumlo
563
564 %files server -f server.lst
565 %defattr(-,root,root)
566 %{_initrddir}/postgresql
567 %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
568 %doc README.urpmi postgresql.%{_vendor}.releasenote
569 %{_bindir}/initdb
570 %{_bindir}/pg_controldata
571 %{_bindir}/pg_ctl
572 %{_bindir}/pg_resetxlog
573 %{_bindir}/postgres
574 %{_bindir}/postmaster
575 %{_bindir}/pg_standby
576 %{_bindir}/pg_archivecleanup
577 %{_bindir}/pg_upgrade
578 %{_mandir}/man1/initdb.1*
579 %{_mandir}/man1/pg_controldata.*
580 %{_mandir}/man1/pg_ctl.1*
581 %{_mandir}/man1/pg_resetxlog.*
582 %{_mandir}/man1/postgres.1*
583 %{_mandir}/man1/postmaster.1*
584 %dir %{_libdir}/postgresql
585 %dir %{_datadir}/postgresql
586 %attr(644,postgres,postgres) %config(noreplace) /var/lib/pgsql/.bashrc
587 %attr(-,postgres,postgres) /var/lib/pgsql/.profile
588 %attr(700,postgres,postgres) %dir %{pgdata}
589 %attr(-,postgres,postgres) %{pgdata}/data
590 %attr(700,postgres,postgres) %dir %{pgdata}/backups
591 %{_libdir}/postgresql/*_and_*.so
592 %{_libdir}/postgresql/pgxml.so
593 %{_libdir}/postgresql/dict_int.so
594 %{_libdir}/postgresql/dict_xsyn.so
595 %{_libdir}/postgresql/test_parser.so
596 %{_libdir}/postgresql/tsearch2.so
597 %{_libdir}/postgresql/dict_snowball.so
598 %{_libdir}/postgresql/auto_explain.so
599 %{_libdir}/postgresql/btree_gin.so
600 %{_libdir}/postgresql/citext.so
601 %{_libdir}/postgresql/pg_stat_statements.so
602 %if %withuuid
603 %{_libdir}/postgresql/uuid-ossp.so
604 %endif
605 %{_libdir}/postgresql/euc2004_sjis2004.so
606 %{_libdir}/postgresql/libpqwalreceiver.so
607 %{_libdir}/postgresql/passwordcheck.so
608 %{_libdir}/postgresql/pg_upgrade_support.so
609 %{_libdir}/postgresql/unaccent.so
610 %{_datadir}/postgresql/postgres.bki
611 %{_datadir}/postgresql/postgres.description
612 %{_datadir}/postgresql/*.sample
613 %{_datadir}/postgresql/timezone
614 %{_datadir}/postgresql/system_views.sql
615 %{_datadir}/postgresql/conversion_create.sql
616 %{_datadir}/postgresql/information_schema.sql
617 %{_datadir}/postgresql/snowball_create.sql
618 %{_datadir}/postgresql/sql_features.txt
619 %{_datadir}/postgresql/postgres.shdescription
620 %dir %{_datadir}/postgresql/timezonesets
621 %{_datadir}/postgresql/timezonesets/Africa.txt
622 %{_datadir}/postgresql/timezonesets/America.txt
623 %{_datadir}/postgresql/timezonesets/Antarctica.txt
624 %{_datadir}/postgresql/timezonesets/Asia.txt
625 %{_datadir}/postgresql/timezonesets/Atlantic.txt
626 %{_datadir}/postgresql/timezonesets/Australia
627 %{_datadir}/postgresql/timezonesets/Australia.txt
628 %{_datadir}/postgresql/timezonesets/Default
629 %{_datadir}/postgresql/timezonesets/Etc.txt
630 %{_datadir}/postgresql/timezonesets/Europe.txt
631 %{_datadir}/postgresql/timezonesets/India
632 %{_datadir}/postgresql/timezonesets/Indian.txt
633 %{_datadir}/postgresql/timezonesets/Pacific.txt
634 %{_datadir}/postgresql/tsearch_data
635
636 %attr(700,postgres,postgres) %dir /var/log/postgres
637 %logrotatedir/%{bname}
638
639 %files devel
640 %defattr(-,root,root)
641 # %doc doc/TODO doc/TODO.detail
642 %{_includedir}/*
643 %{_bindir}/ecpg
644 %{_libdir}/lib*.a
645 %{_libdir}/lib*.so
646 %{_libdir}/postgresql/pgxs/
647 %{_mandir}/man1/ecpg.1*
648 %{_bindir}/pg_config
649 %{_mandir}/man1/pg_config.1*
650 #From %files -n %{libnamedevel}
651 %{_libdir}/libpq.so
652 #From %files -n %{libecpgdevel}
653 %{_libdir}/libecpg.so
654 %{_mandir}/man3/SPI_*.3*
655 %{_mandir}/man3/dblink*.3*
656
657 %files pl
658 %defattr(-,root,root)
659
660 %files plpython
661 %defattr(-,root,root)
662 %{_libdir}/postgresql/plpython.so
663 %{_libdir}/postgresql/plpython2.so
664
665 %files plperl
666 %defattr(-,root,root)
667 %{_libdir}/postgresql/plperl.so
668
669 %files pltcl
670 %defattr(-,root,root)
671 %{_libdir}/postgresql/pltcl.so
672 %{_bindir}/pltcl_delmod
673 %{_bindir}/pltcl_listmod
674 %{_bindir}/pltcl_loadmod
675 %{_datadir}/postgresql/unknown.pltcl
676
677 %files plpgsql
678 %defattr(-,root,root)
679 %{_libdir}/postgresql/plpgsql.so
680
681
682

  ViewVC Help
Powered by ViewVC 1.1.30