/[packages]/updates/1/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/1/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 46868 - (hide annotations) (download)
Fri Feb 4 12:11:06 2011 UTC (13 years, 2 months ago) by dmorgan
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21888 byte(s)
Remove patch 1017, to not diverge from main rpm.org regarding version comparison
1 tmb 343 # Do not change this spec directly but in the svn
2     # $Id: rpm.spec 134789 2007-03-27 15:13:43Z nanardon $
3    
4     %define lib64arches x86_64 ppc64 sparc64
5    
6     %ifarch %lib64arches
7     %define _lib lib64
8     %else
9     %define _lib lib
10     %endif
11    
12     %define _prefix /usr
13     %define _libdir %_prefix/%_lib
14     %define _bindir %_prefix/bin
15     %define _sysconfdir /etc
16     %define _datadir /usr/share
17     %define _defaultdocdir %_datadir/doc
18     %define _localstatedir /var
19     %define _infodir %_datadir/info
20    
21     %if %{?apply_patches:0}%{?!apply_patches:1}
22     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
23     %endif
24    
25     # Define directory which holds rpm config files, and some binaries actually
26     # NOTE: it remains */lib even on lib64 platforms as only one version
27     # of rpm is supported anyway, per architecture
28     %define rpmdir %{_prefix}/lib/rpm
29    
30     %if %{?mklibname:0}%{?!mklibname:1}
31     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
32     %endif
33    
34     %if %{?distsuffix:0}%{?!distsuffix:1}
35 tmb 345 %define distsuffix .mga
36 tmb 343 %endif
37    
38     %if %{?mkrel:0}%{?!mkrel:1}
39 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
40 tmb 343 %endif
41    
42     %if %{?mips:0}%{?!mips:1}
43     %define mips mips mipsel mips32 mips32el mips64 mips64el
44     %endif
45    
46     %if %{?pyver:0}%{?!pyver:1}
47     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
48     %endif
49    
50 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
51     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
52 tmb 343
53 dmorgan 46866 %define rpmversion 4.8.1
54 tmb 343 %define srcver %rpmversion
55 dmorgan 46862 %define libver 4.8
56     %define libmajor 1
57     %define release %mkrel 1
58     %define librpmname %mklibname rpm %{libmajor}
59 tmb 345 %define librpmnamedevel %mklibname -d rpm
60 tmb 343
61     %define buildpython 1
62    
63     %define rpmsetup_version 1.34
64    
65     %define builddebug 0
66     %{?_with_debug:%define builddebug 1}
67    
68     %{?_with_python:%define buildpython 1}
69     %{?_without_python:%define buildpython 0}
70    
71     Summary: The RPM package management system
72     Name: rpm
73     Epoch: 1
74     Version: %{rpmversion}
75     Release: %{release}
76     Group: System/Configuration/Packaging
77    
78     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
79    
80     # Add some undocumented feature to gendiff
81     Patch17: rpm-4.4.2.2-gendiff-improved.patch
82    
83     # if %post of foo-2 fails,
84     # or if %preun of foo-1 fails,
85     # or if %postun of foo-1 fails,
86     # => foo-1 is not removed, so we end up with both packages in rpmdb
87     # this patch makes rpm ignore the error in those cases
88     # failing %pre must still make the rpm install fail (#23677)
89     #
90     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
91     # scripts is ignored with or without this patch)
92     Patch22: rpm-4.6.0-rc1-non-pre-scripts-dont-fail.patch
93    
94     # (fredl) add loging facilities through syslog
95     Patch31: rpm-4.6.0-rc1-syslog.patch
96    
97     # part of Backport from 4.2.1 provides becoming obsoletes bug (fpons)
98     # (is it still needed?)
99     Patch49: rpm-4.6.0-rc1-provides-obsoleted.patch
100    
101 blino 25212 # - force /usr/lib/rpm/manbo/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
102     # - read /usr/lib/rpm/manbo/rpmpopt (not only /usr/lib/rpm/rpmpopt)
103     Patch64: rpm-4.6.0-rc2-manbo-rpmrc-rpmpopt.patch
104    
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107     # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.6.0-rc1-bb-shortcircuit.patch
109    
110     # http://www.redhat.com/archives/rpm-list/2005-April/msg00131.html
111     # http://www.redhat.com/archives/rpm-list/2005-April/msg00132.html
112     # is this useful? "at least erasure ordering is just as non-existent as it was in 4.4.x" says Panu
113 dmorgan 46863 #with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
114     #Patch71: rpm-4.6.0-ordererase.patch#with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
115 dmorgan 46862 #Patch71: rpm-4.6.0-ordererase.patch
116 tmb 343
117     # don't conflict for doc files
118     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
119     Patch83: rpm-4.6.0-no-doc-conflicts.patch
120    
121     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
122     # (is this working??)
123     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
124    
125     # Fix diff issue when buildroot contains some "//"
126     Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
127    
128     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
129     Patch114: rpm-4.6.0-rc1-read-macros_d-dot-macros.patch
130    
131     # remove unused skipDir functionality that conflicts with patch124 below
132 dmorgan 46862 #Patch1124: rpm-4.6.0-rc1-revert-unused-skipDir-functionality.patch
133 tmb 343
134     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
135     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
136     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
137     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
138     # but this is bad design anyway
139 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
140 tmb 343
141     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
142     Patch133: rpm-4.6.0-rc1-weakdeps.patch
143    
144     # convert data in the header to a specific encoding which used in the selected locale.
145     Patch137: rpm-4.6.0-rc1-headerIconv.patch
146    
147     # Mandriva does not need the (broken) ldconfig hack since it uses filetriggers
148 dmorgan 46862 #Patch141: rpm-4.6.0-rc1-drop-skipping-ldconfig-hack.patch
149 tmb 343
150     # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
151     # with this patch, "#%define foo bar" is a fatal error
152     Patch145: rpm-forbid-badly-commented-define-in-spec.patch
153    
154     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
155     Patch146: rpm-4.6.0-rc1-filetriggers.patch
156    
157     # add two fatal errors (during package build)
158     Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
159    
160     # (nb: see the patch for more info about this issue)
161     Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
162    
163     Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
164    
165     Patch157: introduce-_after_setup-which-is-called-after-setup.patch
166     Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
167     Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
168    
169     # avoid "canonicalization unexpectedly shrank by one character" error from
170     # debugedit by adding '/' to the end of the string when the error would be
171     # triggered
172     # see https://bugzilla.redhat.com/show_bug.cgi?id=304121 and
173     # https://bugzilla.redhat.com/show_bug.cgi?id=482903
174    
175     Patch164: rpm-4.6.1-updated-debugedit-for-debug_pubtypes-section.patch
176     Patch165: rpm-4.6.0-fix-debugedit-canonicalization-error.patch
177    
178     #Patch1001: rpm-4.6.0-rc1-new-liblzma.patch
179    
180     # default behaviour in rpm-jbj >= 4.4.6
181     Patch1005: rpm-allow-conflicting-ghost-files.patch
182    
183     Patch1007: rpm-4.6.0-rc3-xz-support.patch
184    
185     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
186     # as this breaks stuff that installs files to $DOCDIR during %%install
187     Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
188    
189     # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
190     # break when these unknown tags might be found in the rpmdb. Notice that this
191     # will only make rpm recognize these, not implement actual support for them..
192     Patch1009: rpm-4.6.0-rpm5-tags.patch
193    
194     # Check chroot return code before running lua script
195     Patch1011: rpm-4.6.0-do-not-run-lua-scripts-when-chroot-fails.patch
196    
197     # Check chroot return code before running external script
198     Patch1012: rpm-4.6.0-do-not-run-scripts-when-chroot-fails.patch
199    
200     # Make sure files in debug packages have good default perms, fixes bug #57758
201     Patch1013: rpm-4.6.0-fix-debug-info-default-permissions.patch
202    
203     # Remove BDB XA support to fix compilation with db 4.8 (upstream)
204     Patch1014: rpm-4.6.0-bdb-xa-removal.patch
205    
206     # Refuse to build a rpm with 2 identical triggers (#60699)
207     #Patch1015: rpm-4.6.0-duplicate-triggers.patch
208    
209     # Automatically handle ruby gem extraction in %setup
210     PAtch1018: rpm-4.6.1-setup-rubygems.patch
211    
212     # Turbolinux patches
213     # add writeHeaderListTofile function into rpm-python (needed by "buildman" build system) (Toshihiro, 2003)
214 dmorgan 46862 #Patch2002: rpm-4.6.0-rc1-python-writeHdlist.patch
215 tmb 343 # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
216     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
217    
218     # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
219     #
220     # This patch fixes the problem when the post-scripts launched by rpm-build.
221     # The post-scripts launched by rpm-build works in LANG environment. If LANG is
222     # other locale except C, then some commands launched by post-scripts will not
223     # display characters which you expected.
224     Patch2005: rpm-4.6.0-rc1-buildlang.patch
225    
226     Patch3000: mips_macros.patch
227     Patch3001: fix_stack_protector_check.patch
228     Patch3002: rpm-4.6.1-mips_define_isa_macros.patch
229     Patch3003: rpm-4.6.1-arm_mips_isa_macros.patch
230     Patch3004: rpm_add_armv5tl.patch
231    
232     License: GPL
233     BuildRequires: autoconf >= 2.57
234     BuildRequires: zlib-devel
235     BuildRequires: bzip2-devel
236     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
237     BuildRequires: automake >= 1.8
238     BuildRequires: elfutils-devel
239     BuildRequires: sed >= 4.0.3
240     BuildRequires: libbeecrypt-devel
241     BuildRequires: ed, gettext-devel
242     BuildRequires: libsqlite3-devel
243     BuildRequires: db4.8-devel
244     BuildRequires: neon-devel
245     BuildRequires: popt-devel
246     BuildRequires: nss-devel
247     BuildRequires: magic-devel
248 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
249 tmb 343 BuildRequires: readline-devel
250     BuildRequires: ncurses-devel
251     BuildRequires: openssl-devel >= 0.9.8
252     BuildRequires: lua-devel
253     # Need for doc
254     #BuildRequires: graphviz
255     BuildRequires: tetex
256     %if %buildpython
257     BuildRequires: python-devel
258     %endif
259    
260     Requires: bzip2 >= 0.9.0c-2
261     Requires: lzma
262     Requires: cpio
263     Requires: gawk
264     Requires: glibc >= 2.1.92
265     Requires: mktemp
266 tmb 345 Requires: setup >= 2.2.0-8
267 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
268 tmb 343 Requires: update-alternatives
269     Requires: %librpmname = %epoch:%version-%release
270     Conflicts: patch < 2.5
271 tmb 345 Conflicts: menu < 2.1.5-29
272 tmb 343 Conflicts: locales < 2.3.1.1
273 tmb 345 Conflicts: man-pages-fr < 0.9.7-16
274     Conflicts: man-pages-pl < 0.4-9
275     Conflicts: perl-URPM < 1.63-3
276 tmb 343 # rpm 4.6.0 dropped support for --repackage, so urpmi-recover can not work anymore:
277     Conflicts: urpmi-recover
278     URL: http://rpm.org/
279     %define git_url http://rpm.org/git/rpm.git
280     Requires(pre): rpm-helper >= 0.8
281     Requires(pre): coreutils
282     Requires(postun): rpm-helper >= 0.8
283     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
284    
285     %description
286     RPM is a powerful command line driven package management system capable of
287     installing, uninstalling, verifying, querying, and updating software packages.
288     Each software package consists of an archive of files along with information
289     about the package like its version, a description, etc.
290    
291     %package -n %librpmname
292 tmb 345 Summary: Library used by rpm
293     Group: System/Libraries
294     Provides: librpm = %version-%release
295 tmb 343
296     %description -n %librpmname
297     RPM is a powerful command line driven package management system capable of
298     installing, uninstalling, verifying, querying, and updating software packages.
299     This package contains common files to all applications based on rpm.
300    
301     %package -n %librpmnamedevel
302     Summary: Development files for applications which will manipulate RPM packages
303     Group: Development/C
304     Requires: rpm = %epoch:%{version}-%{release}
305     Provides: librpm-devel = %version-%release
306     Provides: rpm-devel = %version-%release
307     Obsoletes: rpm-devel < 4.4.1
308     Obsoletes: %{_lib}rpm4.4-devel
309     Obsoletes: %{_lib}rpm4.2-devel
310    
311     %description -n %librpmnamedevel
312     This package contains the RPM C library and header files. These
313     development files will simplify the process of writing programs
314     which manipulate RPM packages and databases and are intended to make
315     it easier to create graphical package managers or any other tools
316     that need an intimate knowledge of RPM packages in order to function.
317    
318     This package should be installed if you want to develop programs that
319     will manipulate RPM packages and databases.
320    
321     %package build
322     Summary: Scripts and executable programs used to build packages
323     Group: System/Configuration/Packaging
324     Requires: autoconf
325     Requires: automake
326     Requires: file
327     Requires: gcc-c++
328     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
329 tmb 345 Requires: libtool-base >= 1.4.3-5
330     Requires: patch >= 2.5.9-7
331 tmb 343 Requires: make
332     Requires: tar
333     Requires: unzip
334     Requires: elfutils
335     Requires: rpm = %epoch:%{version}-%{release}
336 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
337 tmb 343
338     %description build
339     This package contains scripts and executable programs that are used to
340     build packages using RPM.
341    
342     %if %buildpython
343     %package -n python-rpm
344     Summary: Python bindings for apps which will manipulate RPM packages
345     Group: Development/Python
346     Requires: python >= %{pyver}
347     Requires: rpm = %epoch:%{version}-%{release}
348 tmb 345 Obsoletes: rpm-python < %epoch:%version-%release
349     Provides: rpm-python = %version-%release
350 tmb 343
351     %description -n python-rpm
352     The rpm-python package contains a module which permits applications
353     written in the Python programming language to use the interface
354     supplied by RPM (RPM Package Manager) libraries.
355    
356     This package should be installed if you want to develop Python
357     programs that will manipulate RPM packages and databases.
358     %endif
359    
360     %prep
361     %setup -q -n %name-%srcver
362     %apply_patches
363    
364     %build
365    
366     autoreconf
367    
368     %if %builddebug
369     RPM_OPT_FLAGS=-g
370     %endif
371     CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
372     %configure \
373     --enable-nls \
374     --enable-python \
375     --enable-sqlite3 \
376     --without-javaglue \
377     %if %builddebug
378     --enable-debug \
379     %endif
380     --with-external-db \
381     %if %buildpython
382     --with-python=%{pyver} \
383     %else
384     --without-python \
385     %endif
386     --with-glob \
387     --without-selinux \
388     --without-apidocs
389    
390     %make
391    
392     %install
393     rm -rf $RPM_BUILD_ROOT
394    
395     make DESTDIR=%buildroot install
396    
397     %ifarch ppc powerpc
398 blino 25213 ln -sf ppc-%{_real_vendor}-linux $RPM_BUILD_ROOT%{rpmdir}/powerpc-%{_real_vendor}-linux
399 tmb 343 %endif
400    
401     #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
402    
403     # Save list of packages through cron
404     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
405     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
406    
407     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
408     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
409    
410     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
411     for dbi in \
412     Basenames Conflictname Dirnames Group Installtid Name Providename \
413     Provideversion Removetid Requirename Requireversion Triggername \
414     Packages __db.001 __db.002 __db.003 __db.004
415     do
416     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
417     done
418    
419     test -d doc-copy || mkdir doc-copy
420     rm -rf doc-copy/*
421     ln -f doc/manual/* doc-copy/
422     rm -f doc-copy/Makefile*
423    
424     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
425    
426     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
427     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
428     # Put your own system macros here
429     # usually contains
430    
431     # Set this one according your locales
432     # %%_install_langs
433    
434     EOF
435    
436     # Get rid of unpackaged files
437     (cd $RPM_BUILD_ROOT;
438     rm -rf .%{_includedir}/beecrypt/
439     rm -f .%{_libdir}/libbeecrypt.{a,la,so*}
440     rm -f .%{_libdir}/python*/site-packages/rpmmodule.{a,la}
441     rm -f .%{rpmdir}/{Specfile.pm,cpanflute2,cpanflute,sql.prov,sql.req,tcl.req}
442     rm -f .%{rpmdir}/{config.site,cross-build,rpmdiff.cgi}
443     rm -f .%{rpmdir}/trpm
444     rm -f .%{_bindir}/rpmdiff
445     )
446    
447     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
448    
449     %clean
450     rm -rf $RPM_BUILD_ROOT
451    
452     %pre
453     if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
454     echo "
455     You have both
456     /var/lib/rpm/packages.rpm db1 format installed package headers
457     /var/lib/rpm/Packages db3 format installed package headers
458     Please remove (or at least rename) one of those files, and re-install.
459     "
460     exit 1
461     fi
462    
463     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
464    
465     rm -rf /usr/lib/rpm/*-mandrake-*
466 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
467 tmb 343
468 tmb 345
469 tmb 343 %post
470     # nuke __db.00? when updating to this rpm
471     rm -f /var/lib/rpm/__db.00?
472    
473     if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{rpmdir}/convertrpmrc.sh ]
474     then
475     sh %{rpmdir}/convertrpmrc.sh 2>&1 > /dev/null
476     fi
477    
478     if [ -f /var/lib/rpm/packages.rpm ]; then
479     /bin/chown rpm.rpm /var/lib/rpm/*.rpm
480     elif [ ! -f /var/lib/rpm/Packages ]; then
481     /bin/rpm --initdb
482     fi
483    
484     %postun
485     /usr/share/rpm-helper/del-user rpm $1 rpm
486    
487     %triggerpostun -- rpm < 1:4.4.2.3-11
488     if [ -f /etc/rpm/macros.cdb.rpmsave ]; then
489     echo "warning: restoring /etc/rpm/macros.cdb from macros.cdb.rpmsave, please check you really need the changes"
490     mv /etc/rpm/macros.cdb.rpmsave /etc/rpm/macros.cdb
491     fi
492    
493     %define rpmattr %attr(0755, rpm, rpm)
494    
495     %files -f %{name}.lang
496     %defattr(-,root,root)
497     %doc GROUPS CHANGES doc/manual/[a-z]*
498     %attr(0755,rpm,rpm) /bin/rpm
499     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
500     %attr(0755, rpm, rpm) %{_bindir}/gendiff
501     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
502     %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
503     %attr(0755, rpm, rpm) %{_bindir}/rpmsign
504     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
505     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
506    
507     %dir %{_localstatedir}/spool/repackage
508     %dir %{rpmdir}
509     %dir /etc/rpm
510     %config(noreplace) /etc/rpm/macros
511     %dir /etc/rpm/macros.d
512     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
513     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
514     #%attr(0755, rpm, rpm) %{rpmdir}/convertrpmrc.sh
515     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
516     %attr(0644, rpm, rpm) %{rpmdir}/macros
517     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
518     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
519     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
520     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
521    
522     %rpmattr %{rpmdir}/rpm2cpio.sh
523     %rpmattr %{rpmdir}/tgpg
524    
525     %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
526     %ifarch %{ix86} x86_64
527     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
528     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
529     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
530     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
531     %endif
532     %ifarch alpha
533     %attr( -, rpm, rpm) %{rpmdir}/platform/alpha*
534     %endif
535     %ifarch %{sunsparc}
536     %attr( -, rpm, rpm) %{rpmdir}/platform/sparc*
537     %endif
538     %ifarch ppc powerpc
539     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
540     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
541     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
542     %attr( -, rpm, rpm) %{rpmdir}/platform/powerpc-*
543     %endif
544     %ifarch ppc powerpc ppc64
545     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc*series-*
546     %endif
547     %ifarch ppc64
548     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
549     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
550     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
551     %endif
552     %ifarch ia64
553     %attr( -, rpm, rpm) %{rpmdir}/platform/ia64-*
554     %endif
555     %ifarch x86_64
556     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
557     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
558     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
559     %endif
560     %ifarch %arm
561     %attr( -, rpm, rpm) %{rpmdir}/platform/armv*
562     %endif
563     %ifarch %mips
564     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
565     %endif
566     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
567    
568     %{_mandir}/man[18]/*.[18]*
569     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
570     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
571     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
572     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
573     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
574     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
575    
576     %config(noreplace,missingok) /etc/cron.daily/rpm
577     %config(noreplace,missingok) /etc/logrotate.d/rpm
578    
579     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
580    
581     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
582    
583     %rpmdbattr /var/lib/rpm/Basenames
584     %rpmdbattr /var/lib/rpm/Conflictname
585     %rpmdbattr /var/lib/rpm/__db.0*
586     %rpmdbattr /var/lib/rpm/Dirnames
587     %rpmdbattr /var/lib/rpm/Group
588     %rpmdbattr /var/lib/rpm/Installtid
589     %rpmdbattr /var/lib/rpm/Name
590     %rpmdbattr /var/lib/rpm/Packages
591     %rpmdbattr /var/lib/rpm/Providename
592     %rpmdbattr /var/lib/rpm/Provideversion
593     %rpmdbattr /var/lib/rpm/Removetid
594     %rpmdbattr /var/lib/rpm/Requirename
595     %rpmdbattr /var/lib/rpm/Requireversion
596     %rpmdbattr /var/lib/rpm/Triggername
597    
598     %files build
599     %defattr(-,root,root)
600     %doc CHANGES
601     %doc doc-copy/*
602     %rpmattr %{_bindir}/rpmbuild
603     %rpmattr %{_prefix}/lib/rpm/brp-*
604     %rpmattr %{_prefix}/lib/rpm/check-files
605     %rpmattr %{_prefix}/lib/rpm/debugedit
606 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
607 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
608     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
609     %rpmattr %{_prefix}/lib/rpm/find-provides
610     %rpmattr %{_prefix}/lib/rpm/find-requires
611 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
612 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
613     %rpmattr %{_prefix}/lib/rpm/perl.prov
614     %rpmattr %{_prefix}/lib/rpm/perl.req
615    
616     %rpmattr %{_prefix}/lib/rpm/check-buildroot
617     %rpmattr %{_prefix}/lib/rpm/check-prereqs
618     %rpmattr %{_prefix}/lib/rpm/check-rpaths
619     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
620     %rpmattr %{_prefix}/lib/rpm/javadeps
621     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
622     %rpmattr %{_prefix}/lib/rpm/macros.perl
623     %rpmattr %{_prefix}/lib/rpm/macros.php
624     %rpmattr %{_prefix}/lib/rpm/macros.python
625     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
626     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
627 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
628     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
629 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
630     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
631     %rpmattr %{_prefix}/lib/rpm/rpmdiff
632    
633     %rpmattr %{_prefix}/lib/rpm/rpmdeps
634     #%rpmattr %{_prefix}/lib/rpm/trpm
635     %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
636    
637     %{_mandir}/man8/rpmbuild.8*
638     %{_mandir}/man8/rpmdeps.8*
639    
640     %if %buildpython
641     %files -n python-rpm
642     %defattr(-,root,root)
643     %{_libdir}/python*/site-packages/rpm
644     %endif
645    
646     %files -n %librpmname
647     %defattr(-,root,root)
648 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
649     %{_libdir}/librpmio.so.%{libmajor}*
650     %{_libdir}/librpmbuild.so.%{libmajor}*
651 tmb 343
652     %files -n %librpmnamedevel
653     %defattr(-,root,root)
654     %{_includedir}/rpm
655     %{_libdir}/librpm.la
656     %{_libdir}/librpm.so
657     %{_libdir}/librpmio.la
658     %{_libdir}/librpmio.so
659     %{_libdir}/librpmbuild.la
660     %{_libdir}/librpmbuild.so
661     %{_libdir}/pkgconfig/rpm.pc

  ViewVC Help
Powered by ViewVC 1.1.30