/[packages]/updates/1/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/1/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 54082 - (hide annotations) (download)
Sat Feb 19 11:33:32 2011 UTC (13 years, 2 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21041 byte(s)
patch 70 can die once we reach rpm-4.9 (SILENT)

1 tmb 343 # Do not change this spec directly but in the svn
2     # $Id: rpm.spec 134789 2007-03-27 15:13:43Z nanardon $
3    
4     %define lib64arches x86_64 ppc64 sparc64
5    
6     %ifarch %lib64arches
7     %define _lib lib64
8     %else
9     %define _lib lib
10     %endif
11    
12     %define _prefix /usr
13     %define _libdir %_prefix/%_lib
14     %define _bindir %_prefix/bin
15     %define _sysconfdir /etc
16     %define _datadir /usr/share
17     %define _defaultdocdir %_datadir/doc
18     %define _localstatedir /var
19     %define _infodir %_datadir/info
20    
21     %if %{?apply_patches:0}%{?!apply_patches:1}
22     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
23     %endif
24    
25     # Define directory which holds rpm config files, and some binaries actually
26     # NOTE: it remains */lib even on lib64 platforms as only one version
27     # of rpm is supported anyway, per architecture
28     %define rpmdir %{_prefix}/lib/rpm
29    
30     %if %{?mklibname:0}%{?!mklibname:1}
31     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
32     %endif
33    
34     %if %{?distsuffix:0}%{?!distsuffix:1}
35 tmb 345 %define distsuffix .mga
36 tmb 343 %endif
37    
38     %if %{?mkrel:0}%{?!mkrel:1}
39 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
40 tmb 343 %endif
41    
42     %if %{?mips:0}%{?!mips:1}
43     %define mips mips mipsel mips32 mips32el mips64 mips64el
44     %endif
45    
46     %if %{?pyver:0}%{?!pyver:1}
47     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
48     %endif
49    
50 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
51     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
52 tmb 343
53 dmorgan 46866 %define rpmversion 4.8.1
54 tmb 343 %define srcver %rpmversion
55 dmorgan 46862 %define libver 4.8
56     %define libmajor 1
57     %define release %mkrel 1
58     %define librpmname %mklibname rpm %{libmajor}
59 tmb 345 %define librpmnamedevel %mklibname -d rpm
60 tmb 343
61     %define buildpython 1
62    
63     %define rpmsetup_version 1.34
64    
65     %define builddebug 0
66     %{?_with_debug:%define builddebug 1}
67    
68     %{?_with_python:%define buildpython 1}
69     %{?_without_python:%define buildpython 0}
70    
71     Summary: The RPM package management system
72     Name: rpm
73     Epoch: 1
74     Version: %{rpmversion}
75 dmorgan 49378 Release: %{release}
76 tmb 343 Group: System/Configuration/Packaging
77    
78     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
79    
80     # Add some undocumented feature to gendiff
81     Patch17: rpm-4.4.2.2-gendiff-improved.patch
82    
83     # if %post of foo-2 fails,
84     # or if %preun of foo-1 fails,
85     # or if %postun of foo-1 fails,
86     # => foo-1 is not removed, so we end up with both packages in rpmdb
87     # this patch makes rpm ignore the error in those cases
88     # failing %pre must still make the rpm install fail (#23677)
89     #
90     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
91     # scripts is ignored with or without this patch)
92     Patch22: rpm-4.6.0-rc1-non-pre-scripts-dont-fail.patch
93    
94     # (fredl) add loging facilities through syslog
95     Patch31: rpm-4.6.0-rc1-syslog.patch
96    
97     # part of Backport from 4.2.1 provides becoming obsoletes bug (fpons)
98     # (is it still needed?)
99     Patch49: rpm-4.6.0-rc1-provides-obsoleted.patch
100    
101 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
102     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
103     Patch64: rpm-4.6.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 tv 54082 # http://qa.mandriva.com/show_bug.cgi?id=15896Z
108     # (A different implementation has landed in rpm-4.9)
109 tmb 343 Patch70: rpm-4.6.0-rc1-bb-shortcircuit.patch
110    
111     # http://www.redhat.com/archives/rpm-list/2005-April/msg00131.html
112     # http://www.redhat.com/archives/rpm-list/2005-April/msg00132.html
113     # is this useful? "at least erasure ordering is just as non-existent as it was in 4.4.x" says Panu
114 dmorgan 46863 #with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
115     #Patch71: rpm-4.6.0-ordererase.patch#with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
116 tmb 343
117     # don't conflict for doc files
118     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
119     Patch83: rpm-4.6.0-no-doc-conflicts.patch
120    
121     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
122     # (is this working??)
123     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
124    
125     # Fix diff issue when buildroot contains some "//"
126     Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
127    
128     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
129     Patch114: rpm-4.6.0-rc1-read-macros_d-dot-macros.patch
130    
131     # remove unused skipDir functionality that conflicts with patch124 below
132 dmorgan 46862 #Patch1124: rpm-4.6.0-rc1-revert-unused-skipDir-functionality.patch
133 tmb 343
134     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
135     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
136     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
137     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
138     # but this is bad design anyway
139 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
140 tmb 343
141     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
142     Patch133: rpm-4.6.0-rc1-weakdeps.patch
143    
144 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
145     Patch135: rpm-4.4.2.3-rc1-fix-debugedit.patch
146    
147 tmb 343 # convert data in the header to a specific encoding which used in the selected locale.
148     Patch137: rpm-4.6.0-rc1-headerIconv.patch
149    
150     # Mandriva does not need the (broken) ldconfig hack since it uses filetriggers
151 dmorgan 46862 #Patch141: rpm-4.6.0-rc1-drop-skipping-ldconfig-hack.patch
152 tmb 343
153     # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
154     # with this patch, "#%define foo bar" is a fatal error
155     Patch145: rpm-forbid-badly-commented-define-in-spec.patch
156    
157     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
158     Patch146: rpm-4.6.0-rc1-filetriggers.patch
159    
160     # add two fatal errors (during package build)
161     Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162    
163     # (nb: see the patch for more info about this issue)
164     Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165    
166     Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
167    
168     Patch157: introduce-_after_setup-which-is-called-after-setup.patch
169     Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
170     Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
171    
172     #Patch1001: rpm-4.6.0-rc1-new-liblzma.patch
173    
174     # default behaviour in rpm-jbj >= 4.4.6
175     Patch1005: rpm-allow-conflicting-ghost-files.patch
176    
177     Patch1007: rpm-4.6.0-rc3-xz-support.patch
178    
179     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
180     # as this breaks stuff that installs files to $DOCDIR during %%install
181     Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
182    
183     # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
184     # break when these unknown tags might be found in the rpmdb. Notice that this
185     # will only make rpm recognize these, not implement actual support for them..
186     Patch1009: rpm-4.6.0-rpm5-tags.patch
187    
188     # Turbolinux patches
189     # add writeHeaderListTofile function into rpm-python (needed by "buildman" build system) (Toshihiro, 2003)
190 dmorgan 46862 #Patch2002: rpm-4.6.0-rc1-python-writeHdlist.patch
191 tmb 343 # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
192     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
193    
194     # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
195     #
196     # This patch fixes the problem when the post-scripts launched by rpm-build.
197     # The post-scripts launched by rpm-build works in LANG environment. If LANG is
198     # other locale except C, then some commands launched by post-scripts will not
199     # display characters which you expected.
200     Patch2005: rpm-4.6.0-rc1-buildlang.patch
201    
202 dmorgan 49378 Patch2000: rpm-4.6.0-rc1-serial-tag.patch
203     # re-enable "copyright" tag (Kiichiro, 2005)
204     Patch2001: rpm-4.6.0-rc1-copyright-tag.patch
205    
206 tmb 343 Patch3000: mips_macros.patch
207     Patch3001: fix_stack_protector_check.patch
208 dmorgan 49378 Patch3002: mips_define_isa_macros.patch
209     Patch3003: rpm_arm_mips_isa_macros.patch
210 tmb 343 Patch3004: rpm_add_armv5tl.patch
211    
212     License: GPL
213     BuildRequires: autoconf >= 2.57
214     BuildRequires: zlib-devel
215     BuildRequires: bzip2-devel
216     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
217     BuildRequires: automake >= 1.8
218     BuildRequires: elfutils-devel
219     BuildRequires: sed >= 4.0.3
220     BuildRequires: libbeecrypt-devel
221     BuildRequires: ed, gettext-devel
222     BuildRequires: libsqlite3-devel
223     BuildRequires: db4.8-devel
224     BuildRequires: neon-devel
225     BuildRequires: popt-devel
226     BuildRequires: nss-devel
227     BuildRequires: magic-devel
228 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
229 tmb 343 BuildRequires: readline-devel
230     BuildRequires: ncurses-devel
231     BuildRequires: openssl-devel >= 0.9.8
232     BuildRequires: lua-devel
233     # Need for doc
234     #BuildRequires: graphviz
235     BuildRequires: tetex
236     %if %buildpython
237     BuildRequires: python-devel
238     %endif
239    
240     Requires: bzip2 >= 0.9.0c-2
241     Requires: lzma
242     Requires: cpio
243     Requires: gawk
244     Requires: glibc >= 2.1.92
245     Requires: mktemp
246 tmb 345 Requires: setup >= 2.2.0-8
247 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
248 tmb 343 Requires: update-alternatives
249     Requires: %librpmname = %epoch:%version-%release
250     Conflicts: patch < 2.5
251 tmb 345 Conflicts: menu < 2.1.5-29
252 tmb 343 Conflicts: locales < 2.3.1.1
253 tmb 345 Conflicts: man-pages-fr < 0.9.7-16
254     Conflicts: man-pages-pl < 0.4-9
255     Conflicts: perl-URPM < 1.63-3
256 tmb 343 # rpm 4.6.0 dropped support for --repackage, so urpmi-recover can not work anymore:
257     Conflicts: urpmi-recover
258     URL: http://rpm.org/
259     %define git_url http://rpm.org/git/rpm.git
260     Requires(pre): rpm-helper >= 0.8
261     Requires(pre): coreutils
262     Requires(postun): rpm-helper >= 0.8
263     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
264    
265     %description
266     RPM is a powerful command line driven package management system capable of
267     installing, uninstalling, verifying, querying, and updating software packages.
268     Each software package consists of an archive of files along with information
269     about the package like its version, a description, etc.
270    
271     %package -n %librpmname
272 tmb 345 Summary: Library used by rpm
273     Group: System/Libraries
274     Provides: librpm = %version-%release
275 tmb 343
276     %description -n %librpmname
277     RPM is a powerful command line driven package management system capable of
278     installing, uninstalling, verifying, querying, and updating software packages.
279     This package contains common files to all applications based on rpm.
280    
281     %package -n %librpmnamedevel
282     Summary: Development files for applications which will manipulate RPM packages
283     Group: Development/C
284     Requires: rpm = %epoch:%{version}-%{release}
285     Provides: librpm-devel = %version-%release
286     Provides: rpm-devel = %version-%release
287     Obsoletes: rpm-devel < 4.4.1
288     Obsoletes: %{_lib}rpm4.4-devel
289     Obsoletes: %{_lib}rpm4.2-devel
290    
291     %description -n %librpmnamedevel
292     This package contains the RPM C library and header files. These
293     development files will simplify the process of writing programs
294     which manipulate RPM packages and databases and are intended to make
295     it easier to create graphical package managers or any other tools
296     that need an intimate knowledge of RPM packages in order to function.
297    
298     This package should be installed if you want to develop programs that
299     will manipulate RPM packages and databases.
300    
301     %package build
302     Summary: Scripts and executable programs used to build packages
303     Group: System/Configuration/Packaging
304     Requires: autoconf
305     Requires: automake
306     Requires: file
307     Requires: gcc-c++
308     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
309 tmb 345 Requires: libtool-base >= 1.4.3-5
310     Requires: patch >= 2.5.9-7
311 tmb 343 Requires: make
312     Requires: tar
313     Requires: unzip
314     Requires: elfutils
315     Requires: rpm = %epoch:%{version}-%{release}
316 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
317 tmb 343
318     %description build
319     This package contains scripts and executable programs that are used to
320     build packages using RPM.
321    
322     %if %buildpython
323     %package -n python-rpm
324     Summary: Python bindings for apps which will manipulate RPM packages
325     Group: Development/Python
326     Requires: python >= %{pyver}
327     Requires: rpm = %epoch:%{version}-%{release}
328 tmb 345 Obsoletes: rpm-python < %epoch:%version-%release
329     Provides: rpm-python = %version-%release
330 tmb 343
331     %description -n python-rpm
332     The rpm-python package contains a module which permits applications
333     written in the Python programming language to use the interface
334     supplied by RPM (RPM Package Manager) libraries.
335    
336     This package should be installed if you want to develop Python
337     programs that will manipulate RPM packages and databases.
338     %endif
339    
340     %prep
341     %setup -q -n %name-%srcver
342     %apply_patches
343    
344     %build
345    
346     autoreconf
347    
348     %if %builddebug
349     RPM_OPT_FLAGS=-g
350     %endif
351     CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
352     %configure \
353     --enable-nls \
354     --enable-python \
355     --enable-sqlite3 \
356     --without-javaglue \
357     %if %builddebug
358     --enable-debug \
359     %endif
360     --with-external-db \
361     %if %buildpython
362     --with-python=%{pyver} \
363     %else
364     --without-python \
365     %endif
366     --with-glob \
367     --without-selinux \
368     --without-apidocs
369    
370     %make
371    
372     %install
373     rm -rf $RPM_BUILD_ROOT
374    
375     make DESTDIR=%buildroot install
376    
377     %ifarch ppc powerpc
378 blino 25213 ln -sf ppc-%{_real_vendor}-linux $RPM_BUILD_ROOT%{rpmdir}/powerpc-%{_real_vendor}-linux
379 tmb 343 %endif
380    
381     #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
382    
383     # Save list of packages through cron
384     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
385     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
386    
387     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
388     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
389    
390     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
391     for dbi in \
392     Basenames Conflictname Dirnames Group Installtid Name Providename \
393     Provideversion Removetid Requirename Requireversion Triggername \
394     Packages __db.001 __db.002 __db.003 __db.004
395     do
396     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
397     done
398    
399     test -d doc-copy || mkdir doc-copy
400     rm -rf doc-copy/*
401     ln -f doc/manual/* doc-copy/
402     rm -f doc-copy/Makefile*
403    
404     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
405    
406     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
407     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
408     # Put your own system macros here
409     # usually contains
410    
411     # Set this one according your locales
412     # %%_install_langs
413    
414     EOF
415    
416     # Get rid of unpackaged files
417     (cd $RPM_BUILD_ROOT;
418     rm -rf .%{_includedir}/beecrypt/
419     rm -f .%{_libdir}/libbeecrypt.{a,la,so*}
420     rm -f .%{_libdir}/python*/site-packages/rpmmodule.{a,la}
421     rm -f .%{rpmdir}/{Specfile.pm,cpanflute2,cpanflute,sql.prov,sql.req,tcl.req}
422     rm -f .%{rpmdir}/{config.site,cross-build,rpmdiff.cgi}
423     rm -f .%{rpmdir}/trpm
424     rm -f .%{_bindir}/rpmdiff
425     )
426    
427     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
428    
429     %clean
430     rm -rf $RPM_BUILD_ROOT
431    
432     %pre
433     if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
434     echo "
435     You have both
436     /var/lib/rpm/packages.rpm db1 format installed package headers
437     /var/lib/rpm/Packages db3 format installed package headers
438     Please remove (or at least rename) one of those files, and re-install.
439     "
440     exit 1
441     fi
442    
443     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
444    
445     rm -rf /usr/lib/rpm/*-mandrake-*
446 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
447 tmb 343
448 tmb 345
449 tmb 343 %post
450     # nuke __db.00? when updating to this rpm
451     rm -f /var/lib/rpm/__db.00?
452    
453     if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{rpmdir}/convertrpmrc.sh ]
454     then
455     sh %{rpmdir}/convertrpmrc.sh 2>&1 > /dev/null
456     fi
457    
458     if [ -f /var/lib/rpm/packages.rpm ]; then
459     /bin/chown rpm.rpm /var/lib/rpm/*.rpm
460     elif [ ! -f /var/lib/rpm/Packages ]; then
461     /bin/rpm --initdb
462     fi
463    
464     %postun
465     /usr/share/rpm-helper/del-user rpm $1 rpm
466    
467     %triggerpostun -- rpm < 1:4.4.2.3-11
468     if [ -f /etc/rpm/macros.cdb.rpmsave ]; then
469     echo "warning: restoring /etc/rpm/macros.cdb from macros.cdb.rpmsave, please check you really need the changes"
470     mv /etc/rpm/macros.cdb.rpmsave /etc/rpm/macros.cdb
471     fi
472    
473     %define rpmattr %attr(0755, rpm, rpm)
474    
475     %files -f %{name}.lang
476     %defattr(-,root,root)
477     %doc GROUPS CHANGES doc/manual/[a-z]*
478     %attr(0755,rpm,rpm) /bin/rpm
479     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
480     %attr(0755, rpm, rpm) %{_bindir}/gendiff
481     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
482     %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
483     %attr(0755, rpm, rpm) %{_bindir}/rpmsign
484     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
485     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
486    
487     %dir %{_localstatedir}/spool/repackage
488     %dir %{rpmdir}
489     %dir /etc/rpm
490     %config(noreplace) /etc/rpm/macros
491     %dir /etc/rpm/macros.d
492     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
493     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
494     #%attr(0755, rpm, rpm) %{rpmdir}/convertrpmrc.sh
495     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
496     %attr(0644, rpm, rpm) %{rpmdir}/macros
497     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
498     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
499     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
500     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
501    
502     %rpmattr %{rpmdir}/rpm2cpio.sh
503     %rpmattr %{rpmdir}/tgpg
504    
505     %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
506     %ifarch %{ix86} x86_64
507     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
508     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
509     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
510     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
511     %endif
512     %ifarch alpha
513     %attr( -, rpm, rpm) %{rpmdir}/platform/alpha*
514     %endif
515     %ifarch %{sunsparc}
516     %attr( -, rpm, rpm) %{rpmdir}/platform/sparc*
517     %endif
518     %ifarch ppc powerpc
519     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
520     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
521     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
522     %attr( -, rpm, rpm) %{rpmdir}/platform/powerpc-*
523     %endif
524     %ifarch ppc powerpc ppc64
525     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc*series-*
526     %endif
527     %ifarch ppc64
528     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
529     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
530     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
531     %endif
532     %ifarch ia64
533     %attr( -, rpm, rpm) %{rpmdir}/platform/ia64-*
534     %endif
535     %ifarch x86_64
536     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
537     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
538     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
539     %endif
540     %ifarch %arm
541     %attr( -, rpm, rpm) %{rpmdir}/platform/armv*
542     %endif
543     %ifarch %mips
544     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
545     %endif
546     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
547    
548     %{_mandir}/man[18]/*.[18]*
549     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
550     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
551     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
552     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
553     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
554     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
555    
556     %config(noreplace,missingok) /etc/cron.daily/rpm
557     %config(noreplace,missingok) /etc/logrotate.d/rpm
558    
559     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
560    
561     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
562    
563     %rpmdbattr /var/lib/rpm/Basenames
564     %rpmdbattr /var/lib/rpm/Conflictname
565     %rpmdbattr /var/lib/rpm/__db.0*
566     %rpmdbattr /var/lib/rpm/Dirnames
567     %rpmdbattr /var/lib/rpm/Group
568     %rpmdbattr /var/lib/rpm/Installtid
569     %rpmdbattr /var/lib/rpm/Name
570     %rpmdbattr /var/lib/rpm/Packages
571     %rpmdbattr /var/lib/rpm/Providename
572     %rpmdbattr /var/lib/rpm/Provideversion
573     %rpmdbattr /var/lib/rpm/Removetid
574     %rpmdbattr /var/lib/rpm/Requirename
575     %rpmdbattr /var/lib/rpm/Requireversion
576     %rpmdbattr /var/lib/rpm/Triggername
577    
578     %files build
579     %defattr(-,root,root)
580     %doc CHANGES
581     %doc doc-copy/*
582     %rpmattr %{_bindir}/rpmbuild
583     %rpmattr %{_prefix}/lib/rpm/brp-*
584     %rpmattr %{_prefix}/lib/rpm/check-files
585     %rpmattr %{_prefix}/lib/rpm/debugedit
586 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
587 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
588     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
589     %rpmattr %{_prefix}/lib/rpm/find-provides
590     %rpmattr %{_prefix}/lib/rpm/find-requires
591 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
592 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
593     %rpmattr %{_prefix}/lib/rpm/perl.prov
594     %rpmattr %{_prefix}/lib/rpm/perl.req
595    
596     %rpmattr %{_prefix}/lib/rpm/check-buildroot
597     %rpmattr %{_prefix}/lib/rpm/check-prereqs
598     %rpmattr %{_prefix}/lib/rpm/check-rpaths
599     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
600     %rpmattr %{_prefix}/lib/rpm/javadeps
601     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
602     %rpmattr %{_prefix}/lib/rpm/macros.perl
603     %rpmattr %{_prefix}/lib/rpm/macros.php
604     %rpmattr %{_prefix}/lib/rpm/macros.python
605     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
606     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
607 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
608     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
609 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
610     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
611     %rpmattr %{_prefix}/lib/rpm/rpmdiff
612    
613     %rpmattr %{_prefix}/lib/rpm/rpmdeps
614     #%rpmattr %{_prefix}/lib/rpm/trpm
615     %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
616    
617     %{_mandir}/man8/rpmbuild.8*
618     %{_mandir}/man8/rpmdeps.8*
619    
620     %if %buildpython
621     %files -n python-rpm
622     %defattr(-,root,root)
623     %{_libdir}/python*/site-packages/rpm
624     %endif
625    
626     %files -n %librpmname
627     %defattr(-,root,root)
628 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
629     %{_libdir}/librpmio.so.%{libmajor}*
630     %{_libdir}/librpmbuild.so.%{libmajor}*
631 tmb 343
632     %files -n %librpmnamedevel
633     %defattr(-,root,root)
634     %{_includedir}/rpm
635     %{_libdir}/librpm.la
636     %{_libdir}/librpm.so
637     %{_libdir}/librpmio.la
638     %{_libdir}/librpmio.so
639     %{_libdir}/librpmbuild.la
640     %{_libdir}/librpmbuild.so
641     %{_libdir}/pkgconfig/rpm.pc

  ViewVC Help
Powered by ViewVC 1.1.30