/[packages]/updates/1/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/1/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 59113 - (hide annotations) (download)
Thu Feb 24 22:48:46 2011 UTC (13 years, 1 month ago) by dmorgan
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21059 byte(s)
Add comment about patch17 that is a candidate for a drop
1 tmb 343 # Do not change this spec directly but in the svn
2     # $Id: rpm.spec 134789 2007-03-27 15:13:43Z nanardon $
3    
4     %define lib64arches x86_64 ppc64 sparc64
5    
6     %ifarch %lib64arches
7     %define _lib lib64
8     %else
9     %define _lib lib
10     %endif
11    
12     %define _prefix /usr
13     %define _libdir %_prefix/%_lib
14     %define _bindir %_prefix/bin
15     %define _sysconfdir /etc
16     %define _datadir /usr/share
17     %define _defaultdocdir %_datadir/doc
18     %define _localstatedir /var
19     %define _infodir %_datadir/info
20    
21     %if %{?apply_patches:0}%{?!apply_patches:1}
22     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
23     %endif
24    
25     # Define directory which holds rpm config files, and some binaries actually
26     # NOTE: it remains */lib even on lib64 platforms as only one version
27     # of rpm is supported anyway, per architecture
28     %define rpmdir %{_prefix}/lib/rpm
29    
30     %if %{?mklibname:0}%{?!mklibname:1}
31     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
32     %endif
33    
34     %if %{?distsuffix:0}%{?!distsuffix:1}
35 tmb 345 %define distsuffix .mga
36 tmb 343 %endif
37    
38     %if %{?mkrel:0}%{?!mkrel:1}
39 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
40 tmb 343 %endif
41    
42     %if %{?mips:0}%{?!mips:1}
43     %define mips mips mipsel mips32 mips32el mips64 mips64el
44     %endif
45    
46     %if %{?pyver:0}%{?!pyver:1}
47     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
48     %endif
49    
50 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
51     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
52 tmb 343
53 dmorgan 46866 %define rpmversion 4.8.1
54 tmb 343 %define srcver %rpmversion
55 dmorgan 46862 %define libver 4.8
56     %define libmajor 1
57     %define release %mkrel 1
58     %define librpmname %mklibname rpm %{libmajor}
59 tmb 345 %define librpmnamedevel %mklibname -d rpm
60 tmb 343
61     %define buildpython 1
62    
63     %define rpmsetup_version 1.34
64    
65     %define builddebug 0
66     %{?_with_debug:%define builddebug 1}
67    
68     %{?_with_python:%define buildpython 1}
69     %{?_without_python:%define buildpython 0}
70    
71     Summary: The RPM package management system
72     Name: rpm
73     Epoch: 1
74     Version: %{rpmversion}
75 dmorgan 49378 Release: %{release}
76 tmb 343 Group: System/Configuration/Packaging
77    
78     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
79    
80     # Add some undocumented feature to gendiff
81 dmorgan 59113 ## To be dropped.
82 tmb 343 Patch17: rpm-4.4.2.2-gendiff-improved.patch
83    
84     # if %post of foo-2 fails,
85     # or if %preun of foo-1 fails,
86     # or if %postun of foo-1 fails,
87     # => foo-1 is not removed, so we end up with both packages in rpmdb
88     # this patch makes rpm ignore the error in those cases
89     # failing %pre must still make the rpm install fail (#23677)
90     #
91     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
92     # scripts is ignored with or without this patch)
93     Patch22: rpm-4.6.0-rc1-non-pre-scripts-dont-fail.patch
94    
95     # (fredl) add loging facilities through syslog
96     Patch31: rpm-4.6.0-rc1-syslog.patch
97    
98     # part of Backport from 4.2.1 provides becoming obsoletes bug (fpons)
99     # (is it still needed?)
100     Patch49: rpm-4.6.0-rc1-provides-obsoleted.patch
101    
102 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
103     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
104     Patch64: rpm-4.6.1-mageia-rpmrc-rpmpopt.patch
105 blino 25212
106 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
107     # From popular request, we allow to do this
108 tv 54082 # http://qa.mandriva.com/show_bug.cgi?id=15896Z
109     # (A different implementation has landed in rpm-4.9)
110 tmb 343 Patch70: rpm-4.6.0-rc1-bb-shortcircuit.patch
111    
112     # http://www.redhat.com/archives/rpm-list/2005-April/msg00131.html
113     # http://www.redhat.com/archives/rpm-list/2005-April/msg00132.html
114     # is this useful? "at least erasure ordering is just as non-existent as it was in 4.4.x" says Panu
115 dmorgan 46863 #with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
116     #Patch71: rpm-4.6.0-ordererase.patch#with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
117 tmb 343
118     # don't conflict for doc files
119     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
120     Patch83: rpm-4.6.0-no-doc-conflicts.patch
121    
122     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
123     # (is this working??)
124     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
125    
126     # Fix diff issue when buildroot contains some "//"
127     Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
128    
129     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
130     Patch114: rpm-4.6.0-rc1-read-macros_d-dot-macros.patch
131    
132     # remove unused skipDir functionality that conflicts with patch124 below
133 dmorgan 46862 #Patch1124: rpm-4.6.0-rc1-revert-unused-skipDir-functionality.patch
134 tmb 343
135     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
136     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
137     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
138     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
139     # but this is bad design anyway
140 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
141 tmb 343
142     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
143     Patch133: rpm-4.6.0-rc1-weakdeps.patch
144    
145 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
146     Patch135: rpm-4.4.2.3-rc1-fix-debugedit.patch
147    
148 tmb 343 # convert data in the header to a specific encoding which used in the selected locale.
149     Patch137: rpm-4.6.0-rc1-headerIconv.patch
150    
151     # Mandriva does not need the (broken) ldconfig hack since it uses filetriggers
152 dmorgan 46862 #Patch141: rpm-4.6.0-rc1-drop-skipping-ldconfig-hack.patch
153 tmb 343
154     # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
155     # with this patch, "#%define foo bar" is a fatal error
156     Patch145: rpm-forbid-badly-commented-define-in-spec.patch
157    
158     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
159     Patch146: rpm-4.6.0-rc1-filetriggers.patch
160    
161     # add two fatal errors (during package build)
162     Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
163    
164     # (nb: see the patch for more info about this issue)
165     Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
166    
167     Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
168    
169     Patch157: introduce-_after_setup-which-is-called-after-setup.patch
170     Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
171     Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
172    
173     #Patch1001: rpm-4.6.0-rc1-new-liblzma.patch
174    
175     # default behaviour in rpm-jbj >= 4.4.6
176     Patch1005: rpm-allow-conflicting-ghost-files.patch
177    
178     Patch1007: rpm-4.6.0-rc3-xz-support.patch
179    
180     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
181     # as this breaks stuff that installs files to $DOCDIR during %%install
182     Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
183    
184     # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
185     # break when these unknown tags might be found in the rpmdb. Notice that this
186     # will only make rpm recognize these, not implement actual support for them..
187     Patch1009: rpm-4.6.0-rpm5-tags.patch
188    
189     # Turbolinux patches
190     # add writeHeaderListTofile function into rpm-python (needed by "buildman" build system) (Toshihiro, 2003)
191 dmorgan 46862 #Patch2002: rpm-4.6.0-rc1-python-writeHdlist.patch
192 tmb 343 # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
193     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
194    
195     # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
196     #
197     # This patch fixes the problem when the post-scripts launched by rpm-build.
198     # The post-scripts launched by rpm-build works in LANG environment. If LANG is
199     # other locale except C, then some commands launched by post-scripts will not
200     # display characters which you expected.
201     Patch2005: rpm-4.6.0-rc1-buildlang.patch
202    
203 dmorgan 49378 Patch2000: rpm-4.6.0-rc1-serial-tag.patch
204     # re-enable "copyright" tag (Kiichiro, 2005)
205     Patch2001: rpm-4.6.0-rc1-copyright-tag.patch
206    
207 tmb 343 Patch3000: mips_macros.patch
208     Patch3001: fix_stack_protector_check.patch
209 dmorgan 49378 Patch3002: mips_define_isa_macros.patch
210     Patch3003: rpm_arm_mips_isa_macros.patch
211 tmb 343 Patch3004: rpm_add_armv5tl.patch
212    
213     License: GPL
214     BuildRequires: autoconf >= 2.57
215     BuildRequires: zlib-devel
216     BuildRequires: bzip2-devel
217     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
218     BuildRequires: automake >= 1.8
219     BuildRequires: elfutils-devel
220     BuildRequires: sed >= 4.0.3
221     BuildRequires: libbeecrypt-devel
222     BuildRequires: ed, gettext-devel
223     BuildRequires: libsqlite3-devel
224     BuildRequires: db4.8-devel
225     BuildRequires: neon-devel
226     BuildRequires: popt-devel
227     BuildRequires: nss-devel
228     BuildRequires: magic-devel
229 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
230 tmb 343 BuildRequires: readline-devel
231     BuildRequires: ncurses-devel
232     BuildRequires: openssl-devel >= 0.9.8
233     BuildRequires: lua-devel
234     # Need for doc
235     #BuildRequires: graphviz
236     BuildRequires: tetex
237     %if %buildpython
238     BuildRequires: python-devel
239     %endif
240    
241     Requires: bzip2 >= 0.9.0c-2
242     Requires: lzma
243     Requires: cpio
244     Requires: gawk
245     Requires: glibc >= 2.1.92
246     Requires: mktemp
247 tmb 345 Requires: setup >= 2.2.0-8
248 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
249 tmb 343 Requires: update-alternatives
250     Requires: %librpmname = %epoch:%version-%release
251     Conflicts: patch < 2.5
252 tmb 345 Conflicts: menu < 2.1.5-29
253 tmb 343 Conflicts: locales < 2.3.1.1
254 tmb 345 Conflicts: man-pages-fr < 0.9.7-16
255     Conflicts: man-pages-pl < 0.4-9
256     Conflicts: perl-URPM < 1.63-3
257 tmb 343 # rpm 4.6.0 dropped support for --repackage, so urpmi-recover can not work anymore:
258     Conflicts: urpmi-recover
259     URL: http://rpm.org/
260     %define git_url http://rpm.org/git/rpm.git
261     Requires(pre): rpm-helper >= 0.8
262     Requires(pre): coreutils
263     Requires(postun): rpm-helper >= 0.8
264     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
265    
266     %description
267     RPM is a powerful command line driven package management system capable of
268     installing, uninstalling, verifying, querying, and updating software packages.
269     Each software package consists of an archive of files along with information
270     about the package like its version, a description, etc.
271    
272     %package -n %librpmname
273 tmb 345 Summary: Library used by rpm
274     Group: System/Libraries
275     Provides: librpm = %version-%release
276 tmb 343
277     %description -n %librpmname
278     RPM is a powerful command line driven package management system capable of
279     installing, uninstalling, verifying, querying, and updating software packages.
280     This package contains common files to all applications based on rpm.
281    
282     %package -n %librpmnamedevel
283     Summary: Development files for applications which will manipulate RPM packages
284     Group: Development/C
285     Requires: rpm = %epoch:%{version}-%{release}
286     Provides: librpm-devel = %version-%release
287     Provides: rpm-devel = %version-%release
288     Obsoletes: rpm-devel < 4.4.1
289     Obsoletes: %{_lib}rpm4.4-devel
290     Obsoletes: %{_lib}rpm4.2-devel
291    
292     %description -n %librpmnamedevel
293     This package contains the RPM C library and header files. These
294     development files will simplify the process of writing programs
295     which manipulate RPM packages and databases and are intended to make
296     it easier to create graphical package managers or any other tools
297     that need an intimate knowledge of RPM packages in order to function.
298    
299     This package should be installed if you want to develop programs that
300     will manipulate RPM packages and databases.
301    
302     %package build
303     Summary: Scripts and executable programs used to build packages
304     Group: System/Configuration/Packaging
305     Requires: autoconf
306     Requires: automake
307     Requires: file
308     Requires: gcc-c++
309     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
310 tmb 345 Requires: libtool-base >= 1.4.3-5
311     Requires: patch >= 2.5.9-7
312 tmb 343 Requires: make
313     Requires: tar
314     Requires: unzip
315     Requires: elfutils
316     Requires: rpm = %epoch:%{version}-%{release}
317 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
318 tmb 343
319     %description build
320     This package contains scripts and executable programs that are used to
321     build packages using RPM.
322    
323     %if %buildpython
324     %package -n python-rpm
325     Summary: Python bindings for apps which will manipulate RPM packages
326     Group: Development/Python
327     Requires: python >= %{pyver}
328     Requires: rpm = %epoch:%{version}-%{release}
329 tmb 345 Obsoletes: rpm-python < %epoch:%version-%release
330     Provides: rpm-python = %version-%release
331 tmb 343
332     %description -n python-rpm
333     The rpm-python package contains a module which permits applications
334     written in the Python programming language to use the interface
335     supplied by RPM (RPM Package Manager) libraries.
336    
337     This package should be installed if you want to develop Python
338     programs that will manipulate RPM packages and databases.
339     %endif
340    
341     %prep
342     %setup -q -n %name-%srcver
343     %apply_patches
344    
345     %build
346    
347     autoreconf
348    
349     %if %builddebug
350     RPM_OPT_FLAGS=-g
351     %endif
352     CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
353     %configure \
354     --enable-nls \
355     --enable-python \
356     --enable-sqlite3 \
357     --without-javaglue \
358     %if %builddebug
359     --enable-debug \
360     %endif
361     --with-external-db \
362     %if %buildpython
363     --with-python=%{pyver} \
364     %else
365     --without-python \
366     %endif
367     --with-glob \
368     --without-selinux \
369     --without-apidocs
370    
371     %make
372    
373     %install
374     rm -rf $RPM_BUILD_ROOT
375    
376     make DESTDIR=%buildroot install
377    
378     %ifarch ppc powerpc
379 blino 25213 ln -sf ppc-%{_real_vendor}-linux $RPM_BUILD_ROOT%{rpmdir}/powerpc-%{_real_vendor}-linux
380 tmb 343 %endif
381    
382     #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
383    
384     # Save list of packages through cron
385     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
386     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
387    
388     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
389     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
390    
391     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
392     for dbi in \
393     Basenames Conflictname Dirnames Group Installtid Name Providename \
394     Provideversion Removetid Requirename Requireversion Triggername \
395     Packages __db.001 __db.002 __db.003 __db.004
396     do
397     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
398     done
399    
400     test -d doc-copy || mkdir doc-copy
401     rm -rf doc-copy/*
402     ln -f doc/manual/* doc-copy/
403     rm -f doc-copy/Makefile*
404    
405     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
406    
407     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
408     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
409     # Put your own system macros here
410     # usually contains
411    
412     # Set this one according your locales
413     # %%_install_langs
414    
415     EOF
416    
417     # Get rid of unpackaged files
418     (cd $RPM_BUILD_ROOT;
419     rm -rf .%{_includedir}/beecrypt/
420     rm -f .%{_libdir}/libbeecrypt.{a,la,so*}
421     rm -f .%{_libdir}/python*/site-packages/rpmmodule.{a,la}
422     rm -f .%{rpmdir}/{Specfile.pm,cpanflute2,cpanflute,sql.prov,sql.req,tcl.req}
423     rm -f .%{rpmdir}/{config.site,cross-build,rpmdiff.cgi}
424     rm -f .%{rpmdir}/trpm
425     rm -f .%{_bindir}/rpmdiff
426     )
427    
428     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
429    
430     %clean
431     rm -rf $RPM_BUILD_ROOT
432    
433     %pre
434     if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
435     echo "
436     You have both
437     /var/lib/rpm/packages.rpm db1 format installed package headers
438     /var/lib/rpm/Packages db3 format installed package headers
439     Please remove (or at least rename) one of those files, and re-install.
440     "
441     exit 1
442     fi
443    
444     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
445    
446     rm -rf /usr/lib/rpm/*-mandrake-*
447 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
448 tmb 343
449 tmb 345
450 tmb 343 %post
451     # nuke __db.00? when updating to this rpm
452     rm -f /var/lib/rpm/__db.00?
453    
454     if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{rpmdir}/convertrpmrc.sh ]
455     then
456     sh %{rpmdir}/convertrpmrc.sh 2>&1 > /dev/null
457     fi
458    
459     if [ -f /var/lib/rpm/packages.rpm ]; then
460     /bin/chown rpm.rpm /var/lib/rpm/*.rpm
461     elif [ ! -f /var/lib/rpm/Packages ]; then
462     /bin/rpm --initdb
463     fi
464    
465     %postun
466     /usr/share/rpm-helper/del-user rpm $1 rpm
467    
468     %triggerpostun -- rpm < 1:4.4.2.3-11
469     if [ -f /etc/rpm/macros.cdb.rpmsave ]; then
470     echo "warning: restoring /etc/rpm/macros.cdb from macros.cdb.rpmsave, please check you really need the changes"
471     mv /etc/rpm/macros.cdb.rpmsave /etc/rpm/macros.cdb
472     fi
473    
474     %define rpmattr %attr(0755, rpm, rpm)
475    
476     %files -f %{name}.lang
477     %defattr(-,root,root)
478     %doc GROUPS CHANGES doc/manual/[a-z]*
479     %attr(0755,rpm,rpm) /bin/rpm
480     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
481     %attr(0755, rpm, rpm) %{_bindir}/gendiff
482     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
483     %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
484     %attr(0755, rpm, rpm) %{_bindir}/rpmsign
485     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
486     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
487    
488     %dir %{_localstatedir}/spool/repackage
489     %dir %{rpmdir}
490     %dir /etc/rpm
491     %config(noreplace) /etc/rpm/macros
492     %dir /etc/rpm/macros.d
493     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
494     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
495     #%attr(0755, rpm, rpm) %{rpmdir}/convertrpmrc.sh
496     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
497     %attr(0644, rpm, rpm) %{rpmdir}/macros
498     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
499     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
500     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
501     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
502    
503     %rpmattr %{rpmdir}/rpm2cpio.sh
504     %rpmattr %{rpmdir}/tgpg
505    
506     %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
507     %ifarch %{ix86} x86_64
508     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
509     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
510     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
511     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
512     %endif
513     %ifarch alpha
514     %attr( -, rpm, rpm) %{rpmdir}/platform/alpha*
515     %endif
516     %ifarch %{sunsparc}
517     %attr( -, rpm, rpm) %{rpmdir}/platform/sparc*
518     %endif
519     %ifarch ppc powerpc
520     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
521     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
522     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
523     %attr( -, rpm, rpm) %{rpmdir}/platform/powerpc-*
524     %endif
525     %ifarch ppc powerpc ppc64
526     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc*series-*
527     %endif
528     %ifarch ppc64
529     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
530     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
531     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
532     %endif
533     %ifarch ia64
534     %attr( -, rpm, rpm) %{rpmdir}/platform/ia64-*
535     %endif
536     %ifarch x86_64
537     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
538     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
539     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
540     %endif
541     %ifarch %arm
542     %attr( -, rpm, rpm) %{rpmdir}/platform/armv*
543     %endif
544     %ifarch %mips
545     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
546     %endif
547     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
548    
549     %{_mandir}/man[18]/*.[18]*
550     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
551     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
552     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
553     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
554     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
555     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
556    
557     %config(noreplace,missingok) /etc/cron.daily/rpm
558     %config(noreplace,missingok) /etc/logrotate.d/rpm
559    
560     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
561    
562     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
563    
564     %rpmdbattr /var/lib/rpm/Basenames
565     %rpmdbattr /var/lib/rpm/Conflictname
566     %rpmdbattr /var/lib/rpm/__db.0*
567     %rpmdbattr /var/lib/rpm/Dirnames
568     %rpmdbattr /var/lib/rpm/Group
569     %rpmdbattr /var/lib/rpm/Installtid
570     %rpmdbattr /var/lib/rpm/Name
571     %rpmdbattr /var/lib/rpm/Packages
572     %rpmdbattr /var/lib/rpm/Providename
573     %rpmdbattr /var/lib/rpm/Provideversion
574     %rpmdbattr /var/lib/rpm/Removetid
575     %rpmdbattr /var/lib/rpm/Requirename
576     %rpmdbattr /var/lib/rpm/Requireversion
577     %rpmdbattr /var/lib/rpm/Triggername
578    
579     %files build
580     %defattr(-,root,root)
581     %doc CHANGES
582     %doc doc-copy/*
583     %rpmattr %{_bindir}/rpmbuild
584     %rpmattr %{_prefix}/lib/rpm/brp-*
585     %rpmattr %{_prefix}/lib/rpm/check-files
586     %rpmattr %{_prefix}/lib/rpm/debugedit
587 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
588 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
589     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
590     %rpmattr %{_prefix}/lib/rpm/find-provides
591     %rpmattr %{_prefix}/lib/rpm/find-requires
592 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
593 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
594     %rpmattr %{_prefix}/lib/rpm/perl.prov
595     %rpmattr %{_prefix}/lib/rpm/perl.req
596    
597     %rpmattr %{_prefix}/lib/rpm/check-buildroot
598     %rpmattr %{_prefix}/lib/rpm/check-prereqs
599     %rpmattr %{_prefix}/lib/rpm/check-rpaths
600     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
601     %rpmattr %{_prefix}/lib/rpm/javadeps
602     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
603     %rpmattr %{_prefix}/lib/rpm/macros.perl
604     %rpmattr %{_prefix}/lib/rpm/macros.php
605     %rpmattr %{_prefix}/lib/rpm/macros.python
606     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
607     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
608 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
609     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
610 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
611     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
612     %rpmattr %{_prefix}/lib/rpm/rpmdiff
613    
614     %rpmattr %{_prefix}/lib/rpm/rpmdeps
615     #%rpmattr %{_prefix}/lib/rpm/trpm
616     %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
617    
618     %{_mandir}/man8/rpmbuild.8*
619     %{_mandir}/man8/rpmdeps.8*
620    
621     %if %buildpython
622     %files -n python-rpm
623     %defattr(-,root,root)
624     %{_libdir}/python*/site-packages/rpm
625     %endif
626    
627     %files -n %librpmname
628     %defattr(-,root,root)
629 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
630     %{_libdir}/librpmio.so.%{libmajor}*
631     %{_libdir}/librpmbuild.so.%{libmajor}*
632 tmb 343
633     %files -n %librpmnamedevel
634     %defattr(-,root,root)
635     %{_includedir}/rpm
636     %{_libdir}/librpm.la
637     %{_libdir}/librpm.so
638     %{_libdir}/librpmio.la
639     %{_libdir}/librpmio.so
640     %{_libdir}/librpmbuild.la
641     %{_libdir}/librpmbuild.so
642     %{_libdir}/pkgconfig/rpm.pc

  ViewVC Help
Powered by ViewVC 1.1.30