/[packages]/updates/1/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/1/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 74203 - (hide annotations) (download)
Fri Mar 18 15:41:49 2011 UTC (13 years, 1 month ago) by dmorgan
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21297 byte(s)
Add patch from rtp to fix build on arm (P3005)
1 tmb 343 # Do not change this spec directly but in the svn
2     # $Id: rpm.spec 134789 2007-03-27 15:13:43Z nanardon $
3    
4     %define lib64arches x86_64 ppc64 sparc64
5    
6     %ifarch %lib64arches
7     %define _lib lib64
8     %else
9     %define _lib lib
10     %endif
11    
12     %define _prefix /usr
13     %define _libdir %_prefix/%_lib
14     %define _bindir %_prefix/bin
15     %define _sysconfdir /etc
16     %define _datadir /usr/share
17     %define _defaultdocdir %_datadir/doc
18     %define _localstatedir /var
19     %define _infodir %_datadir/info
20    
21     %if %{?apply_patches:0}%{?!apply_patches:1}
22     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
23     %endif
24    
25     # Define directory which holds rpm config files, and some binaries actually
26     # NOTE: it remains */lib even on lib64 platforms as only one version
27     # of rpm is supported anyway, per architecture
28     %define rpmdir %{_prefix}/lib/rpm
29    
30     %if %{?mklibname:0}%{?!mklibname:1}
31     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
32     %endif
33    
34     %if %{?distsuffix:0}%{?!distsuffix:1}
35 tmb 345 %define distsuffix .mga
36 tmb 343 %endif
37    
38     %if %{?mkrel:0}%{?!mkrel:1}
39 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
40 tmb 343 %endif
41    
42     %if %{?mips:0}%{?!mips:1}
43     %define mips mips mipsel mips32 mips32el mips64 mips64el
44     %endif
45    
46     %if %{?pyver:0}%{?!pyver:1}
47     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
48     %endif
49    
50 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
51     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
52 tmb 343
53 dmorgan 46866 %define rpmversion 4.8.1
54 tmb 343 %define srcver %rpmversion
55 dmorgan 46862 %define libver 4.8
56     %define libmajor 1
57 dmorgan 74203 %define release %mkrel 8
58 dmorgan 46862 %define librpmname %mklibname rpm %{libmajor}
59 tmb 345 %define librpmnamedevel %mklibname -d rpm
60 tmb 343
61     %define buildpython 1
62    
63     %define rpmsetup_version 1.34
64    
65     %define builddebug 0
66     %{?_with_debug:%define builddebug 1}
67    
68     %{?_with_python:%define buildpython 1}
69     %{?_without_python:%define buildpython 0}
70    
71     Summary: The RPM package management system
72     Name: rpm
73     Epoch: 1
74     Version: %{rpmversion}
75 dmorgan 49378 Release: %{release}
76 tmb 343 Group: System/Configuration/Packaging
77    
78     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
79    
80     # if %post of foo-2 fails,
81     # or if %preun of foo-1 fails,
82     # or if %postun of foo-1 fails,
83     # => foo-1 is not removed, so we end up with both packages in rpmdb
84     # this patch makes rpm ignore the error in those cases
85     # failing %pre must still make the rpm install fail (#23677)
86     #
87     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
88     # scripts is ignored with or without this patch)
89     Patch22: rpm-4.6.0-rc1-non-pre-scripts-dont-fail.patch
90    
91     # (fredl) add loging facilities through syslog
92 dmorgan 62708 # Patch sent to upstream for inclusion
93     # http://lists.rpm.org/pipermail/rpm-maint/2011-March/002994.htm
94 dmorgan 62618 Patch31: rpm-4.8.1-syslog.patch
95 tmb 343
96     # part of Backport from 4.2.1 provides becoming obsoletes bug (fpons)
97     # (is it still needed?)
98     Patch49: rpm-4.6.0-rc1-provides-obsoleted.patch
99    
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 62722 # Patch mageia Specific => Not merge candidate
103 tmb 47730 Patch64: rpm-4.6.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 tv 54082 # http://qa.mandriva.com/show_bug.cgi?id=15896Z
108     # (A different implementation has landed in rpm-4.9)
109 tmb 343 Patch70: rpm-4.6.0-rc1-bb-shortcircuit.patch
110    
111     # http://www.redhat.com/archives/rpm-list/2005-April/msg00131.html
112     # http://www.redhat.com/archives/rpm-list/2005-April/msg00132.html
113     # is this useful? "at least erasure ordering is just as non-existent as it was in 4.4.x" says Panu
114 dmorgan 46863 #with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
115     #Patch71: rpm-4.6.0-ordererase.patch#with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
116 tmb 343
117     # don't conflict for doc files
118     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
119     Patch83: rpm-4.6.0-no-doc-conflicts.patch
120    
121     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
122     # (is this working??)
123     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
124    
125     # Fix diff issue when buildroot contains some "//"
126     Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
127    
128     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
129     Patch114: rpm-4.6.0-rc1-read-macros_d-dot-macros.patch
130    
131     # remove unused skipDir functionality that conflicts with patch124 below
132 dmorgan 46862 #Patch1124: rpm-4.6.0-rc1-revert-unused-skipDir-functionality.patch
133 tmb 343
134     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
135     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
136     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
137     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
138     # but this is bad design anyway
139 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
140 tmb 343
141     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
142     Patch133: rpm-4.6.0-rc1-weakdeps.patch
143    
144 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
145     Patch135: rpm-4.4.2.3-rc1-fix-debugedit.patch
146    
147 tmb 343 # convert data in the header to a specific encoding which used in the selected locale.
148     Patch137: rpm-4.6.0-rc1-headerIconv.patch
149    
150     # Mandriva does not need the (broken) ldconfig hack since it uses filetriggers
151 dmorgan 46862 #Patch141: rpm-4.6.0-rc1-drop-skipping-ldconfig-hack.patch
152 tmb 343
153     # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
154     # with this patch, "#%define foo bar" is a fatal error
155     Patch145: rpm-forbid-badly-commented-define-in-spec.patch
156    
157     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
158     Patch146: rpm-4.6.0-rc1-filetriggers.patch
159    
160     # add two fatal errors (during package build)
161     Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162    
163     # (nb: see the patch for more info about this issue)
164     Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165    
166     Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
167    
168     Patch157: introduce-_after_setup-which-is-called-after-setup.patch
169     Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
170     Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
171    
172     #Patch1001: rpm-4.6.0-rc1-new-liblzma.patch
173    
174     # default behaviour in rpm-jbj >= 4.4.6
175     Patch1005: rpm-allow-conflicting-ghost-files.patch
176    
177     Patch1007: rpm-4.6.0-rc3-xz-support.patch
178    
179     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
180     # as this breaks stuff that installs files to $DOCDIR during %%install
181     Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
182    
183     # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
184     # break when these unknown tags might be found in the rpmdb. Notice that this
185     # will only make rpm recognize these, not implement actual support for them..
186     Patch1009: rpm-4.6.0-rpm5-tags.patch
187    
188 dmorgan 62040 # Automatically handle ruby gem extraction in %setup
189     Patch1018: rpm-4.8.1-setup-rubygems.patch
190    
191 tmb 343 # Turbolinux patches
192     # add writeHeaderListTofile function into rpm-python (needed by "buildman" build system) (Toshihiro, 2003)
193 dmorgan 46862 #Patch2002: rpm-4.6.0-rc1-python-writeHdlist.patch
194 tmb 343 # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
195     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
196    
197     # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
198     #
199     # This patch fixes the problem when the post-scripts launched by rpm-build.
200     # The post-scripts launched by rpm-build works in LANG environment. If LANG is
201     # other locale except C, then some commands launched by post-scripts will not
202     # display characters which you expected.
203     Patch2005: rpm-4.6.0-rc1-buildlang.patch
204    
205 dmorgan 49378 Patch2000: rpm-4.6.0-rc1-serial-tag.patch
206     # re-enable "copyright" tag (Kiichiro, 2005)
207     Patch2001: rpm-4.6.0-rc1-copyright-tag.patch
208    
209 tmb 343 Patch3000: mips_macros.patch
210     Patch3001: fix_stack_protector_check.patch
211 dmorgan 49378 Patch3002: mips_define_isa_macros.patch
212     Patch3003: rpm_arm_mips_isa_macros.patch
213 tmb 343 Patch3004: rpm_add_armv5tl.patch
214 dmorgan 74203 # This patch allow to fix build of rpm on other arch like ARM
215     Patch3005: rpm_fix_platformdir.patch
216 tmb 343
217     License: GPL
218     BuildRequires: autoconf >= 2.57
219     BuildRequires: zlib-devel
220     BuildRequires: bzip2-devel
221     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
222     BuildRequires: automake >= 1.8
223     BuildRequires: elfutils-devel
224     BuildRequires: sed >= 4.0.3
225     BuildRequires: libbeecrypt-devel
226     BuildRequires: ed, gettext-devel
227     BuildRequires: libsqlite3-devel
228     BuildRequires: db4.8-devel
229     BuildRequires: neon-devel
230     BuildRequires: popt-devel
231     BuildRequires: nss-devel
232     BuildRequires: magic-devel
233 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
234 tmb 343 BuildRequires: readline-devel
235     BuildRequires: ncurses-devel
236     BuildRequires: openssl-devel >= 0.9.8
237     BuildRequires: lua-devel
238     # Need for doc
239     #BuildRequires: graphviz
240 dmorgan 64206 BuildRequires: texlive
241 tmb 343 %if %buildpython
242     BuildRequires: python-devel
243     %endif
244    
245     Requires: bzip2 >= 0.9.0c-2
246     Requires: lzma
247     Requires: cpio
248     Requires: gawk
249     Requires: glibc >= 2.1.92
250     Requires: mktemp
251 tmb 345 Requires: setup >= 2.2.0-8
252 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
253 tmb 343 Requires: update-alternatives
254     Requires: %librpmname = %epoch:%version-%release
255     Conflicts: patch < 2.5
256 tmb 345 Conflicts: menu < 2.1.5-29
257 tmb 343 Conflicts: locales < 2.3.1.1
258 tmb 345 Conflicts: man-pages-fr < 0.9.7-16
259     Conflicts: man-pages-pl < 0.4-9
260     Conflicts: perl-URPM < 1.63-3
261 tmb 343 # rpm 4.6.0 dropped support for --repackage, so urpmi-recover can not work anymore:
262     Conflicts: urpmi-recover
263     URL: http://rpm.org/
264     %define git_url http://rpm.org/git/rpm.git
265     Requires(pre): rpm-helper >= 0.8
266     Requires(pre): coreutils
267     Requires(postun): rpm-helper >= 0.8
268     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
269    
270     %description
271     RPM is a powerful command line driven package management system capable of
272     installing, uninstalling, verifying, querying, and updating software packages.
273     Each software package consists of an archive of files along with information
274     about the package like its version, a description, etc.
275    
276     %package -n %librpmname
277 tmb 345 Summary: Library used by rpm
278     Group: System/Libraries
279     Provides: librpm = %version-%release
280 tmb 343
281     %description -n %librpmname
282     RPM is a powerful command line driven package management system capable of
283     installing, uninstalling, verifying, querying, and updating software packages.
284     This package contains common files to all applications based on rpm.
285    
286     %package -n %librpmnamedevel
287     Summary: Development files for applications which will manipulate RPM packages
288     Group: Development/C
289     Requires: rpm = %epoch:%{version}-%{release}
290     Provides: librpm-devel = %version-%release
291     Provides: rpm-devel = %version-%release
292     Obsoletes: rpm-devel < 4.4.1
293     Obsoletes: %{_lib}rpm4.4-devel
294     Obsoletes: %{_lib}rpm4.2-devel
295    
296     %description -n %librpmnamedevel
297     This package contains the RPM C library and header files. These
298     development files will simplify the process of writing programs
299     which manipulate RPM packages and databases and are intended to make
300     it easier to create graphical package managers or any other tools
301     that need an intimate knowledge of RPM packages in order to function.
302    
303     This package should be installed if you want to develop programs that
304     will manipulate RPM packages and databases.
305    
306     %package build
307     Summary: Scripts and executable programs used to build packages
308     Group: System/Configuration/Packaging
309     Requires: autoconf
310     Requires: automake
311     Requires: file
312     Requires: gcc-c++
313     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
314 tmb 345 Requires: libtool-base >= 1.4.3-5
315     Requires: patch >= 2.5.9-7
316 tmb 343 Requires: make
317     Requires: tar
318     Requires: unzip
319     Requires: elfutils
320     Requires: rpm = %epoch:%{version}-%{release}
321 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
322 tmb 343
323     %description build
324     This package contains scripts and executable programs that are used to
325     build packages using RPM.
326    
327     %if %buildpython
328     %package -n python-rpm
329     Summary: Python bindings for apps which will manipulate RPM packages
330     Group: Development/Python
331     Requires: python >= %{pyver}
332     Requires: rpm = %epoch:%{version}-%{release}
333 tmb 345 Obsoletes: rpm-python < %epoch:%version-%release
334     Provides: rpm-python = %version-%release
335 tmb 343
336     %description -n python-rpm
337     The rpm-python package contains a module which permits applications
338     written in the Python programming language to use the interface
339     supplied by RPM (RPM Package Manager) libraries.
340    
341     This package should be installed if you want to develop Python
342     programs that will manipulate RPM packages and databases.
343     %endif
344    
345     %prep
346     %setup -q -n %name-%srcver
347     %apply_patches
348    
349     %build
350    
351     autoreconf
352    
353     %if %builddebug
354     RPM_OPT_FLAGS=-g
355     %endif
356     CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
357     %configure \
358     --enable-nls \
359     --enable-python \
360     --enable-sqlite3 \
361     --without-javaglue \
362     %if %builddebug
363     --enable-debug \
364     %endif
365     --with-external-db \
366     %if %buildpython
367     --with-python=%{pyver} \
368     %else
369     --without-python \
370     %endif
371     --with-glob \
372     --without-selinux \
373     --without-apidocs
374    
375     %make
376    
377     %install
378     rm -rf $RPM_BUILD_ROOT
379    
380     make DESTDIR=%buildroot install
381    
382     %ifarch ppc powerpc
383 blino 25213 ln -sf ppc-%{_real_vendor}-linux $RPM_BUILD_ROOT%{rpmdir}/powerpc-%{_real_vendor}-linux
384 tmb 343 %endif
385    
386     #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
387    
388     # Save list of packages through cron
389     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
390     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
391    
392     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
393     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
394    
395     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
396     for dbi in \
397     Basenames Conflictname Dirnames Group Installtid Name Providename \
398     Provideversion Removetid Requirename Requireversion Triggername \
399     Packages __db.001 __db.002 __db.003 __db.004
400     do
401     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
402     done
403    
404     test -d doc-copy || mkdir doc-copy
405     rm -rf doc-copy/*
406     ln -f doc/manual/* doc-copy/
407     rm -f doc-copy/Makefile*
408    
409     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
410    
411     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
412     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
413     # Put your own system macros here
414     # usually contains
415    
416     # Set this one according your locales
417     # %%_install_langs
418    
419     EOF
420    
421     # Get rid of unpackaged files
422     (cd $RPM_BUILD_ROOT;
423     rm -rf .%{_includedir}/beecrypt/
424     rm -f .%{_libdir}/libbeecrypt.{a,la,so*}
425     rm -f .%{_libdir}/python*/site-packages/rpmmodule.{a,la}
426     rm -f .%{rpmdir}/{Specfile.pm,cpanflute2,cpanflute,sql.prov,sql.req,tcl.req}
427     rm -f .%{rpmdir}/{config.site,cross-build,rpmdiff.cgi}
428     rm -f .%{rpmdir}/trpm
429     rm -f .%{_bindir}/rpmdiff
430     )
431    
432     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
433    
434     %clean
435     rm -rf $RPM_BUILD_ROOT
436    
437     %pre
438     if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
439     echo "
440     You have both
441     /var/lib/rpm/packages.rpm db1 format installed package headers
442     /var/lib/rpm/Packages db3 format installed package headers
443     Please remove (or at least rename) one of those files, and re-install.
444     "
445     exit 1
446     fi
447    
448     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
449    
450     rm -rf /usr/lib/rpm/*-mandrake-*
451 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
452 tmb 343
453 tmb 345
454 tmb 343 %post
455     # nuke __db.00? when updating to this rpm
456     rm -f /var/lib/rpm/__db.00?
457    
458     if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{rpmdir}/convertrpmrc.sh ]
459     then
460     sh %{rpmdir}/convertrpmrc.sh 2>&1 > /dev/null
461     fi
462    
463     if [ -f /var/lib/rpm/packages.rpm ]; then
464     /bin/chown rpm.rpm /var/lib/rpm/*.rpm
465     elif [ ! -f /var/lib/rpm/Packages ]; then
466     /bin/rpm --initdb
467     fi
468    
469     %postun
470     /usr/share/rpm-helper/del-user rpm $1 rpm
471    
472     %triggerpostun -- rpm < 1:4.4.2.3-11
473     if [ -f /etc/rpm/macros.cdb.rpmsave ]; then
474     echo "warning: restoring /etc/rpm/macros.cdb from macros.cdb.rpmsave, please check you really need the changes"
475     mv /etc/rpm/macros.cdb.rpmsave /etc/rpm/macros.cdb
476     fi
477    
478     %define rpmattr %attr(0755, rpm, rpm)
479    
480     %files -f %{name}.lang
481     %defattr(-,root,root)
482     %doc GROUPS CHANGES doc/manual/[a-z]*
483     %attr(0755,rpm,rpm) /bin/rpm
484     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
485     %attr(0755, rpm, rpm) %{_bindir}/gendiff
486     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
487     %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
488     %attr(0755, rpm, rpm) %{_bindir}/rpmsign
489     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
490     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
491    
492     %dir %{_localstatedir}/spool/repackage
493     %dir %{rpmdir}
494     %dir /etc/rpm
495     %config(noreplace) /etc/rpm/macros
496     %dir /etc/rpm/macros.d
497     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
498     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
499     #%attr(0755, rpm, rpm) %{rpmdir}/convertrpmrc.sh
500     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
501     %attr(0644, rpm, rpm) %{rpmdir}/macros
502     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
503     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
504     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
505     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
506    
507     %rpmattr %{rpmdir}/rpm2cpio.sh
508     %rpmattr %{rpmdir}/tgpg
509    
510     %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
511     %ifarch %{ix86} x86_64
512     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
513     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
514     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
515     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
516     %endif
517     %ifarch alpha
518     %attr( -, rpm, rpm) %{rpmdir}/platform/alpha*
519     %endif
520     %ifarch %{sunsparc}
521     %attr( -, rpm, rpm) %{rpmdir}/platform/sparc*
522     %endif
523     %ifarch ppc powerpc
524     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
525     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
526     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
527     %attr( -, rpm, rpm) %{rpmdir}/platform/powerpc-*
528     %endif
529     %ifarch ppc powerpc ppc64
530     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc*series-*
531     %endif
532     %ifarch ppc64
533     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
534     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
535     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
536     %endif
537     %ifarch ia64
538     %attr( -, rpm, rpm) %{rpmdir}/platform/ia64-*
539     %endif
540     %ifarch x86_64
541     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
542     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
543     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
544     %endif
545     %ifarch %arm
546     %attr( -, rpm, rpm) %{rpmdir}/platform/armv*
547     %endif
548     %ifarch %mips
549     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
550     %endif
551     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
552    
553     %{_mandir}/man[18]/*.[18]*
554     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
555     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
556     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
557     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
558     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
559     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
560    
561     %config(noreplace,missingok) /etc/cron.daily/rpm
562     %config(noreplace,missingok) /etc/logrotate.d/rpm
563    
564     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
565    
566     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
567    
568     %rpmdbattr /var/lib/rpm/Basenames
569     %rpmdbattr /var/lib/rpm/Conflictname
570     %rpmdbattr /var/lib/rpm/__db.0*
571     %rpmdbattr /var/lib/rpm/Dirnames
572     %rpmdbattr /var/lib/rpm/Group
573     %rpmdbattr /var/lib/rpm/Installtid
574     %rpmdbattr /var/lib/rpm/Name
575     %rpmdbattr /var/lib/rpm/Packages
576     %rpmdbattr /var/lib/rpm/Providename
577     %rpmdbattr /var/lib/rpm/Provideversion
578     %rpmdbattr /var/lib/rpm/Removetid
579     %rpmdbattr /var/lib/rpm/Requirename
580     %rpmdbattr /var/lib/rpm/Requireversion
581     %rpmdbattr /var/lib/rpm/Triggername
582    
583     %files build
584     %defattr(-,root,root)
585     %doc CHANGES
586     %doc doc-copy/*
587     %rpmattr %{_bindir}/rpmbuild
588     %rpmattr %{_prefix}/lib/rpm/brp-*
589     %rpmattr %{_prefix}/lib/rpm/check-files
590     %rpmattr %{_prefix}/lib/rpm/debugedit
591 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
592 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
593     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
594     %rpmattr %{_prefix}/lib/rpm/find-provides
595     %rpmattr %{_prefix}/lib/rpm/find-requires
596 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
597 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
598     %rpmattr %{_prefix}/lib/rpm/perl.prov
599     %rpmattr %{_prefix}/lib/rpm/perl.req
600    
601     %rpmattr %{_prefix}/lib/rpm/check-buildroot
602     %rpmattr %{_prefix}/lib/rpm/check-prereqs
603     %rpmattr %{_prefix}/lib/rpm/check-rpaths
604     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
605     %rpmattr %{_prefix}/lib/rpm/javadeps
606     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
607     %rpmattr %{_prefix}/lib/rpm/macros.perl
608     %rpmattr %{_prefix}/lib/rpm/macros.php
609     %rpmattr %{_prefix}/lib/rpm/macros.python
610     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
611     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
612 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
613     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
614 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
615     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
616     %rpmattr %{_prefix}/lib/rpm/rpmdiff
617    
618     %rpmattr %{_prefix}/lib/rpm/rpmdeps
619     #%rpmattr %{_prefix}/lib/rpm/trpm
620     %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
621    
622     %{_mandir}/man8/rpmbuild.8*
623     %{_mandir}/man8/rpmdeps.8*
624    
625     %if %buildpython
626     %files -n python-rpm
627     %defattr(-,root,root)
628     %{_libdir}/python*/site-packages/rpm
629     %endif
630    
631     %files -n %librpmname
632     %defattr(-,root,root)
633 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
634     %{_libdir}/librpmio.so.%{libmajor}*
635     %{_libdir}/librpmbuild.so.%{libmajor}*
636 tmb 343
637     %files -n %librpmnamedevel
638     %defattr(-,root,root)
639     %{_includedir}/rpm
640     %{_libdir}/librpm.la
641     %{_libdir}/librpm.so
642     %{_libdir}/librpmio.la
643     %{_libdir}/librpmio.so
644     %{_libdir}/librpmbuild.la
645     %{_libdir}/librpmbuild.so
646     %{_libdir}/pkgconfig/rpm.pc

  ViewVC Help
Powered by ViewVC 1.1.30