/[packages]/updates/1/rpm/current/SPECS/rpm.spec
ViewVC logotype

Contents of /updates/1/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 216262 - (show annotations) (download)
Wed Feb 29 21:55:50 2012 UTC (12 years, 1 month ago) by pterjan
File size: 21500 byte(s)
- Backport kill-libio patch (Bug #1962)
1 # Do not change this spec directly but in the svn
2 # $Id: rpm.spec 134789 2007-03-27 15:13:43Z nanardon $
3
4 %define lib64arches x86_64 ppc64 sparc64
5
6 %ifarch %lib64arches
7 %define _lib lib64
8 %else
9 %define _lib lib
10 %endif
11
12 %define _prefix /usr
13 %define _libdir %_prefix/%_lib
14 %define _bindir %_prefix/bin
15 %define _sysconfdir /etc
16 %define _datadir /usr/share
17 %define _defaultdocdir %_datadir/doc
18 %define _localstatedir /var
19 %define _infodir %_datadir/info
20
21 %if %{?apply_patches:0}%{?!apply_patches:1}
22 %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
23 %endif
24
25 # Define directory which holds rpm config files, and some binaries actually
26 # NOTE: it remains */lib even on lib64 platforms as only one version
27 # of rpm is supported anyway, per architecture
28 %define rpmdir %{_prefix}/lib/rpm
29
30 %if %{?mklibname:0}%{?!mklibname:1}
31 %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
32 %endif
33
34 %if %{?distsuffix:0}%{?!distsuffix:1}
35 %define distsuffix .mga
36 %endif
37
38 %if %{?mkrel:0}%{?!mkrel:1}
39 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
40 %endif
41
42 %if %{?mips:0}%{?!mips:1}
43 %define mips mips mipsel mips32 mips32el mips64 mips64el
44 %endif
45
46 %if %{?pyver:0}%{?!pyver:1}
47 %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
48 %endif
49
50 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
51 %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
52
53 %define rpmversion 4.8.1
54 %define srcver %rpmversion
55 %define libver 4.8
56 %define libmajor 1
57 %define release %mkrel 10
58 %define librpmname %mklibname rpm %{libmajor}
59 %define librpmnamedevel %mklibname -d rpm
60
61 %define buildpython 1
62
63 %define rpmsetup_version 1.34
64
65 %define builddebug 0
66 %{?_with_debug:%define builddebug 1}
67
68 %{?_with_python:%define buildpython 1}
69 %{?_without_python:%define buildpython 0}
70
71 %define subrel 3
72
73 Summary: The RPM package management system
74 Name: rpm
75 Epoch: 1
76 Version: %{rpmversion}
77 Release: %{release}
78 Group: System/Configuration/Packaging
79
80 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81
82 # if %post of foo-2 fails,
83 # or if %preun of foo-1 fails,
84 # or if %postun of foo-1 fails,
85 # => foo-1 is not removed, so we end up with both packages in rpmdb
86 # this patch makes rpm ignore the error in those cases
87 # failing %pre must still make the rpm install fail (#23677)
88 #
89 # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
90 # scripts is ignored with or without this patch)
91 Patch22: rpm-4.6.0-rc1-non-pre-scripts-dont-fail.patch
92
93 # (fredl) add loging facilities through syslog
94 # Patch sent to upstream for inclusion
95 # http://lists.rpm.org/pipermail/rpm-maint/2011-March/002994.htm
96 Patch31: rpm-4.8.1-syslog.patch
97
98 # part of Backport from 4.2.1 provides becoming obsoletes bug (fpons)
99 # (is it still needed?)
100 Patch49: rpm-4.6.0-rc1-provides-obsoleted.patch
101
102 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
103 # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
104 # Patch mageia Specific => Not merge candidate
105 Patch64: rpm-4.6.1-mageia-rpmrc-rpmpopt.patch
106
107 # In original rpm, -bb --short-circuit does not work and run all stage
108 # From popular request, we allow to do this
109 # http://qa.mandriva.com/show_bug.cgi?id=15896Z
110 # (A different implementation has landed in rpm-4.9)
111 Patch70: rpm-4.6.0-rc1-bb-shortcircuit.patch
112
113 # http://www.redhat.com/archives/rpm-list/2005-April/msg00131.html
114 # http://www.redhat.com/archives/rpm-list/2005-April/msg00132.html
115 # is this useful? "at least erasure ordering is just as non-existent as it was in 4.4.x" says Panu
116 #with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
117 #Patch71: rpm-4.6.0-ordererase.patch#with rpm 4.8.0, breaks urpmi testsuite (ordering-scriptlets)
118
119 # don't conflict for doc files
120 # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
121 Patch83: rpm-4.6.0-no-doc-conflicts.patch
122
123 # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
124 # (is this working??)
125 Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
126
127 # Fix diff issue when buildroot contains some "//"
128 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
129
130 # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
131 Patch114: rpm-4.6.0-rc1-read-macros_d-dot-macros.patch
132
133 # remove unused skipDir functionality that conflicts with patch124 below
134 #Patch1124: rpm-4.6.0-rc1-revert-unused-skipDir-functionality.patch
135
136 # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
137 # files from the package (eg COPYING) in the db. This is quite costly when not in cache
138 # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
139 # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
140 # but this is bad design anyway
141 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
142
143 # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
144 Patch133: rpm-4.6.0-rc1-weakdeps.patch
145
146 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
147 Patch135: rpm-4.4.2.3-rc1-fix-debugedit.patch
148
149 # convert data in the header to a specific encoding which used in the selected locale.
150 Patch137: rpm-4.6.0-rc1-headerIconv.patch
151
152 # Mandriva does not need the (broken) ldconfig hack since it uses filetriggers
153 #Patch141: rpm-4.6.0-rc1-drop-skipping-ldconfig-hack.patch
154
155 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
156 # with this patch, "#%define foo bar" is a fatal error
157 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
158
159 # cf http://wiki.mandriva.com/en/Rpm_filetriggers
160 Patch146: rpm-4.6.0-rc1-filetriggers.patch
161
162 # add two fatal errors (during package build)
163 Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
164
165 # (nb: see the patch for more info about this issue)
166 Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
167
168 Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
169
170 Patch157: introduce-_after_setup-which-is-called-after-setup.patch
171 Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
172 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
173
174
175 Patch160: rpm-4.8.1-kill-libio.patch
176
177 #Patch1001: rpm-4.6.0-rc1-new-liblzma.patch
178
179 # default behaviour in rpm-jbj >= 4.4.6
180 Patch1005: rpm-allow-conflicting-ghost-files.patch
181
182 Patch1007: rpm-4.6.0-rc3-xz-support.patch
183
184 # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
185 # as this breaks stuff that installs files to $DOCDIR during %%install
186 Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
187
188 # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
189 # break when these unknown tags might be found in the rpmdb. Notice that this
190 # will only make rpm recognize these, not implement actual support for them..
191 Patch1009: rpm-4.6.0-rpm5-tags.patch
192
193 # Automatically handle ruby gem extraction in %setup
194 Patch1018: rpm-4.8.1-setup-rubygems.patch
195
196 # Turbolinux patches
197 # add writeHeaderListTofile function into rpm-python (needed by "buildman" build system) (Toshihiro, 2003)
198 #Patch2002: rpm-4.6.0-rc1-python-writeHdlist.patch
199 # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
200 Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
201
202 # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
203 #
204 # This patch fixes the problem when the post-scripts launched by rpm-build.
205 # The post-scripts launched by rpm-build works in LANG environment. If LANG is
206 # other locale except C, then some commands launched by post-scripts will not
207 # display characters which you expected.
208 Patch2005: rpm-4.6.0-rc1-buildlang.patch
209
210 Patch2000: rpm-4.6.0-rc1-serial-tag.patch
211 # re-enable "copyright" tag (Kiichiro, 2005)
212 Patch2001: rpm-4.6.0-rc1-copyright-tag.patch
213
214 Patch3000: mips_macros.patch
215 Patch3001: fix_stack_protector_check.patch
216 Patch3002: mips_define_isa_macros.patch
217 Patch3003: rpm_arm_mips_isa_macros.patch
218 Patch3004: rpm_add_armv5tl.patch
219 # This patch allow to fix build of rpm on other arch like ARM
220 Patch3005: rpm_fix_platformdir.patch
221
222 # CVE Patches
223 Patch4000: rpm-4.8.1-CVE-2011-3378-1.patch
224 Patch4001: rpm-4.8.1-CVE-2011-3378-2.patch
225 Patch4002: rpm-4.8.1-CVE-2011-3378-3.patch
226
227 License: GPL
228 BuildRequires: autoconf >= 2.57
229 BuildRequires: zlib-devel
230 BuildRequires: bzip2-devel
231 BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
232 BuildRequires: automake >= 1.8
233 BuildRequires: elfutils-devel
234 BuildRequires: sed >= 4.0.3
235 BuildRequires: libbeecrypt-devel
236 BuildRequires: ed, gettext-devel
237 BuildRequires: libsqlite3-devel
238 BuildRequires: db4.8-devel
239 BuildRequires: neon-devel
240 BuildRequires: popt-devel
241 BuildRequires: nss-devel
242 BuildRequires: magic-devel
243 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
244 BuildRequires: readline-devel
245 BuildRequires: ncurses-devel
246 BuildRequires: openssl-devel >= 0.9.8
247 BuildRequires: lua-devel
248 # Need for doc
249 #BuildRequires: graphviz
250 BuildRequires: texlive
251 %if %buildpython
252 BuildRequires: python-devel
253 %endif
254
255 Requires: bzip2 >= 0.9.0c-2
256 Requires: lzma
257 Requires: cpio
258 Requires: gawk
259 Requires: glibc >= 2.1.92
260 Requires: mktemp
261 Requires: setup >= 2.2.0-8
262 Requires: rpm-%{_real_vendor}-setup >= 1.85
263 Requires: update-alternatives
264 Requires: %librpmname = %epoch:%version-%release
265 Conflicts: patch < 2.5
266 Conflicts: menu < 2.1.5-29
267 Conflicts: locales < 2.3.1.1
268 Conflicts: man-pages-fr < 0.9.7-16
269 Conflicts: man-pages-pl < 0.4-9
270 Conflicts: perl-URPM < 1.63-3
271 # rpm 4.6.0 dropped support for --repackage, so urpmi-recover can not work anymore:
272 Conflicts: urpmi-recover
273 URL: http://rpm.org/
274 %define git_url http://rpm.org/git/rpm.git
275 Requires(pre): rpm-helper >= 0.8
276 Requires(pre): coreutils
277 Requires(postun): rpm-helper >= 0.8
278 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
279
280 %description
281 RPM is a powerful command line driven package management system capable of
282 installing, uninstalling, verifying, querying, and updating software packages.
283 Each software package consists of an archive of files along with information
284 about the package like its version, a description, etc.
285
286 %package -n %librpmname
287 Summary: Library used by rpm
288 Group: System/Libraries
289 Provides: librpm = %version-%release
290
291 %description -n %librpmname
292 RPM is a powerful command line driven package management system capable of
293 installing, uninstalling, verifying, querying, and updating software packages.
294 This package contains common files to all applications based on rpm.
295
296 %package -n %librpmnamedevel
297 Summary: Development files for applications which will manipulate RPM packages
298 Group: Development/C
299 Requires: rpm = %epoch:%{version}-%{release}
300 Provides: librpm-devel = %version-%release
301 Provides: rpm-devel = %version-%release
302 Obsoletes: rpm-devel < 4.4.1
303 Obsoletes: %{_lib}rpm4.4-devel
304 Obsoletes: %{_lib}rpm4.2-devel
305
306 %description -n %librpmnamedevel
307 This package contains the RPM C library and header files. These
308 development files will simplify the process of writing programs
309 which manipulate RPM packages and databases and are intended to make
310 it easier to create graphical package managers or any other tools
311 that need an intimate knowledge of RPM packages in order to function.
312
313 This package should be installed if you want to develop programs that
314 will manipulate RPM packages and databases.
315
316 %package build
317 Summary: Scripts and executable programs used to build packages
318 Group: System/Configuration/Packaging
319 Requires: autoconf
320 Requires: automake
321 Requires: file
322 Requires: gcc-c++
323 # We need cputoolize & amd64-* alias to x86_64-* in config.sub
324 Requires: libtool-base >= 1.4.3-5
325 Requires: patch >= 2.5.9-7
326 Requires: make
327 Requires: tar
328 Requires: unzip
329 Requires: elfutils
330 Requires: rpm = %epoch:%{version}-%{release}
331 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
332
333 %description build
334 This package contains scripts and executable programs that are used to
335 build packages using RPM.
336
337 %if %buildpython
338 %package -n python-rpm
339 Summary: Python bindings for apps which will manipulate RPM packages
340 Group: Development/Python
341 Requires: python >= %{pyver}
342 Requires: rpm = %epoch:%{version}-%{release}
343 Obsoletes: rpm-python < %epoch:%version-%release
344 Provides: rpm-python = %version-%release
345
346 %description -n python-rpm
347 The rpm-python package contains a module which permits applications
348 written in the Python programming language to use the interface
349 supplied by RPM (RPM Package Manager) libraries.
350
351 This package should be installed if you want to develop Python
352 programs that will manipulate RPM packages and databases.
353 %endif
354
355 %prep
356 %setup -q -n %name-%srcver
357 %apply_patches
358
359 %build
360
361 autoreconf
362
363 %if %builddebug
364 RPM_OPT_FLAGS=-g
365 %endif
366 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
367 %configure \
368 --enable-nls \
369 --enable-python \
370 --enable-sqlite3 \
371 --without-javaglue \
372 %if %builddebug
373 --enable-debug \
374 %endif
375 --with-external-db \
376 %if %buildpython
377 --with-python=%{pyver} \
378 %else
379 --without-python \
380 %endif
381 --with-glob \
382 --without-selinux \
383 --without-apidocs
384
385 %make
386
387 %install
388 rm -rf $RPM_BUILD_ROOT
389
390 make DESTDIR=%buildroot install
391
392 %ifarch ppc powerpc
393 ln -sf ppc-%{_real_vendor}-linux $RPM_BUILD_ROOT%{rpmdir}/powerpc-%{_real_vendor}-linux
394 %endif
395
396 #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
397
398 # Save list of packages through cron
399 mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
400 install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
401
402 mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
403 install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
404
405 mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
406 for dbi in \
407 Basenames Conflictname Dirnames Group Installtid Name Providename \
408 Provideversion Removetid Requirename Requireversion Triggername \
409 Packages __db.001 __db.002 __db.003 __db.004
410 do
411 touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
412 done
413
414 test -d doc-copy || mkdir doc-copy
415 rm -rf doc-copy/*
416 ln -f doc/manual/* doc-copy/
417 rm -f doc-copy/Makefile*
418
419 mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
420
421 mkdir -p %buildroot%_sysconfdir/rpm/macros.d
422 cat > %buildroot%_sysconfdir/rpm/macros <<EOF
423 # Put your own system macros here
424 # usually contains
425
426 # Set this one according your locales
427 # %%_install_langs
428
429 EOF
430
431 # Get rid of unpackaged files
432 (cd $RPM_BUILD_ROOT;
433 rm -rf .%{_includedir}/beecrypt/
434 rm -f .%{_libdir}/libbeecrypt.{a,la,so*}
435 rm -f .%{_libdir}/python*/site-packages/rpmmodule.{a,la}
436 rm -f .%{rpmdir}/{Specfile.pm,cpanflute2,cpanflute,sql.prov,sql.req,tcl.req}
437 rm -f .%{rpmdir}/{config.site,cross-build,rpmdiff.cgi}
438 rm -f .%{rpmdir}/trpm
439 rm -f .%{_bindir}/rpmdiff
440 )
441
442 %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
443
444 %clean
445 rm -rf $RPM_BUILD_ROOT
446
447 %pre
448 if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
449 echo "
450 You have both
451 /var/lib/rpm/packages.rpm db1 format installed package headers
452 /var/lib/rpm/Packages db3 format installed package headers
453 Please remove (or at least rename) one of those files, and re-install.
454 "
455 exit 1
456 fi
457
458 /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
459
460 rm -rf /usr/lib/rpm/*-mandrake-*
461 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
462
463
464 %post
465 # nuke __db.00? when updating to this rpm
466 rm -f /var/lib/rpm/__db.00?
467
468 if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{rpmdir}/convertrpmrc.sh ]
469 then
470 sh %{rpmdir}/convertrpmrc.sh 2>&1 > /dev/null
471 fi
472
473 if [ -f /var/lib/rpm/packages.rpm ]; then
474 /bin/chown rpm.rpm /var/lib/rpm/*.rpm
475 elif [ ! -f /var/lib/rpm/Packages ]; then
476 /bin/rpm --initdb
477 fi
478
479 %postun
480 /usr/share/rpm-helper/del-user rpm $1 rpm
481
482 %triggerpostun -- rpm < 1:4.4.2.3-11
483 if [ -f /etc/rpm/macros.cdb.rpmsave ]; then
484 echo "warning: restoring /etc/rpm/macros.cdb from macros.cdb.rpmsave, please check you really need the changes"
485 mv /etc/rpm/macros.cdb.rpmsave /etc/rpm/macros.cdb
486 fi
487
488 %define rpmattr %attr(0755, rpm, rpm)
489
490 %files -f %{name}.lang
491 %defattr(-,root,root)
492 %doc GROUPS CHANGES doc/manual/[a-z]*
493 %attr(0755,rpm,rpm) /bin/rpm
494 %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
495 %attr(0755, rpm, rpm) %{_bindir}/gendiff
496 %attr(0755, rpm, rpm) %{_bindir}/rpmdb
497 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
498 %attr(0755, rpm, rpm) %{_bindir}/rpmsign
499 %attr(0755, rpm, rpm) %{_bindir}/rpmquery
500 %attr(0755, rpm, rpm) %{_bindir}/rpmverify
501
502 %dir %{_localstatedir}/spool/repackage
503 %dir %{rpmdir}
504 %dir /etc/rpm
505 %config(noreplace) /etc/rpm/macros
506 %dir /etc/rpm/macros.d
507 %attr(0755, rpm, rpm) %{rpmdir}/config.guess
508 %attr(0755, rpm, rpm) %{rpmdir}/config.sub
509 #%attr(0755, rpm, rpm) %{rpmdir}/convertrpmrc.sh
510 %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
511 %attr(0644, rpm, rpm) %{rpmdir}/macros
512 %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
513 %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
514 %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
515 %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
516
517 %rpmattr %{rpmdir}/rpm2cpio.sh
518 %rpmattr %{rpmdir}/tgpg
519
520 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
521 %ifarch %{ix86} x86_64
522 %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
523 %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
524 %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
525 %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
526 %endif
527 %ifarch alpha
528 %attr( -, rpm, rpm) %{rpmdir}/platform/alpha*
529 %endif
530 %ifarch %{sunsparc}
531 %attr( -, rpm, rpm) %{rpmdir}/platform/sparc*
532 %endif
533 %ifarch ppc powerpc
534 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
535 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
536 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
537 %attr( -, rpm, rpm) %{rpmdir}/platform/powerpc-*
538 %endif
539 %ifarch ppc powerpc ppc64
540 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc*series-*
541 %endif
542 %ifarch ppc64
543 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
544 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
545 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
546 %endif
547 %ifarch ia64
548 %attr( -, rpm, rpm) %{rpmdir}/platform/ia64-*
549 %endif
550 %ifarch x86_64
551 %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
552 %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
553 %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
554 %endif
555 %ifarch %arm
556 %attr( -, rpm, rpm) %{rpmdir}/platform/armv*
557 %endif
558 %ifarch %mips
559 %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
560 %endif
561 %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
562
563 %{_mandir}/man[18]/*.[18]*
564 %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
565 %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
566 %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
567 %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
568 %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
569 %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
570
571 %config(noreplace,missingok) /etc/cron.daily/rpm
572 %config(noreplace,missingok) /etc/logrotate.d/rpm
573
574 %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
575
576 %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
577
578 %rpmdbattr /var/lib/rpm/Basenames
579 %rpmdbattr /var/lib/rpm/Conflictname
580 %rpmdbattr /var/lib/rpm/__db.0*
581 %rpmdbattr /var/lib/rpm/Dirnames
582 %rpmdbattr /var/lib/rpm/Group
583 %rpmdbattr /var/lib/rpm/Installtid
584 %rpmdbattr /var/lib/rpm/Name
585 %rpmdbattr /var/lib/rpm/Packages
586 %rpmdbattr /var/lib/rpm/Providename
587 %rpmdbattr /var/lib/rpm/Provideversion
588 %rpmdbattr /var/lib/rpm/Removetid
589 %rpmdbattr /var/lib/rpm/Requirename
590 %rpmdbattr /var/lib/rpm/Requireversion
591 %rpmdbattr /var/lib/rpm/Triggername
592
593 %files build
594 %defattr(-,root,root)
595 %doc CHANGES
596 %doc doc-copy/*
597 %rpmattr %{_bindir}/rpmbuild
598 %rpmattr %{_prefix}/lib/rpm/brp-*
599 %rpmattr %{_prefix}/lib/rpm/check-files
600 %rpmattr %{_prefix}/lib/rpm/debugedit
601 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
602 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
603 %rpmattr %{_prefix}/lib/rpm/find-lang.sh
604 %rpmattr %{_prefix}/lib/rpm/find-provides
605 %rpmattr %{_prefix}/lib/rpm/find-requires
606 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
607 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
608 %rpmattr %{_prefix}/lib/rpm/perl.prov
609 %rpmattr %{_prefix}/lib/rpm/perl.req
610
611 %rpmattr %{_prefix}/lib/rpm/check-buildroot
612 %rpmattr %{_prefix}/lib/rpm/check-prereqs
613 %rpmattr %{_prefix}/lib/rpm/check-rpaths
614 %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
615 %rpmattr %{_prefix}/lib/rpm/javadeps
616 %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
617 %rpmattr %{_prefix}/lib/rpm/macros.perl
618 %rpmattr %{_prefix}/lib/rpm/macros.php
619 %rpmattr %{_prefix}/lib/rpm/macros.python
620 %rpmattr %{_prefix}/lib/rpm/mono-find-provides
621 %rpmattr %{_prefix}/lib/rpm/mono-find-requires
622 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
623 %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
624 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
625 %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
626 %rpmattr %{_prefix}/lib/rpm/rpmdiff
627
628 %rpmattr %{_prefix}/lib/rpm/rpmdeps
629 #%rpmattr %{_prefix}/lib/rpm/trpm
630 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
631
632 %{_mandir}/man8/rpmbuild.8*
633 %{_mandir}/man8/rpmdeps.8*
634
635 %if %buildpython
636 %files -n python-rpm
637 %defattr(-,root,root)
638 %{_libdir}/python*/site-packages/rpm
639 %endif
640
641 %files -n %librpmname
642 %defattr(-,root,root)
643 %{_libdir}/librpm.so.%{libmajor}*
644 %{_libdir}/librpmio.so.%{libmajor}*
645 %{_libdir}/librpmbuild.so.%{libmajor}*
646
647 %files -n %librpmnamedevel
648 %defattr(-,root,root)
649 %{_includedir}/rpm
650 %{_libdir}/librpm.la
651 %{_libdir}/librpm.so
652 %{_libdir}/librpmio.la
653 %{_libdir}/librpmio.so
654 %{_libdir}/librpmbuild.la
655 %{_libdir}/librpmbuild.so
656 %{_libdir}/pkgconfig/rpm.pc

  ViewVC Help
Powered by ViewVC 1.1.30