/[packages]/updates/1/spamassassin/current/SPECS/spamassassin.spec
ViewVC logotype

Annotation of /updates/1/spamassassin/current/SPECS/spamassassin.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 232277 - (hide annotations) (download)
Sat Apr 21 10:33:11 2012 UTC (12 years ago) by remmy
File size: 18915 byte(s)
Add explicit requirement on version and release of perl-Mail-SpamAssassin

1 remmy 224286 %define bootstrap 0
2 remmy 232277 %define subrel 5
3 ennael 37397 %{?_without_bootstrap: %global bootstrap 0}
4     %{?_with_bootstrap: %global bootstrap 1}
5    
6 ennael 33043 %define fname Mail-SpamAssassin
7    
8     Summary: A spam filter for email which can be invoked from mail delivery agents
9     Name: spamassassin
10     Version: 3.3.2
11 remmy 216431 Release: %mkrel 1
12 ennael 33043 License: Apache License
13     Group: Networking/Mail
14     URL: http://spamassassin.apache.org/
15 remmy 208394 Source0: http://www.apache.org/dist/spamassassin/source/%{fname}-%{version}.tar.gz
16 ennael 33043 Source2: spamd.init
17     Source3: spamd.sysconfig
18     Source4: spamassassin-default.rc
19     Source5: spamassassin-spamc.rc
20     Source6: sa-update.cron
21     Source7: spamd.logrotate
22     Source8: spamd.conf
23     # (fc) 2.60-5mdk don't use version dependent perl call in #!
24     Patch0: spamassassin-3.2.0-fixbang.patch
25     Patch1: Mail-SpamAssassin-3.1.5-no_spamcop.diff
26     Requires(post): rpm-helper
27     Requires(preun): rpm-helper
28     BuildRequires: gnupg
29     BuildRequires: openssl-devel
30 remmy 211214 BuildRequires: perl(Apache::Test)
31 ennael 33043 BuildRequires: perl(Archive::Tar)
32 remmy 215872 BuildRequires: perl(DB_File)
33 ennael 33043 BuildRequires: perl-devel
34     BuildRequires: perl(Digest::SHA)
35 remmy 215872 BuildRequires: perl(Encode::Detect)
36 ennael 33043 BuildRequires: perl(ExtUtils::MakeMaker) >= 6.17
37 remmy 215872 BuildRequires: perl(HTML::Parser)
38 ennael 33043 BuildRequires: perl(IO::Socket::INET6)
39 remmy 215872 BuildRequires: perl(IO::Socket::SSL)
40     BuildRequires: perl(IO::Zlib)
41     BuildRequires: perl(IP::Country)
42     BuildRequires: perl(LWP)
43     BuildRequires: perl(Mail::DKIM) >= 0.37
44     BuildRequires: perl(Mail::SPF)
45     BuildRequires: perl(Net::DNS)
46     BuildRequires: perl(Net::Ident)
47     BuildRequires: perl(Socket6)
48     BuildRequires: perl(Sys::Hostname::Long)
49     BuildRequires: perl(Time::HiRes)
50 ennael 33043 BuildRequires: perl-version
51     BuildRequires: re2c
52 remmy 215872 # The requires are derived automatically from META.yml. The below require is
53     # given on http://svn.apache.org/repos/asf/spamassassin/branches/3.3/INSTALL
54     # but missing from META.yml ... better safe than sorry!
55     Requires: perl(LWP)
56 remmy 216527 # And one on a package we create ourselves:
57 remmy 232277 Requires: perl-Mail-SpamAssassin >= %{version}-%{release}
58 remmy 215872 # Suggests unfortunately do not get derived automatically yet:
59     Suggests: gnupg
60     Suggests: perl(Compress::Zlib)
61     Suggests: perl(DB_File)
62     Suggests: perl(DBI)
63     Suggests: perl(Digest::SHA)
64     Suggests: perl(Encode::Detect)
65     Suggests: perl(Getopt::Long)
66     Suggests: perl(HTTP::Date)
67     Suggests: perl(IO::Socket::INET6)
68     Suggests: perl(IO::Socket::SSL)
69     Suggests: perl(IP::Country::Fast)
70     Suggests: perl(LWP::UserAgent)
71     Suggests: perl(Mail::DKIM) >= 0.37
72     Suggests: perl(Mail::SPF)
73     Suggests: perl(MIME::Base64)
74     Suggests: perl(Net::DNS) >= 0.58
75     Suggests: perl(Net::Ident)
76     Suggests: perl(Net::SMTP)
77    
78 ennael 37520 %if ! %bootstrap
79 remmy 215873 Requires: spamassassin-rules >= 3.3.2
80 ennael 37520 %endif
81 ennael 33043
82     %description
83     SpamAssassin provides you with a way to reduce if not completely eliminate
84     Unsolicited Commercial Email (SPAM) from your incoming email. It can
85     be invoked by a MDA such as sendmail or postfix, or can be called from
86     a procmail script, .forward file, etc. It uses a genetic-algorithm
87     evolved scoring system to identify messages which look spammy, then
88     adds headers to the message so they can be filtered by the user's mail
89     reading software. This distribution includes the spamd/spamc components
90     which create a server that considerably speeds processing of mail.
91    
92     SpamAssassin also includes support for reporting spam messages
93     automatically, and/or manually, to collaborative filtering databases such
94     as Vipul's Razor, DCC or pyzor.
95     Install perl-Razor-Agent package to get Vipul's Razor support.
96     Install dcc package to get Distributed Checksum Clearinghouse (DCC) support.
97     Install pyzor package to get Pyzor support.
98    
99     To enable spamassassin, if you are receiving mail locally, simply add
100     this line to your ~/.procmailrc:
101     INCLUDERC=/etc/mail/spamassassin/spamassassin-default.rc
102    
103 remmy 215681 To filter spam for all users, add that line to /etc/procmailrc or
104     create that file if doesn't exist yet.
105 ennael 33043
106     %package sa-compile
107     Summary: Compiles SpamAssassin rulesets into native perl code
108     Group: Networking/Mail
109     Requires: gcc make
110     Requires: perl-devel
111     Requires: re2c
112    
113     %description sa-compile
114     sa-compile uses re2c to compile the site-wide parts of the SpamAssassin
115     ruleset. No part of user_prefs or any files included from user_prefs can be
116     built into the compiled set. This compiled set is then used by the
117     "Mail::SpamAssassin::Plugin::Rule2XSBody" plugin to speed up SpamAssassin's
118     operation, where possible, and when that plugin is loaded. re2c can match
119     strings much faster than perl code, by constructing a DFA to match many simple
120     strings in parallel, and compiling that to native object code. Not all
121     SpamAssassin rules are amenable to this conversion, however.
122    
123     %package tools
124     Summary: Miscleanous tools for SpamAssassin
125     Group: Networking/Mail
126     Requires: perl-Mail-SpamAssassin = %{version}
127    
128     %description tools
129     Miscleanous tools from various authors, distributed with SpamAssassin.
130     See /usr/share/doc/spamassassin-tools-*/.
131    
132     %package spamd
133     Summary: Daemonized version of SpamAssassin
134     Group: System/Servers
135 ennael 37955 %if ! %bootstrap
136 ennael 33043 Requires(post): rpm-helper spamassassin-rules >= 3.3.0
137 ennael 37955 %endif
138 ennael 33043 Requires(preun): rpm-helper
139     Requires: spamassassin = %{version}
140    
141     %description spamd
142     The purpose of this program is to provide a daemonized version of the
143     spamassassin executable. The goal is improving throughput performance
144     for automated mail checking.
145    
146     This is intended to be used alongside "spamc", a fast, low-overhead C
147     client program.
148    
149     %package spamc
150     Summary: A client for spamd
151     Group: Networking/Mail
152    
153     %description spamc
154     Spamc is the client half of the spamc/spamd pair. It should be used in
155     place of "spamassassin" in scripts to process mail. It will read the
156     mail from STDIN, and spool it to its connection to spamd, then read
157     the result back and print it to STDOUT. Spamc has extremely low
158     overhead in loading, so it should be much faster to load than the
159     whole spamassassin program.
160    
161     %package -n perl-%{fname}
162     Summary: SpamAssassin e-mail filter Perl modules
163     Group: Development/Perl
164     Requires: perl(HTML::Parser)
165    
166     %description -n perl-%{fname}
167     Mail::SpamAssassin is a module to identify spam using text analysis and
168     several internet-based realtime blacklists. Using its rule base, it uses a
169     wide range of heuristic tests on mail headers and body text to identify
170     ``spam'', also known as unsolicited commercial email. Once identified, the
171     mail can then be optionally tagged as spam for later filtering using the
172     user's own mail user-agent application.
173    
174     %package -n perl-%{fname}-Spamd
175     Summary: A mod_perl2 module implementing the spamd protocol
176     Group: Development/Perl
177     Requires: apache-mod_perl
178    
179     %description -n perl-%{fname}-Spamd
180     This distribution contains a mod_perl2 module, implementing the spamd protocol
181     from the SpamAssassin (http://spamassassin.apache.org/) project in Apache2.
182     It's mostly compatible with the original spamd.
183    
184     %prep
185    
186 remmy 208394 %setup -q -n %{fname}-%{version}
187 ennael 33043 %patch0 -p0 -b .fixbang
188     %patch1 -p0
189    
190     cp %{SOURCE2} spamd.init
191     cp %{SOURCE3} spamd.sysconfig
192     cp %{SOURCE6} sa-update.cron
193     cp %{SOURCE7} spamd.logrotate
194     cp %{SOURCE8} spamd.conf
195    
196     # svn cleansing...
197     for i in `find . -type d -name .svn`; do
198     if [ -e "$i" ]; then rm -rf $i; fi >&/dev/null
199     done
200    
201     %build
202    
203     %{__perl} \
204     Makefile.PL \
205     INSTALLDIRS=vendor \
206     SYSCONFDIR=%{_sysconfdir} \
207     DATADIR=%{_datadir}/spamassassin \
208     ENABLE_SSL=yes \
209     RUN_NET_TESTS=no < /dev/null
210    
211     %make OPTIMIZE="%{optflags}" LDFLAGS="%{ldflags}"
212    
213     pushd spamd-apache2
214     %{__perl} Makefile.PL INSTALLDIRS=vendor < /dev/null
215     %make
216     popd
217    
218     %check
219     #cat >> t/config.dist << EOF
220     #run_net_tests=y
221     #run_spamd_prefork_stress_test=y
222     #EOF
223     export LANG=C
224     export LC_ALL=C
225     export LANGUAGE=C
226     # useless and broken test case
227     rm -f t/make_install.t
228     # requires polish locales?!?
229     rm -f t/lang_pl_tests.t
230 remmy 208394 # do not work
231     # error: Can't locate auto/Net/SSLeay/CTX_v2_new.al
232     rm -f t/spamd_ssl_tls.t
233     rm -f t/spamd_ssl_v2.t
234    
235 ennael 33043 make FULLPERL="%{_bindir}/perl" test
236    
237     %install
238    
239     %makeinstall_std
240    
241     pushd spamd-apache2
242     %makeinstall_std
243     popd
244    
245     install -d %{buildroot}%{_sysconfdir}/mail/%{name}/sa-update-keys
246     install -d %{buildroot}%{_sysconfdir}/sysconfig
247     install -d %{buildroot}%{_sysconfdir}/cron.daily
248     install -d %{buildroot}%{_sysconfdir}/logrotate.d
249     install -d %{buildroot}%{_initrddir}
250     install -d %{buildroot}/var/spool/spamassassin
251     install -d %{buildroot}/var/log/spamassassin
252     install -d %{buildroot}/var/lib/spamassassin
253     install -d %{buildroot}%{_sysconfdir}/httpd/conf/webapps.d
254    
255     cat << EOF >> %{buildroot}%{_sysconfdir}/mail/%{name}/v330.pre
256    
257     # Mail::SpamAssassin::Plugin::AWL - Normalize scores via auto-whitelist
258     loadplugin Mail::SpamAssassin::Plugin::AWL
259     EOF
260    
261     cat << EOF >> %{buildroot}%{_sysconfdir}/mail/%{name}/local.cf
262     required_hits 5
263     rewrite_header Subject [SPAM]
264     report_safe 0
265     ifplugin Mail::SpamAssassin::Plugin::AWL
266     auto_whitelist_path /var/spool/spamassassin/auto-whitelist
267     auto_whitelist_file_mode 0666
268     endif # Mail::SpamAssassin::Plugin::AWL
269     EOF
270    
271     install -m0755 spamd.init %{buildroot}%{_initrddir}/spamd
272     install -m0644 spamd.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/spamd
273     install -m0755 sa-update.cron %{buildroot}%{_sysconfdir}/cron.daily/sa-update
274     install -m0644 spamd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/spamd
275     install -m0644 spamd.conf %{buildroot}/%{_sysconfdir}/httpd/conf/webapps.d/spamd.conf
276    
277     install -m0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/mail/spamassassin/
278     install -m0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/mail/spamassassin/
279    
280     # bork bork
281     install -m0644 rules/*.pre %{buildroot}%{_sysconfdir}/mail/%{name}/
282    
283     # cleanup
284     rm -f %{buildroot}%{_bindir}/apache-spamd.pl
285     rm -f %{buildroot}%{_mandir}/man1/apache-spamd.pl.1*
286    
287     # these are not meant to be relased
288     rm -f %{buildroot}%{perl_vendorlib}/Mail/SpamAssassin/Plugin/P595Body.pm
289     rm -f %{buildroot}%{perl_vendorlib}/Mail/SpamAssassin/Plugin/RabinKarpBody.pm
290    
291     %post
292     [ -f %{_sysconfdir}/spamassassin.cf ] && %{__mv} %{_sysconfdir}/spamassassin.cf %{_sysconfdir}/mail/spamassassin/migrated.cf || true
293     [ -f %{_sysconfdir}/mail/spamassassin.cf ] && /bin/mv %{_sysconfdir}/mail/spamassassin.cf %{_sysconfdir}/mail/spamassassin/migrated.cf || true
294    
295 spuhler 65714
296 ennael 33043 %post spamd
297 spuhler 65714
298    
299 ennael 33043 # -a and --auto-whitelist options were removed from 3.0.0
300     # prevent service startup failure
301     perl -p -i -e 's/(["\s]-\w+)a/$1/ ; s/(["\s]-)a(\w+)/$1$2/ ; s/(["\s])-a\b/$1/' /etc/sysconfig/spamd
302     perl -p -i -e 's/ --auto-whitelist//' /etc/sysconfig/spamd
303    
304     # fix permissions
305     if [ -f %{_sysconfdir}/mail/%{name}/local.cf ]; then
306    
307     auto_whitelist_path="`grep "^auto_whitelist_path" %{_sysconfdir}/mail/%{name}/local.cf | awk '{ print $2 }'`"
308     auto_whitelist_file_mode="`grep "^auto_whitelist_file_mode" %{_sysconfdir}/mail/%{name}/local.cf | awk '{ print $2 }'`"
309    
310     if [ "${auto_whitelist_path}" == "/var/spool/%{name}" ]; then
311     echo "Correcting \"auto_whitelist_path\" (#27424) in the %{_sysconfdir}/mail/%{name}/local.cf file..."
312     perl -pi -e "s|/var/spool/%{name}\b|/var/spool/%{name}/auto-whitelist|g" %{_sysconfdir}/mail/%{name}/local.cf
313     auto_whitelist_path="/var/spool/%{name}/auto-whitelist"
314     fi
315    
316     if ! [ -z "${auto_whitelist_path}" ]; then
317     touch ${auto_whitelist_path}
318     if [ -z "${auto_whitelist_file_mode}" ]; then
319     auto_whitelist_file_mode="0666"
320     fi
321     chmod ${auto_whitelist_file_mode} ${auto_whitelist_path}
322     fi
323    
324     fi
325 spuhler 65714 # Need to run sa-update otherwise the spamd will not start until a cron job completes
326     echo "need to run sa-update"
327 remmy 211214 /usr/bin/sa-update -v
328 ennael 33043
329     %_post_service spamd
330    
331     %preun spamd
332     %_preun_service spamd
333    
334     %files
335     %doc README Changes sample-*.txt procmailrc.example INSTALL TRADEMARK
336 remmy 211214 %doc CREDITS UPGRADE USAGE META.yml
337 ennael 33043 %dir %{_sysconfdir}/mail/%{name}
338     %dir %attr(0700,root,root) %{_sysconfdir}/mail/%{name}/sa-update-keys
339     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/mail/%{name}/*.cf
340     %config(noreplace) %{_sysconfdir}/mail/%{name}/*.pre
341     %config(noreplace) %{_sysconfdir}/mail/%{name}/spamassassin-default.rc
342     %dir %attr(0777,root,root) /var/spool/spamassassin
343     %dir /var/lib/spamassassin
344     %attr(0755,root,root) %{_bindir}/sa-awl
345     %attr(0755,root,root) %{_bindir}/sa-check_spamd
346     %attr(0755,root,root) %{_bindir}/sa-learn
347     %attr(0755,root,root) %{_bindir}/sa-update
348     %attr(0755,root,root) %{_bindir}/spamassassin
349 remmy 208394 %{_mandir}/man1/sa-awl.1*
350 ennael 33043 %{_mandir}/man1/sa-learn.1*
351 remmy 211214 %{_mandir}/man1/sa-update.1*
352 ennael 33043 %{_mandir}/man1/spamassassin.1*
353     %{_mandir}/man1/spamassassin-run.1*
354     %{_datadir}/spamassassin
355    
356     %files sa-compile
357     %defattr(-,root,root)
358     %attr(0755,root,root) %{_bindir}/sa-compile
359     %{_mandir}/man1/sa-compile.1*
360    
361     %files tools
362     %defattr(-,root,root)
363     %doc sql ldap
364    
365     %files spamd
366     %defattr(-,root,root)
367     %doc spamd/README* spamd/PROTOCOL
368     %attr(0700,root,root) %{_sysconfdir}/cron.daily/sa-update
369     %attr(0755,root,root) %{_initrddir}/spamd
370     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/spamd
371     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/logrotate.d/spamd
372     %attr(0755,root,root) %{_bindir}/spamd
373     %{_mandir}/man1/spamd.1*
374     %dir %attr(0755,root,root) /var/log/spamassassin
375    
376     %files spamc
377     %defattr(-,root,root)
378     %config(noreplace) %{_sysconfdir}/mail/%{name}/spamassassin-spamc.rc
379     %attr(0755,root,root) %{_bindir}/spamc
380     %{_mandir}/man1/spamc.1*
381    
382     %files -n perl-%{fname}
383     %defattr(644,root,root,755)
384     %dir %{perl_vendorlib}/Mail/SpamAssassin
385     %{perl_vendorlib}/Mail/SpamAssassin/*.pm
386     %{perl_vendorlib}/Mail/SpamAssassin.pm
387     %{perl_vendorlib}/spamassassin-run.pod
388     %dir %{perl_vendorlib}/Mail/SpamAssassin/Bayes
389     %dir %{perl_vendorlib}/Mail/SpamAssassin/BayesStore
390     %dir %{perl_vendorlib}/Mail/SpamAssassin/Conf
391     %dir %{perl_vendorlib}/Mail/SpamAssassin/Locker
392     %dir %{perl_vendorlib}/Mail/SpamAssassin/Logger
393     %dir %{perl_vendorlib}/Mail/SpamAssassin/Message
394     %dir %{perl_vendorlib}/Mail/SpamAssassin/Message/Metadata
395     %dir %{perl_vendorlib}/Mail/SpamAssassin/Plugin
396     %dir %{perl_vendorlib}/Mail/SpamAssassin/Util
397     %{perl_vendorlib}/Mail/SpamAssassin/Bayes/*.pm
398     %{perl_vendorlib}/Mail/SpamAssassin/BayesStore/*.pm
399     %{perl_vendorlib}/Mail/SpamAssassin/Conf/*.pm
400     %{perl_vendorlib}/Mail/SpamAssassin/Locker/*.pm
401     %{perl_vendorlib}/Mail/SpamAssassin/Logger/*.pm
402     %{perl_vendorlib}/Mail/SpamAssassin/Message/Metadata/*.pm
403     %{perl_vendorlib}/Mail/SpamAssassin/Message/*.pm
404     %{perl_vendorlib}/Mail/SpamAssassin/Plugin/*.pm
405     %{perl_vendorlib}/Mail/SpamAssassin/Util/*.pm
406     %{_mandir}/man3/Mail::SpamAssassin.3pm*
407     %{_mandir}/man3/Mail::SpamAssassin::AICache.3pm*
408     %{_mandir}/man3/Mail::SpamAssassin::ArchiveIterator.3pm*
409     %{_mandir}/man3/Mail::SpamAssassin::AsyncLoop.3pm*
410     %{_mandir}/man3/Mail::SpamAssassin::AutoWhitelist.3pm*
411     %{_mandir}/man3/Mail::SpamAssassin::Bayes.3pm*
412     %{_mandir}/man3/Mail::SpamAssassin::BayesStore.3pm*
413     %{_mandir}/man3/Mail::SpamAssassin::BayesStore::BDB.3pm*
414     %{_mandir}/man3/Mail::SpamAssassin::BayesStore::MySQL.3pm*
415     %{_mandir}/man3/Mail::SpamAssassin::BayesStore::PgSQL.3pm*
416     %{_mandir}/man3/Mail::SpamAssassin::BayesStore::SQL.3pm*
417     %{_mandir}/man3/Mail::SpamAssassin::Client.3pm*
418     %{_mandir}/man3/Mail::SpamAssassin::Conf.3pm*
419     %{_mandir}/man3/Mail::SpamAssassin::Conf::LDAP.3pm*
420     %{_mandir}/man3/Mail::SpamAssassin::Conf::Parser.3pm*
421     %{_mandir}/man3/Mail::SpamAssassin::Conf::SQL.3pm*
422     %{_mandir}/man3/Mail::SpamAssassin::DnsResolver.3pm*
423     %{_mandir}/man3/Mail::SpamAssassin::Logger.3pm*
424     %{_mandir}/man3/Mail::SpamAssassin::Logger::File.3pm*
425     %{_mandir}/man3/Mail::SpamAssassin::Logger::Stderr.3pm*
426     %{_mandir}/man3/Mail::SpamAssassin::Logger::Syslog.3pm*
427     %{_mandir}/man3/Mail::SpamAssassin::Message.3pm*
428     %{_mandir}/man3/Mail::SpamAssassin::Message::Metadata.3pm*
429     %{_mandir}/man3/Mail::SpamAssassin::Message::Node.3pm*
430     %{_mandir}/man3/Mail::SpamAssassin::PerMsgLearner.3pm*
431     %{_mandir}/man3/Mail::SpamAssassin::PerMsgStatus.3pm*
432     %{_mandir}/man3/Mail::SpamAssassin::PersistentAddrList.3pm*
433     %{_mandir}/man3/Mail::SpamAssassin::Plugin.3pm*
434     %{_mandir}/man3/Mail::SpamAssassin::Plugin::AccessDB.3pm*
435 remmy 208394 #%{_mandir}/man3/Mail::SpamAssassin::Plugin::AskDNS.3pm*
436 ennael 33043 %{_mandir}/man3/Mail::SpamAssassin::Plugin::AntiVirus.3pm*
437     %{_mandir}/man3/Mail::SpamAssassin::Plugin::ASN.3pm*
438     %{_mandir}/man3/Mail::SpamAssassin::Plugin::AutoLearnThreshold.3pm*
439     %{_mandir}/man3/Mail::SpamAssassin::Plugin::AWL.3pm*
440     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Bayes.3pm*
441     %{_mandir}/man3/Mail::SpamAssassin::Plugin::BodyRuleBaseExtractor.3pm*
442     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Check.3pm*
443     %{_mandir}/man3/Mail::SpamAssassin::Plugin::DCC.3pm*
444     %{_mandir}/man3/Mail::SpamAssassin::Plugin::DKIM.3pm*
445     %{_mandir}/man3/Mail::SpamAssassin::PluginHandler.3pm*
446     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Hashcash.3pm*
447     %{_mandir}/man3/Mail::SpamAssassin::Plugin::MIMEHeader.3pm*
448 remmy 208394 #%{_mandir}/man3/Mail::SpamAssassin::Plugin::NetCache.3pm*
449 ennael 33043 %{_mandir}/man3/Mail::SpamAssassin::Plugin::OneLineBodyRuleType.3pm*
450     %{_mandir}/man3/Mail::SpamAssassin::Plugin::PhishTag.3pm*
451     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Pyzor.3pm*
452     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Razor2.3pm*
453     %{_mandir}/man3/Mail::SpamAssassin::Plugin::RelayCountry.3pm*
454     %{_mandir}/man3/Mail::SpamAssassin::Plugin::ReplaceTags.3pm*
455     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Reuse.3pm*
456     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Rule2XSBody.3pm*
457     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Shortcircuit.3pm*
458     %{_mandir}/man3/Mail::SpamAssassin::Plugin::SpamCop.3pm*
459     %{_mandir}/man3/Mail::SpamAssassin::Plugin::SPF.3pm*
460     %{_mandir}/man3/Mail::SpamAssassin::Plugin::Test.3pm*
461     %{_mandir}/man3/Mail::SpamAssassin::Plugin::TextCat.3pm*
462     %{_mandir}/man3/Mail::SpamAssassin::Plugin::URIDetail.3pm*
463     %{_mandir}/man3/Mail::SpamAssassin::Plugin::URIDNSBL.3pm*
464     %{_mandir}/man3/Mail::SpamAssassin::Plugin::VBounce.3pm*
465     %{_mandir}/man3/Mail::SpamAssassin::Plugin::WhiteListSubject.3pm*
466     %{_mandir}/man3/Mail::SpamAssassin::SQLBasedAddrList.3pm*
467     %{_mandir}/man3/Mail::SpamAssassin::SubProcBackChannel.3pm*
468     %{_mandir}/man3/Mail::SpamAssassin::Timeout.3pm*
469     %{_mandir}/man3/Mail::SpamAssassin::Util.3pm*
470     %{_mandir}/man3/Mail::SpamAssassin::Util::DependencyInfo.3pm*
471     %{_mandir}/man3/Mail::SpamAssassin::Util::Progress.3pm*
472     %{_mandir}/man3/Mail::SpamAssassin::Util::RegistrarBoundaries.3pm*
473     %{_mandir}/man3/spamassassin-run.3pm*
474    
475     %files -n perl-%{fname}-Spamd
476     %defattr(644,root,root,755)
477     %doc spamd-apache2/README.apache
478     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/httpd/conf/webapps.d/spamd.conf
479     %dir %{perl_vendorlib}/Mail/SpamAssassin/Spamd
480     %{perl_vendorlib}/Mail/SpamAssassin/Spamd/Apache2.pm
481     %{perl_vendorlib}/Mail/SpamAssassin/Spamd/Config.pm
482     %{perl_vendorlib}/Mail/SpamAssassin/Spamd.pm
483     %dir %{perl_vendorlib}/Mail/SpamAssassin/Spamd/Apache2
484     %{perl_vendorlib}/Mail/SpamAssassin/Spamd/Apache2/AclRFC1413.pm
485     %{perl_vendorlib}/Mail/SpamAssassin/Spamd/Apache2/Config.pm
486     %{perl_vendorlib}/Mail/SpamAssassin/Spamd/Apache2/AclIP.pm
487     %{_mandir}/man3/Mail::SpamAssassin::Spamd.3pm*
488     %{_mandir}/man3/Mail::SpamAssassin::Spamd::Apache2.3pm*
489     %{_mandir}/man3/Mail::SpamAssassin::Spamd::Apache2::AclIP.3pm*
490     %{_mandir}/man3/Mail::SpamAssassin::Spamd::Apache2::AclRFC1413.3pm*
491     %{_mandir}/man3/Mail::SpamAssassin::Spamd::Apache2::Config.3pm*
492     %{_mandir}/man3/Mail::SpamAssassin::Spamd::Config.3pm*

  ViewVC Help
Powered by ViewVC 1.1.30