/[packages]/updates/1/webmin/current/SPECS/webmin.spec
ViewVC logotype

Contents of /updates/1/webmin/current/SPECS/webmin.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 394863 - (show annotations) (download)
Wed Feb 6 16:17:18 2013 UTC (11 years, 2 months ago) by luigiwalser
File size: 7255 byte(s)
1.620
1 # zero out some useless deps.
2 # (tv) we'd better had a link in minicom & package Encode::HanConvert:
3 %define _requires_exceptions HanConvert\\|runscript
4
5 # don't spend time with this either
6 %define _enable_debug_packages %{nil}
7 %define debug_package %{nil}
8
9 Summary: An SSL web-based administration interface for Unix systems
10 Name: webmin
11 Version: 1.620
12 Release: %mkrel 1
13 License: BSD
14 Group: System/Configuration/Other
15 URL: http://www.webmin.com/webmin/
16 Source0: http://heanet.dl.sourceforge.net/project/webadmin/%{name}/%{version}/%{name}-%{version}.tar.gz
17 Source2: other.modules.tar.bz2
18 # some images were missing
19 Source33: advanced.png
20 Source34: descs.png
21 Source4: webmin-postinstallscript.sh
22 Source5: webmin
23 Source6: webmin.initscript
24 Source9: http://www.openit.it/index.php/openit_en/content/download/2474/10171/file/openvpn-2.0.wbm.gz
25 Source10: webmin.pam
26 Source11: webmin-16.png
27 Source12: webmin-32.png
28 Source13: webmin-48.png
29 # uses include instead of pam_stack
30 Source14: webmin.pam-new
31 Source15: webmin.logrotate
32 Source16: webmin-grub-config
33 # (gc) have the updates; this needs to change for each version and/or release, see
34 # http://www.webmin.com/webmin/updates.html
35 Patch1: webmin-1.610-remove-atboot-problem
36 Patch5: webmin-fix-newmods.patch
37 Patch7: webmin-0.85-never-fail-detect-os.patch
38 Patch8: webmin-0.85-enable-changed-theme-at-installation.patch
39 Patch10: webmin-1.510-fix-os-list.patch
40
41 Patch17: webmin-1.220-remove-mandrakestuff-from-init.patch
42 Patch19: webmin-0.92-add-default-configs-logviewer-fp2k.patch
43 Patch21: webmin-0.950-add-netsaint-mandrake-config.patch
44 Patch23: webmin-1.020-ssl-location.patch
45 Patch26: webmin-1.060-mysql-fix-installing-missing-packages.patch
46 Patch29: webmin-1.100-let-localauth-config.patch
47 Patch32: webmin-1.310-usermin-fix-installing-missing-package.diff
48 Patch33: webmin-1.610-postgresql-fix-installing-missing-packages.patch
49 Patch35: webmin-1.220-usermin-fix-index.patch
50 Patch37: webmin-temp-permission-fix.diff
51 Patch38: webmin-ssldir-cosmetic.diff
52 Patch39: webmin-fix-bandwith.diff
53 Patch40: webmin-fix-sarg.diff
54 Patch41: webmin-1.610-urpmi.patch
55 Patch42: webmin-1.610-service-names.patch
56 Patch43: webmin-1.610-syslog.patch
57 Patch44: webmin-openvpn-config.patch
58 Requires(pre): rpm-helper
59 Requires: perl
60 Requires: perl-CGI
61 Requires: lsof
62 Requires(pre): sed chkconfig findutils coreutils initscripts grep perl-Net_SSLeay perl-Authen-PAM
63 Provides: %{name}-%{version}
64 BuildArch: noarch
65
66 %description
67 A web-based administration interface for Unix systems. Using Webmin you can
68 configure DNS, Samba, NFS, local/remote filesystems, Apache, Sendmail/Postfix,
69 and more using your web browser.
70
71 After installation, enter the URL https://localhost:10000/ into your browser
72 and login as root with your root password. Please consider logging in and
73 modify your password for security issue.
74
75 PLEASE NOTE THAT THIS VERSION NOW USES SECURE WEB TRANSACTIONS: YOU HAVE TO
76 LOGIN TO "https://localhost:10000/" AND NOT "http://localhost:10000/".
77
78 %prep
79
80 %setup -q -a2
81
82 for module in cfengine inetd jabber netsaint pptp-server sentry webalizer wuftpd; do
83 rm -fr %{name}-%{version}/$module
84 done
85
86 %setup -q -D -T -c -a 9 -n %{name}-%{version}
87 %patch1 -p0
88 %patch5 -p0
89 %patch7 -p1
90 %patch8 -p1
91 %patch10 -p1
92
93 %patch19 -p0
94 %patch21 -p0
95 %patch23 -p1
96 %patch26 -p1
97 %patch29 -p1
98 %patch32 -p0
99 %patch33 -p1
100 %patch35 -p1
101 %patch37 -p1
102 %patch38 -p1
103 %patch39 -p1
104 %patch40 -p1
105 %patch41 -p0
106 %patch42 -p0
107 %patch43 -p0
108 %patch44 -p0
109
110 find bind8 -type f -maxdepth 1 | xargs perl -pi -e 's|/var/run/named\.pid|/var/run/named/named.pid|'
111
112 # daouda: added mageia-linux to known OS
113 cp config-mandrake-linux config-mageia
114
115 perl -pi -e 's|mandrake-linux|mageia mandrake-linux| if $_ =~ /^os_support.*mandrake-linux/ && $_ !~ /mageia/' */module.info
116 perl -pi -e 's|mageia|mageia{-r "/etc/named.boot"}| if $_ =~ /^os_support.*mageia/' dnsadmin/module.info
117 perl -pi -e 's|^cachemgr_path=.*$|cachemgr_path=/var/www/cgi-bin/cachemgr.cgi|g' squid/config-mandrake-linux*
118
119 (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
120 rm -f mount/freebsd-mounts-*
121 rm -f mount/openbsd-mounts-*
122
123 find -name ".xvpics" -o -name ".*.swp" | xargs rm -rf
124
125 cp %{SOURCE16} grub/config-mandrake-linux
126
127 %build
128
129 # nothing to do here...
130
131 %install
132 rm -rf %{buildroot}
133
134 # IMPORTANT: there is no %{_datadir} and so on, since the directories are decided by the post install script.
135 mkdir -p %{buildroot}/usr/share/webmin
136 mkdir -p %{buildroot}/%{_initrddir}
137 mkdir -p %{buildroot}/usr/bin
138
139 find -type f -print0 | xargs -0 chmod a+r
140 find -type d -print0 | xargs -0 chmod a+rx
141
142 cp -a * %{buildroot}/usr/share/webmin
143 install -m755 %{SOURCE6} %{buildroot}/%{_initrddir}/webmin
144 install -m755 %{SOURCE4} %{buildroot}/usr/share/webmin/postinstall.sh
145 install -m755 %{SOURCE5} %{buildroot}/usr/bin
146
147 mkdir -p %{buildroot}/%{_sysconfdir}/pam.d
148
149 install -m755 %{SOURCE14} %{buildroot}/%{_sysconfdir}/pam.d/webmin
150
151 rm -rf %{buildroot}/usr/share/webmin/*/{CVS,*/CVS}
152 rm -f `find %{buildroot} -type f -name .cvsignore`
153
154 # (gc) remove zero-length files (to check sometimes if they are still zero-length'ed)
155 for i in /usr/share/webmin/caldera/images/letters/254.gif /usr/share/webmin/i4lctrl-0.6.7/lang/de /usr/share/webmin/caldera/images/letters/255.gif; do
156 if [ -f $i ]; then rm -f %{buildroot}$i; fi
157 done
158
159 echo "rpm" > %{buildroot}/usr/share/webmin/install-type
160
161 # (sb) remove development file
162 rm -f %{buildroot}/usr/share/webmin/mount/macos-mounts.c
163
164 echo 'blue-theme' > %{buildroot}%{_datadir}/webmin/defaulttheme
165
166
167 # Install icons
168 install -d -m 0755 %{buildroot}%{_liconsdir}
169 install -d -m 0755 %{buildroot}%{_miconsdir}
170 install -m 0644 %{SOURCE11} %{buildroot}%{_miconsdir}/webmin.png
171 install -m 0644 %{SOURCE12} %{buildroot}%{_iconsdir}/webmin.png
172 install -m 0644 %{SOURCE11} %{buildroot}%{_liconsdir}/webmin.png
173
174 # Menu entry
175
176 # XDG menu
177 install -d %{buildroot}%{_datadir}/applications
178 cat > %{buildroot}%{_datadir}/applications/mageia-%{name}.desktop << EOF
179 [Desktop Entry]
180 Name=%{name}
181 Comment=%{summary}
182 Exec=%{_bindir}/www-browser https://localhost:10000/
183 Icon=%{name}
184 Terminal=false
185 Type=Application
186 Categories=X-Mageia-System-Configuration-Other;Settings;
187 EOF
188
189 rm -fr %{buildroot}/usr/share/webmin/acl/Authen-SolarisRBAC-0.1
190
191 #logrotate
192 install -d %{buildroot}%{_sysconfdir}/logrotate.d
193 install -m 0644 %{SOURCE15} %{buildroot}%{_sysconfdir}/logrotate.d/webmin
194
195 %post
196 if [ "$1" != 0 ]; then
197 service webmin status >/dev/null 2>/dev/null && need_restart=1
198 service webmin stop >/dev/null 2>/dev/null || :
199 else
200 [[ -e /etc/cron.allow ]] && if [ "x`grep root /etc/cron.allow`" == "x" ] ; then
201 echo root >> /etc/cron.allow
202 fi
203 fi
204 /usr/share/webmin/postinstall.sh
205 [[ -n $need_restart ]] && service webmin start >/dev/null 2>/dev/null || :
206
207 %preun
208 %_preun_service webmin
209
210 %postun
211 if [ "$1" = 0 ]; then
212 rm -rf /etc/webmin /var/webmin /var/lib/webmin /var/run/webmin /var/log/webmin
213 fi
214
215 %clean
216 rm -rf %{buildroot}
217
218 %files
219 %defattr(-, root, root, 0755)
220 %doc README LICENCE
221 %{_initrddir}/webmin
222 %config(noreplace) %{_sysconfdir}/pam.d/webmin
223 %config(noreplace) %{_sysconfdir}/logrotate.d/webmin
224 /usr/share/webmin
225 /usr/bin/%{name}
226 %{_iconsdir}/%{name}.png
227 %{_liconsdir}/%{name}.png
228 %{_miconsdir}/%{name}.png
229 %{_datadir}/applications/*.desktop

  ViewVC Help
Powered by ViewVC 1.1.30