/[packages]/updates/2/dosemu/current/SPECS/dosemu.spec
ViewVC logotype

Contents of /updates/2/dosemu/current/SPECS/dosemu.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 260821 - (show annotations) (download)
Fri Jun 15 16:26:41 2012 UTC (12 years, 7 months ago) by dams
File size: 4946 byte(s)
new svn snapshot to fix mga#6437
1 %define dosver 1.0
2 %define svnsnapshot 2072
3
4 #disable for plugins
5 %define _disable_ld_no_undefined 1
6
7 Summary: DOSEMU allows you to to run DOS programs
8 Name: dosemu
9 Version: 1.4.0.1
10 Release: %mkrel 5
11 Source0: %{name}-%{version}-svn2072.tar.xz
12 Source1: %{name}-freedos-%{dosver}-bin.tar.bz2
13 Source11: xdosemu-16x16.png
14 Source12: xdosemu-32x32.png
15 Source13: xdosemu-48x48.png
16 #Patch0: dosemu-1.4.0.1.diff
17 Patch1: dosemu-1.4.0-dexeconfig-open-O_CREAT-3params.patch
18 Patch2: dosemu-1.4.0-fix-str-fmt.patch
19 # This patch gives a warning when dosemu is run as a user and can't access LOWMEM
20 # (and users can't by default, for security reasons)
21 # Next dosemu release should work better, with this kind of message :
22 # EXPERIMENTAL: using non-zero memory base address 0x110000.
23 # You can use the better-tested zero based setup using
24 # sysctl -w vm.mmap_min_addr=0
25 # as root, or by changing the vm.mmap_min_addr setting in
26 # /etc/sysctl.conf or a file in /etc/sysctl.d/ to 0.
27 Patch3: dosemu-1.4.0.1-lowmem-as-user-pb.patch
28 License: GPLv2+
29 Url: http://dosemu.sourceforge.net/
30 Group: Emulators
31 BuildRequires: bison flex X11-devel svgalib-devel
32 BuildRequires: bdftopcf slang-devel SDL-devel
33 #Requires: dosimage
34 Requires: %{name}-freedos = %{version}-%{release}
35 Exclusivearch: %{ix86}
36
37 %description
38 DOSEMU is a user-level program which uses certain special features
39 of the Linux kernel and the 80386 processor to run MS-DOS/FreeDOS/
40 DR-DOS, DOS programs, and many DPMI applications in what we in the
41 biz call a `DOS box'.
42
43 %package -n xdosemu
44 Requires: %{name} = %{version}-%{release} dosimage
45 Summary: A DOS emulator for the X Window System
46 Group: Emulators
47
48 %description -n xdosemu
49 Xdosemu is a version of the dosemu DOS emulator that runs with the X
50 Window System. Xdosemu provides VGA graphics and mouse support.
51
52 Install xdosemu if you need to run DOS programs on your system, and you'd
53 like to do so with the convenience of graphics support and mouse
54 capabilities.
55
56 %package freedos
57 Summary: A FreeDOS hdimage for dosemu, a DOS emulator, to use
58 Group: Emulators
59 Provides: dosimage
60
61 %description freedos
62 Generally, the dosemu DOS emulator requires either that your system
63 have some version of DOS available or that your system's partitions
64 were formatted and installed with DOS. If your system does not meet
65 either of the previous requirements, you can instead use the dosemu-
66 freedos package, which contains required files which will be
67 installed in '/usr/share/dosemu/freedos-1.0'
68
69 Install dosemu-freedos if you are installing the dosemu package
70 and you don't have a version of DOS available on your system,
71 and your system's partitions were not formatted and installed
72 with DOS.
73
74 %prep
75 %setup -q -n %{name}-%{version}-svn%{svnsnapshot}
76 #%patch0 -p1
77 %patch1 -p1
78 %patch2 -p0
79 #%patch3 -p0
80
81 bunzip2 -c %{SOURCE1} | gzip -c > freedos.tgz
82
83 %build
84 %configure2_5x --with-fdtarball=freedos.tgz \
85 --with-svgalib \
86 --with-x
87 %make
88
89 %install
90 %{makeinstall_std}
91
92 mkdir -p %{buildroot}%{_iconsdir}/hicolor/{16x16,32x32,48x48}/apps
93 install -m644 %{SOURCE11} -D \
94 %{buildroot}%{_iconsdir}/hicolor/16x16/apps/x%{name}.png
95 install -m644 %{SOURCE12} -D \
96 %{buildroot}%{_iconsdir}/hicolor/32x32/apps/x%{name}.png
97 install -m644 %{SOURCE13} -D \
98 %{buildroot}%{_iconsdir}/hicolor/48x48/apps/x%{name}.png
99
100 #xdg menu
101 mkdir -p %{buildroot}%{_datadir}/applications
102 cat > %{buildroot}%{_datadir}/applications/xdosemu.desktop <<EOF
103 [Desktop Entry]
104 Name=Xdosemu
105 Comment=DOS emulator running under X
106 Exec=%{_bindir}/x%{name}
107 Icon=x%{name}
108 Terminal=false
109 Type=Application
110 Categories=X-MandrivaLinux-MoreApplications-Emulators;Emulator;
111 EOF
112
113 rm -rf %{buildroot}%{_docdir}
114
115 # move freedos to another place to fix update issue (#34837)
116 mv %{buildroot}%{_datadir}/%{name}/freedos \
117 %{buildroot}%{_datadir}/%{name}/freedos-%{dosver}
118
119 %files
120 %doc doc/*
121 %{_bindir}/dosemu.bin
122 %{_bindir}/dosemu
123 %{_bindir}/mkfatimage
124 %{_bindir}/mkfatimage16
125 %{_bindir}/midid
126 %{_bindir}/dosdebug
127 %{_libdir}/dosemu/libplugin*.so
128 %{_mandir}/man1/mkfatimage16.1*
129 %{_mandir}/man1/dosdebug.1*
130 %{_mandir}/man1/dosemu.1*
131 %{_mandir}/man1/dosemu.bin.1*
132 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
133 %lang(ru) %{_mandir}/ru/man1/dosdebug.1*
134 %lang(ru) %{_mandir}/ru/man1/dosemu.1*
135 %lang(ru) %{_mandir}/ru/man1/dosemu.bin.1*
136 %{_datadir}/dosemu/commands
137 %{_datadir}/dosemu/keymap
138 %{_datadir}/dosemu/Xfonts
139 %config(noreplace) %{_sysconfdir}/dosemu.conf
140 %config(noreplace) %{_sysconfdir}/drives/c
141 %config(noreplace) %{_sysconfdir}/drives/d
142 %config(noreplace) %{_sysconfdir}/dosemu.users
143 %config(noreplace) %{_sysconfdir}/global.conf
144
145 %files -n xdosemu
146 %{_bindir}/xdosemu
147 %{_mandir}/man1/xdosemu.1*
148 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
149 %{_iconsdir}/hicolor/16x16/apps/x%{name}.png
150 %{_iconsdir}/hicolor/32x32/apps/x%{name}.png
151 %{_iconsdir}/hicolor/48x48/apps/x%{name}.png
152 %{_datadir}/applications/xdosemu.desktop
153
154 %files freedos
155 %{_datadir}/dosemu/freedos-%{dosver}
156 %{_datadir}/dosemu/drive_z

  ViewVC Help
Powered by ViewVC 1.1.30