1 |
%bcond_without lib |
2 |
|
3 |
%define major 3 |
4 |
%define libname %mklibname %{name} %{major} |
5 |
%define develname %mklibname -d %{name} |
6 |
%define sdevelname %mklibname -d -s %{name} |
7 |
%define cvsver 3_14_1 |
8 |
|
9 |
%define nspr_libname %mklibname nspr 4 |
10 |
|
11 |
# this seems fragile, so require the exact version or later (#58754) |
12 |
%define sqlite3_version %(pkg-config --modversion sqlite3 &>/dev/null && pkg-config --modversion sqlite3 2>/dev/null || echo 0) |
13 |
%define nspr_version %(pkg-config --modversion nspr &>/dev/null && pkg-config --modversion nspr 2>/dev/null || echo 0) |
14 |
|
15 |
Name: nss |
16 |
Version: 3.14.1 |
17 |
Release: %mkrel 2 |
18 |
Epoch: 2 |
19 |
Summary: Netscape Security Services |
20 |
Group: System/Libraries |
21 |
License: MPLv1.1 or GPLv2+ or LGPLv2+ |
22 |
URL: http://www.mozilla.org/projects/security/pki/nss/index.html |
23 |
Source0: ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_%{cvsver}_RTM/src/nss-%{version}.tar.gz |
24 |
Source1: nss.pc.in |
25 |
Source2: nss-config.in |
26 |
Source3: blank-cert8.db |
27 |
Source4: blank-key3.db |
28 |
Source5: blank-secmod.db |
29 |
# https://www.verisign.com/support/verisign-intermediate-ca/secure-site-intermediate/index.html |
30 |
# converted from PEM to DER format with openssl command: |
31 |
# openssl x509 -in cert.pem -inform PEM -outform DER -out cert.der |
32 |
# this way we can avoid a buildrequires for openssl |
33 |
Source7: verisign-class-3-secure-server-ca.der |
34 |
# Brasilian government certificate |
35 |
# verified in person with a government official |
36 |
Source8: http://www.icpbrasil.gov.br/certificadoACRaiz.crt |
37 |
Patch0: nss-no-rpath.patch |
38 |
Patch1: nss-fixrandom.patch |
39 |
Patch4: renegotiate-transitional.patch |
40 |
BuildRequires: rootcerts >= 1:20121229.00 |
41 |
BuildRequires: libnspr-devel >= 2:%{nspr_version} |
42 |
BuildRequires: libz-devel |
43 |
BuildRequires: sqlite3-devel >= 3.6.22 |
44 |
BuildRequires: zip |
45 |
|
46 |
%description |
47 |
Network Security Services (NSS) is a set of libraries designed to |
48 |
support cross-platform development of security-enabled client and server |
49 |
applications. Applications built with NSS can support SSL v2 and v3, |
50 |
TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and |
51 |
other security standards. For detailed information on standards supported, see |
52 |
http://www.mozilla.org/projects/security/pki/nss/overview.html. |
53 |
%if %without lib |
54 |
|
55 |
Note: This package currently contains the NSS binaries only. The |
56 |
libraries have been not been included due to conflicts with the Mozilla |
57 |
libraries. |
58 |
%endif |
59 |
|
60 |
%package doc |
61 |
Summary: Network Security Services (NSS) - Documentation |
62 |
Group: Books/Computer books |
63 |
BuildArch: noarch |
64 |
|
65 |
%description doc |
66 |
Documentation for Network Security Services. |
67 |
|
68 |
%if %with lib |
69 |
%package -n %{libname} |
70 |
Summary: Network Security Services (NSS) |
71 |
Group: System/Libraries |
72 |
Provides: mozilla-nss = %{epoch}:%{version}-%{release} |
73 |
Requires(post): nss |
74 |
Requires(post): rpm-helper |
75 |
Requires: %{mklibname sqlite3_ 0} >= %{sqlite3_version} |
76 |
Requires: %{nspr_libname} >= %{nspr_version} |
77 |
|
78 |
%description -n %{libname} |
79 |
Network Security Services (NSS) is a set of libraries designed to |
80 |
support cross-platform development of security-enabled server |
81 |
applications. Applications built with NSS can support SSL v2 and v3, |
82 |
TLS, PKCS #5, PKCS #7, PKCS #11, PKCS |
83 |
#12, S/MIME, X.509 v3 certificates, and other security standards. For |
84 |
detailed information on standards supported, see |
85 |
http://www.mozilla.org/projects/security/pki/nss/overview.html. |
86 |
|
87 |
%package -n %{develname} |
88 |
Summary: Network Security Services (NSS) - development files |
89 |
Group: Development/C++ |
90 |
Requires: %{libname} = %{epoch}:%{version}-%{release} |
91 |
Requires: libnspr-devel |
92 |
Provides: libnss-devel = %{epoch}:%{version}-%{release} |
93 |
Provides: nss-devel = %{epoch}:%{version}-%{release} |
94 |
Obsoletes: %{libname}-devel < 2:3.12-8 |
95 |
Conflicts: %{libname} < 2:3.12-8 |
96 |
|
97 |
%description -n %{develname} |
98 |
Header files to doing development with Network Security Services. |
99 |
|
100 |
%package -n %{sdevelname} |
101 |
Summary: Network Security Services (NSS) - static libraries |
102 |
Group: Development/C++ |
103 |
Requires: %{libname} = %{epoch}:%{version}-%{release} |
104 |
Requires: %{develname} = %{epoch}:%{version}-%{release} |
105 |
Requires: libnspr-devel >= 2:%{nspr_version} |
106 |
Provides: libnss-static-devel = %{epoch}:%{version}-%{release} |
107 |
Provides: nss-static-devel = %{epoch}:%{version}-%{release} |
108 |
Conflicts: libopenssl-static-devel |
109 |
Obsoletes: %{libname}-static-devel < 2:3.12-8 |
110 |
|
111 |
%description -n %{sdevelname} |
112 |
Static libraries for doing development with Network Security Services. |
113 |
%endif |
114 |
|
115 |
%prep |
116 |
|
117 |
%setup -q |
118 |
%patch0 -p0 |
119 |
%patch1 -p0 |
120 |
%patch4 -p0 -b .transitional |
121 |
|
122 |
find . -type d -perm 0700 -exec chmod 755 {} \; |
123 |
find . -type f -perm 0555 -exec chmod 755 {} \; |
124 |
find . -type f -perm 0444 -exec chmod 644 {} \; |
125 |
find . -name '*.h' -executable -exec chmod -x {} \; |
126 |
find . -name '*.c' -executable -exec chmod -x {} \; |
127 |
|
128 |
%build |
129 |
%setup_compile_flags |
130 |
export BUILD_OPT=1 |
131 |
export OPTIMIZER="%{optflags}" |
132 |
export XCFLAGS="%{optflags}" |
133 |
export LDOPTS="$LDFLAGS" |
134 |
export ARCHFLAG="$LDFLAGS" |
135 |
export LIBDIR=%{_libdir} |
136 |
export USE_SYSTEM_ZLIB=1 |
137 |
export ZLIB_LIBS="-lz" |
138 |
export PKG_CONFIG_ALLOW_SYSTEM_LIBS=1 |
139 |
export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1 |
140 |
export NSPR_INCLUDE_DIR=`%{_bindir}/pkg-config --cflags-only-I nspr | %{__sed} 's/-I//'` |
141 |
export NSPR_LIB_DIR=`%{_bindir}/pkg-config --libs-only-L nspr | %{__sed} 's/-L//'` |
142 |
export MOZILLA_CLIENT=1 |
143 |
export NS_USE_GCC=1 |
144 |
export NSS_USE_SYSTEM_SQLITE=1 |
145 |
export NSS_ENABLE_ECC=1 |
146 |
%ifarch x86_64 ppc64 ia64 s390x |
147 |
export USE_64=1 |
148 |
%endif |
149 |
|
150 |
# Parallel is broken as of 3.11.4 :( |
151 |
%make -j1 -C ./mozilla/security/nss \ |
152 |
build_coreconf \ |
153 |
build_dbm \ |
154 |
all |
155 |
|
156 |
# install new Verisign intermediate certificate |
157 |
# http://qa.mandriva.com/show_bug.cgi?id=29612 |
158 |
# use built addbuildin command to avoid having |
159 |
# a buildrequires for nss |
160 |
ADDBUILTIN=`%{_bindir}/find . -type f -name addbuiltin` |
161 |
if [ -z "$ADDBUILTIN" ]; then |
162 |
exit 1 |
163 |
fi |
164 |
ADDBUILTIN="$PWD/$ADDBUILTIN" |
165 |
OLD="$LD_LIBRARY_PATH" |
166 |
libpath=`%{_bindir}/find mozilla/dist/ -name "Linux2.*" -type d` |
167 |
# to use the built libraries instead of requiring nss |
168 |
# again as buildrequires |
169 |
export LD_LIBRARY_PATH="$PWD/$libpath/lib" |
170 |
|
171 |
pushd mozilla/security/nss/lib/ckfw/builtins |
172 |
|
173 |
# recreate certificates |
174 |
%{__perl} ./certdata.perl < /etc/pki/tls/mozilla/certdata.txt |
175 |
|
176 |
%make clean |
177 |
%make -j1 |
178 |
|
179 |
popd |
180 |
export LD_LIBRARY_PATH="$OLD" |
181 |
|
182 |
%install |
183 |
%{__rm} -rf %{buildroot} |
184 |
|
185 |
pushd mozilla/dist/$(uname -s)* |
186 |
|
187 |
%{__mkdir_p} %{buildroot}%{_bindir} |
188 |
%{__cp} -aL bin/* %{buildroot}%{_bindir} |
189 |
|
190 |
%if %with lib |
191 |
%{__mkdir_p} %{buildroot}%{_libdir} |
192 |
%{__mkdir_p} %{buildroot}/%{_lib} |
193 |
%{__mkdir_p} %{buildroot}%{_includedir}/nss |
194 |
%{__cp} -aL ../public/nss/* %{buildroot}%{_includedir}/nss |
195 |
|
196 |
%{__cp} -aL lib/libcrmf.a \ |
197 |
lib/libnss.a \ |
198 |
lib/libnssb.a \ |
199 |
lib/libnssckbi.so \ |
200 |
lib/libnssckfw.a \ |
201 |
lib/libnssutil.a \ |
202 |
lib/libsmime.a \ |
203 |
lib/libssl.a \ |
204 |
%{buildroot}%{_libdir} |
205 |
|
206 |
# Copy the binary libraries we want |
207 |
for file in libsoftokn3.so libfreebl3.so libnss3.so libnssutil3.so \ |
208 |
libssl3.so libsmime3.so libnssckbi.so libnssdbm3.so |
209 |
do |
210 |
%{__install} -m 755 lib/$file %{buildroot}/%{_lib} |
211 |
ln -sf ../../%{_lib}/$file %{buildroot}%{_libdir}/$file |
212 |
done |
213 |
|
214 |
# These ghost files will be generated in the post step |
215 |
# Make sure chk files can be found in both places |
216 |
for file in libsoftokn3.chk libfreebl3.chk |
217 |
do |
218 |
touch %{buildroot}/%{_lib}/$file |
219 |
ln -s ../../%{_lib}/$file %{buildroot}%{_libdir}/$file |
220 |
done |
221 |
|
222 |
%{__mkdir_p} %{buildroot}%{_libdir}/pkgconfig |
223 |
%{__cat} %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \ |
224 |
-e "s,%%prefix%%,%{_prefix},g" \ |
225 |
-e "s,%%exec_prefix%%,%{_prefix},g" \ |
226 |
-e "s,%%includedir%%,%{_includedir}/nss,g" \ |
227 |
-e "s,%%NSPR_VERSION%%,%{nspr_version},g" \ |
228 |
-e "s,%%NSS_VERSION%%,%{version},g" > \ |
229 |
%{buildroot}%{_libdir}/pkgconfig/nss.pc |
230 |
%endif |
231 |
|
232 |
popd |
233 |
|
234 |
%if %with lib |
235 |
export NSS_VMAJOR=`%{__cat} mozilla/security/nss/lib/nss/nss.h | %{__grep} "#define.*NSS_VMAJOR" | %{__awk} '{print $3}'` |
236 |
export NSS_VMINOR=`%{__cat} mozilla/security/nss/lib/nss/nss.h | %{__grep} "#define.*NSS_VMINOR" | %{__awk} '{print $3}'` |
237 |
export NSS_VPATCH=`echo %{version} | sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'` |
238 |
|
239 |
%{__mkdir_p} %{buildroot}%{_bindir} |
240 |
%{__cat} %{SOURCE2} | %{__sed} -e "s,@libdir@,%{_libdir},g" \ |
241 |
-e "s,@prefix@,%{_prefix},g" \ |
242 |
-e "s,@exec_prefix@,%{_prefix},g" \ |
243 |
-e "s,@includedir@,%{_includedir}/nss%{major},g" \ |
244 |
-e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \ |
245 |
-e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \ |
246 |
-e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \ |
247 |
> %{buildroot}/%{_bindir}/nss-config |
248 |
%endif |
249 |
|
250 |
pushd mozilla/security/nss/cmd/smimetools |
251 |
%{__install} -m 0755 smime %{buildroot}%{_bindir} |
252 |
%{__perl} -pi -e 's|/usr/local/bin|%{_bindir}|g' %{buildroot}%{_bindir}/smime |
253 |
popd |
254 |
|
255 |
# add docs |
256 |
%{__mkdir_p} docs/SSLsample |
257 |
#%{__cp} -a mozilla/security/nss/cmd/SSLsample/README docs/SSLsample/ |
258 |
|
259 |
%{__mkdir_p} docs/bltest |
260 |
%{__cp} -a mozilla/security/nss/cmd/bltest/tests/* docs/bltest/ |
261 |
|
262 |
%{__mkdir_p} docs/certcgi |
263 |
%{__cp} -a mozilla/security/nss/cmd/certcgi/*.html docs/certcgi/ |
264 |
%{__cp} -a mozilla/security/nss/cmd/certcgi/HOWTO.txt docs/certcgi/ |
265 |
|
266 |
%{__mkdir_p} docs/modutil |
267 |
%{__cp} -a mozilla/security/nss/cmd/modutil/*.html docs/modutil/ |
268 |
|
269 |
%{__mkdir_p} docs/signtool |
270 |
%{__cp} -a mozilla/security/nss/cmd/signtool/README docs/signtool/ |
271 |
|
272 |
%{__mkdir_p} docs/signver |
273 |
%{__cp} -a mozilla/security/nss/cmd/signver/examples/1/*.pl docs/signver/ |
274 |
%{__cp} -a mozilla/security/nss/cmd/signver/examples/1/*.html docs/signver/ |
275 |
|
276 |
%{__mkdir_p} docs/ssltap |
277 |
%{__cp} -a mozilla/security/nss/cmd/ssltap/*.html docs/ssltap/ |
278 |
|
279 |
# Install the empty NSS db files |
280 |
%{__mkdir_p} %{buildroot}%{_sysconfdir}/pki/nssdb |
281 |
%{__install} -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/pki/nssdb/cert8.db |
282 |
%{__install} -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/pki/nssdb/key3.db |
283 |
%{__install} -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/pki/nssdb/secmod.db |
284 |
|
285 |
%{_bindir}/find docs -type f | %{_bindir}/xargs -t %{__perl} -pi -e 's/\r$//g' |
286 |
|
287 |
%multiarch_binaries %{buildroot}%{_bindir}/nss-config |
288 |
|
289 |
%clean |
290 |
%{__rm} -rf %{buildroot} |
291 |
|
292 |
%if %with lib |
293 |
%post -n %{libname} |
294 |
%create_ghostfile /%{_lib}/libsoftokn%{major}.chk root root 644 |
295 |
%create_ghostfile /%{_lib}/libfreebl%{major}.chk root root 644 |
296 |
%{_bindir}/shlibsign -i /%{_lib}/libsoftokn%{major}.so >/dev/null 2>/dev/null |
297 |
%{_bindir}/shlibsign -i /%{_lib}/libfreebl%{major}.so >/dev/null 2>/dev/null |
298 |
%endif |
299 |
|
300 |
%files |
301 |
%defattr(0644,root,root,0755) |
302 |
%attr(0755,root,root) %{_bindir}/addbuiltin |
303 |
%attr(0755,root,root) %{_bindir}/atob |
304 |
%attr(0755,root,root) %{_bindir}/baddbdir |
305 |
%attr(0755,root,root) %{_bindir}/bltest |
306 |
%attr(0755,root,root) %{_bindir}/btoa |
307 |
%attr(0755,root,root) %{_bindir}/certcgi |
308 |
%attr(0755,root,root) %{_bindir}/certutil |
309 |
%attr(0755,root,root) %{_bindir}/checkcert |
310 |
%attr(0755,root,root) %{_bindir}/chktest |
311 |
%attr(0755,root,root) %{_bindir}/cmsutil |
312 |
%attr(0755,root,root) %{_bindir}/conflict |
313 |
%attr(0755,root,root) %{_bindir}/crlutil |
314 |
%attr(0755,root,root) %{_bindir}/crmftest |
315 |
%attr(0755,root,root) %{_bindir}/dbtest |
316 |
%attr(0755,root,root) %{_bindir}/derdump |
317 |
%attr(0755,root,root) %{_bindir}/dertimetest |
318 |
%attr(0755,root,root) %{_bindir}/digest |
319 |
%attr(0755,root,root) %{_bindir}/encodeinttest |
320 |
%attr(0755,root,root) %{_bindir}/fipstest |
321 |
%attr(0755,root,root) %{_bindir}/httpserv |
322 |
%attr(0755,root,root) %{_bindir}/listsuites |
323 |
%attr(0755,root,root) %{_bindir}/lowhashtest |
324 |
%attr(0755,root,root) %{_bindir}/makepqg |
325 |
%attr(0755,root,root) %{_bindir}/mangle |
326 |
%attr(0755,root,root) %{_bindir}/modutil |
327 |
%attr(0755,root,root) %{_bindir}/multinit |
328 |
%attr(0755,root,root) %{_bindir}/nonspr10 |
329 |
%attr(0755,root,root) %{_bindir}/ocspclnt |
330 |
%attr(0755,root,root) %{_bindir}/ocspresp |
331 |
%attr(0755,root,root) %{_bindir}/oidcalc |
332 |
%attr(0755,root,root) %{_bindir}/p7content |
333 |
%attr(0755,root,root) %{_bindir}/p7env |
334 |
%attr(0755,root,root) %{_bindir}/p7sign |
335 |
%attr(0755,root,root) %{_bindir}/p7verify |
336 |
%attr(0755,root,root) %{_bindir}/pk11mode |
337 |
%attr(0755,root,root) %{_bindir}/pk12util |
338 |
%attr(0755,root,root) %{_bindir}/pk1sign |
339 |
%attr(0755,root,root) %{_bindir}/pkix-errcodes |
340 |
%attr(0755,root,root) %{_bindir}/pp |
341 |
%attr(0755,root,root) %{_bindir}/pwdecrypt |
342 |
%attr(0755,root,root) %{_bindir}/remtest |
343 |
%attr(0755,root,root) %{_bindir}/rsaperf |
344 |
%attr(0755,root,root) %{_bindir}/sdrtest |
345 |
%attr(0755,root,root) %{_bindir}/secmodtest |
346 |
%attr(0755,root,root) %{_bindir}/selfserv |
347 |
%attr(0755,root,root) %{_bindir}/shlibsign |
348 |
%attr(0755,root,root) %{_bindir}/signtool |
349 |
%attr(0755,root,root) %{_bindir}/signver |
350 |
%attr(0755,root,root) %{_bindir}/smime |
351 |
%attr(0755,root,root) %{_bindir}/ssltap |
352 |
%attr(0755,root,root) %{_bindir}/strsclnt |
353 |
%attr(0755,root,root) %{_bindir}/symkeyutil |
354 |
%attr(0755,root,root) %{_bindir}/tstclnt |
355 |
%attr(0755,root,root) %{_bindir}/vfychain |
356 |
%attr(0755,root,root) %{_bindir}/vfyserv |
357 |
%dir %{_sysconfdir}/pki/nssdb |
358 |
%config(noreplace) %{_sysconfdir}/pki/nssdb/cert8.db |
359 |
%config(noreplace) %{_sysconfdir}/pki/nssdb/key3.db |
360 |
%config(noreplace) %{_sysconfdir}/pki/nssdb/secmod.db |
361 |
|
362 |
%files doc |
363 |
%defattr(0644,root,root,0755) |
364 |
%doc docs/* |
365 |
|
366 |
%if %with lib |
367 |
%files -n %{libname} |
368 |
%defattr(0755,root,root,0755) |
369 |
/%{_lib}/libfreebl%{major}.so |
370 |
/%{_lib}/libnss%{major}.so |
371 |
/%{_lib}/libnssckbi.so |
372 |
/%{_lib}/libsmime%{major}.so |
373 |
/%{_lib}/libsoftokn%{major}.so |
374 |
/%{_lib}/libssl%{major}.so |
375 |
/%{_lib}/libnssutil%{major}.so |
376 |
/%{_lib}/libnssdbm%{major}.so |
377 |
%defattr(0644,root,root,0755) |
378 |
%ghost /%{_lib}/libsoftokn%{major}.chk |
379 |
%ghost /%{_lib}/libfreebl%{major}.chk |
380 |
|
381 |
%files -n %{develname} |
382 |
%defattr(0644,root,root,0755) |
383 |
%attr(0755,root,root) %{_bindir}/nss-config |
384 |
%attr(0755,root,root) %{multiarch_bindir}/nss-config |
385 |
%_libdir/*.so |
386 |
%dir %{_includedir}/nss |
387 |
%{_includedir}/nss/base64.h |
388 |
%{_includedir}/nss/blapit.h |
389 |
%{_includedir}/nss/certdb.h |
390 |
%{_includedir}/nss/cert.h |
391 |
%{_includedir}/nss/certt.h |
392 |
%{_includedir}/nss/ciferfam.h |
393 |
%{_includedir}/nss/cmmf.h |
394 |
%{_includedir}/nss/cmmft.h |
395 |
%{_includedir}/nss/cms.h |
396 |
%{_includedir}/nss/cmsreclist.h |
397 |
%{_includedir}/nss/cmst.h |
398 |
%{_includedir}/nss/crmf.h |
399 |
%{_includedir}/nss/crmft.h |
400 |
%{_includedir}/nss/cryptohi.h |
401 |
%{_includedir}/nss/cryptoht.h |
402 |
%{_includedir}/nss/ecl-exp.h |
403 |
%{_includedir}/nss/hasht.h |
404 |
%{_includedir}/nss/jar-ds.h |
405 |
%{_includedir}/nss/jarfile.h |
406 |
%{_includedir}/nss/jar.h |
407 |
%{_includedir}/nss/key.h |
408 |
%{_includedir}/nss/keyhi.h |
409 |
%{_includedir}/nss/keyt.h |
410 |
%{_includedir}/nss/keythi.h |
411 |
%{_includedir}/nss/nssb64.h |
412 |
%{_includedir}/nss/nssb64t.h |
413 |
%{_includedir}/nss/nssbase.h |
414 |
%{_includedir}/nss/nssbaset.h |
415 |
%{_includedir}/nss/nssck.api |
416 |
%{_includedir}/nss/nssckbi.h |
417 |
%{_includedir}/nss/nssckepv.h |
418 |
%{_includedir}/nss/nssckft.h |
419 |
%{_includedir}/nss/nssckfwc.h |
420 |
%{_includedir}/nss/nssckfw.h |
421 |
%{_includedir}/nss/nssckfwt.h |
422 |
%{_includedir}/nss/nssckg.h |
423 |
%{_includedir}/nss/nssckmdt.h |
424 |
%{_includedir}/nss/nssckt.h |
425 |
%{_includedir}/nss/nss.h |
426 |
%{_includedir}/nss/nssilckt.h |
427 |
%{_includedir}/nss/nssilock.h |
428 |
%{_includedir}/nss/nsslocks.h |
429 |
%{_includedir}/nss/nsslowhash.h |
430 |
%{_includedir}/nss/nssrwlk.h |
431 |
%{_includedir}/nss/nssrwlkt.h |
432 |
%{_includedir}/nss/nssutil.h |
433 |
%{_includedir}/nss/ocsp.h |
434 |
%{_includedir}/nss/ocspt.h |
435 |
%{_includedir}/nss/p12.h |
436 |
%{_includedir}/nss/p12plcy.h |
437 |
%{_includedir}/nss/p12t.h |
438 |
%{_includedir}/nss/pk11func.h |
439 |
%{_includedir}/nss/pk11pqg.h |
440 |
%{_includedir}/nss/pk11priv.h |
441 |
%{_includedir}/nss/pk11pub.h |
442 |
%{_includedir}/nss/pk11sdr.h |
443 |
%{_includedir}/nss/pkcs11f.h |
444 |
%{_includedir}/nss/pkcs11.h |
445 |
%{_includedir}/nss/pkcs11n.h |
446 |
%{_includedir}/nss/pkcs11p.h |
447 |
%{_includedir}/nss/pkcs11t.h |
448 |
%{_includedir}/nss/pkcs11u.h |
449 |
%{_includedir}/nss/pkcs12.h |
450 |
%{_includedir}/nss/pkcs12t.h |
451 |
%{_includedir}/nss/pkcs7t.h |
452 |
%{_includedir}/nss/portreg.h |
453 |
%{_includedir}/nss/preenc.h |
454 |
%{_includedir}/nss/secasn1.h |
455 |
%{_includedir}/nss/secasn1t.h |
456 |
%{_includedir}/nss/seccomon.h |
457 |
%{_includedir}/nss/secder.h |
458 |
%{_includedir}/nss/secdert.h |
459 |
%{_includedir}/nss/secdig.h |
460 |
%{_includedir}/nss/secdigt.h |
461 |
%{_includedir}/nss/secerr.h |
462 |
%{_includedir}/nss/sechash.h |
463 |
%{_includedir}/nss/secitem.h |
464 |
%{_includedir}/nss/secmime.h |
465 |
%{_includedir}/nss/secmod.h |
466 |
%{_includedir}/nss/secmodt.h |
467 |
%{_includedir}/nss/secoid.h |
468 |
%{_includedir}/nss/secoidt.h |
469 |
%{_includedir}/nss/secpkcs5.h |
470 |
%{_includedir}/nss/secpkcs7.h |
471 |
%{_includedir}/nss/secport.h |
472 |
%{_includedir}/nss/shsign.h |
473 |
%{_includedir}/nss/smime.h |
474 |
%{_includedir}/nss/sslerr.h |
475 |
%{_includedir}/nss/ssl.h |
476 |
%{_includedir}/nss/sslproto.h |
477 |
%{_includedir}/nss/sslt.h |
478 |
%{_includedir}/nss/utilmodt.h |
479 |
%{_includedir}/nss/utilpars.h |
480 |
%{_includedir}/nss/utilparst.h |
481 |
%{_includedir}/nss/utilrename.h |
482 |
%{_libdir}/pkgconfig/nss.pc |
483 |
%{_libdir}/libsoftokn%{major}.chk |
484 |
%{_libdir}/libfreebl%{major}.chk |
485 |
|
486 |
%files -n %{sdevelname} |
487 |
%defattr(0644,root,root,0755) |
488 |
%{_libdir}/libcrmf.a |
489 |
%{_libdir}/libnss.a |
490 |
%{_libdir}/libnssutil.a |
491 |
%{_libdir}/libnssb.a |
492 |
%{_libdir}/libnssckfw.a |
493 |
%{_libdir}/libsmime.a |
494 |
%{_libdir}/libssl.a |
495 |
%endif |