/[packages]/updates/2/opera/current/SPECS/opera.spec
ViewVC logotype

Annotation of /updates/2/opera/current/SPECS/opera.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 100086 - (hide annotations) (download)
Sat May 21 21:50:07 2011 UTC (12 years, 11 months ago) by ahmad
Original Path: cauldron/opera/current/SPECS/opera.spec
File size: 5103 byte(s)
- Update to 11.11, mainly a bug fix release; also fixes a critical security issue:
  http://www.opera.com/support/kb/view/992/
  should fix (mga#1372)
- Update the file list

1 ahmad 94297 %define name opera
2 ahmad 100086 %define version 11.11
3     %define rel 1
4 ahmad 94297 %define snap 0
5 ahmad 100086 %define buildnb 2109
6 ahmad 94297
7     %define tarball_base %{name}-%{version}-%{buildnb}
8    
9     %define arch_exclude_files_from_autoreq ^$
10     %ifarch x86_64
11     # Exclude 32-bit requires on x86_64; plugins will pull them.
12     %define arch_exclude_files_from_autoreq ^%{_libdir}/%{name}/operapluginwrapper-ia32-linux$
13     %endif
14    
15     # Exclude requires on GTK/KDE toolkits, they are optional and used
16     # automatically when present.
17     %define common_exclude_files_from_autoreq ^%{_libdir}/%{name}/libopera.\\+\\.so$
18    
19     %define _exclude_files_from_autoreq %{arch_exclude_files_from_autoreq}\\|%{common_exclude_files_from_autoreq}
20    
21     Summary: Opera Web Browser for Linux
22     Name: %{name}
23     Version: %{version}
24     %if %snap
25     Release: %mkrel 0.%buildnb.%rel
26     %else
27     Release: %mkrel %rel
28     %endif
29     %define shortver %(echo %version | tr -d .)
30     Source0: http://get.opera.com/pub/opera/linux/%{shortver}/%{tarball_base}.i386.linux.tar.xz
31     Source1: http://get.opera.com/pub/opera/linux/%{shortver}/%{tarball_base}.x86_64.linux.tar.xz
32     Source2: bookmarks.adr
33     License: Freeware
34     Url: http://www.opera.com/
35     Group: Networking/WWW
36     ExclusiveArch: %ix86 x86_64
37     BuildRequires: desktop-file-utils
38    
39     %description
40     Opera for Linux is an alternative feature-rich Web browser.
41    
42     %prep
43     %ifarch x86_64
44     %setup -qTn %{name}-%{version}-%{buildnb}.%{_arch}.linux -b1
45     %else
46     %setup -qTn %{name}-%{version}-%{buildnb}.%{_arch}.linux -b0
47     %endif
48    
49     %install
50     rm -rf $RPM_BUILD_ROOT
51     ./install --system --repackage %{buildroot}%{_prefix} --prefix %{_prefix}
52    
53     %if "%_lib" != "lib"
54     mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir}
55     %endif
56     sed -i 's,/usr/lib,%{_libdir},' %{buildroot}%{_bindir}/opera
57    
58     rm -rf rpmdocs
59     mv %{buildroot}%{_docdir}/opera rpmdocs
60    
61 ahmad 94306 # install bookmarks file
62 ahmad 94297 install -m644 %{SOURCE2} %{buildroot}%_datadir/%name/defaults/bookmarks.adr
63    
64     desktop-file-install --dir %{buildroot}%{_datadir}/applications \
65     --add-category=X-MandrivaLinux-CrossDesktop \
66     %{buildroot}%{_datadir}/applications/%{name}-browser.desktop
67    
68     # StartupNotify does not work correctly when opera is already running;
69     # the already-existing window is activated and a new tab is opened
70     # and the completion signal is not sent.
71 ahmad 94306 echo "StartupNotify=false" >> %{buildroot}%{_datadir}/applications/%{name}-browser.desktop
72 ahmad 94297
73     %clean
74     rm -rf $RPM_BUILD_ROOT
75    
76     %files
77     %defattr(-,root,root)
78     %doc rpmdocs/*
79     %_bindir/opera
80     %_bindir/opera-widget-manager
81     %_libdir/opera
82    
83     %_iconsdir/hicolor/*/apps/%{name}-*.*
84     %_iconsdir/hicolor/*/mimetypes/%{name}-*.*
85     %_datadir/applications/%{name}-browser.desktop
86     %_datadir/applications/%{name}-widget-installer.desktop
87     %_datadir/applications/%{name}-widget-manager.desktop
88     %_datadir/mime/packages/%{name}-*.xml
89     %_mandir/man1/opera*
90    
91     %dir %{_datadir}/opera
92     %{_datadir}/opera/encoding.bin
93     %{_datadir}/opera/*.dtd
94     %{_datadir}/opera/lngcode.txt
95     %{_datadir}/opera/package-id.ini
96     %{_datadir}/opera/defaults
97     %{_datadir}/opera/extra
98     %{_datadir}/opera/files.sig
99     %{_datadir}/opera/files_old.sig
100     %{_datadir}/opera/package
101     %{_datadir}/opera/skin
102     %{_datadir}/opera/styles
103     %{_datadir}/opera/ui
104     %{_datadir}/opera/unite
105     %{_datadir}/opera/locale/en
106    
107     # langs
108     %dir %{_datadir}/%{name}/locale
109 ahmad 100086 # %lang(af) %{_datadir}/opera/locale/af
110     # %lang(az) %{_datadir}/opera/locale/az
111 ahmad 94297 %lang(be) %{_datadir}/%name/locale/be
112     %lang(bg) %{_datadir}/%name/locale/bg
113     %lang(cs) %{_datadir}/%name/locale/cs
114     %lang(da) %{_datadir}/%name/locale/da
115     %lang(de) %{_datadir}/%name/locale/de
116     %lang(el) %{_datadir}/%name/locale/el
117     %lang(en_GB) %{_datadir}/%name/locale/en-GB
118     %lang(es) %{_datadir}/%name/locale/es-ES
119     %lang(es) %{_datadir}/%name/locale/es-LA
120     %lang(et) %{_datadir}/%name/locale/et
121     %lang(fi) %{_datadir}/%name/locale/fi
122     %lang(fr) %{_datadir}/%name/locale/fr
123     %lang(fr_CA) %{_datadir}/%name/locale/fr-CA
124     %lang(fy) %{_datadir}/%name/locale/fy
125     %lang(gd) %{_datadir}/opera/locale/gd
126     %lang(hi) %{_datadir}/%name/locale/hi
127     %lang(hr) %{_datadir}/%name/locale/hr
128     %lang(hu) %{_datadir}/%name/locale/hu
129     %lang(id) %{_datadir}/%name/locale/id
130     %lang(it) %{_datadir}/%name/locale/it
131     %lang(ja) %{_datadir}/%name/locale/ja
132     %lang(ka) %{_datadir}/%name/locale/ka
133     %lang(ko) %{_datadir}/%name/locale/ko
134     %lang(lt) %{_datadir}/%name/locale/lt
135 ahmad 100086 # %lang(me) %{_datadir}/opera/locale/me
136 ahmad 94297 %lang(mk) %{_datadir}/%name/locale/mk
137 ahmad 100086 # %lang(ms) %{_datadir}/opera/locale/ms
138 ahmad 94297 %lang(nb) %{_datadir}/%name/locale/nb
139     %lang(nl) %{_datadir}/%name/locale/nl
140     %lang(nn) %{_datadir}/%name/locale/nn
141     %lang(pl) %{_datadir}/%name/locale/pl
142     %lang(pt) %{_datadir}/%name/locale/pt
143     %lang(pt_BR) %{_datadir}/%name/locale/pt-BR
144     %lang(ro) %{_datadir}/%name/locale/ro
145     %lang(ru) %{_datadir}/%name/locale/ru
146     %lang(sk) %{_datadir}/%name/locale/sk
147     %lang(sr) %{_datadir}/%name/locale/sr
148     %lang(sv) %{_datadir}/%name/locale/sv
149     %lang(ta) %{_datadir}/%name/locale/ta
150     %lang(te) %{_datadir}/%name/locale/te
151 ahmad 100086 # %lang(th) %{_datadir}/opera/locale/th
152     # %lang(tl) %{_datadir}/opera/locale/tl
153 ahmad 94297 %lang(tr) %{_datadir}/%name/locale/tr
154     %lang(uk) %{_datadir}/%name/locale/uk
155 ahmad 100086 # %lang(uz) %{_datadir}/opera/locale/uz
156 ahmad 94297 %lang(vi) %{_datadir}/%name/locale/vi
157     %lang(zh_CN) %{_datadir}/%name/locale/zh-cn
158     %lang(zh_TW) %{_datadir}/%name/locale/zh-tw

  ViewVC Help
Powered by ViewVC 1.1.30