1 |
%define sqname squashfs |
2 |
%define sqver 4.2 |
3 |
%define release %mkrel 3 |
4 |
%define Summary Utilities for the creation of compressed squashfs images |
5 |
|
6 |
Name: %{sqname}-tools |
7 |
Version: %{sqver} |
8 |
Release: %{release} |
9 |
Summary: %{Summary} |
10 |
License: GPLv2+ |
11 |
Group: File tools |
12 |
URL: http://squashfs.sourceforge.net/ |
13 |
Source0: %{sqname}%{sqver}.tar.gz |
14 |
Patch0: unsquashfs-add-checks-for-corrupted-data-in-opendir-functions.patch |
15 |
Patch1: compressors-mksquashfs-unsquashfs-broken-if-GZIP_SUPPORT-is-not-defined.patch |
16 |
# fix CVE-2012-4024 (from fedora) |
17 |
Patch2: path-issue.patch |
18 |
# fix CVE-2012-4025 (from fedora) |
19 |
Patch3: buffer-issue.patch |
20 |
BuildRequires: zlib-devel attr-devel lzma-devel |
21 |
|
22 |
%description |
23 |
squashfs-tools are utilities for the creation of compressed squashfs images. |
24 |
|
25 |
%prep |
26 |
%setup -q -n %{sqname}%{sqver} |
27 |
%apply_patches |
28 |
|
29 |
%build |
30 |
cd squashfs-tools |
31 |
%make XZ_SUPPORT=1 COMP_DEFAULT=xz |
32 |
|
33 |
%install |
34 |
rm -rf %{buildroot} |
35 |
install -d %{buildroot}%{_bindir} |
36 |
cd squashfs-tools |
37 |
install -m 755 mksquashfs unsquashfs %{buildroot}%{_bindir} |
38 |
|
39 |
%clean |
40 |
rm -rf %{buildroot} |
41 |
|
42 |
%files |
43 |
#%doc README |
44 |
%{_bindir}/mksquashfs |
45 |
%{_bindir}/unsquashfs |