/[packages]/updates/8/flac/current/SPECS/flac.spec
ViewVC logotype

Contents of /updates/8/flac/current/SPECS/flac.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1785736 - (show annotations) (download)
Sat Feb 26 20:55:12 2022 UTC (2 years, 1 month ago) by ns80
File size: 4252 byte(s)
- add upstream patch for CVE-2021-0561 (mga#30098)

1 %define major 8
2 %define libname %mklibname %{name} %{major}
3 %define libnamedev %mklibname %{name} -d
4 %define majorpp 6
5 %define libnamepp %mklibname %{name}++ %{majorpp}
6 %define libnameppdev %mklibname %{name}++ -d
7
8 Name: flac
9 Version: 1.3.3
10 %define subrel 1
11 Release: %mkrel 3
12 Summary: An encoder/decoder for the Free Lossless Audio Codec
13 Group: Sound/Editors and Converters
14 License: BSD and GPLv2+
15 URL: http://xiph.org/flac/
16 Source0: http://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
17 Patch0: 2e7931c27eb15e387da440a37f12437e35b22dd4.patch
18 Patch1: e1575e4a7c5157cbf4e4a16dbd39b74f7174c7be.patch
19 BuildRequires: automake
20 BuildRequires: gettext-devel
21 BuildRequires: id3lib-devel
22 BuildRequires: libtool
23 BuildRequires: pkgconfig(ogg)
24 %ifarch %{ix86}
25 BuildRequires: nasm
26 %endif
27
28 %description
29 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
30
31 FLAC is comprised of 1) `libFLAC', a library which implements
32 reference encoders and decoders, licensed under the GNU Lesser
33 General Public License (LGPL); 2) `flac', a command-line program for
34 encoding and decoding files, licensed under the GNU General public
35 License (GPL); 3) `metaflac', a command-line program for editing
36 FLAC metadata, licensed under the GPL; 4) player plugins for XMMS
37 and Winamp, licensed under the GPL; and 5) documentation, licensed
38 under the GNU Free Documentation License.
39
40
41 %package -n %{libname}
42 Summary: Shared libraries for FLAC
43 Group: System/Libraries
44
45 %description -n %{libname}
46 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
47
48 This package contains the C libraries.
49
50 %package -n %{libnamedev}
51 Summary: Libraries and headers needed for building apps using FLAC
52 Group: Development/C
53
54 Requires: %{libname} = %{version}-%{release}
55 Requires: pkgconfig(ogg)
56 Provides: flac-devel = %{version}-%{release}
57 Provides: libflac-devel = %{version}-%{release}
58 Provides: liboggflac-devel = %{version}-%{release}
59
60 %description -n %{libnamedev}
61 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
62
63 This package contains the libraries and header files necessary to develop
64 applications using FLAC written in C.
65
66 %package -n %{libnamepp}
67 Summary: Shared C++ libraries for FLAC
68 Group: System/Libraries
69
70 %description -n %{libnamepp}
71 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
72
73 This package contains the libraries for C++ applications.
74
75 %package -n %{libnameppdev}
76 Summary: Libraries and headers needed for building apps using FLAC++
77 Group: Development/C++
78
79 Requires: %{libnamepp} = %{version}-%{release}
80 Requires: %{libnamedev} = %{version}-%{release}
81 Provides: flac++-devel = %{version}-%{release}
82 Provides: libflac++-devel = %{version}-%{release}
83 Provides: liboggflac++-devel = %{version}-%{release}
84
85 %description -n %{libnameppdev}
86 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
87
88 This package contains the libraries and header files necessary to develop
89 applications using FLAC written in C++.
90
91 %prep
92 %autosetup -p1
93
94 %build
95 ./autogen.sh -V
96
97 rm -rf html
98 cp -r doc/html .
99
100 # (cg) Note that the --with-ogg is needed to prevent a lib path error
101 # leaking to all applications that link against libflac as the libFLAC.la
102 # file ultimately contains -L/usr/lib even on 64 bit platforms, which causes
103 # linking warnings to be shown in other applications, about incompatibile types
104 # for libraries where you have both 32 and 64 bit version installed like ptheads etc.
105 %configure \
106 --disable-static \
107 --disable-xmms-plugin \
108 --disable-thorough-tests \
109 --with-ogg
110
111 %make_build
112
113 %install
114 %make_install
115
116 mv %{buildroot}%{_datadir}/doc/flac installed-docs
117
118 find %{buildroot} -name '*.la' -delete
119
120 %check
121 make check
122
123 %files
124 %doc AUTHORS COPYING* README installed-docs/*
125 %{_bindir}/%{name}
126 %{_bindir}/meta%{name}
127 %{_mandir}/man1/*%{name}.1*
128
129 %files -n %{libname}
130 %{_libdir}/libFLAC.so.%{major}{,.*}
131
132 %files -n %{libnamepp}
133 %{_libdir}/libFLAC++.so.%{majorpp}{,.*}
134
135 %files -n %{libnamedev}
136 %{_includedir}/FLAC
137 %{_libdir}/libFLAC.so
138 %{_datadir}/aclocal/libFLAC.m4
139 %{_libdir}/pkgconfig/%{name}.pc
140
141 %files -n %{libnameppdev}
142 %{_includedir}/FLAC++
143 %{_libdir}/libFLAC++.so
144 %{_datadir}/aclocal/libFLAC++.m4
145 %{_libdir}/pkgconfig/%{name}++.pc

  ViewVC Help
Powered by ViewVC 1.1.30