/[packages]/updates/8/flightgear/current/SPECS/flightgear.spec
ViewVC logotype

Contents of /updates/8/flightgear/current/SPECS/flightgear.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1784860 - (show annotations) (download)
Fri Feb 25 19:59:04 2022 UTC (2 years, 3 months ago) by eatdirt
File size: 3099 byte(s)
Update to bug fix release 2020.3.12
1 #(eatdirt) LTS releases have the second digit >=3: like 2020.3.*,
2 #etc.. Preview versions have the second digit <=2.
3 #
4 Summary: The FlightGear Flight Simulator
5 Name: flightgear
6 Version: 2020.3.12
7 Release: %mkrel 1
8 License: GPLv2+
9 Group: Games/Simulation
10 URL: http://www.flightgear.org/
11 Source0: https://downloads.sf.net/flightgear/%{name}-%{version}.tar.bz2
12
13 BuildRequires: boost-devel
14 BuildRequires: cmake
15 BuildRequires: libomp-devel
16 BuildRequires: pkgconfig(flite)
17 BuildRequires: fltk-devel
18 BuildRequires: pkgconfig(freeglut)
19 BuildRequires: gsm-devel
20 BuildRequires: libgomp-devel
21 BuildRequires: plib-devel
22 BuildRequires: pkgconfig(dbus-1)
23 BuildRequires: pkgconfig(gdal)
24 BuildRequires: pkgconfig(gl)
25 BuildRequires: pkgconfig(glew)
26 BuildRequires: pkgconfig(openal)
27 BuildRequires: pkgconfig(openthreads)
28 #(eatdirt) 3.6 is now working (almost) fine
29 BuildRequires: pkgconfig(openscenegraph)
30 BuildRequires: pkgconfig(Qt5Core)
31 BuildRequires: pkgconfig(Qt5Gui)
32 BuildRequires: pkgconfig(Qt5Help)
33 BuildRequires: pkgconfig(Qt5Qml)
34 BuildRequires: pkgconfig(Qt5Svg)
35 BuildRequires: pkgconfig(Qt5QuickWidgets)
36 BuildRequires: pkgconfig(Qt5Widgets)
37 BuildRequires: qt5platformsupport-devel
38 BuildRequires: pkgconfig(speex)
39 BuildRequires: pkgconfig(speexdsp)
40 BuildRequires: pkgconfig(sqlite3)
41 BuildRequires: pkgconfig(udev)
42 BuildRequires: pkgconfig(xmu)
43 BuildRequires: pkgconfig(zlib)
44 BuildRequires: pkgconfig(libevent)
45 BuildRequires: simgear-devel >= %{version}
46 Requires: flightgear-data >= %{version}
47
48 #(eatdirt), lets'try again, this should be fixed
49 #### we get only segfaults in 32 bit starting with version 2018.2.2
50 ####ExclusiveArch: x86_64
51
52 Obsoletes: fgrun <= 2016.1.1
53
54 %description
55 The Flight Gear project is working to create a sophisticated flight simulator
56 framework for the development and pursuit of interesting flight simulator
57 ideas. We are developing a solid basic sim that can be expanded and improved
58 upon by anyone interested in contributing.
59
60 %prep
61 %setup -q
62 %autopatch -p1
63
64 %build
65 %cmake \
66 -DBUILD_SHARED_LIBS=OFF \
67 -DFG_DATA_DIR=%{_gamesdatadir}/%{name} \
68 -DSYSTEM_FLITE=ON \
69 -DSYSTEM_GSM=ON \
70 -DSYSTEM_SPEEX=ON \
71 -DSYSTEM_SQLITE=ON \
72 -DSIMGEAR_SHARED=ON \
73 -DENABLE_GDAL=ON \
74 -DENABLE_OPENMP=ON \
75 -DFG_BUILD_TYPE="Release" \
76 -DENABLE_COMPOSITOR=OFF \
77 %ifnarch %{arm} %{ix86}
78 -DENABLE_SIMD:BOOL=ON \
79 %else
80 -DENABLE_SIMD:BOOL=OFF \
81 %endif
82 -DCMAKE_BUILD_TYPE="Release"
83
84
85 %cmake_build
86
87 %install
88 %cmake_install
89
90 install -D package/org.flightgear.FlightGear.desktop %{buildroot}%{_datadir}/applications/org.flightgear.FlightGear.desktop
91
92 pushd icons
93 mkdir -p %{buildroot}%{_iconsdir}/hicolor
94 for i in `find * -maxdepth 0 -type d`
95 do
96 cp -fr $i %{buildroot}%{_iconsdir}/hicolor/
97 done
98
99
100
101
102 %files
103 %doc README AUTHORS docs-mini/
104 %{_bindir}/*
105 %{_datadir}/bash-completion/completions/fgfs
106 %{_datadir}/zsh/site-functions/_fgfs
107 %{_datadir}/applications/org.flightgear.FlightGear.desktop
108 %{_datadir}/metainfo/org.flightgear.FlightGear.metainfo.xml
109 %{_iconsdir}/hicolor/*/apps/fgcom.*
110 %{_iconsdir}/hicolor/*/apps/flightgear.*
111 %{_mandir}/man*/*.*
112 %{_mandir}/it/man*/*.*

  ViewVC Help
Powered by ViewVC 1.1.30