/[packages]/updates/8/nextcloud-client/current/SPECS/nextcloud-client.spec
ViewVC logotype

Annotation of /updates/8/nextcloud-client/current/SPECS/nextcloud-client.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1245192 - (hide annotations) (download)
Wed Jul 25 08:55:25 2018 UTC (5 years, 8 months ago) by daviddavid
Original Path: cauldron/nextcloud-client/current/SPECS/nextcloud-client.spec
File size: 6447 byte(s)
- add patch to fix build with new Qt5 >= 5.11.0

1 neoclust 1064247 %global _hardened_build 1
2 daviddavid 1065511 %define _cmake_skip_rpath %nil
3     # exclude devel(libocsync)
4     %global __requires_exclude ^(devel\\(libocsync.*)$
5 neoclust 1064247
6     Name: nextcloud-client
7 guillomovitch 1188211 Version: 2.3.3
8 daviddavid 1245192 Release: %mkrel 2
9 neoclust 1064247 Summary: The Nextcloud Client
10 daviddavid 1065364 Group: Archiving/Backup
11 neoclust 1064247
12     # -libs are LGPLv2+, rest GPLv2
13     License: LGPLv2+ and GPLv2
14     Url: https://nextcloud.com/install/#install-clients
15 guillomovitch 1130020 Source0: https://github.com/nextcloud/client_theming/archive/client_theming-%{version}.tar.gz
16 neoclust 1064247 Source1: https://download.owncloud.com/desktop/stable/owncloudclient-%{version}.tar.xz
17     Source2: %{name}.appdata.xml
18 guillomovitch 1188211 Patch0: %{name}-2.3.3-syslibs.patch
19 guillomovitch 1130020 Patch1: %{name}-icon.patch
20 daviddavid 1245192 Patch2: %{name}-2.3.3-fix-qt-5.11.patch
21 neoclust 1064247
22     BuildRequires: desktop-file-utils
23     BuildRequires: doxygen
24 daviddavid 1065511 BuildRequires: pkgconfig(neon)
25     BuildRequires: pkgconfig(openssl)
26 daviddavid 1245192 BuildRequires: python2dist(sphinx)
27 daviddavid 1065364 BuildRequires: qtsingleapplication-qt5-devel
28     BuildRequires: appstream-util
29 neoclust 1064247
30     BuildRequires: kf5-macros
31    
32     BuildRequires: cmake(KF5KIO)
33    
34     BuildRequires: cmake(Qt5Keychain)
35    
36     BuildRequires: pkgconfig(sqlite3)
37    
38 daviddavid 1245192 BuildRequires: pkgconfig(Qt5Core)
39     BuildRequires: pkgconfig(Qt5Gui)
40     BuildRequires: pkgconfig(Qt5Network)
41 daviddavid 1065364 BuildRequires: pkgconfig(Qt5Concurrent)
42     BuildRequires: pkgconfig(Qt5WebKitWidgets)
43     BuildRequires: pkgconfig(Qt5DBus)
44     BuildRequires: pkgconfig(Qt5Help)
45 daviddavid 1245192 BuildRequires: pkgconfig(Qt5Xml)
46 neoclust 1064247
47 daviddavid 1065364 Provides: owncloud-client = %version-%release
48     Obsoletes: owncloud-client < 2.2.4-2
49 neoclust 1064247
50     %description
51     Nextcloud-client enables you to connect to your private Nextcloud Server.
52     With it you can create folders in your home directory, and keep the contents
53     of those folders synced with your Nextcloud server. Simply copy a file into
54     the directory and the Nextcloud Client does the rest.
55    
56 daviddavid 1065364 %files
57 neoclust 1064247 %{_bindir}/nextcloud
58     %{_bindir}/nextcloudcmd
59     %{_datadir}/applications/nextcloud.desktop
60 daviddavid 1065365 %dir %{_datadir}/nextcloud
61     %{_datadir}/nextcloud/i18n/
62 neoclust 1064247 %{_datadir}/icons/hicolor/*/apps/*
63     %{_datadir}/appdata/%{name}.appdata.xml
64 daviddavid 1065511 %dir %{_sysconfdir}/Nextcloud
65 neoclust 1064247 %{_sysconfdir}/Nextcloud/sync-exclude.lst
66    
67     #------------------------------------------------------------------------------
68    
69     %package nautilus
70 daviddavid 1065364 Summary: nextcloud client nautilus extension
71     Requires: nautilus
72     Requires: nautilus-python
73     Requires: %{name} = %{version}-%{release}
74 neoclust 1064247
75     %description nautilus
76     The nextcloud desktop client nautilus extension.
77    
78     %files nautilus
79     %{_datadir}/nautilus-python/extensions/*
80    
81     #------------------------------------------------------------------------------
82    
83     %package nemo
84     Summary: Nemo overlay icons
85     Requires: nemo
86     Requires: nemo-python
87 neoclust 1065358 Requires: %{name} = %{version}-%{release}
88 neoclust 1064247
89     %description nemo
90     This package provides overlay icons to visualize the sync state
91     in the nemo file manager.
92    
93     %files nemo
94     %{_datadir}/nemo-python/extensions/*
95    
96 guillomovitch 1130020 %package caja
97     Summary: Caja overlay icons
98     Requires: caja
99     Requires: python-caja
100     Requires: %{name}%{?_isa} = %{version}-%{release}
101    
102     %description caja
103     This package provides overlay icons to visualize the sync state
104     in the caja file manager.
105    
106     %files caja
107     %{_datadir}/caja-python/extensions/*
108 neoclust 1064247 #------------------------------------------------------------------------------
109    
110     %package dolphin
111     Summary: Dolphin overlay icons
112     Requires: dolphin
113 neoclust 1065358 Requires: %{name} = %{version}-%{release}
114 neoclust 1064247
115     %description dolphin
116     The nextcloud desktop client dolphin extension.
117    
118     %files dolphin
119 daviddavid 1065365 %{_kf5_libdir}/libnextclouddolphinpluginhelper.so
120 neoclust 1064247 %{_kf5_plugindir}/overlayicon/nextclouddolphinoverlayplugin.so
121     %{_qt5_plugindir}/nextclouddolphinactionplugin.so
122 daviddavid 1065365 %{_kf5_services}/nextclouddolphinactionplugin.desktop
123 neoclust 1064247
124     #------------------------------------------------------------------------------
125    
126     %define nextcloudsync_major 0
127     %define libnextcloudsync %mklibname nextcloudsync %nextcloudsync_major
128    
129     %package -n %libnextcloudsync
130 daviddavid 1065364 Summary: The Nextcloud Client Libraries
131     Group: System/Libraries
132 daviddavid 1065365 # From owncloud-client
133     Obsoletes: %{_lib}owncloudsync2 < 2.2.4-2
134 neoclust 1064247
135     %description -n %libnextcloudsync
136 daviddavid 1065364 The Nextcloud Client Libraries.
137 neoclust 1064247
138     %files -n %libnextcloudsync
139     %{_libdir}/libnextcloudsync.so.%nextcloudsync_major
140     %{_libdir}/libnextcloudsync.so.%version
141    
142     #------------------------------------------------------------------------------
143    
144     %define libocsync_major 0
145 daviddavid 1065365 %define liblibocsync %mklibname ocsync %libocsync_major
146 neoclust 1064247
147     %package -n %liblibocsync
148 daviddavid 1065364 Summary: The Nextcloud Client Libraries
149     Group: System/Libraries
150 daviddavid 1065365 Obsoletes: %{_lib}libocsync0 < 2.2.4-4
151     # From owncloud-client
152     Obsoletes: %{_lib}ocsync2 < 2.2.4-2
153 neoclust 1064247
154     %description -n %liblibocsync
155 daviddavid 1065364 The Nextcloud Client Libraries.
156 neoclust 1064247
157    
158     %files -n %liblibocsync
159 daviddavid 1065365 %dir %_libdir/nextcloud
160 neoclust 1064247 %_libdir/nextcloud/libocsync.so.%{libocsync_major}
161     %_libdir/nextcloud/libocsync.so.%{version}
162 daviddavid 1065364
163 neoclust 1064247 #------------------------------------------------------------------------------
164    
165 daviddavid 1065365 %define develname %mklibname %{name} -d
166    
167     %package -n %{develname}
168 daviddavid 1065364 Summary: Development files for nextcloud-client
169     License: LGPLv2+
170     Requires: %libnextcloudsync = %{version}-%{release}
171     Requires: %liblibocsync = %{version}-%{release}
172     Provides: %{name}-static = %{version}-%{release}
173 daviddavid 1065365 Provides: %{name}-devel = %{version}-%{release}
174     Obsoletes: %{name}-devel < 2.2.4-4
175     # From owncloud-client
176     Obsoletes: %{_lib}owncloud-client-devel < 2.2.4-2
177 neoclust 1064247
178 daviddavid 1065365 %description -n %{develname}
179 daviddavid 1065364 Development headers for use of the nextcloud-client library.
180 neoclust 1064247
181 daviddavid 1065365 %files -n %{develname}
182 neoclust 1064247 %{_libdir}/libnextcloudsync.so
183     %{_includedir}/nextcloudsync/
184     %{_libdir}/libnextcloudsync.so
185     %{_libdir}/nextcloud/libocsync.so
186    
187     #------------------------------------------------------------------------------
188    
189     %prep
190     %setup -q -n client_theming-%{version}
191 guillomovitch 1130020 %setup -q -T -D -a 1 -n client_theming-%{version}
192 neoclust 1064247 rm -Rf client
193     mv owncloudclient-%{version} client
194 guillomovitch 1130020 pushd client
195 neoclust 1064247 %patch0 -p1
196 guillomovitch 1130020 popd
197 neoclust 1064247 %patch1 -p1
198 daviddavid 1245192 %patch2 -p1
199 neoclust 1064247 rm -rf src/3rdparty/qtlockedfile src/3rdparty/qtsingleapplication
200    
201     %build
202 daviddavid 1065364
203 daviddavid 1065365 %cmake_kf5 \
204     -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
205     -DOEM_THEME_DIR=`pwd`/../nextcloudtheme ../client
206     %make_build
207 neoclust 1064247
208    
209     %install
210 daviddavid 1065365 %make_install -C build
211    
212 guillomovitch 1188211 %find_lang client --with-qt
213 neoclust 1064247 mkdir -p %{buildroot}%{_datadir}/appdata/
214     install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
215    
216    
217     %check
218     appstream-util validate-relax --nonet %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
219    

  ViewVC Help
Powered by ViewVC 1.1.30