/[packages]/updates/8/python-django/current/SPECS/python-django.spec
ViewVC logotype

Annotation of /updates/8/python-django/current/SPECS/python-django.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1064734 - (hide annotations) (download)
Wed Nov 2 13:47:45 2016 UTC (7 years, 5 months ago) by philippem
Original Path: cauldron/python-django/current/SPECS/python-django.spec
File size: 4219 byte(s)
update to 1.8.16 fix CVE-2016-9013 and CVE-2016-9014 mga#19690
1 dmorgan 42460 %define module django
2     %define tarname Django
3    
4     Summary: A high-level Python Web framework
5 ovitters 648416 Name: python-%{module}
6 philippem 1064734 Version: 1.8.16
7 philippem 906190 Release: %mkrel 1
8 philippem 1057084 Source0: https://files.pythonhosted.org/packages/source/D/%{tarname}/%{tarname}-%{version}.tar.gz
9 philippem 671692 Patch0: python-django-1.7-py3-admin-completion
10 dmorgan 42460 License: BSD
11     Group: Development/Python
12     Url: http://www.djangoproject.com
13     BuildArch: noarch
14 misc 142748 BuildRequires: python-setuptools
15 marja 472897 BuildRequires: python-sphinx
16 daviddavid 887169 BuildRequires: python-sphinx_rtd_theme
17 marja 472897 BuildRequires: python-devel
18 marja 473530 BuildRequires: python3-devel
19 philippem 475168 BuildRequires: python3-setuptools
20 daviddavid 887169 BuildRequires: python3-sphinx_rtd_theme
21 daviddavid 887094 Requires: %{name}-bash-completion = %{version}-%{release}
22 dmorgan 42460
23     %description
24     Django is a high-level Python Web framework that encourages rapid development
25     and clean, pragmatic design.
26    
27     Developed and used over the past two years by a fast-moving online-news
28     operation, Django was designed from scratch to handle two challenges: the
29     intensive deadlines of a newsroom and the stringent requirements of experienced
30     Web developers. It has convenient niceties for developing content-management
31     systems, but it's an excellent tool for building any Web site.
32    
33     Django focuses on automating as much as possible and adhering to the
34     DRY principle.
35    
36 philippem 612783 %package bash-completion
37     Group: Development/Python
38     Summary: bash completion files for Django
39    
40    
41     %description bash-completion
42     This package contains the bash completion files form Django high-level
43     Python Web framework.
44    
45 philippem 475168 %package -n python3-%{module}
46 marja 473530 Summary: A high-level Python Web framework
47     Group: Development/Python
48 daviddavid 887094 Requires: %{name}-bash-completion = %{version}-%{release}
49 marja 473530
50 philippem 475168 %description -n python3-%{module}
51 marja 473530
52     Django is a high-level Python Web framework that encourages rapid development
53     and clean, pragmatic design.
54    
55     Developed and used over the past two years by a fast-moving online-news
56     operation, Django was designed from scratch to handle two challenges: the
57     intensive deadlines of a newsroom and the stringent requirements of experienced
58     Web developers. It has convenient niceties for developing content-management
59     systems, but it's an excellent tool for building any Web site.
60    
61     Django focuses on automating as much as possible and adhering to the
62     DRY principle.
63    
64 philippem 475168 %package doc
65     Summary: Documentation for django
66     Group: Development/Python
67     Provides: python3-%{module}-doc = %{version}-%{release}
68 marja 473530
69 philippem 475168 %description doc
70     This package contains documentation for Django,
71     a high-level Python Web framework.
72    
73 dmorgan 42460 %prep
74     %setup -q -n %{tarname}-%{version}
75 philippem 612783 %patch0
76 oden 622907
77 philippem 612783 # empty files
78     for f in \
79     django/contrib/staticfiles/models.py \
80     django/contrib/webdesign/models.py \
81     django/contrib/humanize/models.py \
82     ; do
83     echo "# just a comment" > $f
84     done
85 marja 473530 cp -a . %{py3dir}
86 dmorgan 42460
87     %build
88 daviddavid 887094 %py2_build
89    
90 marja 473530 pushd %{py3dir}
91 daviddavid 887094 %py3_build
92 marja 473530 popd
93 dmorgan 42460
94     %install
95 marja 473530 # must do install of python 3 subpackage first, so that we don't
96     # overwrite django-admin script with the python 3 version
97     pushd %{py3dir}
98 daviddavid 887094 %py3_install
99 philippem 612783 mv %{buildroot}%{_bindir}/django-admin.py %{buildroot}%{_bindir}/python3-django-admin
100 marja 473530 popd
101 dmorgan 42460
102 daviddavid 887094 %py2_install
103 marja 473530
104 philippem 612783 # build documentation
105     (cd docs && mkdir djangohtml && mkdir -p _build/{doctrees,html} && make html)
106    
107    
108     # install man pages
109     mkdir -p %{buildroot}%{_mandir}/man1/
110     cp -p docs/man/* %{buildroot}%{_mandir}/man1/
111     cp -a %{buildroot}%{_mandir}/man1/django-admin.1 %{buildroot}%{_mandir}/man1/python3-django-admin.1
112    
113     # install bash completion script
114     mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
115     install -m 0644 -p extras/django_bash_completion \
116     %{buildroot}%{_sysconfdir}/bash_completion.d/
117    
118     # Fix items in %%{_bindir}
119     mv %{buildroot}%{_bindir}/django-admin.py %{buildroot}%{_bindir}/django-admin
120    
121 philippem 819717
122 dmorgan 42460 %files
123 philippem 612783 %doc AUTHORS LICENSE README.rst
124     %{_mandir}/man1/*
125     # except the python3 prefix
126     %exclude %{_mandir}/man1/python3-*
127     %{_bindir}/django-admin
128 daviddavid 887094 %{python2_sitelib}/%{module}
129     %{python2_sitelib}/%{tarname}-*.egg-info
130 marja 473530
131 philippem 475168 %files -n python3-%{module}
132 philippem 612783 %doc AUTHORS LICENSE README.rst
133     %{_mandir}/man1/python3-*
134     %{_bindir}/python3-django-admin
135 marja 473530 %{python3_sitelib}/%{module}
136     %{python3_sitelib}/%{tarname}-*.egg-info
137 philippem 475168
138     %files doc
139 philippem 612783 %doc docs/_build/html
140 philippem 475168
141 philippem 612783 %files bash-completion
142     %dir %{_sysconfdir}/bash_completion.d/
143     %config(noreplace) %{_sysconfdir}/bash_completion.d/django_bash_completion
144    

  ViewVC Help
Powered by ViewVC 1.1.30