/[packages]/updates/8/python-django/current/SPECS/python-django.spec
ViewVC logotype

Annotation of /updates/8/python-django/current/SPECS/python-django.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 42460 - (hide annotations) (download)
Thu Jan 27 22:58:10 2011 UTC (13 years, 2 months ago) by dmorgan
Original Path: cauldron/python-django/current/SPECS/python-django.spec
File size: 1532 byte(s)
imported package python-django
1 dmorgan 42460 %define module django
2     %define tarname Django
3     %define name python-%module
4     %define version 1.2.3
5     %define release %mkrel 2
6    
7     Summary: A high-level Python Web framework
8     Name: %{name}
9     Version: %{version}
10     Release: %{release}
11     Source0: http://media.djangoproject.com/releases/%{version}/%{tarname}-%{version}.tar.gz
12     License: BSD
13     Group: Development/Python
14     Url: http://www.djangoproject.com
15     BuildRoot: %{_tmppath}/%{name}-buildroot
16     BuildArch: noarch
17     BuildRequires: python-setuptools, python-sphinx
18     %py_requires -d
19    
20     %description
21     Django is a high-level Python Web framework that encourages rapid development
22     and clean, pragmatic design.
23    
24     Developed and used over the past two years by a fast-moving online-news
25     operation, Django was designed from scratch to handle two challenges: the
26     intensive deadlines of a newsroom and the stringent requirements of experienced
27     Web developers. It has convenient niceties for developing content-management
28     systems, but it's an excellent tool for building any Web site.
29    
30     Django focuses on automating as much as possible and adhering to the
31     DRY principle.
32    
33     %prep
34     %setup -q -n %{tarname}-%{version}
35     sed -i 's/^\(ez_setup.use_setuptools\)/#\1/' setup.py
36    
37     %build
38     PYTHONDONTWRITEBYTECODE= %__python setup.py build
39     make -C docs/ html
40    
41     %install
42     %__rm -rf %{buildroot}
43     PYTHONDONTWRITEBYTECODE= %__python setup.py install --root=%{buildroot}
44    
45     %clean
46     %__rm -rf %{buildroot}
47    
48     %files
49     %defattr(-,root,root)
50     %doc LICENSE README docs/_build/html
51     %_bindir/*
52     %py_puresitedir/%{module}
53     %py_puresitedir/%{tarname}-*.egg-info
54    
55    

  ViewVC Help
Powered by ViewVC 1.1.30