/[packages]/updates/8/python-django/current/SPECS/python-django.spec
ViewVC logotype

Annotation of /updates/8/python-django/current/SPECS/python-django.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 473530 - (hide annotations) (download)
Fri Aug 30 15:27:23 2013 UTC (10 years, 7 months ago) by marja
Original Path: cauldron/python-django/current/SPECS/python-django.spec
File size: 2676 byte(s)
update to 1.5.2 and add python3
1 dmorgan 42460 %define module django
2     %define tarname Django
3 marja 472897 %define name python-%{module}
4 marja 473530 %define version 1.5.2
5     %define release %mkrel 1
6 dmorgan 42460
7     Summary: A high-level Python Web framework
8     Name: %{name}
9     Version: %{version}
10     Release: %{release}
11 marja 473530 Source0: https://pypi.python.org/packages/source/D/Django/Django-%{version}.tar.gz
12 dmorgan 42460 License: BSD
13     Group: Development/Python
14     Url: http://www.djangoproject.com
15     BuildArch: noarch
16 misc 142748 BuildRequires: python-setuptools
17 marja 472897 BuildRequires: python-sphinx
18     BuildRequires: python-devel
19 marja 473530 BuildRequires: python3-devel
20 dmorgan 42460
21     %description
22     Django is a high-level Python Web framework that encourages rapid development
23     and clean, pragmatic design.
24    
25     Developed and used over the past two years by a fast-moving online-news
26     operation, Django was designed from scratch to handle two challenges: the
27     intensive deadlines of a newsroom and the stringent requirements of experienced
28     Web developers. It has convenient niceties for developing content-management
29     systems, but it's an excellent tool for building any Web site.
30    
31     Django focuses on automating as much as possible and adhering to the
32     DRY principle.
33    
34 marja 473530 %package -n python3-django
35     Summary: A high-level Python Web framework
36     Group: Development/Python
37    
38     %description -n python3-django
39    
40     Django is a high-level Python Web framework that encourages rapid development
41     and clean, pragmatic design.
42    
43     Developed and used over the past two years by a fast-moving online-news
44     operation, Django was designed from scratch to handle two challenges: the
45     intensive deadlines of a newsroom and the stringent requirements of experienced
46     Web developers. It has convenient niceties for developing content-management
47     systems, but it's an excellent tool for building any Web site.
48    
49     Django focuses on automating as much as possible and adhering to the
50     DRY principle.
51    
52    
53 dmorgan 42460 %prep
54     %setup -q -n %{tarname}-%{version}
55     sed -i 's/^\(ez_setup.use_setuptools\)/#\1/' setup.py
56 marja 473530 cp -a . %{py3dir}
57 dmorgan 42460
58     %build
59 marja 472897 %{__python} setup.py build
60 dmorgan 42460 make -C docs/ html
61 marja 473530 pushd %{py3dir}
62     %{__python3} setup.py build
63     popd
64 dmorgan 42460
65     %install
66 marja 473530 # must do install of python 3 subpackage first, so that we don't
67     # overwrite django-admin script with the python 3 version
68     pushd %{py3dir}
69     %{__python3} setup.py install --skip-build --root %{buildroot}
70     mv %{buildroot}%{_bindir}/django-admin.py %{buildroot}%{_bindir}/python3-django-admin.py
71     popd
72 dmorgan 42460
73 marja 473530 %{__python} setup.py install --skip-build --root %{buildroot}
74    
75 dmorgan 42460 %files
76 marja 473530 %doc LICENSE README* docs/_build/html
77     %{_bindir}/django-admin.py
78 marja 472897 %{python_sitelib}/%{module}
79     %{python_sitelib}/%{tarname}-*.egg-info
80 marja 473530
81     %files -n python3-django
82     %doc LICENSE README* docs/_build/html
83     %{_bindir}/python3-django-admin.py
84     %{python3_sitelib}/%{module}
85     %{python3_sitelib}/%{tarname}-*.egg-info

  ViewVC Help
Powered by ViewVC 1.1.30