/[packages]/updates/8/python-django/current/SPECS/python-django.spec
ViewVC logotype

Annotation of /updates/8/python-django/current/SPECS/python-django.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 543295 - (hide annotations) (download)
Tue Oct 22 02:08:36 2013 UTC (10 years, 6 months ago) by umeabot
Original Path: cauldron/python-django/current/SPECS/python-django.spec
File size: 2951 byte(s)
Mageia 4 Mass Rebuild
1 dmorgan 42460 %define module django
2     %define tarname Django
3 marja 472897 %define name python-%{module}
4 oden 480299 %define version 1.5.4
5 umeabot 543295 %define release %mkrel 3
6 dmorgan 42460
7     Summary: A high-level Python Web framework
8     Name: %{name}
9     Version: %{version}
10     Release: %{release}
11 philippem 475168 Source0: https://pypi.python.org/packages/source/D/%{tarname}/%{tarname}-%{version}.tar.gz
12 dmorgan 42460 License: BSD
13     Group: Development/Python
14     Url: http://www.djangoproject.com
15     BuildArch: noarch
16 misc 142748 BuildRequires: python-setuptools
17 marja 472897 BuildRequires: python-sphinx
18     BuildRequires: python-devel
19 marja 473530 BuildRequires: python3-devel
20 philippem 475168 BuildRequires: python3-setuptools
21 dmorgan 42460
22     %description
23     Django is a high-level Python Web framework that encourages rapid development
24     and clean, pragmatic design.
25    
26     Developed and used over the past two years by a fast-moving online-news
27     operation, Django was designed from scratch to handle two challenges: the
28     intensive deadlines of a newsroom and the stringent requirements of experienced
29     Web developers. It has convenient niceties for developing content-management
30     systems, but it's an excellent tool for building any Web site.
31    
32     Django focuses on automating as much as possible and adhering to the
33     DRY principle.
34    
35 philippem 475168 %package -n python3-%{module}
36 marja 473530 Summary: A high-level Python Web framework
37     Group: Development/Python
38    
39 philippem 475168 %description -n python3-%{module}
40 marja 473530
41     Django is a high-level Python Web framework that encourages rapid development
42     and clean, pragmatic design.
43    
44     Developed and used over the past two years by a fast-moving online-news
45     operation, Django was designed from scratch to handle two challenges: the
46     intensive deadlines of a newsroom and the stringent requirements of experienced
47     Web developers. It has convenient niceties for developing content-management
48     systems, but it's an excellent tool for building any Web site.
49    
50     Django focuses on automating as much as possible and adhering to the
51     DRY principle.
52    
53 philippem 475168 %package doc
54     Summary: Documentation for django
55     Group: Development/Python
56     Provides: python3-%{module}-doc = %{version}-%{release}
57 marja 473530
58 philippem 475168 %description doc
59     This package contains documentation for Django,
60     a high-level Python Web framework.
61    
62 dmorgan 42460 %prep
63     %setup -q -n %{tarname}-%{version}
64     sed -i 's/^\(ez_setup.use_setuptools\)/#\1/' setup.py
65 marja 473530 cp -a . %{py3dir}
66 dmorgan 42460
67     %build
68 marja 472897 %{__python} setup.py build
69 dmorgan 42460 make -C docs/ html
70 marja 473530 pushd %{py3dir}
71     %{__python3} setup.py build
72     popd
73 dmorgan 42460
74     %install
75 marja 473530 # must do install of python 3 subpackage first, so that we don't
76     # overwrite django-admin script with the python 3 version
77     pushd %{py3dir}
78     %{__python3} setup.py install --skip-build --root %{buildroot}
79     mv %{buildroot}%{_bindir}/django-admin.py %{buildroot}%{_bindir}/python3-django-admin.py
80     popd
81 dmorgan 42460
82 marja 473530 %{__python} setup.py install --skip-build --root %{buildroot}
83    
84 dmorgan 42460 %files
85 philippem 475168 %doc README*
86 marja 473530 %{_bindir}/django-admin.py
87 marja 472897 %{python_sitelib}/%{module}
88     %{python_sitelib}/%{tarname}-*.egg-info
89 marja 473530
90 philippem 475168 %files -n python3-%{module}
91     %doc README*
92 marja 473530 %{_bindir}/python3-django-admin.py
93     %{python3_sitelib}/%{module}
94     %{python3_sitelib}/%{tarname}-*.egg-info
95 philippem 475168
96     %files doc
97     %doc README* docs/_build/html
98    

  ViewVC Help
Powered by ViewVC 1.1.30