1 |
%define name irker |
2 |
%define version 1.11 |
3 |
%define release %mkrel 1 |
4 |
|
5 |
%define hookdir %{_prefix}/lib/%{name} |
6 |
|
7 |
Name: %{name} |
8 |
Version: %{version} |
9 |
Release: %{release} |
10 |
Summary: IRC Message Relay |
11 |
License: BSD |
12 |
Group: Networking/IRC |
13 |
URL: http://www.catb.org/esr/irker/ |
14 |
Source0: http://www.catb.org/~esr/irker/%{name}-%{version}.tar.gz |
15 |
Source1: irkerd.init |
16 |
Patch0: irker-1.9-systemd-unit-user.patch |
17 |
BuildArch: noarch |
18 |
Requires(post,postun): rpm-helper |
19 |
Requires: python-irc |
20 |
Requires: python-simplejson |
21 |
BuildRequires: xmlto |
22 |
BuildRequires: docbook-style-xsl |
23 |
|
24 |
%description |
25 |
An IRC client that runs as a daemon accepting notification requestsas JSON |
26 |
objects presented to a listening socket. It is meant to be used by hook scripts |
27 |
in version-control repositories, allowing them to send commit notifications to |
28 |
project IRC channels. |
29 |
|
30 |
A hook script that works with git, hg, and svn is included in the distribution. |
31 |
|
32 |
%prep |
33 |
%setup -q |
34 |
%apply_patches |
35 |
sed -i 's/-o 0 -g 0 //' Makefile |
36 |
|
37 |
%build |
38 |
%make |
39 |
|
40 |
%install |
41 |
rm -rf %{buildroot} |
42 |
%makeinstall_std |
43 |
%__install -D --mode=755 irkerhook.py %{buildroot}%{hookdir}/irkerhook.py |
44 |
%__install -D --mode=755 %{SOURCE1} %{buildroot}%{_initrddir}/irkerd |
45 |
|
46 |
%pre |
47 |
%_pre_useradd %{name} / /bin/false |
48 |
|
49 |
%post |
50 |
%_post_service %{name}d |
51 |
|
52 |
%preun |
53 |
%_preun_service %{name}d |
54 |
|
55 |
%postun |
56 |
%_postun_userdel %{name} |
57 |
|
58 |
%clean |
59 |
rm -rf %{buildroot} |
60 |
|
61 |
%files |
62 |
%doc README |
63 |
%config(noreplace) %_initrddir/irkerd |
64 |
%{_bindir}/%{name}* |
65 |
%{_mandir}/man*/%{name}* |
66 |
%dir %hookdir |
67 |
%{hookdir}/irkerhook.py |