/[packages]/updates/infra_2/bash/current/SPECS/bash.spec
ViewVC logotype

Annotation of /updates/infra_2/bash/current/SPECS/bash.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 5648 - (hide annotations) (download)
Tue Jan 11 01:02:05 2011 UTC (13 years, 3 months ago) by blino
Original Path: cauldron/bash/current/SPECS/bash.spec
File size: 6551 byte(s)
remove old versions and conflicts/obsoletes
1 pterjan 229 %define i18ndate 20010626
2    
3     Name: bash
4     Version: 4.1
5 blino 5648 Release: %mkrel 7
6 pterjan 229 Summary: The GNU Bourne Again shell (bash)
7     Group: Shells
8     License: GPLv2+
9     URL: http://www.gnu.org/software/bash/bash.html
10     Source0: ftp://ftp.gnu.org/pub/gnu/bash/%{name}-%{version}.tar.gz
11     Source1: %{SOURCE0}.sig
12     Source2: ftp://ftp.gnu.org/pub/gnu/bash/bash-doc-3.2.tar.bz2
13     Source3: dot-bashrc
14     Source4: dot-bash_profile
15     Source5: dot-bash_logout
16     Source6: alias.sh
17     Source7: bashrc
18     Source8: profile.d-bash
19     Patch1: bash-2.02-security.patch
20     # ensure profile is read (Redhat)
21     Patch3: bash-4.0-profile.patch
22     Patch4: bash-2.05b-readlinefixes.patch
23     Patch6: bash-2.04-compat.patch
24     #https://bugzilla.novell.com/attachment.cgi?id=67684
25     Patch100: bash-3.1-extended_quote.patch
26     # Official upstream patches
27     Patch10: bash41-001
28     Patch11: bash41-002
29     Patch12: bash41-003
30     Patch13: bash41-004
31     Patch14: bash41-005
32     # none
33     Patch1000: bash-strcoll-bug.diff
34     Patch1003: bash-2.05b-checkwinsize.patch
35     Patch1004: bash-3.2-lzma-copmpletion.patch
36 blino 5648 # (fc) speedup bash completion (Fedora) (Fedora bug #475229)
37 pterjan 229 Patch1005: bash-3.2-speed-completion.patch
38 blino 5648 # (fc) fix format string
39 pterjan 229 Patch1006: bash-3.2-format-security.patch
40     BuildRequires: autoconf2.5
41     BuildRequires: bison
42     BuildRequires: groff
43     BuildRequires: libtermcap-devel
44     BuildRequires: texinfo
45     # explicit file provides
46     Provides: /bin/sh
47     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
48    
49     %description
50     Bash is a GNU project sh-compatible shell or command language
51     interpreter. Bash (Bourne Again shell) incorporates useful features
52     from the Korn shell (ksh) and the C shell (csh). Most sh scripts
53     can be run by bash without modification.
54    
55     Bash offers several improvements over sh, including command line
56     editing, unlimited size command history, job control, shell
57     functions and aliases, indexed arrays of unlimited size and
58     integer arithmetic in any base from two to 64. Bash is ultimately
59     intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
60     Tools standard.
61    
62     %package doc
63     Summary: Documentation for the GNU Bourne Again shell (bash)
64     Group: Books/Computer books
65     Requires: %{name} = %{version}-%{release}
66     Obsoletes: bash3-doc < 3.2.48
67     Provides: bash3-doc
68    
69     %description doc
70     This package provides documentation for GNU Bourne Again shell (bash).
71    
72     %prep
73     %setup -q -a 2
74     mv doc/README .
75    
76     %patch1 -p1 -b .security
77     %patch3 -p1 -b .profile
78     # 20060126 warly obsolete exept maybe for the replacement of @ by kH, this will have to be checked
79     #%patch4 -p1 -b .readline
80     %patch6 -p1 -b .compat
81     %patch10 -p0 -b .001
82     %patch11 -p0 -b .002
83     %patch12 -p0 -b .003
84     %patch13 -p0 -b .004
85     %patch14 -p0 -b .005
86     %patch1000 -p1 -b .strcoll_bugx
87     %patch1003 -p1 -b .checkwinsize
88     %patch1004 -p1 -b .lzma
89     %patch1006 -p1 -b .format-security
90     %patch100 -p0 -b .quote
91    
92     echo %{version} > _distribution
93     echo %{release} > _patchlevel
94     sed -i -e s/mdk// _patchlevel
95    
96     %build
97     #libtoolize --copy --force
98    
99     #export CFLAGS="$RPM_OPT_FLAGS"
100     #export CONFIGURE_TOP=".."
101     export DEBUGGER_START_FILE="%{_datadir}/bashdb/bashdb-main.inc"
102    
103     %configure2_5x \
104     --disable-command-timing \
105     --disable-rpath \
106     --enable-history \
107     --enable-job-control \
108     --enable-multibyte \
109     --enable-readline \
110     --with-installed-readline \
111     --with-gnu-malloc \
112     --without-bash-malloc
113    
114     %make
115     #CFLAGS="$RPM_OPT_FLAGS"
116     # all tests must pass
117     %check
118     make check
119    
120     %install
121     rm -rf %{buildroot}
122    
123     %makeinstall_std
124    
125     # beurk
126     rm -rf %{buildroot}%{_datadir}/locale/en@boldquot/ %{buildroot}%{_datadir}/locale/en@quot/
127    
128     #Sucks
129     chmod +w doc/texinfo.tex
130     chmod 755 examples/misc/aliasconv.*
131     chmod 755 examples/misc/cshtobash
132     chmod 755 %{buildroot}%{_bindir}/bashbug
133    
134     # Take out irritating ^H's from the documentation
135     mkdir tmp_doc
136     for i in `/bin/ls doc/` ; \
137     do cat doc/$i > tmp_doc/$i ; \
138     cat tmp_doc/$i | perl -p -e 's/.//g' > doc/$i ; \
139     rm tmp_doc/$i ; \
140     done
141     rmdir tmp_doc
142    
143     mkdir -p %{buildroot}/bin
144     pushd %{buildroot} && mv usr/bin/bash bin/bash && popd
145     pushd %{buildroot}/bin && ln -s bash sh && popd
146     pushd %{buildroot}/bin && ln -sf bash bash3 && popd
147    
148     # make builtins.1 and rbash.1 with bash.1 in place (fix mdv#51379)
149     pushd doc
150     mkdir tmp_fix_so
151     cd tmp_fix_so
152     cp ../builtins.1 ../rbash.1 .
153     sed -e '/^.if \\n(zZ=1 .ig zZ/,/^.zZ/d' ../bash.1 > bash.1
154     soelim builtins.1 > ../builtins.1
155     sed -e '/^.if \\n(zY=1 .ig zY/,/^.zY/d' ../bash.1 > bash.1
156     soelim rbash.1 > ../rbash.1
157     popd
158    
159     # make manpages for bash builtins as per suggestion in DOC/README
160     cd doc
161     sed -e '
162     /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
163     /^\.SH NAME/d
164     s/^bash, //
165     s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
166     s/,//g
167     b
168     }
169     d
170     ' builtins.1 > man.pages
171     install -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
172    
173     install -m 644 rbash.1 %{buildroot}%{_mandir}/man1/rbash.1
174    
175     for i in `cat man.pages` ; do
176     echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
177     done
178    
179     # now turn man.pages into a filelist for the man subpackage
180    
181     cat man.pages |tr -s ' ' '\n' |sed '
182     1i\
183     %defattr(0644,root,root,0755)
184     s:^:%{_mandir}/man1/:
185     s/$/.1%{_extension}/
186     ' > ../man.pages
187    
188     perl -p -i -e 's!.*/(printf|export|echo|pwd|test|kill).1%{_extension}!!' ../man.pages
189    
190     mkdir -p %{buildroot}%{_sysconfdir}/skel
191     mkdir -p %{buildroot}%{_sysconfdir}/profile.d
192     install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/skel/.bashrc
193     install -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/skel/.bash_profile
194     install -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/skel/.bash_logout
195     install -m 644 %{SOURCE6} %{buildroot}%{_sysconfdir}/profile.d/60alias.sh
196     install -m 644 %{SOURCE7} %{buildroot}%{_sysconfdir}/bashrc
197     install -m 644 %{SOURCE8} %{buildroot}%{_sysconfdir}/profile.d/95bash-extras.sh
198    
199     ln -s bash %{buildroot}/bin/rbash
200    
201     # These're provided by other packages
202     rm -f %{buildroot}{%{_infodir}/dir,%{_mandir}/man1/{echo,export,kill,printf,pwd,test}.1}
203 dmorgan 5623 rm -f %{buildroot}%{_datadir}/locale/ru/LC_MESSAGES/bash.mo
204 pterjan 229 cd ..
205    
206     install -m 644 doc/bash.info %{buildroot}%{_infodir}/
207    
208     %find_lang %{name}
209    
210     # merges list
211     cat man.pages %{name}.lang > files.list
212    
213     %clean
214     rm -rf %{buildroot}
215    
216     %files -f files.list
217     %defattr(-,root,root)
218     %doc README
219     %config(noreplace) %{_sysconfdir}/skel/.b*
220     %{_sysconfdir}/profile.d/60alias.sh
221     %{_sysconfdir}/profile.d/95bash-extras.sh
222     %config(noreplace) %{_sysconfdir}/bashrc
223     /bin/rbash
224     /bin/bash
225     /bin/bash3
226     /bin/sh
227     %{_infodir}/bash.info*
228     %{_mandir}/man1/bash.1*
229     %{_mandir}/man1/rbash.1*
230     %{_mandir}/man1/builtins.1*
231     %{_mandir}/man1/bashbug.1*
232     %{_bindir}/bashbug
233    
234     %files doc
235     %defattr(-,root,root)
236     %doc COMPAT NEWS NOTES POSIX CHANGES
237     %doc examples
238     %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
239    
240    

  ViewVC Help
Powered by ViewVC 1.1.30