/[packages]/updates/infra_2/perl-RPM4/current/SPECS/perl-RPM4.spec
ViewVC logotype

Annotation of /updates/infra_2/perl-RPM4/current/SPECS/perl-RPM4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 156425 - (hide annotations) (download)
Tue Oct 18 21:14:33 2011 UTC (12 years, 5 months ago) by tv
Original Path: cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec
File size: 2014 byte(s)
- patch 2: drop support for rpm-4.4.x (too much ifdef/else/endif spaghetti
  and already broken since rpm-4.6 & rpm-4.8 support patches)
- Patch 3: declare 4.8.0 & 4.8.1 in order to make 4.9.x checks work
- Patch 4: initial rpm-4.9.x support
1 jquelin 14433 # This spec is in the SVN
2     # $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $
3    
4     %define module RPM4
5     %define name perl-%{module}
6     %define version 0.23
7 tv 156425 %define release %mkrel 15
8 jquelin 14433
9     %define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm)
10    
11     Name: %{name}
12     Version: %{version}
13     Release: %{release}
14     Summary: Perl bindings to use rpmlib and manage hdlist files
15     License: GPL
16     Group: Development/Perl
17     Source: %{module}-%{version}.tar.gz
18     Patch0: RPM4-fix-build-with-rpm46.patch
19 dmorgan 48941 Patch1: RPM4-0.23-rpm48.patch
20 tv 156425 # (tv) drop support for rpm-4.4.x (too much ifdef/else/endif spaghetti and already broken since rpm-4.6 & rpm-4.8 support patches)
21     Patch2: RPM4-0.23-drop-support-for-rpm44.diff
22     # (tv) declare 4.8.0 & 4.8.1 in order to make 4.9.x checks work:
23     Patch3: RPM4-0.23-rpm48-bis.patch
24     # (tv) initial rpm-4.9.x support:
25     Patch4: RPM4-0.23-rpm49.patch
26 jquelin 14433 Url: http://search.cpan.org/dist/RPM4/
27 sander85 104940
28     BuildRequires: perl-devel >= 5.8.0
29     BuildRequires: rpm-devel
30     BuildRequires: perl-Digest-SHA1
31     BuildRequires: librpmconstant-devel
32     BuildRequires: packdrake
33     BuildRequires: perl-MDV-Packdrakeng
34     BuildRequires: gnupg
35    
36 jquelin 14433 Requires: perl
37     # we can now expect librpm API to be at least backward compatible
38     Requires: rpm >= %{rpm_version}
39    
40     %description
41     This module provides a perl interface to the rpmlib.
42    
43     It allows to write scripts to:
44     - query rpm headers,
45     - query rpm database,
46     - build rpm specs,
47     - install/uninstall specfiles,
48     - check dependencies.
49    
50     It include:
51     - rpm_produced, give what rpm will be produced by a src.rpm or a specfile.
52    
53     %prep
54     %setup -q -n %{module}-%{version}
55     %patch0 -p1 -b .rpm46
56 dmorgan 48941 %patch1 -p1
57 tv 156425 %patch2 -p1
58     %patch3 -p1
59     %patch4 -p1
60 jquelin 14433
61     %build
62     %{__perl} Makefile.PL INSTALLDIRS=vendor
63     %make
64    
65     %check
66     PERL5DIR=`pwd`/src/blib/arch TMPDIR=/tmp %make test
67    
68     %clean
69     rm -rf $RPM_BUILD_ROOT
70    
71     %install
72     rm -rf $RPM_BUILD_ROOT
73     %makeinstall_std
74    
75     %files
76     %defattr(-,root,root)
77     %doc ChangeLog README
78     %doc examples
79     %_bindir/*
80     %{perl_vendorarch}/*
81     %{_mandir}/*/*
82    
83    

  ViewVC Help
Powered by ViewVC 1.1.30